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CHAPTER

ONE

OVERVIEW

These are examples for illustrating the capabilities of VSim.

VSim [VSi] is an arbitrary dimensional, electromagnetics and plasma simulation code consisting of two major com-
ponents:

• VSimComposer, the graphical user interface.

• Vorpal [NC04], the VSim Computational Engine.

VSim also includes many more items such as Python, MPI, data analyzers, and a set of input simplifying macros.

1
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CHAPTER

TWO

VSIM FOR BASIC SIMULATIONS EXAMPLES

These examples demonstrate the basic solvers for simple, grid-aligned boundary conditions.

These examples can be run with any license.

2.1 Basic Examples

2.1.1 Cylindrical Capacitor (cylindricalCapacitor.sdf)

Keywords:

cylindrical, capacitor, electrostatic

Problem description

The Cylindrical Capacitor simulation solves for the potential between two cylinders with a ring of charge.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Cylindrical Capacitor example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select Cylindrical Capacitor and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 2.1.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.

3
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Fig. 2.1: Setup Window for the Cylindrical Capacitor example.

Simulation Properties

In this simulation there is a backgroundChargeDensity0 field which is given by an expression, chargedDist. That
expression is defined as a SpaceTimeFunction. The variables x and y in the expression are place holders for the actual
variables, Z and R, in the simulation. So this is a ring of charge, centered at R = 0.3, with a Gaussian fall off.

There are Dirichlet boundary conditions on the lower and upper R boundaries, with the lower bound set to 10 volts.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Here you can set run parameters, including how many cores to run with (under the Parallel Run Options).

• When you are finished setting run parameters, click on the Run button in the upper left corner of the window.
You will see the output of the run in the right pane. The run has completed when you see the output, “Engine
completed successfully.” This is shown in Fig. 2.2.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

This particular run computes the electrostatic potential, which we see by opening the scalar data and checking the box
next to Phi, which is shown in the right of the visualization tab. See Fig. 2.3.
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Fig. 2.2: The Run Window at the end of execution.

Fig. 2.3: Visualization of the electrostatic potential

2.1. Basic Examples 5
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Further Experiments

Looking inside the field boundary conditions, and highlighting dirichlet0, you can see that 10V was put on the lower
R boundary. You can try experimenting with this, going to run and vizualize with each change. The more voltage, the
less the background charge should matter.

You can take the charge out of the system. Highlight the backgroundChargeDensity0 label. In the property editor
below, double click on chargedDist, hit delete, and type 0.0. Then run and viz, and you will see a potential that is
independent of Z.

In Data View, choose Field Analysis and Field E_r with the Vertical Lineout Settings, then hit “Perform Lineout”. You
will see, as expected, that the radial electric field is positive (pointing outward) and falling off with the expected 1/r
behavior.

2.1.2 Oscillating Dipole Above Conducting Plane (emOscDipoleAboveConduc-
tor.sdf)

Keywords:

emOscDipoleAboveConductor, radiation

Problem Description

This problem consists of an infintesimally short dipole located a variable height and orientation above a conducting
plane. This simulation consists of electric and magnetic fields that can be visualized to see how the distance between,
and orientation of the dipole relative to the antenna effects these fields.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Dipole Above Conducting Plane example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select Dipole Above Conducting Plane and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 2.4.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.

Simulation Properties

This example includes several constants for easy adjustment of simulation properties, Including:

• AMPLITUDE: The amplitude of the dipole current

• FREQUENCY: The operating frequency

6 Chapter 2. VSim for Basic Simulations Examples
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Fig. 2.4: Setup Window for the Dipole Above Conducting Plane example.

There is also a SpaceTimeFunction to define the current driver of the dipole source

Other properties of the simulation include open boundaries on all sides except for the lower x boundary, which is a
perfect electric conductor. A Dipole Current source is used to set the location of the dipole source.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and output Files pane. You will see
the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 2.5.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The electric and magnetic field components can be found in the scalar data variables of the data overview tab. To
create the plot shown in Fig. 2.6 do the following:

• Expand Scalar Data

• Expand E

• Select E_y

2.1. Basic Examples 7



VSim Examples, Release 9.0.2-r2448

Fig. 2.5: The Run Window at the end of execution.

• Select the box next to Display Contours and set the # of contours to 12

• Select the box next to Clip All Plots

• Rotate the plot by clicking and dragging your mouse

Further Experiments

In this example the “infinite” electric conductor is simulated by a physical conducting boundary at the bottom of the
simulation. It would be possible to achieve the same results by having a second, equal infintesimal dipole placed the
same height “below” the conducting plane.

The number of “lobes” visible in the far field is dependent on Antenna Orientation and height. If vertically oriented
there will be 2*Height/Wavelength +1 lobes.A horizontally oriented dipole will produce 2*Height/Wavelength lobes.
This can be a bit difficult to visualize using just E-field data as it must be properly thresholded. The lobes will be
easier to see in the example Advanced Dipole Above Conductor, a part of the VSimEM package.

2.1.3 Electromagnetic Plane Wave (emPlaneWave.sdf)

Keywords:

electromagnetics, plane wave, periodic boundary conditions, wave launcher
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Fig. 2.6: The electric field

Problem Description

A linearly-polarized (with electric field in the z-direction) electromagnetic pulse with a sinusoidal amplitude on a plane
wave is launched from the left side (x=0) to propagate in the x-direction. The transverse (y,z) boundary conditions are
periodic.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Electromagnetic Plane Wave example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select Electromagnetic Plane Wave and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 2.7.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.
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Fig. 2.7: Setup Window for the Electromagnetic Plane Wave example.
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Simulation Properties

This example includes several constants for easy adjustment of simulation properties. Those include:

• AMPLITUDE: The amplutide of the plane wave

• WAVELENGTHS: The number of wavelengths inside the domain

There is a SpaceTimeFunction to define the plane wave that is launched with a Port Launcher boundary condition.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 2.8.

Fig. 2.8: The Run Window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The electric and magnetic field components can be found in the scalar data variables of the data overview tab.

• Make sure the Data View drop down is set to Data Overview.
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• Here you can see Variables. Expand the Scalar Data.

• Expand E

• Select E_z

Initially, no field will be seen, as one is looking at Dump 0, the initial dump, when no fields are yet in the simulation.
Move the slider at the bottom of the right pane to see the electric field at different times. The final time is shown in
Fig. 2.9.

Fig. 2.9: Visualization of plane wave as a color contour plot.

Further Experiments

To see more wavelengths, change the value of the WAVELENGTHS variable. What happens to the waves when there
are very few cells in a wavelength?

See the wave reflect off the right boundary by running for more time steps.

Try changing NDIM to 3 to see the how the simulation is uniform across the z- dimension.

2.1.4 Electromagnetic Particle In Cell (emPtclInCell.sdf)

Keywords:

electromagnetics, particle in cell, sheath
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Problem description

A dipole antenna launches a wave from a point that is midway in x and y. The simulation is periodic in y and open in
x. The electromagnetic field and plasma respond self consistently to the antenna current.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Electromagnetic Particle In Cell example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select “Electromagnetic Particle In Cell” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
2.10. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 2.10: Setup Window for Electromagnetic Particle in Cell.

Simulation Properties

This simulation includes several constants for easy adjustment of simulation properties including:
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• N_X, N_Y: The number of cells in each direction

• LEN_X, LEN_Y: The length of the domain in each direction

• PPC: The number of macroparticles per cell

• FREQUENCY: The frequency of the dipole antenna

The Parameters element contains several parameters useful for calculating basic plasma physics properties such as the
plasma frequency and Debye length.

There are 2 SpaceTimeFunctions that are used later in the setup to describe the thermal velocity of the electrons and
the annena current profile.

The simulation has open boundary conditions in x, and periodic in y.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 2.11.

Fig. 2.11: The Run Window at the end of execution of Electromagnetic Particle in Cell.

Visualizing the Results

After performing the above actions, continue as follows:

14 Chapter 2. VSim for Basic Simulations Examples



VSim Examples, Release 9.0.2-r2448

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric field and particles as shown in Fig. 2.12, do the following:

• Expand Particle Data

• Expand electrons0

• Select electrons0

• Expand Scalar Data

• Expand E

• Select E_z

Initially the field is at zero and particles are evenly distributed throughout the simulation. Move the dump slider
forward in time to view the results.

Fig. 2.12: Visualize Window with electric field and particles

Further Experiments

Vary the antenna amplitude, to find out how low it can be before the signal is swamped by the plasma noise.

Add in a magnetic field in the plane.

2.1.5 Vacuum Electromagnetic Pulse (emPulseInVacuum.sdf)

Keywords:

electromagnetics, laser, plane wave pulse, field energy monitoring
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Problem description

A linearly-polarized (with electric field in the z-direction) electromagnetic pulse with a sinusoidal amplitude on a
plane wave is launched from the left side (x=0). The transverse (y, z) boundary conditions are periodic, but the pulse
has finite transverse extent.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Vacuum Electromagnetic Pulse example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select Vacuum Electromagnetic Pulse and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
2.13. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 2.13: The Setup Window for the electromagnetic pulse.
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Simulation Properties

The Vacuum Electromagnetic Pulse example includes several constants for easy adjustment of simulation properties.
Those include:

• AMPLITUDE: The amplitude of the pulse

• WAVELENGTH: The wavelength of the pulse

• PULSELENGTH: The length of the pulse in the propagation direction

• PULSEWIDTH: The width of the pulse in the transverse direction

There is also a SpaceTimeFunction defined for the pulse shape and is used in the Port Launcher boundary condition.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.”

The Run Window, showing settable parameters with the engine output in the right pane, is shown in Fig. 2.14.

Fig. 2.14: The Run Window for the electromagnetic pulse.
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Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The electric and magnetic field components can be found in the scalar data variables of the data overview tab.

• Make sure the Data View drop down is set to Data Overview.

• Here you can see Variables. Expand the Scalar Data.

• Expand E

• Select E_z

• Check the box next to Clip All Plots

• Check the box next to Display Contours and set the # of contours to 5

• Click and drag with your mouse to rotate the view

Initially, no field will be seen, as one is looking at Dump 0, the initial dump, when no fields are yet in the simulation.
Move the slider at the bottom of the right pane to see the magnetic field at different times.

Fig. 2.15: Ez field at Dump 5.

Further Experiments

Increase NX to better resolve the wave and see whether it slips less with respect to the box.

Increase the pulse and box widths (you will also need to increase the number of cells in the transverse directions) to
reduce diffraction.
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2.1.6 Electrostatic Particle In Cell (esPtclInCell.sdf)

Keywords:

electrostatics, particle in cell, sheath

Problem description

This Electrostatic Particle in Cell example computes the electrostatic potential and field in a box with conducting walls
and particle absorbers and with an immobile, background neutralizing charge density. The electrons move to the wall
by the potential, creating a sheath.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The electrostatic particle in cell example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select Electrostatic Particle in Cell and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
2.16. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Simulation Properties

This simulation includes several constants for easy adjustment of simulation properties including:

• N_X, N_Y: The number of cells in each direction

• W_X, W_Y: The length of the domain in each direction

• PPC: The number of macroparticles per cell

The Parameters element contains several parameters useful for calculating basic plasma physics properties such as the
plasma frequency and Debye length.

There is a SpaceTimeFunction used later in the setup to describe the thermal velocity of the electrons.

The simulation is periodic in y with Dirichlet boundary conditions in X set to zero.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” A snapshot of the simulation run completion is shown in Fig. 2.17.
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Fig. 2.16: Setup Window for the electrostatic particle in cell example.

Fig. 2.17: The Run Window at the end of execution.
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Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric potential as shown in Fig. 2.18, do the following:

• Expand Scalar Data

• Select Phi

Move the dump slider forward in time to see the evolution of the field.

Fig. 2.18: The Visualize Window showing the electric potential, Phi, at dump 20.

Further Experiments

Change the plasma density and see whether the frequency in the histories changes.

Use the computePtclNumDensity analysis script in the Analyze Tab to calculate the electron density at each dump and
view the sheath formation.

2.1.7 Half-wave Antenna (halfWaveAntenna.sdf)

Keywords:

electromagnetics, antennas
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Problem Description

The half wave antenna example describes a simple box source in a vacuum.

This simulation can be performed with any license.

Opening the Simulation

The Half Wave Antenna example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select Half Wave Antenna and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
2.19. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 2.19: Setup Window for the Half Wave Antenna example.

Simulation Properties

This example includes several constants for easy adjustment of simulation properties, Including:

22 Chapter 2. VSim for Basic Simulations Examples



VSim Examples, Release 9.0.2-r2448

• WAVELENGTH: The wavelength of the antenna

There is also a SpaceTimeFunction to define the current driver of the half wavelength source.

Other properties of the simulation include port boundaries on all sides except for the lower x boundary, which is a
perfect electric conductor. A Distributed Current source is used to set the current of the half wavelegth source.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. of the window.
You will see the output of the run in the right pane. The run has completed when you see the output, “Engine
completed successfully.” This is shown in Fig. 2.20.

Fig. 2.20: The Run Window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the field pattern as shown in Fig. 2.21, do the following:

• Expand Scalar Data

• Expand B

• Select B_y
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• Select Display Contours and set the # of Contours to 100

• Move the dump slider forward in time

• Rotate the plot by clicking and dragging with your mouse.

Fig. 2.21: Visualization of the wave pattern as a color contour plot.

Further Experiments

Additional experiments worth investigating are:

• Change the frequency of the source.

2.1.8 Parallel Plate Capacitor (parPlateCapacitor.sdf)

Keywords:

electrostatics, parallel plate capacitor

Problem description

This Parallel Plate Capacitor simulation computes the electrostatic potential and field for a parallel plate capacitor. It
can be run in any number of dimensions. It is periodic in the y and z directions when they are present.

This simulation can be performed with a VSimBase license.
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Opening the Simulation

The Parallel Plate Capacitor example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples option.

• Select Parallel Plate Capacitor and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
2.22. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid

Fig. 2.22: Setup Window for the Parallel Plate Capacitor example.

Simulation Properties

The Simulation Elements Tree and Property Editor allow one to choose the distance between the plates, width of
the plates, voltage of the positive plate and the length of a time step (which is irrelevant as this is an electrostatic
simulation)

Running the Simulation

After performing the above actions, continue as follows:
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• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and output Files pane. You will see
the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 2.23.

Fig. 2.23: The Run Window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To create the image shown in Fig. 2.24, proceed as follows:

• Expand Scalar Data and select the box next to Phi

Further Experiments

Change the gap between the plates by changing the length of the grid in the z direction and see how the electric field
changes.

Change a width, e.g., LY and see whether it has an effect on the electric field.

Change the voltage on the right plate and see if it affects the electric field.

Set the periodic directions under BasicSettings to none, add boundary conditions on those directions and see how the
field changes.
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Fig. 2.24: Visualization of plane wave as a color contour plot.

2.1.9 Two-Stream Instability (twoStream.sdf)

Keywords:

electromagnetics, two-stream instability

Problem Description

The two-stream instability is a rapidly growing collision-less plasma instability arising from small charge imbalances.
A local imbalance leads to the acceleration or deceleration of particles in its vicinity, which in turn leads to an even
stronger imbalance. One setup that allows to easily observe the instability is two counter-streaming beams of identical
charge in a periodic system. The advantage of this configuration is that the generated plasma wave becomes a standing
wave, thus allowing to easily observe the formation of the phase space vortices.

In this example, we use two electron streams. At 𝑡 = 0 the streams have drift velocities of magnitude 7.78 × 106 m/s.
In order to accelerate the onset of the instability, the two particle beams are given a small sinusoidal perturbation in
velocity space.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Two-Stream Instability example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.
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• Expand the Basic Examples option.

• Select Two-Stream Instability and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
2.25. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 2.25: Setup Window for the Two-Stream Instability example.

Simulation Properties

There are a number of Constants in this simulation to help make modifying the simulation even easier. Those include:

• XCELLS: The number of cells

• NOM_DEN_E: The electron density

• VBAR: The average velocity

• WAVELENGTHS: The number of wavelengths in the domain to simulate

• PPC: The number of particles per cell.

SpaceTimeFunctions are used to set the velocities of each particle stream.

The simulation is 1 dimensional and periodic in x.
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Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper right corner of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 2.26.

Fig. 2.26: The Run Window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the instability as shown in Fig. 2.27, do the following:

• Select the Phase Space option from the Data View menu

• In the Plot 1 box, change the X-axis to electrons0_x, and the Y-axis to electrons0_ux

• Click the Enable Second Plot box

• In the Plot 2 box, change the Base Variable to electrons1, the X-axis to electrons1_x, and the Y-axis to elec-
trons1_ux

• Click the DRAW button at the bottom, then move the Dump slider forward in time.
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Fig. 2.27: Visualization of the two-stream instability developing in particle phase space.

Further Experiments

Change the average velocity and velocity modulation and see how the speed at which the instability sets in depends
on the modulation.

View the particle density by using the computePtclNumDensity script in the Analyze Window.

2.2 Basic Examples (text-based setup)

2.2.1 Magnetic Fields of Wire (bFieldByJT.pre)

Keywords:

Calculating A vector by a current carrying long linear wire.

Problem description

This simulation illustrates how to model magnetostatics. A straight current, Jo, is directed along the z-axis. The
example solves Poisson’s equation for the vector potential, A. The 0th dump of the simulation is the analytical solution
for the purpose of comparison.

This simulation can be performed with a VSimBase license.
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Opening the Simulation

The magnetic field by a current example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (text-based setup) option.

• Select “Magnetic Fields of Wire (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 2.28.

Fig. 2.28: Setup Window for the magnetic field by a current.

Input File Features

VSimComposer allows the user to vary the applied current and a radius of the wire. These are the main parameters that
affect the A vector. By changing these parameters, a user can run simulations to explore how the A vector depends
on the applied current and radius. The input file, when viewed in the editor, also exposes all the grid sizes of the
simulation that are used by the implemented models.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.
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• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 2.29.

Fig. 2.29: The Run Window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

For this example, one can see the A vector fields. To see the A vector, continue as follows:

• Make sure the Data View drop down is set to Data Overview.

• Here you can see Variables. Expand the Scalar Data. Then expand A

• Four variables are available, the three components of A and the magnitude of the vector. Select A_magnitude.

• Check the box next to Display Contours

• Rotate the view by clicking and dragging your mouse.

Fig. 2.30 shows the visualization seen for A_magnitude.

Further Experiments

This input file can be modified to test different current, and wire radius. This will allow users to study how to use the
magnetostatics capability in Vorpal.

32 Chapter 2. VSim for Basic Simulations Examples



VSim Examples, Release 9.0.2-r2448

Fig. 2.30: Visualization of magnetic fields by the current as a color contour plot.

2.2.2 Oscillating Dipole Above Conducting Plane (emOscDipoleAboveConduc-
torT.pre)

Keywords:

emOscDipoleAboveConductorT, radiation

Problem Description

This problem consists of an infintesimally short dipole located a variable height and orientation above a conducting
plane. This simulation sets up a multifield, which can than have its electric and magnetic fields visualized to see how
the distance between, and orientation of the dipole relative to the antenna effects these fields.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Dipole Above Conducting Plane example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (text-based setup) option.

• Select Dipole Above Conducting Plane (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.
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The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 2.31.

Fig. 2.31: Setup Window for the Dipole Above Conducting Plane example.

Input File Features

This file has key parameters to adjust the antenna polarization, height and operating frequency. In addition the number
of points per wavelength as well as simulation domain size and runtime can be adjusted. Finally the length of one
timestep can be adjusted slightly. The input file itself consists of a multifield with 5 open boundary conditions, and
one conducting boundary condition to simulate the ground plane.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the Logs and output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window below.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.
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Fig. 2.32: The Run Window at the end of execution.

The electric and magnetic field components can be found in the scalar data variables of the data overview tab.

• Make sure the Data View drop down is set to Data Overview.

• Here you can see Variables. Expand the Scalar Data.

• Expand E

• Select E_y

• Check the box next to Display Contours and set the # of contours to 10

Initially, no field will be seen, as one is looking at Dump 0, the initial dump, when no fields are yet in the simulation.
Move the slider at the bottom of the right pane to see the electric field at different times.

Further Experiments

In this example the “infinite” electric conductor is simulated by a physical conducting boundary at the bottom of the
simulation. It would be possible to achieve the same results by having a second, equal infintesimal dipole placed the
same height “below” the conducting plane.

The number of “lobes” visible in the far field is dependent on Antenna Orientation and height. If vertically oriented
there will be 2*Height/Wavelength +1 lobes.A horizontally oriented dipole will produce 2*Height/Wavelength lobes.
This can be a bit difficult to visualize using just E-field data as it must be properly thresholded. The lobes will be
easier to see in the example Advanced Dipole Above Conductor, a part of the VSimEM package.

By adjusting the TIMESTEP_FACTOR timesteps can be made larger. If they get to large the simulation will become
unstable.
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Fig. 2.33: The electric field

To improve computational speed the size of the simulation domain can be optimized by adjusting LX/LY/LZ and
PTS_PER_LAMBDA.

2.2.3 Electromagnetic Plane Wave (emPlaneWaveT.pre)

Keywords:

electromagnetics, plane wave, periodic boundary conditions, wave launcher

Problem Description

A linearly-polarized (with electric field in the y-direction) electromagnetic pulse with a sinusoidal amplitude on a plane
wave is launched from the left side (x=0) to propagate in the x-direction. The transverse (y,z) boundary conditions are
periodic.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Electromagnetic Plane Wave example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (text-based setup) option.
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• Select Electromagnetic Plane Wave (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 2.34.

Fig. 2.34: Setup Window for the Electromagnetic Plane Wave example.

Input File Features

The input file sets the wavelength to be one-third of the box length. It computes the TIMESTEP stability limit for the
time step and sets the actual time step to TIMESTEP_FACTOR times the stability limit for the time step.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper right corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 2.35.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.
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Fig. 2.35: The Run Window at the end of execution.

The electric and magnetic field components can be found in the scalar data variables of the data overview tab.

• Make sure the Data View drop down is set to Data Overview.

• Here you can see Variables. Expand the Scalar Data.

• Expand E

• Select E_y

Initially, no field will be seen, as one is looking at Dump 0, the initial dump, when no fields are yet in the simulation.
Move the slider at the bottom of the right pane to see the electric field at different times. The final time is shown in
Fig. 2.36.

Further Experiments

To see more wavelengths, change the value of the WAVELENGTHS variable. What happens to the waves when there
are very few cells in a wavelength?

See the wave reflect off the right boundary by running for more time steps.

To see a numerical instability, increase TIMESTEP_FACTOR to greater than one.

To see controlled dispersion, change to a 1D simulation and set TIMESTEP_FACTOR to unity.

Try changing NDIM to 3 to see the how the simulation is uniform across the z- dimension.

2.2.4 Electromagnetic Particle In Cell (emPtclInCellT.pre)

Keywords:
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Fig. 2.36: Visualization of plane wave as a color contour plot.

electromagnetics, particle in cell, sheath, box bounding

Problem description

A point antenna launches a wave from a point that is midway in x and z (if two-dimensional) but 1/3 of the way up
from the bottom in y. The electromagnetic field and plasma respond self consistently to an antenna current, if set, or
else the plasma simply evolves due to its initial thermal distribution.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Electromagnetic Particle In Cell example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (text-based setup) option.

• Select “Electromagnetic Particle In Cell” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The key parameters of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 2.37.
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Fig. 2.37: Setup Window for Electromagnetic Particle in Cell.

Input File Features

The input file sets the number of cells along each direction along with the lengths of each direction. The transverse (y,
z) boundary conditions are periodic. There are slab conductors at the limits in x.

The number of vacuum wavelengths in the box can be chosen. The wave frequency 𝜔, is then given from the vacuum
dispersion relation 𝜔 = 𝑐/𝜆.

Particles are loaded on a grid with a thermal velocity to generate a plasma with plasma frequency equal to
OMP_REL times the wave frequency. For the wave amplitude, the antenna strength should satisfy DEZ_ANT >
1.e9*OMP_REL^2.

The time step is chosen to be TIMESTEP_FACTOR times the combined stability limit for plasma oscillations and that
given by the CFL limit for FDTD electromagnetics.

One can turn the antenna off to see just the plasma noise and sheath generation.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 2.38.
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Fig. 2.38: The Run Window at the end of execution of Electromagnetic Particle in Cell.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric field, expand “Scalar Data”, expand the E field box, and select E_magnitude. Move the slider at
the bottom of the right pane to see the electric field at different times. At Dump 4, the rings of radiation surrounding
the antenna can be seen, as shown in Fig. 2.2.4. box, as shown below.

Further Experiments

Vary the antenna amplitude, DEZ_ANT, to find out how low it can be before the signal is swamped by the plasma
noise.

Increase OMP_REL to 1.5 to see that a wave is no longer launched, but what causes that front that travels far from the
antenna.

Add in a magnetic field in the plane; remove the magnetic field out of the plane. Launch a mode with frequency above
the upper-hybrid. Does the shape of the fronts change?

2.2.5 Vacuum Electromagnetic Pulse (emPulseInVacuumT.pre)

Keywords:

electromagnetics, laser, plane wave pulse, field energy monitoring
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Problem description

A linearly-polarized (with electric field in the z-direction) electromagnetic pulse with a sinusoidal amplitude on a
plane wave is launched from the left side (x=0). The transverse (y, z) boundary conditions are periodic, but the pulse
has finite transverse extent.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Vacuum Electromagnetic Pulse example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (text-based setup) option.

• Select Vacuum Electromagnetic Pulse (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window as
shown in Fig. 2.39.

Input File Features

The input file sets the wavelength to be one-eighth of the box length. It computes the CFL stability limit for the time
step and sets the actual time step to TIMESTEP_FACTOR times the stability limit for the time step.

One can change the pulse width and length to see more or less diffraction or dispersion.
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Fig. 2.39: The Setup Window for the electromagnetic pulse.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and output Files pane. You will see
the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.”

The Run Window, showing settable parameters with the engine output in the right pane, is shown in

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The electric and magnetic field components can be found in the scalar data variables of the data overview tab.

• Make sure the Data View drop down is set to Data Overview.

• Here you can see Variables. Expand the Scalar Data.

• Expand B

• Select B_x

• Check the box next to Display Contours and set the # of contours to 10

• Click and drag with your mouse to rotate the view
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Fig. 2.40: The Run Window for the electromagnetic pulse.

Initially, no field will be seen, as one is looking at Dump 0, the initial dump, when no fields are yet in the simulation.
Move the slider at the bottom of the right pane to see the magnetic field at different times.

Further Experiments

Increase CFL_FACTOR to greater than one. One should then see the simulation go numerically unstable, as one will
have violated the CFL condition.

Increase NX to better resolve the wave and see whether it slips less with respect to the box.

Increase the pulse and box widths (you will also need to increase the number of cells in the transverse directions) to
reduce diffraction.

Modify the boundary conditions to be a Matched Absorbing Layer (MAL) or Perfectly Matched Layer (PML) to see
how the wave is absorbed when it reaches the end of the simulation.

2.2.6 Electrostatic Particle In Cell (esPtclInCellT.pre)

Keywords:

electrostatics, particle in cell, sheath, box bounding

Problem description

This electrostatic particle in cell example computes the electrostatic potential and fields in a box with conducting walls
and particle absorbers and with an immobile, background neutralizing charge density. The electrons move to the wall
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Fig. 2.41: Bx fields at Dump 10.

by the potential, creating a sheath.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The electrostatic particle in cell example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (Text-based setup) option.

• Select “Electrostatic Particle in Cell (Text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 2.42.

Input File Features

The input file allows one to choose the simulation dimension, domain size, resolution (number of cells in each di-
rection), electron temperature (eV), electron density, voltage, ratios of cyclotron frequencies to plasma frequency and
electron marcroparticles per cell.
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Fig. 2.42: Setup Window for the electrostatic particle in cell example.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” A snapshot of the simulation run completion is shown in Fig. 2.43.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric potential

• Expand the Scalar Data

• Select phi

• Move the dump slider to the right to Dump 1

The potential in the visualization window resembles that shown in Fig. 2.44.

Further Experiments

Change the plasma density and see whether the frequency in the histories changes.
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Fig. 2.43: The Run Window at the end of execution.

Fig. 2.44: The Visualize Window showing the electric potential, phi, at dump 1.
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Set BZRATIO to 1.0 to observe the upper-hybrid mode.

Set BXRATIO to 1.0 to observe both the plasma mode and the upper-hybrid mode.

Set a value to V_RIGHT to see how the potential distribution changes.

Change the parameter NDIM to 3 to see the potential in 3 dimensions. Note that this will take longer to simulate.

2.2.7 Parallel Plate Capacitor (parPlateCapacitorT.pre)

Keywords:

electrostatics, parallel plate capacitor

Problem description

This Parallel Plate Capacitor simulation computes the electrostatic potential and field for a parallel plate capacitor. It
can be run in any number of dimensions. It is periodic in the y and z directions when they are present.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Parallel Plate Capacitor example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (text-based setup) option.

• Select Parallel Plate Capacitor (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 2.45.

Input File Features

The input file allows one to choose the distance between the plates, width of the plates, voltage of the positive plate
and the length of a time step (which is irrelevant as this is an electrostatic simulation)

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and output Files pane. You will see
the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 2.46.
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Fig. 2.45: Setup Window for the Parallel Plate Capacitor example.

Fig. 2.46: The Run Window at the end of execution.
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Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To visualize the electrostatic potential

• Expand Scalar Data

• Select phi

• Move the time slider to the right to view Dump 1

Fig. 2.47 shows the visualization seen.

Fig. 2.47: Visualization of plane wave as a color contour plot.

Further Experiments

Change the GAP between the plates and see how the electric field changes.

Change a width, e.g., LY and see whether it has an effect on the electric field.

Change the voltage on the right plate and see if it effects the electric field.

Set the boundary conditions to non-periodic (0) and see how the electric field changes.

2.2.8 Two-Stream Instability (twoStreamT.pre)

Keywords:
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electromagnetics, two-stream instability

Problem Description

The two-stream instability is a rapidly growing collision-less plasma instability arising from small charge imbalances.
A local imbalance leads to the acceleration or deceleration of particles in its vicinity, which in turn leads to an even
stronger imbalance. One setup that allows to easily observe the instability is two counter-streaming beams of identical
charge in a periodic system. The advantage of this configuration is that the generated plasma wave becomes a standing
wave, thus allowing to easily observe the formation of the phase space vortices.

In this example, we use two electron streams. At 𝑡 = 0 the streams have drift velocities of magnitude 7.78 × 106 m/s.
In order to accelerate the onset of the instability, the two particle beams are given a small sinusoidal perturbation in
velocity space.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Two-Stream Instability example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Basic Physics option.

• Expand the Basic Examples (text-based setup) option.

• Select Two-Stream Instability (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 2.48.

Input File Features

The simulation setup consists of an electromagnetic field and two particle species, one for each of the two counter
propagating electron particle streams. Each electron stream is given a drift velocity and an additional velocity pertur-
bation. For diagnostic purposes there is also output for species momentum, species energy and field energy histories.

The input file allows one to choose the average beam velocities and the amplitude of modulation. The number of
particles per cell (PPC), dimensionality, length of the simulation and length of a time step can also be modified from
the key parameters window.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper right corner of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 2.49.
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Fig. 2.48: Setup Window for the Two-Stream Instability example.

Fig. 2.49: The Run Window at the end of execution.
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Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the instability in phase space:

• Select the Phase Space option from the Data View menu.

• In the Plot 1 box, change the X-axis to electrons0_x, the Y-axis to electrons0_ux, and Color to Red.

• Click the Enable Second Plot box.

• In the Plot 2 box, change the X-axis to electrons1_x, the Y-axis to electrons1_ux and Color to Blue.

• Click the DRAW button at the bottom

• Move the Dump slider over to dump number 100.

Fig. 2.50: Visualization of the two-stream instability developing in particle phase space.

Further Experiments

Look at the histories to see how the plasma waves exchange energy with fields and each other as the instability
develops.

Change the average velocity and velocity modulation and see how the speed at which the instability sets in depends
on the modulation.

To calculate the density of the particles in the simulation switch the key parameters to

1. VBAR = 7.78e3
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2. PPC = 10. (note that decimal point is important here)

3. NDIM = 2

Then after the simulation has completed go to the Analyze Window, select ptclNumDensity from the drop down menu,
input twoStreamT for the baseName and electrons0 for the speciesName and hit run. This process is detailed further
in VSim In Depth
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CHAPTER

THREE

VSIM FOR ELECTROMAGNETICS EXAMPLES

These examples illustrate how to solve complex problems in electromagnetics.

These examples can be run with a VSimEM license.

3.1 Antennas

3.1.1 Yagi-Uda (YagiUda2p4.sdf)

Keywords:

yagiUdaArrayWireModel, yagiT, far field, radiation

Problem description

A Yagi-Uda array is a directional antenna consisting of several parallel dipole elements. Only one of these dipole
elements is driven, the other elements being parassitic . Directionality is acheived by requiring that there be one
longer element adjacent to the source element, which is refereed to as the reflector. The rest of the elements beginning
adjacent to the source but opposite to the reflector are shorter than the source element, these are called directors. Yagi
antennas are ubiquitous and as such optimal parameters for dipole lengths and separations have been established, we
go with values one would typically find in any text covering the matter. This example illustrates how to obtain the far
field radiation pattern of a Yagi-Uda array.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Yagi-Uda example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select 2.4 GHz Yagi Uda Antenna and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 3.1.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.
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Fig. 3.1: Setup Window for the Yagi-Uda example.

Simulation Properties

This file allows the modification of the antenna operating frequency, antenna dimensions, and simulation domain size.

By adjusting the dimensions any sized Yagi-Uda array can be simulated.

Note: To obtain good far field resolution generally four or more antenna elements is desirable (One source, one
reflector, two or more directors).

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Here you can set run parameters, including how many cores to run with (under the MPI tab).

• When you are finished setting run parameters, click on the Run button in the upper left corner of the Logs and
Output Files pane. You will see the output of the run in the right pane. The run has completed when you see the
output, “Engine completed successfully.” This is shown in Fig. 3.2.

Analyzing the Results

Click the Show All Analyzers button in the bottom left of the window, select “computeFarFieldFromKirchhoffBox.py”
from the list, and click “Open.”
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Fig. 3.2: The Run Window at the end of execution.

Next, select the computeFarFieldFromKirchhoffBox.py analysis script from the Active Analyzer drop down.

The default parameters are sufficient for this problem. Input 10.0 for the farFieldRadius parameter and run the analyzer
by clicking the “Analyze” button.

Visualizing the results

To view the near field pattern, do the following:

• Expand Scalar Data

• Expand E

• Select E_x

• Expand Geometries

• Select poly (YagiUda2p4PecShapes)

• Select Clip All Plots

• Move the dump slider forward in time

The far field radiation pattern can be found in the scalar data variables of the data overview tab underneath the farE
field. Check the farE_magnitude box.

Further Experiments

Try adding more directors and changing their dimensions to see the affect on the far field pattern.
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Fig. 3.3: The electric field near-field pattern.
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Fig. 3.4: The electric field manifestation of the far field pattern.

3.1.2 Antenna on Human Hand with Dielectric (antennaOnHand.sdf)

Keywords:

antennaOnHand, far field, radiation

Problem Description

This problem calculates the far-field radiation pattern of a small (cellular mobile) antenna mounted on a small curved
dielectric (plastic/PVC). The fields interact with the human hand for which the bone structure was approximated by
long thin cylinders. The antenna feed is a 850 MHz source.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Antenna on Human Hand with Dielectric example is accessed from within VSimComposer by the following
actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select “Antenna on Human Hand with Dielectric” and press the Choose button.

• In the resulting dialog, create a new folder if desired, and press the Save button to create a copy of this example.
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The Setup window is now shown with all the implemented physics and geometries. See Fig. 3.5.

Fig. 3.5: Setup Window for the Antenna on Human Hand with Dielectric example.

Simulation Properties

This file allows the modification of antenna operating frequency, dimensions, orientation, simulation domain size.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window below.

Analyzing the Results

After performing the above actions, continue as follows:

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.

• Tick the box “Show All Analyzers” in the bottom left corner of the window.

• Select computeFarFieldFromKirchhoffBox.py from the list and select “Open” (Fig. 3.7)

• Input values for the analyzer parameters. The analyzer may be run multiple times, allowing the user to experi-
ment with different values.
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Fig. 3.6: The Run Window at the end of execution.

– simulationName - antennaOnHand (name of the input file)

– fieldLabel - E (name of the electric field)

– farFieldRadius - 0.5 (distance to far field in m, 10.0 is a good value)

– timeStepStride - 150 (number of timesteps between far field calculations; determines how many far fields
are output)

– getFourierComponent - 0, do not integrate assuming single fourier frequency

– frequency - not used because getFourierComponent is false

– numTheta - 60 (number of theta points in the far field, 30 for a quick calculation, 60 for finer resolution)

– numPhi - 120 (number of phi points in the far field, 60 for a quick calculation, 120 for finer resolution)

– zeroThetaDirection - (0,0,1) (determines orientation of far field coordinate system)

– zeroPhiDirection - (1,0,0) (determines orientation of far field coordinate system

– varyingRadiusMesh - 1 (Set to 1 in order to make far field mesh adapt to magnitude of far field solution:
the classic lobe view - Note: using a varrying mesh option will make the analyzer run very slow.)

• Click “Analyze”

• Depending on the values of numTheta, numPhi, and timeStepStride, the script may need to run for several
minutes or longer.

Visualizing the Results

The far field radiation pattern can be found in the Scalar Data variables of the Data Overview tab. Check the farE
box. The far field mesh can also be plotted; it can be found under Geometries.
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Fig. 3.7: The Analyze panel after running computeFarFieldFromKirchhoffBox.py.

Fig. 3.8: The Far Field Radiation Pattern.
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Further Experiments

The skin can be included as an additional geometry by simply importing the hand geometry a second time within the
same set-up, but with a very slightly higher scaling factor and setting the Skin material for the hand geometry with the
higher scaling factor. Some “by eye” adjustments of the x-, y-, and z- traslation velues may be needed.

3.1.3 Coaxial Loop Antenna (coaxialLoopAntenna.sdf)

Keywords:

coaxial, coaxial waveguide, coaxial cable

Problem description

This example illustrates how to use the coaxial cable Field Boundary Condition and Constructive Solid Geometry to
create a coaxial loop antenna.

This simulation can be run with a VSimEM, VSimMD, VSimPD, or VSimPA license.

Opening the Simulation

The Coaxial Loop Antenna example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select “A Loop Antenna created from a coaxial cable” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is shown Fig. 3.9.

Simulation Properties

This simulation makes use of the new coaxial waveguide Field Boundary Condition in VSim 8.1.

A coaxial waveguide is first constructed by creating a physical coaxial cable that enters the simulation domain. It is
very important that this cable exist from atleast 1 cell outside of to 1 cell inside the simulation boundary. This is done
by first creating a box primitive and setting it along the desired simulation boundary.

A cylinder corresponding to the outer diameter of the coaxial cable is then created, and subtracted from the plate.

A cylinder corresponding to the inner diameter of the coaxial cable is then created and extended into the simulation
space.

It is then made into a loop antenna by adding a second, intersecting cylinder.

The wave itself is specified by a Field Boundary Condition.
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Fig. 3.9: Setup Window for the Coaxial Loop Antenna example.

Running the Simulation

Once finished with the problem setup, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Choose parallel computing options on the MPI tab

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.”

Visualizing the Results

Under Scalar Data select E_z. To slice inside the field, select Clip All Plots in the lower left hand corner. Click on
Plane Controls and change the cut-plane normal to lie along Y instead of Z, and adjust the origin of the normal vector
to .05 . Under the colors button set the min to -10 and the max to 10 to see the field.

Further Experiments

3.1.4 Dipole Above Conducting Plane (dipoleOnConductingPlane.sdf)

Keywords:

dipoleOnConductingPlane, far field, radiation
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Fig. 3.10: The Run Window at the end of execution.

Fig. 3.11: The 𝐸𝑧 field propagating off of the loop antenna.
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Problem Description

This problem illustrates how to obtain far fields within VSim by simulating an infinitesimally short dipole mounted
a variable height above a conducting plane. The conducting plane is simulated by using the method of images and
utilizes an equal magnitude dipole with direction rotated azimuthally by PI, on the opposite side of the plane. This
example is similar to the Oscillating Dipole Above Conducting Plane of VSimBase, but modified with functionality
available as part of the VSimEM package to obtain the far field radiation pattern. The number of lobes in the far field
will vary as a function of height above the conducting plane. There will be 2*HEIGHT/WAVELENGTH + 1 lobes.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Dipole Above Conducting Plane example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select “Dipole Above Conducting Plane” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
3.12. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 3.12: Setup Window for the Dipole Above Conducting Plane example.
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Simulation Properties

This setup includes several Constants and Parameters to help define the dipole signals, including the frequency and
height of the antenna.

There are open boundary conditions on each side of the simulation domain.

The conducting plane is simulated by using the method of images and utilizes an equal magnitude dipole with direction
rotated azimuthally by PI, on the opposite side of the plane.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 3.13.

Fig. 3.13: The Run Window at the end of execution.

Analyzing the Results

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.

• Select the Default computeFarFieldFromKirchhoffBox.py Analyzer

• Input values for the variables given on the left hand side of the screen. Check that these have the following
values.
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– simulationName - dipoleOnConductingPlane (name of the input file)

– fieldLabel - E

– farFieldRadius - 15.

– timeStepStride - 15

– getFourierComponent - 0

– frequency - 3e9

– numTheta - 45 (number of points in the theta direction)

– numPhi - 90 (number of points in the phi direction)

– zeroThetaDirection - (0,0,1)

– zeroPhiDirection - (1,0,0)

– varyingRadiusMesh - 1 (Varys the radius of the field based on field magnitude)

– simpsonIntegration - 0

• Click Run

Fig. 3.14: The Analyze Window at the end of execution.

Visualizing the Results

The far field radiation pattern can be found in the scalar data variables of the data overview tab. Check the
farE_magnitude box.
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Fig. 3.15: The far field radiation pattern

Further Experiments

The number of lobes in the far field is dependent on Antenna Orientation and height. If vertically oriented there will
be 2*Height/Wavelength +1 lobes. A horizontally oriented dipole will produce 2*Height/Wavelength lobes.

The resolution of the far field pattern can be changed by editing the number of theta and phi points in the analyis.

If the Simulation domain is made too small, the results will be distorted as the entire near field must be within the
simulation domain in order to acheive a proper transformation to the far field.

Note that an infinite perfect electric conducting plane is simulated in the computational engine via image theory. An
equal infintesimal dipole is placed the same distance from the conducting “plane” in order to acheive the result of
having an infinite electric conductor.

3.1.5 Dish Antenna (dishAntenna.sdf)

Keywords:

electromagnetics, antennas

Problem Description

The Dish Antenna simulation illustrates how to get the radiation pattern from a source in the presence of a complex
shape.

This simulation can be performed with a VSimEM, VSimMD or VSimPD license.
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Opening the Simulation

The Dish Antenna example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select “Dish Antenna” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
3.16. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 3.16: Setup Window for the Dish Antenna example.

Simulation Properties

One can set the parameters of the grid and the source through the setup tree. The parameters are put under the Constants
section.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.
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• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the Logs and Output Files pane. The run has completed when you see the output,
“Engine completed successfully.” This is shown in Fig. 3.17.

Fig. 3.17: The Run Window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric field reflected from the dish antenna as shown in Fig. 3.18, do the following:

• Expand Scalar Data

• Expand E

• Select E_x

• Expand Geometries

• Select poly (dishAntennaPecShapes)

• Select Clip All Plots

It is easier to see the fields if you change the color scale minimum and maximum. To do so, click on the Colors button,
and set a fixed minimum of -2 and a fixed maximum of 2.

Move the slider at the bottom of the right pane to see the electric field at different times.
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Fig. 3.18: Visualization of a slice of the electric field as a color contour plot at dump 19.

Further Experiments

Additional experiments worth investigating are:

• Change the resolution to see whether more resolution gives a different answer.

• Change the frequency of the source. Be careful, because at high frequencies with the chosen resolution, one will
require a large amount of memory.

3.1.6 Half-Wave Dipole in Free Space (halfWaveDipoleAntenna.sdf)

Keywords:

halfWaveDipoleAntenna, far field, radiation

Problem Description

This problem illustrates how to obtain far field radiation patterns from VSim simulation data. The simulation itself
consists of a half-wavelength long current source in free space.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Half Wave Dipole Antenna example is accessed from within VSimComposer by the following actions:

72 Chapter 3. VSim for Electromagnetics Examples



VSim Examples, Release 9.0.2-r2448

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select “Half-Wave Dipole in Free Space” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
3.19. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 3.19: Setup Window for the Half Wave Dipole Antenna example.

Simulation Properties

This example includes Constants for easy adjustment of simulation properties, Including:

• WAVELENGTH: The wavelength of the antenna

• FREQUENCY: The frequency of the antenna

There are also SpaceTimeFunctions to define the current driver of the half wavelength source.

Other properties of the simulation include open boundaries on all sides. A Distributed Current source is used to set the
current of the half wavelength antenna.
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Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 3.20.

Fig. 3.20: The Run Window at the end of execution.

Analyzing the Results

After performing the above actions, continue as follows:

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.

• Select computeFarFieldFromKirchhoffBox.py (default). Then click Open.

• For this example, edit the following input parameters (the rest should remain at their default setting):

– simulationName - halfWaveDipoleAntenna (name of the input file)

– fieldLabel - E (name of the electromagnetic field)

– farFieldRadius - 0.05 (radius of the far sphere, i.e., distance to the far zone)

– numTheta - 45 (number of points in the theta direction)

– numPhi - 90 (number of points in the phi direction)

• Click the Analyze button in the upper right corner.
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Fig. 3.21: The Analysis window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The far field radiation pattern can be found in the scalar data variables of the data overview tab:

• Expand Scalar Data

• Expand farE

• Select farE_magnitude

• Move the dump slider forward in time to see the evolution

• Click and drag to rotate the image

Further Experiments

The resolution of the far field pattern can be changed by editing the number of theta, phi, and sphere points in the far
field history.

Try implementing a conducting plane to see how it affects the far field.

If the Simulation domain is made to small, the results will be distorted as the entire near field must be within the
simulation domain in order to acheive a proper transformation to the far field.
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Fig. 3.22: The far field radiation pattern

3.1.7 Horn Antenna (hornAntenna.sdf)

Keywords:

sectoral, horn antenna, far field, radiation

Problem description

This example illustrates how to obtain the far field radiation pattern of a sectoral horn antenna. A horn antenna consists
of a flaring metal waveguide shaped like a horn that directs radio waves into a beam. Horns are widely used as antennas
at UHF and microwave frequencies. A sectoral horn is only flared along one axis, the other horn axis has constant
width and is equivalent to the width of the waveguide. Sectoral horns produce a fan shaped beam, wider in the plane
of the narrow sides.

This simulation can be run with a VSimEM license.

Opening the Simulation

The Horn Antenna example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select “Horn Antenna” and press the Choose button.
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• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is shown Fig. 3.23. To obtain the same view as in the figure, in the tree click on Histories to open
that part of the tree. then click on the box next to farFieldBox0 to make the far field box invisible. Right-clicking and
dragging rotates the view.

Fig. 3.23: Setup Window for the Horn Antenna example.

Simulation Properties

The antenna geometry in this example has been setup using CSG in the graphical setup interface. The dimensions of the
antenna can be adjusted by tuning the sizes of the various wedges and cubes used in the antenna’s construction. Under
Constants, the wavelength may be modified, as well as the grid size and resolution. The polarization of the antenna
may be altered by going into CurrentDistributions and changing the components of the driving current source.

Running the Simulation

Once finished with the problem setup, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Choose parallel computing options on the MPI tab.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window below.
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Fig. 3.24: The Run Window at the end of execution.

Analyzing the Results

After performing the above actions, continue as follows:

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.

• Click ‘Show All Analyzers’

• In the resulting dialog, select computeFarFieldFromKirhhoffBox.py (Fig. 3.25) and press Open.

• Input values for the analyzer parameters. The analyzer may be run multiple times, allowing the user to experi-
ment with different values.

– simulationName - hornAntenna (name of the input file)

– fieldLabel - E (name of the electric field)

– farFieldRadius - 10.0 (distance to far field in m, 10.0 is a good value)

– timeStepStride - 20 (number of timesteps between far field calculations; determines how many far fields
are output; 20 steps should yield 4 far fields in this case)

– getFourierComponent - 0 (whether to fourier analyze for a particular frequency)

– frequency - the frequency to use in the fourier analysis.

– numTheta - 18 (number of theta points in the far field, 18 for a quick calculation, 45 for finer resolution)

– numPhi - 36 (number of phi points in the far field, 36 for a quick calculation, 90 for finer resolution)

– zeroThetaDirection - (0,0,1) (determines orientation of far field coordinate system)

– zeroPhiDirection - (1,0,0) (determines orientation of far field coordinate system
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– varyingRadiusMesh - 1 (Set to 1 in order to make far field mesh adapt to magnitude of far field solution:
the classic lobe view)

– simpsonIntegration - 0 (Set to 1 for more accurate integration)

Fig. 3.25: Add the computeFarFieldFromKirhhoffBox.py script to your simulation.

• Click Analyze

• The analysis is completed when you see “Analysis completed successfully” in the Outputs. Depending on the
values of numTheta, numPhi, and timeStepStride, the script may need to run for several minutes or longer.

Visualizing the Results

Under Scalar Data plot 𝐸𝑧 . To slice inside the field, select Clip All Plots in the lower left hand corner. Click on Plane
Controls and change the cut-plane normal to lie along Y instead of Z. You can plot the horn antenna geometry by
selecting poly (hornAntenna) under Geometries. Move the dump slider to view the electric field emanating from the
horn. You can get a better look by adjusting the color scale. Select Log Scale Color in the lower left hand corner and
then click the Colors button above the 3D view. Try adjusting the min and max until the signal is well resolved.

The far field radiation pattern can be found in the Scalar Data variables of the Data Overview tab. Open the farE tree
element and check the farE_magnitude box. The far field mesh can also be plotted; it can be found under Geometries.

Further Experiments

The physical dimensions of the pyramidal horn can be modified in the GUI.

To turn the antenna into an E-plane sectoral horn, try changing the polarization to lie along the flared direction (z).

Try experimenting with different far field reolutions by changing the values of numTheta and numPhi during the
Analyze step. You can also experiment with different far field distances by changing the value of farFieldRadius.
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Fig. 3.26: The Analyze panel after running computeFarFieldFromKirhhoffBox.py.

Try making the domain and the size of the Kirchhoff box larger or smaller (size of the Kirchhoff box is tied to the
domain size by default). If the simulation domain is made too small, the results may appear distorted because the
entire near field must be resolved within the simulation domain in order to achieve a proper transformation to the far
field.

3.1.8 Patch Antenna with Far Fields (patchAntennaFarField.sdf)

Keywords:

patchAntenna, far field, radiation

Problem Description

This problem takes the same patch antenna from the Patch Antenna example (currently text-based only, visual setup
coming soon) and modifies it to calculate the far-field radiation pattern. It is fed with a 5.5GHz source on a microstrip
feed line. The patch itself is mounted on a dielectric substrate made of alumina.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Patch Antenna example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.
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Fig. 3.27: The 𝐸𝑧 field propagating out of the horn. The color scale has been log scaled and the min and max have
been fixed to 10.0 and 500.0, respectively. The geometry’s wireframe has been plotted and the opacity of the mesh
reduced, making it slightly transparent. For convenience, a three-slice operator has been added through the VisIt GUI
(hidden by default) in order to show as much information through one plot as possible. Various clips can be performed
to show the fields on different coordinate planes, one at a time.
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Fig. 3.28: The far field radiation pattern.

• Expand the Antennas option.

• Select “Patch Antenna with Far Fields” and press the Choose button.

• In the resulting dialog, create a new folder if desired, and press the Save button to create a copy of this example.

The Setup window is now shown with all the implemented physics and geometries. See Fig. 3.29.

Simulation Properties

This file allows the modification of antenna operating frequency, dimensions, orientation, simulation domain size.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window below.

Analyzing the Results

After performing the above actions, continue as follows:

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.
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Fig. 3.29: Setup Window for the Patch Antenna example.

Fig. 3.30: The Run Window at the end of execution.
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• Tick the box “Show All Analyzers” in the bottom left corner of the window.

• Select computeFarFieldFromKorhhoffBox.py from the list and select “Open” (Fig. 3.31)

• Input values for the analyzer parameters. The analyzer may be run multiple times, allowing the user to experi-
ment with different values.

– simulationName - patchAntennaFarField (name of the input file)

– fieldLabel - E (name of the electric field)

– farFieldRadius - 10.0 (distance to far field in m, 10.0 is a good value)

– timeStepStride - 20 (number of timesteps between far field calculations; determines how many far fields
are output; 20 steps should yield 4 far fields in this case)

– getFourierComponent - 0, do not integrate assuming single fourier frequency

– frequency - not used because getFourierComponent is false

– numTheta - 36 (number of theta points in the far field, 36 for a quick calculation, 45 for finer resolution)

– numPhi - 72 (number of phi points in the far field, 72 for a quick calculation, 90 for finer resolution)

– zeroThetaDirection - (0,0,1) (determines orientation of far field coordinate system)

– zeroPhiDirection - (1,0,0) (determines orientation of far field coordinate system

– varyingRadiusMesh - 0 (Set to 1 in order to make far field mesh adapt to magnitude of far field solution:
the classic lobe view)

Fig. 3.31: Add the computeFarFieldFromKirhhoffBox.py script to your simulation.

• Click “Analyze”
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• Depending on the values of numTheta, numPhi, and timeStepStride, the script may need to run for several
minutes or longer.

Fig. 3.32: The Analyze panel after running computeFarFieldFromKirhhoffBox.py.

Visualizing the Results

The far field radiation pattern can be found in the Scalar Data variables of the Data Overview tab. Check the farE
box. The far field mesh can also be plotted; it can be found under Geometries.

Further Experiments

The physical dimensions of the patch can be modified to turn it into any rectangular patch. This model can in fact
be used to simulate any form of patch antenna, simply modify the geometry in the Setup Window by expaning
the Parameters tree node and adjusting the values of PATCH_WIDTH, PATCH_LENGTH, PATCH_THICKNESS,
FEED_WIDTH, FEED_LENGTH, and FEED_OFFSET. The thickness of the alumina die may also be adjusted by
modifying DIE_THICKNESS.

3.1.9 Antenna on Predator Drone (predatorDrone.sdf)

Keywords:

predatorDrone, far field, radiation

Problem Description

This problem illustrates how to obtain the far field radiation pattern of a current source antenna mounted on a Predator
Drone.
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Fig. 3.33: The Far Field Radiation Pattern

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Predator Drone example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas option.

• Select “Antenna on Predator Drone” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with the CAD imported geometry and antenna current distribution accessible to the
user. See Fig. 3.34.

One can click and unclick the grid, the farFieldBox0 in the histories, the current distribution, and so forth to see
where those objects are. One can change locations through changing the values under Constants or, in some cases, the
numbers directly in the objects.

Simulation Properties

This file allows the modification of antenna operating frequency, source amplitude, dimensions of the source and the
Kirchhoff box by changing the associated variable values under the Constants.
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Fig. 3.34: Setup Window for the Predator Drone example.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.35.

Analyzing the Results

After the run, one must analyze the Kirchhoff box data to get the far fields. This is done as follows:

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.

• Click on the Show All Analyzers button, then click computeFarFieldFromKirchhoffBox.py, then click on the
Open button. as shown in Fig. 3.36.

If you want, you can grab the divding bar between the list of Analyzers in the Analysis Controls window and the
Analysis Results window, and slide it left to cover up the Analysis Controls window, making more room for the
Analysis Results window.

The default values should all be good, but one must set farFieldRadius. Since the box size is one, it is sufficient to
choose 10.

The analysis script will compute the instantaneous far fields at the timeStepStride. You may also optionally compute
the Fourier amplitude at a single frequency. As this is a single frequency excitation, at 1 GHz, the Fourier amplitude
is indeed of interest, and so you should also set getFourierComponent to 1, and set frequency to 1.0e9.

If you want the script to run faster, lower numTheta to 8 and numPhi to 16.
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Fig. 3.35: The Run Window at the end of execution.

Fig. 3.36: Choosing the Kirchhoff Box Analyzer.
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• You will also usually want to choose Overwrite Existing Files.

• Hit the Analyze button in the top left of the window.

At completion, you will see Fig. 3.37. The far field data is written to vsh5 files in the simulation directory.

Fig. 3.37: The Analysis window at the end of execution.

Visualizing the Results

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The radiation pattern in real space can be visualized by doing the following:

• Expand Scalar Data

• Expand E

• Select one of the scalar fields, such as E_x

• Move the Dump slider to see the far field pattern at different times.

It is useful to reset the color minimum and maximum using the Colors button and the number of Contours, to give a
pleasing pattern, as shown in Fig. 3.38. An odd number of contours will result in a contour at zero field, which often
leads to a less attractive plot with the zero contour filling up the space. Thus, in this case, an even number of contours
is suggested.

The far field radiation pattern, which was computed in the section on Analyzing the data can also be displayed.
Remove the previous image. Then check the farE_magnitude box under Scalar Data, and move the dump slider until
the image stops changing. You will see a spherical surface, representing the Far Field Sphere, and colors indicating
the strength of radiation at each angle that was processed. A notable peak in the radiation pattern is evident in the
forward direction, as seen in Fig. 3.39.
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Fig. 3.38: The radiation pattern in real space

Fig. 3.39: The far field radiation pattern
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Further Experiments

Upon close inspection you will note that the mesh size is slightly too large to fully resolve the thin wing structures
of the tail section. You can experiment with smaller cell size to resolve these structures. Beware that more cells will
increase the run time.

This example can be extended to meet any antenna placement problem with by addition of parameters to define the
current distribution center. The vertical extent of the simulation box could be shrunk to reduce the simulation time,
which would then allow greater resolution of the wavelength.

The main driver of simulation accuracy is the number of points per wavelength. Because of this lower frequencies will
simulate in less time as they require fewer cells to achieve the same resolution in the wave.

3.2 Antennas (text-based setup)

3.2.1 Half-Wave Dipole in Free Space (halfWaveDipoleAntennaT.pre)

Keywords:

halfWaveDipoleAntennaT, far field, radiation

Problem Description

This problem illustrates how to obtain far field radiation patterns from VSim simulation data. The simulation itself
consists of a half-wavelength long current source in free space.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Half Wave Dipole Antenna example is accessed from within VSimComposer by the following actions:

• Select the New From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Antennas (text-based setup) option.

• Select “Half Wave Dipole in Free Space (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 3.40.

Input File Features

This file allows the modification of antenna operating frequency, as well as simulation domain size and far field
resolution. It is also possible to perform this computation with a GPU.
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Fig. 3.40: Setup Window for the Half Wave Dipole Antenna example.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in the window below.

Analyzing the Results

After performing the above actions, continue as follows:

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.

• Click ‘Show All Analyzers’

• In the resulting dialog, select computeFarFieldFromKirhhoffBox.py and press Open.

• Input values for the analyzer parameters. The analyzer may be run multiple times, allowing the user to experi-
ment with different values.

– simulationName - halfWaveDipoleAntennaT (name of the input file)

– fieldLabel - E (name of the electric field)

– farFieldRadius - 10.0 (distance to far field in m, 10.0 is a good value)

– timeStepStride - 3 (number of timesteps between far field calculations; determines how many far fields are
output; 3 steps should yield 6 far fields in this case)
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Fig. 3.41: The Run Window at the end of execution.

– getFourierComponent - 0 (whether to fourier analyze for a particular frequency)

– frequency - the frequency to use in the fourier analysis (not needed here).

– numTheta - 60 (number of theta points in the far field, 18 for a quick calculation, 45 for finer resolution)

– numPhi - 120 (number of phi points in the far field, 36 for a quick calculation, 90 for finer resolution)

– zeroThetaDirection - (0,0,1) (determines orientation of far field coordinate system)

– zeroPhiDirection - (1,0,0) (determines orientation of far field coordinate system

– varyingRadiusMesh - 0 (Set to 1 in order to make far field mesh adapt to magnitude of far field solution:
the classic lobe view)

– simpsonIntegration - 0 (Set to 1 for more accurate integration)

Visualizing the Results

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The far field radiation pattern can be viewed as follows:

• Expand Scalar Data

• Expand farE

• Select farE_magnitude

• Expand Geometries
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Fig. 3.42: The Analysis window at the end of execution.

• Select farSphere

• Click and drag with your mouse to rotate the image

Further Experiments

The resolution of the far field pattern can be changed by editing the numTheta and numPhi values in the Analyzer
Window.

To improve computational speed the size of the simulation domain can be optimized by adjusting LX/LY/LZ and
PTS_PER_LAMBDA. Note that for far field calculations the simulation domain must be square.

If the Simulation domain is made to small, the results will be distorted as the entire near field must be within the
simulation domain in order to acheive a proper transformation to the far field.

3.3 Electrostatics

3.3.1 Like-Charge Dipole (esChargedSpheres.sdf)

Keywords:

electrostatics, like-charge dipole
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Fig. 3.43: The far field radiation pattern

Problem description

This Like-charge Dipole simulation computes the electrostatic potential and field for a dipole of two spheres with
given radius at the same potential.

This simulation can be performed with a VSimEM or VSimPD license, with Composer licensed for Visual Setup.

Opening the Simulation

The like-charge dipole example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Electrostatics option.

• Select Like-charge Dipole and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
3.44. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.
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Fig. 3.44: Setup Window for the Like-charge Dipole example.

Simulation Properties

This simulation uses visual setup to create a simple dipole. To do this we employ a few simple techniques such as
Constructive Solid Geometries (CSG), and field Boundary Conditions. The dipole is constructed as two spheres of
identical size. A Dirichlet boundary condition with the desired voltage is applied on both spheres.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.45.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electrostatic potential of the dipole as seen in Fig. 3.46 do the following:

• Expand Scalar Data

• Select Phi
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Fig. 3.45: The Run Window at the end of execution.

• Select Display Contours

• Select Clip All Plots

Further Experiments

Change the distance between spheres and see how the electric field changes.

Change the sphere radius and see how the electric field changes.

Change the sphere’s potential to observe a change in the electric field.

Determine how the electric field changes with varying resolution.

3.4 Electrostatics (text-based setup)

3.4.1 Like-Charge Dipole (esChargedSpheresT.pre)

Keywords:

electrostatics, like-charge dipole

Problem description

This ike-charge Dipole simulation computes the electrostatic potential and field for a dipole of two spheres with given
radius, at the same potential.
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Fig. 3.46: Visualization of like-charge dipole as a pseudocolor plot.

This simulation can be performed with a VSimEM or VSimPD license.

Opening the Simulation

The like-charge dipole example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Electrostatics (text-based setup) option.

• Select Like-charge Dipole (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 3.47.

Input File Features

The input file allows one to choose the location,radius and electrostatic potential of the spheres. It is also possible to
adjust the size of the simulation domain, start point (m) of the simulation in the X direction, resolution (number of
cells) in the simulation domain and number of dimensions to run the simulation in. The length of one timestep, DT is
also available for modification. As the simulation is electrostatic it does not matter what value is selected for DT.
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Fig. 3.47: Setup Window for the Like-charge Dipole example.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.48.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The electrostatic potential can be viewed as follows:

• Expand Scalar Data

• Select Phi

• Select Display Contours

• Select the Clip All Plots check box

• Move the time slider forward to Dump 1

Fig. 3.49 shows the visualization seen.
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Fig. 3.48: The Run Window at the end of execution.

Fig. 3.49: Visualization of like-charge dipole as a pseudocolor plot.
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Further Experiments

Change the distance between spheres by changing XPOS1 and XPOS2, and see how the electric field changes.

Change the sphere radius RADIUS and see how the electric field changes.

Change the sphere’s potential to observe a change in the electric field.

Determine how the electric field changes with varying resolution.

To reduce computational time NDIM can be switched to 2 to make it a 2D simulation.

3.5 Photonics

3.5.1 Cylindrical Dielectric Fiber (cylFiber.sdf)

Keywords:

Photonics, dielectric fiber

Problem Description

This example illustrates how to compute the modes of a cylindrical fiber for a given propagation constant, 𝛽, which,
because the primary direction of propagation in VSim is along the 𝑥-axis, is also denoted as 𝑘𝑥. The calculation is
performed using excitation of a system with only two cells in the 𝑥-dimension. (The simulation can be performed with
one cell in 𝑥, but this cannot be easily visualized so two are used instead.) This document will show how to extract the
modes and their frequencies, as well as how to get a text-based setup file for further exploration, including solving for
the propagation constant as a function of the frequency.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Cylindrical Dielectric Fiber example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select Cylindrical Dielectric Fiber and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
3.50. Expanding the Constants section of the Simulation Tree shows the user-defined constants of this simulation:

LENGTH_UNIT (real): The length-scale of the simulation. All lengths, such as that of the fiber radius and box size,
are divided by this number to make the geometry lengths of order unity as needed by the geometry engine. In
this case, LENGTH_UNIT is unity, so it has no effect.

WAVELENGTH_VAC (real): Wavelength of the signal in vacuum. Determines the excitation frequency.

N_EFF (real): Estimate of the value of 𝑛𝑒𝑓𝑓 of the expected modes. This determines the wavenumber, 𝑘𝑥 =
2𝜋𝑛𝑒𝑓𝑓/𝜆𝑣𝑎𝑐, of the modes to be found.

RESOLUTION (real): The resolution of the simulation grid. The cell size is set to be this number multiplied by the
smallest simulation feature, i.e., the fiber radius.

3.5. Photonics 101



VSim Examples, Release 9.0.2-r2448

XCELLS (integer): The number of cells to simulate in the x direction.

CFL_NUMBER (real): This times the stable time step gives the time step chosen for the simulation.

FREQ_GAP_REL (real): This times the stable time step gives the time step chosen for the simulation.

Expanding the Parameters section of the tree shows how the other simulation parameters are computed from the
constants. For example, the grid size DX along the 𝑥-axis is set to the resolution multiplied by the vacuum wavelength,
divided by 𝑛𝑒𝑓𝑓 and scaled by LENGTH_UNIT. The excitation central frequency, frequency, is computed from the
vacuum wavelength scaled by the LENGTH_UNIT. The longitudinal wavenumber, KAY, is computed from the desired
𝑛𝑒𝑓𝑓 , and from that the phase shift across cells along the 𝑥-axis is calculated.

The range of frequencies to be excited is [FREQ_LOW, FREQ_HIGH]. Outside of this range by FREQ_GAP, the
excitation drops off to the suppression value. This requires a successively longer excitation time, TIME_EXCITE and
so a successivelong larger NSTEPS_EXCITE, the number of steps for the excitation.

Absorbing layers have been placed at the y and z limits to damp out modes that would be outgoing for a fiber in infinite
space.

In 3D View tab of the right pane of the Setup Window, the fiber and the grid are visible. Right-click and drag to
rotate the view. The simulation has been constructed so that the fiber extends beyond the grid in both the positive and
negative 𝑥-directions, with a fiber diameter one-half the perpendicular domain length.

Fig. 3.50: Setup Window for the Cylindrical Dielectric Fiber example.

Expanding the Materials section of the Simulation tree shows that the simulation includes FiberMaterial. This
was created by importing a material from the Database tab of the right pane of the Setup Window, then changing the
name of the material and changing its properties. A material can be changed arbitrarily once it is in the simulation, as
shown in Fig. 3.51.

Expanding the Geometries of the Elements Tree shows that the simulation includes one geometry, the fiber, and its
material is FiberMaterial. This is seen in Fig. 3.52.

This simulation is excited with the freqBand function. This is a function that has a fairly uniform excitation over a
band of frequencies, falling off steeply outside of the band. The band has been chosen to be centered near where we
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Fig. 3.51: Setup Window for the Cylindrical Dielectric Fiber materials.

Fig. 3.52: Setup Window for the Cylindrical Dielectric Fiber geometries.
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expect to find the modes.

A field history has also been implimented in this simulation, so that the Fourier transform of what has been excited
can be seen.

As noted above, under the Parameters section of the Tree Elements is defined NSTEPS_EXCITE which specifies
the number of steps to excite the desired frequency content. Because FREQ_GAP also distinguishes the peaks, this
excitation time will distinguish the peaks.

Running the Simulation

Once finished with the problem setup, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• For this run we choose 10000 steps, much greater than that (4000) required for the excitation. This further
reduces any effect of the excitation on the signal in free oscillation.

• Choose parallel computing options on the MPI tab.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.53.

Fig. 3.53: The Run Window at the end of execution.

This simulation takes approximately 10 seconds on 4 cores of a modern processor.

Visualizing the spectrum

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

• In the Visualization Controls pane, in the dropdown menu for Data View select History.
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• For graph 1, set the quantity to be plotted to driveCurrent_2.

• For graph 2, set the quantity to be plotted to midUpperRightE_2.

• For graphs 3 and 4 set the quantity to be plotted to <None>.

• In the Visualization Results pane, for each plot, click the Fourier Amplitudes (dB) check box.

• Graph 1 shows the square window in frequency space.

• Graph 2 shows several peaks between 200 and 250 THz.

• To see this region in more detail, for each graph press the limits button and set the minimum to 1.7e14 and the
maximum to 2.7e14. Peaks in the spectrum are seen at the frequencies, 198 THz, 205THz, 217THz, 233, and
several around 250 THz in Fig. 3.54.

Fig. 3.54: The observed spectrum.

Analyzing the data

Since 8 modes were seen, we look for 8. This will requires 3 dumps per mode, or about 27 additional dumps. The
dumps should be spread out over a few oscillations (35 steps each) or so, and it is good to do a few extra. So upon
returning to the Run pane, select 200 time steps, dump periodicity of 5 time steps, and restart at dump 5.

Now go to the Analyze pane, select the extractModes.py analyzer, and press the Open button. Set the field to E, choose
beginDump to be 6, endDump to be 36, nModes to be 8, sampleType of 1, construct to be 1, and 100 of each kind of
points. Upon hitting the Analyze button of the Analyze pane, we sees the list of detected frequencies, of which the
first (mode 0) is the mode of interest, it having frequency of 1.98e14. This is seen in Fig. 3.55.

Visualizing the eigenmodes

Return to the Visualize Window, reload the data, open Scalar Data -> E, and click on E_z (EigenE). Keep the slider on
position 0. With the mouse, turn the image sideways to see the cross section, as shown in Fig. 3.56.
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Fig. 3.55: Extraction of the mode frequencies.

Fig. 3.56: The extracted eigenmode.
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Convergence

This simulation can be repeated for different values of RESOLUTION to see how the frequency varies with the mesh-
ing. We carried out this experiment with RESOLUTION varying over 0.1, 0.05, 0.02, 0.01 and plotted the frequency
versus the inverse grid length in Fig. 3.57.

For each value of the resolution do the excitation run followed by the extraction run:

• Excitation run: Press Reset to Setup Values to get the correct value for the time step. Then set the number of
step in the run panel to what is given by NSTEPS_EXCITE, and also modify the number of steps in the second
run proportionately. E.g., for RESOLUTION = 0.05, NSTEPS_EXCITE = 7916, so in the Run panel choose
Number of Steps = 8000 and Dump Periodicity = 2000. Clear the Restart at Dump Number box. Press the Run
button.

• Extraction run: E.g., for RESOLUTION = 0.05, set the Number of Steps to 400, the Dump Periodicity to 10, and
Restart at Dump Number to be 4.

• Analysis: Same as originally, as all numbers have been scaled.

Fig. 3.57: Convergence of the first mode.

The linear approach to the axis indicates that this is a first order accurate calculation. In other examples we will show
higher-order accuracy. Even so, one can see that the frequency is obtained on the sub-percent level with the finest grid
used.
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Further Experiments

This same process can be used to get the frequency of modes of different wavelengths or of waveguides of different
cross sections or made of different dielectrics.

3.5.2 Dielectric Waveguide with Gaussian Launcher (dielectricWaveguideGaus-
sian.sdf)

Keywords:

Photonic Waveguide, Unidirectional Mode Launcher, MAL,
Guided Mode, Semiconductor

Problem description

The dielectric waveguide consists of a single, straight silicon waveguide that is parallel to the x-axis and centered at
the origin. The waveguide is surrounded by silica. Matched Absorbing Layers (MALs) are used to dampen the E and
B fields near the boundary of the simulation to supress reflected fields.

A gaussian approximation of the fundamental guided mode is launched in the silicon waveguide in the +x direction.
The fundamental mode was extracted in the Dielectric Waveguide Mode Calculation Example.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The dielectric waveguide example can be accessed from within VSimComposer through the following steps:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window, expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select Dielectric Waveguide with Gaussian Launcher and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation will now be available in the Setup window as shown in Fig.
3.58. You can expand the tree elements and navigate through the various properties. The right pane shows a 3D view
of the geometry, as well as the grid. To show or hide the grid, expand the Grid element and select or deselect the box
next to Grid.

Simulation Properties

This example contains a number of constants defined to make the simulation easily modifiable. Some relevant con-
stants are listed below.

PERMITTVITY_WAVEGUIDE and PERMITTVITY_BACKGROUND: Relative permittivities of silicon and silica.
These constants are used in multiple parameters and in the accompanying Python file for solving the waveguide modes.

LENGTH_UNIT: The constant factor by which VSim will scale all simulation lengths.

WAVELENGTH_VAC: Wavelength of the input signal. This wavelength is also used for the calculation of the funda-
mental guided mode of the device.
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Fig. 3.58: The Setup window for the dielectric waveguide example showing some relevant constants.

NWAVELENGTH_MAL: Approximate number of wavelengths that can fit in a MAL region. The thickness of the
MAL regions in this example are measured in wavelengths.

The Materials section contains just silicon and silica.

The Geometries includes the CSG waveguide and its defining parameters.

In Field Dynamics, there are FieldBoundaryConditions and CurrentDistributions to be aware of. In photonics simu-
lations, Matched Absorbing Layers (MALs) are the most stable boundary conditions for preventing reflections. The
gaussian approximation is defined under SpaceTimeFunctions and is set to drive the y-component of the currentSource.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column. You will be asked to Save. Click
Save.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” The
result is shown in Fig. 3.59.

Visualizing the Results

Then proceed to the Visualize window by pressing the Visualize button in the left column.

You can verify that the geometry is correct by visualizing the inverse permittivity as follows:
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Fig. 3.59: The output after a successful run.

• Near the top left corner of the window, make sure Data View is set to Data Overview.

• Expand Scalar Data, expand invEps, and select invEps_z

• In the controls below the variables frame, select Clip All Plots.

By default, the clipping plane is at z = 0, which is in the middle of dielectric waveguide structure height-wise. As
such, this will reveal the dielectric waveguide’s 2D layout geometry as seen in Fig. 3.60.

A useful visualization of the dielectric waveguide would be to view the Z component of the B field to qualitatively see
the mode propagate down the waveguide.

• Near the top left corner of the window, make sure Data View is set to Data Overview.

• Expand Scalar Data, expand B, and select B_z

• In the controls below the variables frame, select Clip All Plots.

• In the top of the screen, press the button that’s titled Colors, check the Fix Minimum and Fix Maximum buttons,
and input {-5e-08, 5e-08} for the min and max, respectively.

Select the highest dump number on the lower right of the screen using the slide bar. Fig. 3.61 shows an example of
what one should expect if one has run the simulation for enough cycles.

Further Experiments

One can experiment by changing constants or introducing a different signal to drive the waveguide.
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Fig. 3.60: Visualization of inverse epsilon field’s Z component

Fig. 3.61: Visualization of the B field’s Z component
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3.5.3 Dielectric Waveguide Mode Calculation (dielectricWaveguideModeCalc.sdf)

Keywords:

Mode Extraction, Photonic Waveguide, Guided Mode, Semiconductor

Problem Description

This example demonstrates running a quasi-2D simulation of a rectangular dielectric waveguide and extracting the
frequency and fields of a guided mode using the filter diagonalization method. The waveguide axis runs parallel to the
x-axis, and is surrounded by Silica in the y and z directions. The y and z boundaries are set to absorb radiation. The
x simulation boundaries are phase-shifting; i.e., fields on the +x boundary are set to the values of the fields on the -x
boundary multiplied by 𝑒𝑖𝜑.

Eigenmodes in such a simulation have the form:

E(x, 𝑡) = E(𝑦, 𝑧)𝑒𝑖(𝑘𝑥−𝜔𝑡)

where the wavenumbers 𝑘 that may be simulated are given by 𝑘𝐿𝑥 = 𝜑 + 2𝜋𝑛, where 𝑛 is any integer and 𝐿𝑥 is the
length of the simulation in the x direction (in this case, two grid cells; or 𝐿𝑥 = 2∆𝑥). Since we will be searching for
the lowest-frequency guided modes, we can safely assume 𝑛 = 0 and set 𝜑 = 𝑘𝐿𝑥 for a desired 𝑘.

The “modal index” or “effective index of refraction” of a waveguide mode is given by 𝑛̄ = 𝑘/𝑘0 where 𝑘0 = 𝜔/𝑐. If
the waveguide has index of refraction 𝑛𝑤 and the cladding 𝑛𝑐 < 𝑛𝑤, then a guided mode will have a modal index in
the range, 𝑛𝑐 < 𝑛̄ < 𝑛𝑤.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Dielectric Waveguide example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select Dielectric Waveguide Mode Calculation and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

Simulation Properties

Constants

This example contains a number of constants defined to make the simulation easily modifiable. The user should avoid
altering constants not mentioned below.

LENGTH_UNIT: This is chosen to make the size of the system of order unity, as sometimes helps with the CSG
construction.

WAVELENGTH_VAC: The estimated vacuum wavelength (frequency divided by the speed of light) for the eigenmode
of interest.

N_EFF_EST: The estimated modal index of the eigenmode of interest; it should have a value between 𝑛𝑐 and 𝑛𝑤.

RESOLUTION: The number of cells per estimated wavelength in the propagation (x) direction.
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HALF_BANDWIDTH: The relative amount above and below the estimated frequency of the mode for excitation.
Found modes should be in this range to be accurate.

SUPPRESSION_FACTOR: a fall of by this factor is considered zero.

CFL_FACTOR: The time step will be chosen to be this times the limit for numerical stability.

PERMITTIVITY_BACKGROUND: This value of electrical permittivity is assigned to the space outside the waveg-
uide. It is set to Silica.

Parameters

Derived from the above are other parameters in the simulation. Some examples:

KAY: the estimated wavenumber, given by N_EFF_EST*(TWOPI/(WAVELENGTH_VAC/LENGTH_UNIT)). Here
one sees a conversion using LENGTH_UNIT.

PHASE: is calculated as described at the beginning.

HEIGHT_WAVEGUIDE: .22e-6/LENGTH_UNIT: is the actual height scaled by LENGTH_UNIT.

NSTEPS_EXCITE: is the computed number of steps to excite the simulation with the desired frequency content.

Setting up the Broad-band Excitation

As delivered, the system is set up for exciting a broad-band with a delta-function in time. A history (eHist) has been
added so that we can see the frequency content of the excitation. A delta current excitation has been selected. This is
shown in Fig. 3.62.

Fig. 3.62: Choosing the delta-function current source
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Running the Broad-band Excitation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons. You will be asked to Save.
Click Save upon the request to save.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” The
result is shown in Fig. 3.63.

Fig. 3.63: Exciting the mode with a broad-band current.

Visualizing the broad-band excitation simulation

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

• From the Data View dropdown menu select History

• Set Graphs 1 and 2 to eHist_1 (the y component).

• Set Graph 3 to <None>.

• In the both graphs, click FFT.

• In the upper graph, select the Zoom radio button, and select a box around the lower peak. The result is shown in
Fig. 3.64.

Both spectra show that there is a mode at around 190e6 Hz, with many more modes above. We will excite the
waveguide with a window of frequencies centered about this mode.
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Fig. 3.64: Spectrum seen from the broad-band excitation.

The Narrow-band Excitation

Now return to Setup, for the narrow-band excitation. HALF_BANDWIDTH is set to 0.1, so that the excitation will
start to fall off at FREQ_MID +- 10%. To change to the narrow-band simulation, choose window for J1 under
currentSource. Under Basic Settings, change steps between dumps to 0. This will make 1 dump at the end of the
run. Under Parameters, check the value of NSTEPS_EXCITE. Now on the Run window, set the Number of Steps to
somewhere around the value of NSTEPS_EXCITE. The Dump Periodicity should be set to 0. Run the simulation and
proceed to the visualization window, setting it up as before. The result is shown in Fig. 3.65.

As seen in Fig. 3.65, our excitation has isolated a single frequency peak, which we can now find precisely using mode
extraction.

Mode extraction by operator

Mode extraction by operator requires that one have sequences of 3 dumps during the time of free oscillation. To get
these, we return to the Setup window, and under Basic Settings, we set dump in groups of to 3 and set steps between
dumps to 20.

We next move to the Run window, make sure Dump at Time Zero is unclicked and put in 1 for Restart at Dump
Number. We set the Number of Steps to 202 (dumps will be at multiples of 20 + 0, 1, or 2). We then empty out (blank)
the Dump Periodicity text box and immediately hit Run.

Once the run finishes and the fields are dumped, proceed to the analysis screen by clicking the Analyze navigation
button. Select extractModesViaOperator.py and click Open. Change the following options:

• electricField: D,DI

• magneticField: B,BI

3.5. Photonics 115



VSim Examples, Release 9.0.2-r2448

Fig. 3.65: Spectrum seen from the narrow-band excitation.

• operator: d2dt2

• dumpRange: 1:

• cellSamples: 0:2,25:36:5,25:36:5

Also check Overwrite Existing Files. Run the analyzer by clicking Analyze button in the upper right corner. The
analyzer output should resemble the following image.

The output in Fig. 3.66 shows that Mode 0 (on the first line) has the smallest relative error.

Visualizing the results

After performing the above actions proceed to the Visualize window by pressing the Visualize button in the left column
of buttons. You may need to Reload Data (bottom left). Visualize an eigenmode by following these steps:

• From the Data View dropdown select Data Overview.

• Expand Scalar Data, expand EigenD, and select EigenD_1.

• Below the visualization, select the dump number (0) that corresponds to a mode number with the lowest operator
error (Mode 0).

The resulting visualization pane should resemble Fig. 3.67.

One can select other components of the electric field to see how they vary for this eigenmode. The profile of the
eigenmode is now saved in a vsh5 file in the folder where the simulation was run.
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Fig. 3.66: Output from the mode extraction script.

Fig. 3.67: Color map of the Dy component of the guided mode.
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Further Experiments

One can run a full convergence study of eigenmode frequencies by altering the RESOLUTION parameter in the Setup
Window and re-running the simulation and mode extraction script.

3.5.4 Dielectric Waveguide Mode Calculation using Point Permittivity (dielec-
tricWaveguideModeCalcPP.sdf)

Keywords:

Mode Extraction, Photonic Waveguide, Guided Mode, Semiconductor

Problem Description

This example demonstrates running a quasi-2D simulation of a rectangular dielectric waveguide and extracting the
frequency and fields of a guided mode using the filter diagonalization method. The waveguide axis runs parallel to the
x-axis, and is surrounded by Silica in the y and z directions. The y and z boundaries are set to absorb radiation. This
simulation uses point permittivity as opposed to permittivity averaging, which is done in Dielectric Waveguide Mode
Calculation. The x simulation boundaries are phase-shifting; i.e., fields on the +x boundary are set to the values of the
fields on the -x boundary multiplied by 𝑒𝑖𝜑.

Eigenmodes in such a simulation have the form:

E(x, 𝑡) = E(𝑦, 𝑧)𝑒𝑖(𝑘𝑥−𝜔𝑡)

where the wavenumbers 𝑘 that may be simulated are given by 𝑘𝐿𝑥 = 𝜑 + 2𝜋𝑛, where 𝑛 is any integer and 𝐿𝑥 is the
length of the simulation in the x direction (in this case, two grid cells; or 𝐿𝑥 = 2∆𝑥). Since we will be searching for
the lowest-frequency guided modes, we can safely assume 𝑛 = 0 and set 𝜑 = 𝑘𝐿𝑥 for a desired 𝑘.

The “modal index” or “effective index of refraction” of a waveguide mode is given by 𝑛̄ = 𝑘/𝑘0 where 𝑘0 = 𝜔/𝑐. If
the waveguide has index of refraction 𝑛𝑤 and the cladding 𝑛𝑐 < 𝑛𝑤, then a guided mode will have a modal index in
the range, 𝑛𝑐 < 𝑛̄ < 𝑛𝑤.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Dielectric Waveguide example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select Dielectric Waveguide Mode Calculation using Point Permittivity and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

Simulation Properties

Constants

This example contains a number of constants defined to make the simulation easily modifiable. The user should avoid
altering constants not mentioned below.
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LENGTH_UNIT: This is chosen to make the size of the system of order unity, as sometimes helps with the CSG
construction.

WAVELENGTH_VAC: The estimated vacuum wavelength (frequency divided by the speed of light) for the eigenmode
of interest.

N_EFF_EST: The estimated modal index of the eigenmode of interest; it should have a value between 𝑛𝑐 and 𝑛𝑤.

RESOLUTION: The number of cells per estimated wavelength in the propagation (x) direction.

HALF_BANDWIDTH: The relative amount above and below the estimated frequency of the mode for excitation.
Found modes should be in this range to be accurate.

SUPPRESSION_FACTOR: a fall of by this factor is considered zero.

CFL_FACTOR: The time step will be chosen to be this times the limit for numerical stability.

PERMITTIVITY_BACKGROUND: This value of electrical permittivity is assigned to the space outside the waveg-
uide. It is set to Silica.

Parameters

Derived from the above are other parameters in the simulation. Some examples:

KAY: the estimated wavenumber, given by N_EFF_EST*(TWOPI/(WAVELENGTH_VAC/LENGTH_UNIT)). Here
one sees a conversion using LENGTH_UNIT.

PHASE: is calculated as described at the beginning.

HEIGHT_WAVEGUIDE: .22e-6/LENGTH_UNIT: is the actual height scaled by LENGTH_UNIT.

NSTEPS_EXCITE: is the computed number of steps to excite the simulation with the desired frequency content.

Setting up the Broad-band Excitation

As delivered, the system is set up for exciting a broad-band with a delta-function in time. A history (eHist) has been
added so that we can see the frequency content of the excitation. A delta current excitation has been selected. This is
shown in Fig. 3.68.

Running the Broad-band Excitation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons. You will be asked to Save.
Click Save upon the request to save.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” The
result is shown in Fig. 3.69.

Visualizing the Broad-band Excitation

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

• From the Data View dropdown menu select History

• Set Graphs 1 and 2 to eHist_1 (the y component).

• Set Graph 3 to <None>.

• In the both graphs, click FFT.
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Fig. 3.68: Choosing the delta-function current source

Fig. 3.69: Run window at the end of a successful run.
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• In the upper graph, select the Zoom radio button, and select a box around the lower peak. The result is shown in
Fig. 3.70.

Fig. 3.70: Spectrum seen from the broad-band excitation.

Both spectra show that there is a mode at around 190e6 Hz, with many more modes above. We will excite the
waveguide with a window of frequencies centered about the lowest mode.

The Narrow-band Excitation

Now return to Setup, for the narrow-band excitation. HALF_BANDWIDTH is set to 0.1, so that the excitation will
start to fall off at FREQ_MID +- 10%. To change to the narrow-band simulation, choose window for J1 under
currentSource. Under Basic Settings, change steps between dumps to 0. This will make 1 dump at the end of the
run. Under Parameters, check the value of NSTEPS_EXCITE. Now on the Run window, set the Number of Steps to
somewhere around the value of NSTEPS_EXCITE. The Dump Periodicity should be set to 0. Run the simulation and
proceed to the visualization window, setting it up as before. The result is shown in Fig. 3.71.

As seen in Fig. 3.71, our excitation has isolated a single frequency peak, which we can now find precisely using mode
extraction.

Mode Extraction by Operator

Mode extraction by operator requires that one have sequences of 3 dumps during the time of free oscillation. To get
these, we return to the Setup window, and under Basic Settings, we set dump in groups of to 3 and set steps between
dumps to 20.

We next move to the Run window, make sure Dump at Time Zero is unclicked and put in 1 for Restart at Dump
Number. We set the Number of Steps to 202 (dumps will be at multiples of 20 + 0, 1, or 2). We then empty out (blank)
the Dump Periodicity text box and hit Run.
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Fig. 3.71: Spectrum seen from the narrow-band excitation.

Once the run finishes and the fields are dumped, proceed to the analysis screen by clicking the Analyze navigation
button. Select extractModesViaOperator.py and click Open. Change the following options:

• electricField: D,DI

• magneticField: B,BI

• operator: d2dt2

• dumpRange: 1:

• cellSamples: 0:2,25:36:5,25:36:5

Also check Overwrite Existing Files. Run the analyzer by clicking Analyze button in the upper right corner. The
analyzer output should resemble Fig. 3.72.

The output in Fig. 3.72 shows that Mode 0 (on the first line) has the smallest relative error.

Visualizing the Fundamental Mode

After performing the above actions proceed to the Visualize window by pressing the Visualize button in the left column
of buttons. You may need to Reload Data (bottom left). Visualize an eigenmode by following these steps:

• From the Data View dropdown select Data Overview.

• Expand Scalar Data, expand EigenD, and select EigenD_1.

• Below the visualization, select the dump number (0) that corresponds to a mode number with the lowest operator
error (Mode 0).
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Fig. 3.72: Output from the mode extraction script.

Fig. 3.73: Color map of the Dy component of the guided mode.
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The resulting visualization pane should resemble Fig. 3.73.

One can select other components of the electric field to see how they vary for this eigenmode. The profile of the
eigenmode is now saved in a vsh5 file in the folder where the simulation was run. This mode is launched into the
waveguide in the Dielectric Waveguide Mode Launch example.

Further Experiments

One can run a full convergence study of eigenmode frequencies by altering the RESOLUTION parameter in the Setup
Window and re-running the simulation and mode extraction script.

3.5.5 Microring Resonator with Gaussian Launcher (microringResonatorGaus-
sian.sdf)

Keywords:

Microring Resonator, Unidirectional Mode Launcher, MAL, Guided Mode, Photonic Device, Semiconductor

Problem Description

The Microring Resonator consist of two straight Silicon waveguides and a Silicon waveguide ring that sits between
the straight Waveguides. All three waveguides rest on top of a Silicon Dioxide slab. The rest of the simulation domain
is set to vacuum. Matched Absorbing Layers (MALs) are used to dampen the E, B and D fields near the boundary of
the simulation, this is a way to dampen reflected fields from the simulation boundaries.

An approximation of the fundamental guided mode profile is launched as a wide band pulse in the input waveguide (
the waveguide in -y ). This input signal is launching in the +x direction.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Microring Resonator example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select Microring Resonator with Gaussian Launcher and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
3.74. You can expand the tree elements and navigate through the various properties. The right pane shows a 3D view
of the geometry, as well as the grid, if actively shown. To show or hide the grid, expand the Grid element and select or
deselect the box next to Grid.

Simulation Properties

This example contains a number of Constants defined to make the simulation easily modifiable.

General Simulation Parameters (Constants):

• WAVEL_MAX = largest wavelength in the wide band signal
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Fig. 3.74: The Setup Window for The Microring Resonator Example

• WAVEL_MIN = smallest wavelength in the wide band signal

• RESOLUTION = inverse of the number of cells per wavelength

• LENGTH_UNIT = This scales the simulation by the value. DO NOT CHANGE THIS PARAMETER

• WAVEGUIDE_PERMITTIVITY = permittivity of the waveguides ensure this is equal to the permittivity set
in the CSG.

• WAVEL_SINGLE = The wavelength used in the single frequency signal

• WAVEL_RESOLVE = The wavelength used in calculation for the number of cells in simulation.

General Simulation Parameters (Parameters):

• RING_RADIUS = radius of the ring in meters scaled by LENGTH_UNIT.

• WIDTH_WAVEGUIDE = Width of waveguides in meters scaled by LENGTH_UNIT.

• HEIGHT_WAVEGUIDE = Height of waveguides in meters scaled by LENGTH_UNIT.

• GAP_WIDTH = Width of the gap between ring and waveguides in meters scaled by LENGTH_UNIT.

This simulation uses a gaussian distribution in the transverse directions as an approximation to the fundamental spatial
mode profile. One can also specify the time signal used to propagate the profile using either a single frequency or
FreqWindow Space Time Functions. The SpacetTimeFunctions are assigned to the transverse components of Current-
Distributions, which can be found under the Field Dynamics drop-down of the simulation setup tree.

The Materials section contains just Silicon and Silica. This section is where one can add or edit materials that get
attached to CSG objects. These Materials contain the relative permittivity.

In Field Dynamics there are FieldBoundaryConditions which set the boundary conditions of the simulation. In pho-
tonics simulations, Matched Absorbing Layers (MALs), are the most stable boundary conditions for preventing reflec-
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tions.

Running the Simulation

When the user has saved the setup, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• When you are finished setting run parameters, click on the Run button in the upper left corner of the
right pane. You will see the output of the run in the right pane. The run has completed when you see
the output, “Engine completed” seen in Fig. 3.75

Fig. 3.75: GUI Run Window at completion.

Analyzing the Results

Using Post analysis scripts one can extract transmission coefficients. This is possible due to the field slab histories that
are located at each port in the simulation. Each port has an E and B slab history in order to integrate over the poynting
flux. This integration is done in a post analysis script called computeSParamsFromHists.py.

Now go to the Analyze pane, select the computeSParamsFromHists.py analyzer, and press the Open button. Set the
maxWavelength to 1.7, outSlabE to be eSlab3, outSlabB to be b. Upon hitting the Analyze button of the Analyze pane,
we see that there will be a list of transmission maximum and the wavelength they occur at. This is seen in Fig. 3.76.
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Fig. 3.76: VSim analyzer tab.

Visualizing the results

After performing the above actions proceed to the Visualize Window by pressing the Visualize button in the left column
of buttons.

One can visualize the transmission coefficients by performing the following:

• Near the top left corner of the window, make sure Data View is set to 1-D Fields.

• In the control Panel select S_eSlab3bSlab3 for graph1 and set graph 2-4 to None.

Once you have performed the above actions one’s screen should look like Fig. 3.77.

Further Experiments

One can experiment by changing the GAP_WIDTH parameters. Then, one can run the computeSParamsViaOverlap-
Integral.py script to extract S-Parameters. One can see now changing the GAP_WIDTH changes the S-Parameters.

3.5.6 Microring Resonator Mode Calculation (microringResonatorModeCalc.sdf)

Keywords:

Mode Solver, Microring Resonator, Unidirectional Mode Launcher, MAL, Guided Mode, Photonic Device, Semiconductor
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Fig. 3.77: Visualization of Transmission Coefficient

Problem Description

This example demonstrates running a quasi-2D simulation of a dielectric waveguide and extracting the frequency and
fields of a guided mode using the filter diagonalization method. This is a quasi-2D simulation of the microringRes-
onator example. The purpose of this example is to calculate the guided mode profile for the microringResonator
example. After the mode profile is calculated one can interpolate the profile to the microringResonator example which
will propagate the profile.

The waveguide axis runs parallel to the x-axis, and is surrounded by cladding in the y and z directions. The cladding
terminates at the y and z simulation boundaries, which are set to perfect conductors (reflecting boundaries). The x
simulation boundaries are phase-shifting; i.e., fields on the +x boundary are set to the values of the fields on the -x
boundary multiplied by 𝑒𝑖𝜑.

Eigenmodes in such a simulation have the form:

E(x, 𝑡) = E(𝑦, 𝑧)𝑒𝑖(𝑘𝑥−𝜔𝑡)

where the wavenumbers 𝑘 that may be simulated are given by 𝑘𝐿𝑥 = 𝜑 + 2𝜋𝑛, where 𝑛 is any integer and 𝐿𝑥 is the
length of the simulation in the x direction (in this case, two grid cells; or 𝐿𝑥 = 2∆𝑥). Since we will be searching for
the lowest-frequency guided modes, we can safely assume 𝑛 = 0 and set 𝜑 = 𝑘𝐿𝑥 for a desired 𝑘.

The “modal index” or “effective index of refraction” of a waveguide mode is given by 𝑛̄ = 𝑘/𝑘0 where 𝑘0 = 𝜔/𝑐. If
the waveguide has index of refraction 𝑛𝑤 and the cladding 𝑛𝑐 < 𝑛𝑤, then a guided mode will have a modal index in
the range, 𝑛𝑐 < 𝑛̄ < 𝑛𝑤.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Microring Resonator Mode Calculation example is accessed from within VSimComposer by the following actions:
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• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select Microring Resonator Mode and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

Simulation Properties

This example contains a number of Constants defined to make the simulation easily modifiable. The user should avoid
altering constants not mentioned below.

General Simulation Parameters:

RESOLUTION: Specifies the coarseness/fineness of the simulation grid. The cell size is set to be this number multi-
plied by the smallest simulation feature, i.e., the smaller of the fiber radius or the simulated longitudinal wavelength.

WAVEL_RESOLVE: Specifies wavelength that is used to calculate the grid spacing (DX,DY,DZ). This should be a
wavelength between WAVEL_MIN and WAVEL_MAX‘.

LENGTH_UNIT: Specifies the length-scale of the simulation. The fiber radius and box size are divided by this number.

Target eigenmode parameters:

NEFF_GUESS: The estimated modal index of the eigenmode of interest; it should have a value between 𝑛𝑐 and 𝑛𝑤.

The following excitation parameters specify the frequency-domain characteristics of the current excitation inside the
waveguide. Eigenmode extraction works well when only a few modes are present in the simulation; so we excite a
narrow band in frequency space (or wavelength space) containing the frequencies (wavelengths) of our eigenmode(s)
of interest. The shape of the frequency window is a flat top with Gaussian tails.

Excitation parameters:

WAVEL_MIN: The lower bound of the flat-top portion of the excitation window in wavelength space.

WAVEL_MAX: The upper bound of the flat-top portion of the excitation window in wavelength space.

Mode extraction is a multi-stage process. Initially, an approximation of the spectrum should be obtained via manual
inspection of an FFT of the fields resulting from a delta function excitation. Then, an excitation should be crafted that
excludes irrelevant modes from an extraction simulation. Finally, the extraction simulation should be excited (without
dumping fields), then restarted with dump settings appropriate for the mode extraction analyzer.

The following parameters help the user choose an appropriate set of options in the Basic Settings section related to
simulation run time and field dump settings (e.g. “number of steps”, “steps between dumps”, etc.). depending on the
type of analysis.

Basic Settings helpers:

NSTEPS_EXCITE: This is the number of time steps required to encompass the entire simulation excitation. When
running the excitation part of the simulation, the “number of steps” should be strictly larger than this parameter.

NSTEPS_EXTRACT: This is the number of time steps required to encompass the entire simulation extraction. When
running the extraction part of the simulation, the “number of steps” should be strictly larger than this parameter.

NSTEPSPERDUMP_EXTRACT: This is the number of time steps per dump required for the mode extraction analysis
script.

NOTE: When dumping fields for this example, the “dump in groups of” should always be set to 3. This can be
accomplished by going to “basic settings” and changing “dump in groups of” to 3.
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In the 2D View tab of the right pane of the Setup Window, the device is visible with a smaller grid encompassing the
lower left section of the input waveguide.

Fig. 3.78: Setup Window for the Microring Resonator Device example.

Expanding the Materials section of the Simulation tree shows that the simulation includes silicon and silica. This was
created by importing a material from the Database tab of the right pane of the Setup Window.

Perform an Exploratory Simulation

An exploratory simulation is one in which the user wishes to discover the approximate frequencies (or wavelengths)
of eigenmodes in a simulation. Such a simulation consists of a wide-band (or short-time) excitation in which we
collect the field values (via the EFieldInWaveguide field History; c.f. Setup -> Histories -> EFieldInWaveguide) and
subsequent FFT analysis.

In the Setup Window, set up a delta-function (in time) excitation by navigating to: Field Dynamics -> CurrentDistri-
butions -> currentSource; then right-clicking on J1(x, y, z, t) and Assign SpaceTimeFunction to deltaFunc.

Finally, run the simulation by clicking the Run button on the left navigation column and then pressing the Run button
in the upper left corner of the right pane.

When the simulation finishes, proceed to the visualization screen by clicking the Visualize button on the left navigation
column. In the Data View dropdown, select History, then select FFT on the eHist_0 plot, seen in Fig. 3.80.

In the next section, we use the location of the peaks (which are in frequency space) to set up a mode extraction
simulation.

Perform extract modes simulation

In this part, we alter the exploratory simulation performed above to extract the lowest-frequency modes identified in
the FFT. Navigate back to the Setup Window.
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Fig. 3.79: Choosing a current source

Fig. 3.80: Setup Window for the Cylindrical Dielectric Fiber geometries.
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First, set up a simulation excitation with a narrow frequency band. In the Setup Window, navigate to: Field Dynamics
-> CurrentDistributions -> currentSource; then right-click on J1(x, y, z, t) and Assign SpaceTimeFunction to gauss-
FreqWindow. Then, set the following constants, which were determined by choosing frequency bounds that contain
the FFT peaks of interest, then converting frequency to wavelength via 𝑐 = 𝑓𝜆.

Now, inspect the NSTEPS_EXCITE parameter and set the following Basic Settings:

• number of steps: At least NSTEPS_EXCITE

• steps between dumps: 0 (turns off dumping)

Run the simulation.

After the simulation run completes, navigate back to the Setup window to prepare the field-dumping portion of the
mode extraction simulation. Set the following Basic Settings:

• number of steps: At least NSTEPS_EXTRACT.

• steps between dumps: NSTEPSPERDUMP_EXTRACT

• dump in groups of : 3

Now, click the Run button on the left navigation column. The field-dumping portion of the mode extraction simulation
must be run as a restart. Set “Restart at Dump Number” to 1. Run the simulation.

Extracting the Modes with an Analyzer

Once the run finishes and the fields are dumped, proceed to the analysis screen by clicking the Analyze navigation
button. In the “Choose an analyzer” dropdown, select extractModesViaOperator.py. Change the following options to

• electricField: D,DI

• magneticField: B,BI

• dumpRange: 2:

• cellSamples: ::10,::10,::10

Also check “Overwrite Existing Files”. Run the analyzer by clicking Analyze button in the upper right corner. The
analyzer output should resemble the following image.

Visualizing the results

After performing the above actions proceed to the Visualize window by pressing the Visualize button in the left column
of buttons. Visualize an eigenmode by following these steps:

• Near the top left corner of the window, make sure Data View is set to Data Overview.

• Expand Scalar Data, expand D, and select EigenD_1

• Below the visualization, select the dump number that corresponds to a mode number with the lowest operator
error (refer to the analyzer output). The large field values in the visualization that appears should be mostly
confined to the waveguide (center of the simulation domain).

Select the EigenD_1 for another interesting guided mode field pattern:

Further Experiments

One can run a full convergence study of eigenmode frequencies by altering the RESOLUTION parameter in the
Setup Window and re-running the simulation and mode extraction script. The simulation grid cell size is set to the
RESOLUTION value times the smallest width of the rectangular waveguide.
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Fig. 3.81: Output from the mode extraction script.

Fig. 3.82: Output from the mode extraction script.
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3.5.7 Gaussian Laser Beam and Photonic Crystal Cavity (photonicCrystal-
GaussSrc.sdf)

Keywords:

Gaussian Beam source, photonic crystal, transmission efficiency

Problem description

This example illustrates how to model a Gaussian beam source that is illuminating a cavity inside a hexagonal photonic
crystal lattice. The physical setup is shown in Fig. 3.83.

Fig. 3.83: The photonic lattice setup

A Gaussian beam is launched from above into the simulation domain, which comprises three layers: a vacuum re-
gion above and a solid dielectric below, which together sandwich a central dielectric layer that contains a lattice of
holes. This example includes two possible time signals with which the Gaussian beam will have either WideBand or
SingleFrequency.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Photonic Crystal example is accessed from within VSimComposer through the following steps:

• Select the New → From Example. . . menu item in the File menu.
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• In the resulting Examples window, expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select “Gaussian Laser Beam and Photonic Crystal Cavity” and press the Choose button.

• In the resulting dialog, create a new folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window, as shown in Fig.
3.84. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 3.84: The Setup Window for the Gaussian Laser Beam and Photonic Crystal Cavity example

Simulation Properties

This example contains a number of constants that are defined to make the simulation easily modifiable, as can be seen
in Fig. 3.85.

All the following constants should be the only properties you should need to alter in order to specify your simulation
domain.

General Simulation Parameters:

• L{X,Y,Z} = The length of your simulation domain in the {X,Y,Z} dimension.

• HT_{VACUUM,SI,SI02} = The height of the vacuum, SI and SI02 layers of the photonic crystal.

Source Specifications: (located in the Parameters section of the Elements Tree)

• {K_THETA,K_PHI,E_CHI} = The {polar angle, azimuthal, angle of polarization} respectively.
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Fig. 3.85: The Setup Window showing the constants

• WAVEL_CENTER = The central wavelength of your wideband signal. This is also the frequency used in
the single frequency simulation type.

• WAVEL_BAND = The wavelength width of your wideband signal, only used in wideBand simType.

• BEAM_WAIST = The width at which your beam power falls off like 1/e.

• BEAM_POWER = The amplitude of your E/M wave.

• GAUSS_ORIGIN_{X,Y,Z} = The point around which your Gaussian profile is centered.

• TURNONCYCLES = The number of cycles you want your single frequency to reach full power.

• SIMCYCLES = Number of wave cycles you want your simulation to run.

• CYCLESPERDUMP = Number of cycles between each dump in the simulation.

The tool used to input the wave into the simulation is a port launcher. It specifies the Electric Displacement Field (D)
at a boundary in this case the lower X boundary. The functions defining your D on the boundary are defined in the
SpaceTimeFunctions element of the Elements Tree.

SpaceTimeFunctions:

• dSingleFreq{Y,Z} = This is the {x,y,z} component of the single frequency Gaussian beam source, as
seen in Fig. 3.85. You put this as a parameter in the current distribution.

• dWideBand{Y,Z} = This is the {x,y,z} component of the wideband Gaussian beam source, as seen in
Fig. 3.85. You put this as a parameter in the current distribution.

To choose which signal you want to input into this example simulation:

1. Expand the FieldBoundaryConditions element.
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2. Left click on the portLauncherLowerX condition.

At this point, you should see what is shown in Fig. 3.86.

Fig. 3.86: The Setup Window for specifying the signal for the portLauncher

3. To add a signal to the portLauncherLowerX just right click on the D{x,y} and select Assign SpaceTimeFunction.
This will expand another menu that will show you all four defined SpaceTimeFunctions. Select which one you
want to input into your simulation. For this documentation, WideBand{Y,Z} will be used to demonstrate the
functionality of this example.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• One can enable MPI options to utilize multi-core systems.

• The default values of Number of Time Steps and Dump Periodicity are taken from the parame-
ters STEPSTOTAL and STEPSPERDUMP, which use the constants SIMCYCLES and CYCLESPERDUMP. The
formulae for these variables can be found back in the Setup Window. These variables are for convenience to
calculate good default values and it is important to know that the override option default values ultimately come
directly from the numbers in the Basic Settings section.

Number of Steps and Dump Periodicity. Just copy these values into the correct fields in the Run
menu.

– Number of Steps = TOTALSTEPS = 32220

– Dump Periodicity = STEPSPERDUMP = 3600
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• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.87.

Fig. 3.87: The Run Window for the Gaussian Laser Beam and Photonic Crystal Cavity example

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

In the simulation, there are specific grid points which store field histories. These histories are placed in various
positions of the simulation.

• In the top field of Visualization Controls, click the drop down menu and select History.

In Fig. 3.88, one can see there are 4 possible graphs to view at one time in the Visualize Window. For each graph, one
can select the following fields to analyze: (0 = x, 1 = y, 2 = z).

• {E,B}_AtDet_{0,1,2} is in the middle of (y,z) plane and 60 nm above the surface of the crystal.

• {E,B}_AtSrc_{0,1,2} is aligned with the inCav history in the (y,z) plane and is 60 nm below the Si layer, into
the SiO2 layer.

• {E,B}_InCav_{0,1,2} is slightly offset from the middle of one of the cavities in the silicon layer (the layer with
the lattice).

In each individual graph, one can choose the FFT option to view the frequency domain of your field. This can enable
the analysis of the frequency response of the photonic crystal cavity.

Fig. 3.88 depicts four graphs of histories. The first two graphs are amplitude vs time, and the second two are a FFT of
the first two on a log scale.
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The first and third graphs depict the history AtSrc_2, while the second and fourth graphs show the AtDet_2 history.

Fig. 3.88: The Visualize Window for the Gaussian Laser Beam and Photonic Crystal Cavity example

Further Experiments

By using the wideband source and examining the field strength detected below the crystal lattice, one may study
the frequency response of this photonic crystal as one changes the device geometry, the dielectric constants, and the
location and polarizations of the radiation source and detector.

3.5.8 Dipole Source Illuminating a Photonic Crystal Cavity (photonicCrys-
talDipoleSrc.sdf)

Keywords:

dipole source, photonic crystal, transmission efficiency

Problem description

This example illustrates how to model a dipole source that is illuminating cavities inside a hexagonal photonic crystal
lattice. The physical arrangement is shown in Fig. 3.89 and Fig. 3.90.

A point-like dipole lies above the simulation domain, which comprises three layers: a vacuum region above and a
solid dielectric below, which together sandwich a central dielectric layer that contains a lattice of holes. This example
includes two possible time signals with which to ring the dipole source, as shown in Fig. 3.91.

This simulation can be performed with a VSimEM license.

3.5. Photonics 139



VSim Examples, Release 9.0.2-r2448

Fig. 3.89: Top view of photonic lattice.

Fig. 3.90: Side view of photonic lattice.
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Fig. 3.91: Two possible time signals for ringing the dipole source.
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Opening the Simulation

This Photonic Crystal example is accessed from within VSimComposer through the following steps:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window, expand the VSim for Electromagnetics option.

• Expand the Photonics option.

• Select “Dipole Source Illuminating a Photonic Crystal Cavity” and press the Choose button.

• In the resulting dialog, create a new folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 3.92.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the photonic crystal geometry. To show or hide the grid, expand the Grid element and
select or deselect the box next to Grid.

Fig. 3.92: The Setup Window for the Dipole Source Illuminating a Photonic Crystal Cavity example

Simulation Properties

This example contains a number of constants defined to make the simulation easily modifiable, as can be seen in Fig.
3.93.

The following constants should be the only properties you should need to alter in order to specify your simulation
domain.

General Simulation Parameters:

• CYCLES_DRIVE = How many cycles at which the E/M source is driven.
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Fig. 3.93: The Setup Window showing the constants

• HT_{VACUUM,SI,SI02} = The height of the vacuum, SI and SI02 layers of the photonic crystal.

• L{X,Y,Z} = The length of your simulation domain in the {X,Y,Z} dimension.

Source Specifications: (located in the Parameters section of the Elements Tree)

• TURNONCYCLES = The number of cycles you want your single frequency to reach full power.

• WAVEL_BAND = The wavelength width of your wideband signal, if doing a wideband simulation.

• WAVEL_CENTER = The central wavelength of your wideband signal, and is the frequency used in the
single frequency simulation type.

• PVEC{X,Y,Z} = The {x,y,z} component of your moment vector for your dipole source.

• HT_DIPOLE = The height of the dipole from the lowerX boundary.

• SIMCYCLES = Number of wave cycles you want your simulation to run.

• CYCLESPERDUMP = Number of cycles between each dump in the simulation.

The tool used to input the wave into the simulation is a port launcher. It specifies the Electric Displacement Field
(D) at a boundary in this case the lower X boundary. The functions defining the D on the boundary are defined in the
SpaceTimeFunctions element of the Elements Tree.

SpaceTimeFunctions:

• dSingleFreqDipole{Y,Z} = This is the {x,y,z} component of the single frequency dipole source;
as seen in Fig. 3.94, you put this as a parameter in the PortLauncher.

• dWideBandDipole{Y,Z} = This is the {x,y,z} component of the wideband dipole source; as seen in
Fig. 3.94, you put this as a parameter in the PortLauncher.
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To choose which signal you want to input into this example simulation:

1. Expand the FieldBoundaryConditions tab.

2. Left click on the portLauncherLowerX condition.

At this point, you should see what is shown in Fig. 3.94:

Fig. 3.94: The Setup Window showing where to specifying the applied field signal for the port launcher

3. To change the signal applied to the portLauncherLowerX, right click on the Dx(x, y, z, t) or Dy(x, y, z, t)
property and select Assign SpaceTimeFunction. This will expand another menu that will show you all four
defined SpaceTimeFunctions. Select which one you want to input into your simulation. For this documentation,
dWideBandDipole{Y,Z} is selected by default to demonstrate the functionality of the example.

Running the Simulation

Once finished with the problem setup, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• One can enable MPI options to utilize multi-core systems.

• The default values of Number of Time Steps and Dump Periodicity are taken from the parame-
ters STEPSTOTAL and STEPSPERDUMP, which use the constants SIMCYCLES and CYCLESPERDUMP. The
formulae for these variables can be found back in the Setup Window. These variables are for convenience to
calculate good default values and it is important to know that the override option default values ultimately come
directly from the numbers in the Basic Settings section.

– Number of Steps = STEPSTOTAL = 36250

– Dump Periodicity = STEPSPERDUMP = 3600
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• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.95.

Fig. 3.95: The Run Window for the Dipole Source Illuminating a Photonic Crystal Cavity example

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

In the simulation, there are specific grid points which store field histories. These histories are placed in various
positions of the simulation.

• In the top field of Visualization Controls, click the drop down menu and select History.

In Fig. 3.96, one can see there are 4 possible graphs to view at one time in the Visualize Window. For each graph, one
can select the following fields to analyze: (0 = x, 1 = y, 2 = z).

• {E,B}_AtDet_{0,1,2} = In the middle of (y,z) plane and 60 nm above the surface of the crystal.

• {E,B}_AtSrc_{0,1,2} = Is aligned with the inCav history in the (y,z) plane and is 60 nm below the Si layer, into
the SiO2 layer.

• {E,B}_InCav_{0,1,2} = Is slightly offset from the middle of one of the cavities in the Silicon layer (the layer
with the lattice).

In each individual graph, one can choose the FFT option to view the frequency domain of your field. This can enable
the analysis of the frequency response of the photonic crystal cavity.

Fig. 3.96 depicts four graphs of histories. The first two graphs are amplitude vs time, and the second two are a FFT of
the first two on a log scale.
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The first and third graphs depict the history AtSrc_2, while the second and fourth graphs show the AtDet_2 history.

Fig. 3.96: The Visualize Window for the Dipole Source Illuminating a Photonic Crystal Cavity example

Further Experiments

By using the wideband source and examining the field strength detected below the crystal lattice, one may study
the frequency response of this photonic crystal as one changes the device geometry, the dielectric constants, and the
location and polarizations of the radiation source and detector.

3.6 Photonics (text-based setup)

3.6.1 Dipole Source Illuminating a Photonic Crystal Cavity (photonicCrys-
talDipoleSrcT.pre)

Keywords:

dipole source, photonic crystal, transmission efficiency

Problem description

This example illustrates how to model a dipole source that is illuminating a cavity inside a hexagonal photonic crystal
lattice. The physical arrangement is shown in Fig. 3.97 and Fig. 3.98.

A point-like dipole lies above the simulation domain, which is comprised of three layers: a vacuum region above and a
solid dielectric below, which together sandwich a central dielectric layer that contains a lattice of holes. This example
includes two possible time signals with which to ring the dipole source, as shown in Fig. 3.99.

146 Chapter 3. VSim for Electromagnetics Examples



VSim Examples, Release 9.0.2-r2448

Fig. 3.97: Top view of photonic lattice.

Fig. 3.98: Side view of photonic lattice.
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Fig. 3.99: Two possible time signals for ringing the dipole source.
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This simulation can be performed with a VSimEM license.

Opening the Simulation

This Photonic Crystal example is accessed from within VSimComposer through the following steps:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window, expand the VSim for Electromagnetics option.

• Expand the Photonics (Text-based setup) option.

• Select “Dipole Source Illuminating a Photonic Crystal Cavity (Text-based setup)” and press the Choose button.

• In the resulting dialog, create a new folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window,
as shown in Fig. 3.100. A WideBand simulation type (see the SimType input value) will be used to demonstrate the
functionality of this example.

Fig. 3.100: The Setup Window for the Dipole Source Illuminating a Photonic Crystal Cavity (Text-based
setup)example

Input File Features

The Input File is shown in Fig. 3.100. This specifies the parameters of the simulation in SI units, see Fig. 3.98 for
clarification.

General simulation parameters:

• NDIM = Number of dimensions (3).
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• SimType = {WideBand, SingleFrequency}

– WideBand = Runs the simulation with a wideBand electromagnetic wave as the source in
the simulation. The CyclesDrive parameter dictates how large this pulse is.

– SingleFrequency = Runs the simulation with a single frequency source. This fre-
quency is determined by the waveLengthCtr parameter.

• SimCycles = Number of cycles run in simulation.

• CyclesDrive = Number of cycles that the signal is driven.

• CyclesPerDump = Number of cyles per dump.

• NominalCellSize = The size of your cells; should be small enough to resolve your dielec-
tric cavities in the crystal.

Photonic crystal specifications:

• HoleDiam = Hole diameter, in meters.

• HolePitch = Hole spacing in the hexagonal lattice, in meters.

• NumHolesY = Number of rows of holes in the photonic crystal lattice.

• NumHolesZ = Number of columns of holes in the photonic crystal lattice.

• HtVacuum = Height of vacuum, along x-axis.

• HtSi = Height of silicon layer, along x-axis.

• HtSiO2 = Height of silica layer, along x-axis.

• IndexRefrSiO2 = Index of refraction for silica.

• IndexRefrSi = Index of refraction for silicon.

• MarginY = Size of buffer zone on each side of the photonic crystal in the y-direction.

• MarginZ = Size of buffer zone on each side of the photonic crystal in the z-direction.

Source specifications:

• HtDipole = Height of dipole, along x-axis.

• PVec{x,y,z} = The {x,y,z}-component of your dipole vector.

• WaveLengthCtr = The central wavelength of your wideband signal, and is the frequency
used as the single frequency simulation type.

• WaveLengthBand = The wavelength width of your wideband signal, only used in wideBand
simType.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• One can enable MPI options to utilize multi-core systems.

• The default values of Number of Time Steps and Dump Periodicity are calculated from the Cy-
cleDrive and CyclesPerDump in the Setup Window shown in Fig. 3.100.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.101.
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Fig. 3.101: The Run Window for the Dipole Source Illuminating a Photonic Crystal Cavity (Text-based setup) example

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

• In the top field of Visualization Controls, click the drop down menu entitled Data View and select History.

In the simulation, there are specific grid points which store field histories. These histories are placed in various
positions of the simulation.

In Fig. 3.102, one can see there are 4 possible graphs to view at one time in the Visualize Window. For each graph, one
can select the following fields to anaylize: (0 = x, 1 = y, 2 = z).

• {E,B}_AtCtr_{0,1,2} = {0,0} in {y,z} plane in the middle of SiLayer.

• {E,B}_AtDet_{0,1,2} = Just above the upper x boundary.

• {E,B}_AtSrc_{0,1,2} = Just below the source.

• {E,B}_InCav_{0,1,2} = In the cavity off center.

• E_AtHole_{0,1,2} = In the middle of the second hole.

• E_AtMargin{Z,Y}_{0,1,2} = Just inside the Z or Y margin.

• poyntingFluxDet = Just above the upper x boundary.

• poyntingFluxSrc = Just below the source.

In each individual graph, one can choose the FFT option to view the frequency domain of your field. This can enable
the analysis of the frequency response of the photonic crystal cavity. Fig. 3.102 depicts four graphs of histories. The
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first two graphs are amplitude vs time, and the second two are a FFT of the first two on a log scale. The first and third
graphs depict the history AtSrc_1, while the second and fourth graphs show the AtHole2_1 history.

Fig. 3.102: The Visualize Window for the Dipole Source Illuminating a Photonic Crystal Cavity (Text-based setup)
example

Further Experiments

By using the wide-band source and examining the field strength detected below the crystal lattice, one may study
the frequency response of this photonic crystal as one changes the device geometry, the dielectric constants, and the
location and polarizations of the radiation source and detector.

3.6.2 Gaussian Laser Beam and Photonic Crystal Cavity (photonicCrystalGaussS-
rcT.pre)

Keywords:

Gaussian Beam source, photonic crystal, transmission efficiency

Problem description

This example illustrates how to model a Gaussian beam source that is illuminating a cavity inside a hexagonal photonic
crystal lattice. The physical arrangement is shown in Fig. 3.103.

A Gaussian beam is launched from above into the simulation domain, which comprises three layers: a vacuum region
above and a solid dielectric below, which together sandwich a central dielectric layer that contains a lattice of holes.
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Fig. 3.103: Top view of the photonic lattice.
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This example includes two possible time signals for the Gaussian beam: WideBand or SingleFrequency, as shown in
Fig. 3.103.

This simulation can be performed with a VSimEM license.

Opening the Simulation

This example is accessed from within VSimComposer through the following steps:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window, expand the VSim for Electromagnetics option.

• Expand the Photonics (Text-based setup) option.

• Select “Gaussian Laser Beam and Photonic Crystal Cavity (Text-based setup)” and press the Choose button.

• In the resulting dialog, create a new folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 3.104. For this documentation, a WideBand SimType will be used to demonstrate the functionality
of this example.

Fig. 3.104: The Setup Window for the Gaussian Laser Beam and Photonic Crystal Cavity (Text-based setup) example

Input File Features

The setup shown in Fig. 3.104 specifies the parameters of the simulation in SI units. For a visual reference of what
these variables do, consult Fig. 3.103.

General simulation parameters:
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• NDIM = Number of dimensions (3).

• SimType = {WideBand, SingleFrequency}.

– WideBand = Runs the simulation with a wideBand electromagnetic wave as the source in
the simulation. The CyclesDrive parameter dictates how large this pulse is.

– SingleFrequency = Runs the simulation with a single frequency source. This fre-
quency is determined by the waveLengthCtr parameter.

• SimCycles = Number of cycles run in simulation.

• CyclesDrive = Number of cycles to drive the wideband source.

• CyclesPerDump = Number of cyles per dump.

• NominalCellSize = The size of your cells, should be small enough to resolve your dielec-
tric cavities in the crystal.

Photonic crystal specifications:

• HoleDiam = Diameter of each hole in crystal lattice.

• HolePitch = Distance between the center of each hole, all distances equal due to lattice.

• NumHolesY = Number of rows of holes.

• NumHolesZ = Number of columns of holes.

• HtVacuum = Height of vacuum, along x-axis.

• HtSi = Height of silicon layer, along x-axis.

• HtSiO2 = Height of silica layer, along x-axis.

• IndexRefrSiO2 = Index of refraction for silica.

• IndexRefrSi = Index of refraction for silicon.

• MarginY = How far the edge of the crystal is from your lattice in the x-direction.

• MarginZ = how far the edge of the crystal is from your lattice in the z-direction.

Source specifications:

• BeamPowr = Power of the beam.

• WaistDiam = Diameter of your Gaussian beam waist.

• {ThetaK,phiK,chiE} = The {polar angle, azimuthal, angle of polarization} respectively.

• WaveLengthCtr = The central wavelength of your wideband singal, and is the frequency
used as the single frequency simulation type.

• WaveLengthBand = The wavelength width of your wide band signal, only used in wideBand
simType.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• MPI can be enabled to utilize multi-core systems.

• The default values of Number of Time Steps and Dump Periodicity are calculated using by the
CyclesDrive and CyclesPerDump inputs in the Setup Window.
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• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.105.

Fig. 3.105: The Run Window for the Gaussian Laser Beam and Photonic Crystal Cavity (Text-based setup) example

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The input file specifies grid points at which to record field histories.

• In the top field of Visualization Controls, click the drop down menu and select History.

By default, there are 4 possible graphs viewable at one time in the Visualize Window. For each graph, one can select
from the following fields: (0 = x, 1 = y, 2 = z).

• {E,B}_AtCtr_{0,1,2} = {0,0} in {y,z} plane in the middle of SiLayer.

• {E,B}_AtDet_{0,1,2} = Just above the upper x boundary.

• {E,B}_AtSrc_{0,1,2} = Just below the source.

• {E,B}_InCav_{0,1,2} = In the cavity off center.

• E_AtHole_{0,1,2} = In the middle of the second hole.

• E_AtMargin{Z,Y}_{0,1,2} = Just inside the z or y margin.

• poyntingFluxDet = Just above the upper x boundary.

• poyntingFluxSrc = Just below the source.
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In each individual graph, one can choose the FFT option to view the frequency domain of your field. This can enable
the analysis of the frequency response of the photonic crystal cavity. Below, Fig. 3.106 depicts four graphs of histories.
The first two graphs are amplitude vs time, and the second two are a FFT of the first two on a log scale. The first and
third graphs depict the history AtSrc_2, while the second and fourth graphs show the AtDet_2 history.

Fig. 3.106: The Visualize Window for the Gaussian Laser Beam and Photonic Crystal Cavity (Text-based setup)
example

Further Experiments

By using the wide-band source and examining the field strength detected below the crystal lattice, one may study the
frequency response of this photonic crystal as the device geometry, dielectric constants, location and polarizations of
the radiation source and detector change.

3.6.3 Dielectric Waveguide with Mode Launcher using Point Permittivity (dielec-
tricWaveguideModeLaunchPPT.pre)

Keywords:

Mode Loading, Photonic Waveguide, Unidirectional Mode Launcher, MAL,
Guided Mode, Semiconductor

Problem description

The dielectric waveguide consists of a single, straight silicon waveguide that is parallel to the x-axis and centered at
the origin. The waveguide is surrounded by silica. Matched Absorbing Layers (MALs) are used to dampen the E and
B fields near the boundary of the simulation. This is a way to dampen reflected fields from the simulation boundaries.
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The fundamental guided mode is launched in the silicon waveguide in the +x direction. The fundamental mode was
extracted in the “Dielectric Waveguide Mode Calculation using Point Permittivty” example. The extractModesViaOp-
erator.py analyzer produced the eigenmode vsh5 which is loaded into this simulation.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The dielectric waveguide example can be accessed from within VSimComposer through the following steps:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window, expand the VSim for Electromagnetics option.

• Expand the Photonics (text-based setup) option.

• Select Dielectric Waveguide with Mode Launcher using Point Permittivity (text-based setup) and press the
Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

Some relvant parameters should now be visible as seen in Fig. 3.107. You can access more of the variables, functions,
and geometries by clicking View Input File in the tool bar.

Fig. 3.107: The Setup window for the dielectric waveguide example showing some relevant constants.

Simulation Properties

This example contains a number of constants defined to make the simulation easily modifiable. Some relevant con-
stants are listed below.
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PERMITTVITY_WAVEGUIDE and PERMITTVITY_BACKGROUND: Relative permittivities of silicon and silica.
These constants are used in multiple parameters and in the accompanying Python file for solving the waveguide modes.

LENGTH_UNIT: The constant factor by which VSim will scale all simulation lengths.

WAVELENGTH_VAC: Wavelength of the input signal. This wavelength is also used for the calculation of the funda-
mental guided mode of the device.

NWAVELENGTH_MAL: Approximate number of wavelengths that can fit in a MAL region. The thickness of the
MAL regions in this example are measured in wavelengths.

In photonics simulations, Matched Absorbing Layers (MALs) are the most stable boundary conditions for preventing
reflections. The eigen mode is imported form a vsh5 file. This can be seen in the input file.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column. You will be asked to Save. Click
Save.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” The
result is shown in Fig. 3.108.

Fig. 3.108: The output after a successful run.

Visualizing the Results

Then proceed to the Visualize window by pressing the Visualize button in the left column.

3.6. Photonics (text-based setup) 159



VSim Examples, Release 9.0.2-r2448

A useful visualization of the dielectric waveguide would be to view the y-component of the E field to qualitatively see
the mode propagate down the waveguide.

• Near the top left corner of the window, make sure Data View is set to Data Overview.

• Expand Scalar Data, expand E, and select E_y

• In the controls below the variables frame, select Clip All Plots.

• In the top of the screen, press the button that’s titled Colors, check the Fix Minimum and Fix Maximum buttons,
and input {-.03, .03} for the min and max, respectively.

Fig. 3.109 shows an example of what one should expect if one has run the simulation for enough cycles.

Fig. 3.109: Visualization of the B field’s Z component

Further Experiments

One can experiment by changing constants or introducing a different signal to drive the waveguide.

3.6.4 Drude-Lorentz MIM Waveguide (MIMwaveguideT.pre)

Problem Description

A metal-insulator-metal (MIM) waveguide can propagate optical frequency electromagnetic radiation due to the ef-
fective negative index material property of the metal at those frequencies. This negative index material is represented
with a time-domain Drude model dielectric, which can support a wide range of frequencies and wide bandwidth.
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In addition to the MIM waveguide, a section of the insulator is removed, and replaced with a resonant absorber
material, using a time-domain version of the traditional Lorentz material.

Fig. 3.110: Longitudinal electric field in the MIM waveguide.

A spatial gaussian waveform is incident on the edge of the MIM waveguide, coupling to it, and propagating down
the length of the waveguide until it encounters the Lorentz material inclusion, where the wave is absorbed. For the
incident wave to couple effectively to the MIM waveguide, the spatial size of the gaussian waveform must be a good
match to the size of the waveguide, or a large portion of the incident wave will scatter off the structure, rather than
coupling to it.

Also, the width, strength, and natural frequency of the Lorentz material inclusion determines whether the wave is
reflected, absorbed, or transmitted when it encounters the inclusion.

The length of the MIM waveguide, and the direction of wave propagation is in the x-direction. The width of the
waveguide is in the z-direction, and the height of the waveguide is in the y-direction. The waveguide sits atop an
insulator substrate, and is surrounded by air. The boundaries of the simulation are ports, allowing for incoming and
outgoing waves.
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Fig. 3.111: Transverse electric field in the MIM waveguide.

This simulation is the primary example demonstrating the use of the general purpose Drude-Debye-Lorentz-Dielectric
macro file, DrudeDebyeLorentzDielectric. Calls to these macros can be found by searching the input file for the string
“DDLD”.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The MIM waveguide example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides (text-based setup) option.

• Select “Drude-Lorentz MIM Waveguide (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem will now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 3.112.

Input File Features

The input file allows the user to choose the waveguide geometry parameters, the material properties of the Drude
metal, insulator, and Lorentz inclusion, and the frequency and spatial size of the incident wave.

The input file also contains a parameter to adjust the spatial resolution of the mesh.

Default parameters are selected to correspond to violet light, a Drude material corresponding to silver, SiO2 insulator
(and substrate), and a Lorentz material corresponding to AlAs. The default variable values can be compared to the well
known material properties of these materials to establish the exact correspondence to the well-known mathematical
descriptions of the Drude and Lorentz models.

162 Chapter 3. VSim for Electromagnetics Examples



VSim Examples, Release 9.0.2-r2448

Fig. 3.112: Setup Window for the MIMwaveguideT example.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 3.113.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The results are best viewed by looking at the 𝑦 component of the electric field. To view the fields:

• Expand Scalar Data

• Expand edgeE

• Select edgeE_y

• Select the Clip All Plots checkbox

• Move the dump slider forward in time

You can add the structure by expanding Geometries and selecting the poly box. The field is shown in Fig. 3.114.
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Fig. 3.113: The Run Window at the end of execution.

Fig. 3.114: Visualization of the 𝐸𝑦 field component.
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We can see that fields are well coupled between the two metal layers of the waveguide, with only some small leakage,
and transient behavior at the entrance. The fields then diminish abruptly at the inclusion, where the wave is mostly
absorbed.

3.7 Scattering

3.7.1 Scattering off Multiple Objects (dielecPlusMetalObjs.sdf)

Keywords:

electromagnetics, pulse, dielectric

Problem Description

The Scattering off Multiple Objects simulation illustrates the ability to define different materials with different dielec-
tric properties (perfect electric conductor, sapphire, alumina) and have an electromagnetic pulse reflect off of both a
complex metal surface and dielectric medium. It also illustrates a wave launcher to be used with different dielectric
materials. This example can also be modified to calculate Radar Cross Sections.

This simulation can be performed with a VSimEM, VSimMD or VSimPD license.

Opening the Simulation

The Scattering off Multiple Objects example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Scattering option.

• Select “Scattering off Multiple Objects” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
3.115. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Simulation Properties

This simulation includes just 1 user defined constant, WAVELENGTH, and just 2 user defined parameters, FRE-
QUENCY and OMEGA. These three terms will define the incoming wave which is defined in the SpaceTimeFunctions
element.

CSG shapes are used to define the geometries of the simulation. A sphere is unioned with a cylinder and given a
material of sapphire. The box is an alumina structure and the truncated cone serves as a perfect electric conductor.

Placing all of these shapes and various materials in the same simulation shows the how the electromagnetic wave can
scatter off of different materials.
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Fig. 3.115: Setup Window for the Scattering off Multiple Objects example.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Here you can set run parameters, including how many cores to run with (under the MPI tab).

• When you are finished setting run parameters, click on the Run button in the upper left corner of the Logs and
output Files pane. You will see the output of the run in the right pane. The run has completed when you see the
output, “Engine completed successfully.” This is shown in Fig. 3.116.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric field, as well as the geometries as shown in Fig. 3.117, do the following:

• Expand Scalar Data

• Expand E

• Select E_z

• Expand Geometries

• Select poly (AluminaObject) poly (PECObject) poly (sapphireObject)

• Select Clip All Plots
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Fig. 3.116: The Run Window at the end of execution.

• Above the image, select Colors

• In the Color Options window set the color table to hot_desaturated and fix the minimum and maximum values
to -2 and 2, respectively.

• Click Apply, followed by OK.

Initially, no field will be seen, as one is looking at Dump 1 when no fields are yet in the simulation. Move the slider at
the bottom of the right pane to see the electric field at different times.

In this example, it is beneficial to change the color table to better see the fields penetrating the dielectric objects. To
do this, click on the Colors button at the top of the visualization and select “hot_desaturated”, for example.

Further Experiments

One idea is to include radar cross section histories at setup time to be able to visualize the far fields.

This example is easily modifiable to include a different geometry and wave form.

Try changing the materials to see how it affects the wave.

3.8 Scattering (text-based setup)

3.8.1 Ground Penetrating Radar (groundPenetratingRadarT.pre)

Keywords:
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Fig. 3.117: Visualization of wave as it hits the objects.

GPR, ground penetrating radar, lossy dielectric

Problem description

This simulation launches a plane wave, polarized in the Z-direction into a lossy dielectric. Embedded within the lossy
dielectric is a mine, modelled as a pure electric conductor. The return wave at the surface can be monitored with
histories. The simulation is 2D, but with minor effort can be expanded to 3 dimensions.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Ground Penetrating Radar example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Scattering (text-based setup) option.

• Select “Ground Penetrating Radar (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The key parameters of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 3.118.
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Fig. 3.118: Setup Window for the Ground Penetrating Radar example.

Input File Features

This file allows for the modification of plane wave operating frequency, simulation domain size, resolution, dielectric
permittivity, size and conductivity, mine size and location as well as history location.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in the window below.

Visualizing the Results

• After the simulation has completed running, click on the Visualize Window.

The electric field can be viewed by:

• Expand Scalar Data

• Expand E

• Select E_z

• Expand Geometries
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Fig. 3.119: The Run Window at the end of execution.

• Select poly

• Move the dump slider forward in time

The wave reflection measured at the three surface locations can be viewed under the Histories Data View

Further Experiments

The parameters of the dielectric can be easily modified. It would also be possible to modify the sources to be horn
antennas instead of point sources; this would more accurately model a real world ground penetrating radar situation.

3.8.2 Radar Cross Section of a Cylinder (radarCrossSectionT.pre)

Keywords:

RCS, far field, radar cross section

Problem description

This simulation launches a plane wave, polarized in the Y-direction at a conducting cylinder in free space. After the
plane wave has been launched the Radar Cross section is computed. This problem is a template to solve any Bistatic
radar cross section problem.

This simulation can be performed with a VSimEM license.
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Fig. 3.120: The electric field in the simulation space. Seen here: the cylindrical cone mine-shape.

Opening the Simulation

The radarCrossSectionT example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Advanced Examples (Text-based setup) option.

• Select “Radar Cross Section” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The key parameters of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in the figure Fig. 3.121.

Input File Features

This file allows the modification of plane wave operating frequency, orientation, simulation domain size and far field
resolution. This file has had it’s accuracy reduced marginally in order to reduce run time. It is generally recommended
that between 10 and 20 points per wavelength are used for full accuracy.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.
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Fig. 3.121: Setup Window for the Radar Cross Section example.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 3.122

Analyzing the data

To calculate the radar cross section at far field, complete the following steps:

• Proceed to the Analysis window by pressing the Analyze button in the left column of buttons.

• Click ‘Show All Analyzers’

• In the resulting dialog, select computeFarFieldFromKirhhoffBox.py (Fig. 3.123) and press Open.

• Input values for the analyzer parameters. The analyzer may be run multiple times, allowing the user to experi-
ment with different values.

– simulationName - radarCrossSectionT (name of the input file)

– fieldLabel - E (name of the electric field)

– farFieldRadius - 10.0 (distance to far field in m, 10.0 is a good value)

– timeStepStride - 20 (number of timesteps between far field calculations; determines how many far fields
are output; 20 steps should yield 4 far fields in this case)

– getFourierComponent - 0 (whether to fourier analyze for a particular frequency)

– frequency - the frequency to use in the fourier analysis (not needed here).

– numTheta - 60 (number of theta points in the far field, 18 for a quick calculation, 45 for finer resolution)
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Fig. 3.122: The Run Window at the end of execution.

Fig. 3.123: The Analysis Window after running
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– numPhi - 120 (number of phi points in the far field, 36 for a quick calculation, 90 for finer resolution)

– zeroThetaDirection - (0,0,1) (determines orientation of far field coordinate system)

– zeroPhiDirection - (1,0,0) (determines orientation of far field coordinate system

– varyingRadiusMesh - 0 (Set to 1 in order to make far field mesh adapt to magnitude of far field solution:
the classic lobe view)

– simpsonIntegration - 0 (Set to 1 for more accurate integration)

Fig. 3.124: The Analysis Window after running

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The Radar cross section as shown in Fig. 3.125, do the following:

• Expand Scalar Data

• Select farE

• Expand Geometries

• Select farSphere

• Select poly

• Select Clip All Plots

You should see the far field, time-dependent signal on the sphere with the cylinder in the center.
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Fig. 3.125: The radar cross section

Further Experiments

The physical dimensions of the cylinder can be modified from the parameters window.

3.9 Other EM

3.9.1 Spherical Lens (sphericalLens.sdf)

Keywords:

refraction, focusing, dielectrics

Problem Description

The Spherical Lens is a full wave solution to a simple, thin lens with spherical surfaces. Focusing occurs because light
rays farther from the center hit the surface at a more oblique angle, resulting in more bending, according to Snell’s
law. The focusing length of a spherical lens is given by 𝑓 = 𝑅/(2 − 2/𝑒𝑝𝑠

1/2
𝑟 ), where math:eps_r is the relative

permittivity of the material making up the lens.

This simulation can be performed with a VSimEM license.

Opening the Simulation

The Spherical Lens example is accessed from within VSimComposer by the following actions:
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• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electro option.

• Expand the Other EM option.

• Select “Spherical Lens” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the setup window as shown in Fig.
3.126. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 3.126: Setup window for the Spherical Lens example.

Simulation Properties

The spherical lens is constructed in CSG using the intersection of two spheres. You can pull the spheres apart to get a
taller lens, and you can change the radius of the spheres to have a lens with more curvature. The grid is set so that it
will capture the focus at the right for the initial setup.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.
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• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 3.127.

Fig. 3.127: The Run window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize window by pressing the Visualize button in the left column of buttons.

To see the field focus after the lens as shown in Fig. 3.128, do the following:

• Expand Scalar Data, expand E

• Select E_z

• Click the Colors button and set the minimum to -1 and the maximum to +1.

• Expand Geometries

• Select poly

• Select Clip all plots

• Move the dump slide to the right to see the wave come in, focus after the lens, and then diverge again after
approximately x=0.4. One can see interference of the incoming wave with the reflection off the face of the lens.
One can also see interference patterns within the lens.
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Fig. 3.128: Visualization of the lens focusing

Further Experiments

Use a material of larger dielectric constant to see more focusing.

Reduce the sphere radii to have more focusing.

3.10 Other EM (text-based setup)

3.10.1 Specific Absorption Rate (humanHeadT.pre)

Keywords:

dielectrics, power calculations, stl files

Problem Description

The Specific Absorption Rate simulation computes the power absorption in a human head where the brain tissue is
approximated using the salt water model. A dipole source is included to imitate a simple antenna source from a cell
phone. This example can serve as the basis for a true specific absorption rate calculation for a human head with a
source coming from a cell phone antenna.

This simulation can only be performed with a VSimEM, VSimMD or VSimPD license.
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Opening the Simulation

The Human Head example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Other EM (text-based setup) option.

• Select “Specific Absorption Rate (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the right pane of the “Setup” window,
as shown in humanheadtsetupwin.

Fig. 3.129: Setup window for the Human Head example.

Input File Features

The input file allows one to select the frequency of the dipole source as well as the number of grid points to include per
wavelength for the wave in a vacuum. One can also set the dielectric value and conductivity value in the human head.
We have also included the ability to select the position of the dipole source approximating the cell phone antenna.
A voxel representation of the human head can also be used for more specific tissue values via a voxel dat file with
python.

Running the Simulation

After performing the above actions, continue as follows:
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• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 3.130.

Fig. 3.130: The Run window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize window by pressing the Visualize button in the left column of buttons.

To create the image shown in Fig. 3.131:

• Expand Scalar Data

• Select ESquared

• Expand Geometries

• Select poly

• Select Log Scale Color

• Select Display Contours and set the # of contours to 7

• Select Clip All Plots

• Click the Plane Controls button and set the Clip Plane Normal to X

• Set the Origin Of Normal Vector to X = 0.1, Y = 0, Z = 0
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• Move the dump slider forward in time

• Click and drag with the mouse to rotate the image

Fig. 3.131: Visualization of the absorption of power by a human head via a clip.

Further Experiments

We suggest the user change the frequency of the dipole source to imitate different cell phone models at different
frequencies.

We also suggest the user change the position of the dipole implying a change in location of the cell phone antenna.

It would also be interesting to change the dielectric and conductivity value to model a dipole source in a vacuum.

3.10.2 Photonic Crystal in Metal Cavity (phcInMetalCavityT.pre)

Problem Description

A photonic crystal (PhC) is capable of confining electromagnetic fields in waveguides and cavities using a periodic
geometry. This simulation features a dielectric photonic crystal cavity—a triangular lattice of dielectric rods, with one
rod removed—inside a metal cavity. The cavity axis, and the dielectric rods, are in the 𝑧 direction.

The photonic crystal structure is similar to that described in [BWC08], truncated after two layers of the lattice structure.
The metal cavity resembles an elliptical (or rounded pillbox) cavity, with short beam tubes.

Modeling dielectric and metal can be difficult: at dielectric corners or triple points (where dielectric, metal, and vacuum
meet), the electromagnetic fields generally must diverge (to infinity) to preserve continuity dictated by Maxwell’s
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Fig. 3.132: The metal cavity surrounding the PhC structure.
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Fig. 3.133: The vacuum region (inside the metal cavity, outside the dielectric rods).

equations [Had02]. However, when the interface between dielectric and vacuum is always perpendicular to the metal
surface, as in this simulation, the fields remain finite.

This simulation demonstrates a method for combining dielectric and metal, as long as the metal surface is perpendicular
to 𝑥, 𝑦, or 𝑧 whenever it intersects dielectric (and the vacuum/dielectric interface remains perpendicular to the metal
surface at those points).

When the PhC cavity mode is excited, the fields are trapped radially mainly by the dielectric rods.

This simulation can be performed with a VSimEM, VSimMD or VSimPA license.

Opening the Simulation

The PhC in Metal Cavity example is accessed from within VSimComposer by the following actions

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Electromagnetics option.

• Expand the Other EM (text-based setup) option.

• Select “Photonic Crystal in Metal Cavity (text-based setup)” and press the Choose button.

• In the resulting dialog, create a new folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem will now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 3.134.

Input File Features

The input file allows the user to choose the dielectric contrast and radius of the rods, the shapes and sizes of the cavity
and beam tubes (to some extent), the grid resolution, and the number of oscillations to simulate after excitation. The
entire simulation is scaled to the lattice constant, which is set to 1 by default.
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Fig. 3.134: Setup Window for the phcInMetalCavityT example.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right pane of the window. You will see the
output of the run in that pane. The run has completed when you see the output “Engine completed successfully.”
This is shown in Fig. 3.135.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

Due to the symmetry of this system, the results are best viewed by looking at the 𝑧 component of the electric field as
follows:

• Expand Scalar Data

• Expand edgeE

• Select edgeE_z

• Select Clip All Plots

• Click Plane Controls and set the Normal in the 𝑧-direction

• Expand Geometries

184 Chapter 3. VSim for Electromagnetics Examples



VSim Examples, Release 9.0.2-r2448

Fig. 3.135: The Run Window at the end of execution.

• Select poly

The field at dump 2 is shown in Fig. 3.136.

We can see that fields are trapped by the two layers of dielectric rods, and to a lesser (but final) extent by the surround-
ing metal cavity.
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Fig. 3.136: Visualization of the 𝐸𝑧 field component.
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CHAPTER

FOUR

VSIM FOR MICROWAVE DEVICE EXAMPLES

These examples illustrate how to solve complex problems in microwave devices.

These examples can be run with a VSimMD license.

4.1 Cavities and Waveguides

4.1.1 Coaxial Cylinder (coax.sdf)

Keywords:

coax, coaxial geometry, cylinder, current pulse, rlc circuit, step potential

Problem description

This example probes the electromagnetic properties of a semi-infinite coaxial cylinder. One end of the cylinder lies
in the simulation space. The length of the cable is large compared to its diameter. The outer radius is 8 cm, the inner
radius is 2 cm, and the section considered is 20 cm long. The inner cylinder is shorter than the outer cylinder and
there is an electron absorbing cap on the end of the outer cylinder. When the simulation initiates, a single EM pulse is
launched into the open, continuous end of the geometry and propagates to the capped tip. Electrons are ejected from
the tip of the inner cylinder when the pulse reaches it.

This computational model is equivalent to applying a step-potential to one end of a coaxial cable. The step-potential
propagates at the speed of light until it reaches the tip of the inner cylinder. The RLC nature of the coax cable causes
overshoot and ringing of the potential. At the inner tip, an attenuating series of oscillations occurs accompanied by
electron emissions. Gradually the tip potential stabilizes at the applied potential.

This simulation can be performed with a VSimMD license.

Opening the simulation

The coax example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides option.

• Select Coaxial Cylinder and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.
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Fig. 4.1: The electrons are emitted from the tip of the inner cylinder after the pulse reaches it.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 4.2.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.

Simulation properties

The coax example includes several Constants for easy adjustment of simulation properties. Those include:

• TFACTOR: A ramping factor of the applied field

• EFACTOR: The amplitude of the applied field

• EMITTED_CURRENT: The current emitted from the tip of the inner cylinder

There are also several SpaceTimeFunctions defined for easy application to wave launchers and particle emitters. Those
include:

• edgeDy: The applied field in the y-direction

• edgeDz: The applied field in the z-direction

• nomask: This allows emission from the entire geometry of the flux emitter

Other Properties of the simulation include CSG defined geometries, a wave launcher on the lower x boundary, and a
settable flux emitter on the tip of the inner cylinder.

Running the simulation

After performing the above actions, continue as follows:
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Fig. 4.2: Setup Window for the Coaxial Cylinder example.

• Proceed to the Run Window by pressing the Run button in the left column.

• To run the file, click the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.3.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by clicking the Visualize button in the left column.

To create the image seen in Fig. 4.4, proceed as follows:

• In the variables tree expand Scalar Data

• Expand E

• Select E_y

• Expand Geometries

• Select poly (coaxGeom)

• Beneath the variables tree, select Display Contours and set the # of contours to 10

• Select Clip All Plots

• In the Particle Style section, set the size to 6 and choose Sphere for Symbol

• In the variables tree expand Particle Data
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Fig. 4.3: The Run Window at the end of a successful execution.

• Expand electrons

• Select electrons_ux

• Now in the right pane move the dump slider forward in time

• The axis and legends can be hidden using the dropdown menu in the lower left corner of the window

To obtain a clearer picture of what is happening at the cylinder tip, switch the Data View (in the left pane) to History.
One dimensional plots of the number of electrons (called numMacroPtcls), the electric potential (phi), and the emitted
and absorbed current should come up automatically.

You can set the location of Graph 2 to Window 1 as in Fig. 4.5.

The potential is measured between the interior of the inner cylinder and the capped end of the outer cylinder. The
plot of the potential is noisy due to the emission of electrons from the tip. It may be insightful to run the simulation
once without electrons so you can see the ringing on the waveform of phi. A similar signal is obtained by hooking up
an oscilloscope to a coaxial cable. Electrons can be suppressed by setting the EMITTED_CURRENT parameter to 0
during setup.

The coaxial cylinder behaves like an RLC circuit: the cylinders provide a series resistance along their length, they are
coupled capacitively, and generate self-inductance due to the current. By default, the rise-time of the pulse is near the
resonance of the circuit, resulting in an acceptable rise time, low overshoot, and quick damping. This makes it a good
driver of the circuit.

Further Experiments

Try experimenting with different dimensions of coax. In particular, note how the radii and pulse profile affect the
potential response on the phi History plot.
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Fig. 4.4: Visualization of the coaxial cylinder as a color contour plot.

Fig. 4.5: The History visualization window with the electrons.
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4.1.2 Cylindrical Waveguide (cylindricalWaveguide.sdf)

Keywords:

electromagnetics, waveguide, dispersion

Problem Description

This VSimMD example illustrates how to find the modes of a cylindrical waveguide.

This simulation can be performed with a VSimMD license.

Simulation Properties

A section of cylindrical waveguide is simulated with the goal of extracting its propagating mode frequencies. The
simulation is only two cells wide in X, but through the use of a phase-shifting periodic boundary condition, a much
longer waveguide is simulated. The modes are extracted for longitudinal k-vectors, 2𝜋𝑛

𝐿𝑥
. The maximum current

is 𝐼0 = 𝐼 (𝜏/2). The waveguide is first excited with a transverse current that is off axis so as to excite modes of
any symmetry. The temporal excitation is chosen to excite only a range of frequencies, from somewhat below the
lowest cutoff up to the modes corresponding to 𝑛 = 1. The Fourier transform of a history recording the electric field
shows a clean output with a modest number of modes. Precise values for those frequencies can be obtained using the
extractModes analyzer.

Opening the Simulation

The Cylindrical Waveguide example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides option.

• Select Cylindrical Waveguide and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 4.6.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. (To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.) For the current view, the setup has been rotated
to be able to see down the waveguide, and the view of the grid has been turned off. The box inside the waveguide is
the location of the current source that will drive the waveguide.

Opening Functions of the tree shows a function, freqBandPulse, which is

𝑓𝑟𝑒𝑞𝐵𝑎𝑛𝑑𝑃𝑢𝑙𝑠𝑒(𝑡, 𝑓𝑙, 𝑓ℎ, 𝛿𝑓 , 𝑡𝑜𝑓𝑓 ) = 𝐻(𝑡𝑜𝑓𝑓 − 𝑡)𝑒𝑥𝑝(−𝛿2𝑓 (𝑡− 0.5𝑡𝑜𝑓𝑓 )2)
𝑠𝑖𝑛(2𝜋𝑓ℎ(𝑡− 0.5𝑡𝑜𝑓𝑓 )) − 𝑠𝑖𝑛(2𝜋𝑓𝑙(𝑡− 0.5𝑡𝑜𝑓𝑓 ))

(2𝜋𝑓ℎ − 2𝜋𝑓𝑙)(𝑡− 0.5𝑡𝑜𝑓𝑓 )

This function has a Fourier spectrum that is fairly flat for 𝑓𝑙 < 𝑓 < 𝑓ℎ and falls off rapidly over a frequency width of
𝛿𝑓 , so that it is nearly zero for 𝑓 < 𝑓𝑙 − 𝛿𝑓 or 𝑓 < 𝑓ℎ + 𝛿𝑓 . This excitation gives a range of modes to be analyzed.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run icon in the left panel.
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Fig. 4.6: Initial Setup Window for the Cylindrical Waveguide example.

• Check the center panel that you will run for 20,000 steps, dumping every 2,000.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.7.

Visualizing the spectrum

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize icon in the left panel.

• Select History under Data View.

• For Graph 4, select <None> to be plotted.

• Then for each plot select the FFT checkbox

• In the upper right corner of each plot, select Limits and set X-Axis max to 2e9.

• The result should be that shown in Fig. 4.8.

One can see the TM mode in this spectrum. One can measure the mode frequency by projecting the spectrum down
on the axis. With this simulation of 20,000 steps, for a total time of 103 ns, one expects the peak to have a width of
roughly 1/103 ns or 0.01 GHz. This gives the error in the frequency from this method.
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Fig. 4.7: Run Window for the Cylindrical Waveguide example after the initial run.

Fig. 4.8: Spectrum for the Cylindrical Waveguide example after the initial run.
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Analyzing the Spectrum

We can obtain more accurate frequencies using the Filter Diagonalization Method. To do this, we need to take a bit
more data. We need to have the number of dumps equal to three times the number of modes, so we run again, restarting
from dump 10 for another 300 steps, dumping every 50 time steps. This will give us an additional 6 dumps. The Run
Window for this part of the simulation is shown in Fig. 4.9.

Fig. 4.9: Run Window for the Cylindrical Waveguide example for the second run.

We now move to the Analyze Window, open extractModes, and set the field to be E. Then set the number of modes to
be 2, and the begin and end dumps to be 10 and 16, respectively. Also set sampleType to 1. Upon hitting the Analyze
button in the upper right, one sees the analysis output as shown in Fig. 4.10.

The computed mode frequencies are shown along with the inverse-Q values. Since this system is not lossy, the values
of invQ, when significant, indicate that the mode calculations are dubious. However, we see that the 2nd mode has
been well obtained.

These modes will now show up in the visualize panel, where one can reload the data, and modes will show up as seen
in Fig. 4.11. The well obtained mode occupies dumps 1-16.

4.1.3 Pillbox Cavity (pillboxCavity.sdf)

Keywords:

Pillbox cavity, Figures of merit, Transit time factor, Geometry factor
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Fig. 4.10: Analysis window for the Cylindrical Waveguide example for mode extraction.
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Fig. 4.11: Analysis window for the Cylindrical Waveguide example for mode extraction.
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Problem description

This VSimMD example demonstrates the usage of VSim in computing the eigenmodes and figures of merit of two
simple cavities. One may select either the closed pillbox cavity for which the analytic solution is well known, or a
cavity based on the closed pillbox, but having outlets leading to the periodic domain boundaries. Like other examples
utilizing the extractModes.py analyzer, the simulation run is done in two steps. In the first step, the cavity is excited by
a sinc pulse current source and output is dumped only at the end of this excitation run. Then in the second step, output
is dumped at intervals which are sufficiently short compared to the frequencies of interest. The output from the second
run is used by the extractModes.py analyzer to compute the eigenmodes. Then, the computeTransitTimeFactor.py and
computeCavityG analyzers are used to compute the transit time factors and geometry factors of the eigenmodes.

This simulation can be performed with a VSimMD or VSimEM license.

Opening the Simulation

The pillbox cavity example is accessed from within VSimComposer by the following actions:

• Go to File → New → From Example. . .

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides option.

• Select “Pillbox Cavity” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The properties and values that create the simulation are accessible in the left pane when the Setup Window is selected.
The right pane shows a 3D view of the selected geometry components, grids and current distributions.

The geometry of the closed pillbox cavity is called pillboxCavityAnalytical and the geometry of the periodic cavity with
outlets on either end is called pillboxCavityWithTube. These can be visualized individually by expanding Geometries,
de-selecting and then expanding CSG, and then selecting either pillboxCavityAnalytical or pillboxCavityWithTube.

Running the Simulation and Analyzing Results

Step 1: Cavity selection

• If you want to model the closed cavity, skip Step 1 and go to Step 2. The closed cavity is set by default.

• To model the periodic cavity, go to the Setup Window.

• Go to Geometries → CSG.

• Click on pillboxCavityAnalytical under CSG.

• The bottom left pane will show properties of the selected geometry. At this time, the material should be set to
PEC (perfect electric conductor). Double click on PEC and select the blank line.

• Now click on pillboxCavityWithTube under CSG.

• Select PEC as the material for pillboxCavityWithTube.

Step 2: Excitation

• Go to the Run Window by pressing the Run button in the left column of buttons.

• This simulation may be accelerated by running on multiple MPI ranks. The parallel options are in the Parallel
Run Options box below Additional Run Options in the Runtime Options pane.
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Fig. 4.12: Visualizing the periodic cavity geometry in the Setup Window.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will see
the output of the run in this pane. The simulation will run for 30000 time steps and dump output once at the end.
The run has completed when you see the output, “Engine completed successfully.” A snapshot of the simulation
run completion is shown in Fig. 4.13.

Step 3: Evolving the excited cavity

• After the first step is complete, change Number of Steps to 2000, change Dump Periodicity to 100.

• In the Additional Run Options Box, make sure that the Dump at Time Zero box is unchecked and that Restart at
Dump Number is set to 1.

• Click run. The run has completed when you see the output, “Engine completed successfully.” A snapshot of the
simulation run completion is shown in Fig. 4.14. When this run is finished, the last step should be step 32000.

Note: The simulation must be run in two steps because there must be no driving currents flowing in the simulation
while dumping data used to extract the eigenmodes. So, while the drive is ringing the cavity, there is no need to dump
data. We switch the dump periodicity after the driving current has shut off in order to resolve the frequency of the
eignemodes of interest.

Step 4: Computing the eigenmodes

• Go to the analyzer window by selecting Analyze in the left column.
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Fig. 4.13: The Run window at the end of a successful execution.

Fig. 4.14: The Run window at the end of a successful execution.
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• Select extractModes.py from the set of default analyzers. Then click “Open” on the bottom right of the Analysis
Controls pane.

• Compute the electric field eigenfunctions. After the analyzer loads, ensure the following parameters are entered:

– simulationName: “pillboxCavity”

– field: “E”

– beginDump: “2”

– endDump: “21”

– nModes: “5”

– sampleType: “0”

– numberUniformPoints: “20”

– numberRandomPoints: “100”

– construct: “1”

Also, check the “Overwrite Existing Files” box. Double-check your entries against what is shown in Fig. 4.15.

Fig. 4.15: Computing the electric field eigenfunctions and frequencies using the extractModes.py analyzer.

• Press the Analyze button which is located in the upper right corner.

• Compute the magnetic field eigenfunctions. Change field to “B” and press Analyze again. After the analysis is
finished, and scrolling down in the Outputs log pane you should see what is shown in Fig. 4.16.

• Note that extractModes.py outputs the frequencies of the computed modes in the Run Output pane. The first
mode, mode 0, should have a frequency of approximately 1 GHz.
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Fig. 4.16: The Outputs pane after Analyzing to determine the eigenmodes of the magentic field.

Step 5: Computing the transit time factor

• Select computeTransitTimeFactor.py from the default analyzers and press “Open” on the bottom right of the
Analysis Controls pane.

• After the analyzer loads, ensure the following parameters are entered:

– simulationName: “pillboxCavity”

– beginDump: “0”

– endDump: “0”

– beta: “1”

– axis: “0”

– offsetx0: “0”

– offsetx1: “0”

And compare against what is shown in Fig. 4.17

• Press Analyze.

• If you have selected the closed cavity, the transit time factor (the value following “Transit time factor, T=Vacc/V0
=”) should be very close the the analytic value of 2/𝜋.
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Fig. 4.17: Computing the transit time factor for the eigenmode of interest.

Step 6: Computing the geometry factor

• Select computeCavityG.py and click “Open”.

• If you have selected the closed cavity, then enter “pillboxCavityAnalytical” for cavityGeometryName. Other-
wise, enter “pillboxCavityWithTube” for cavityGeometryName.

• Select begin dump to 0 and end dump to 2.

• If you have selected the closed cavity, the geometry factor should be very close the the analytic value of 257.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To see the projection of the magnetic field of the fundamental mode onto the cavity walls, do the following:

• Ensure that Data Overview is selected from the Data View drop down menu.

• Expand Scalar Data

• Expand Bsurf

• Check BsurfMagnitude

• Click the Plane Controls button at the bottom of the Visualization Controls pane on the left of the Composer
window.
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Fig. 4.18: Computing the geometry factor for the eigenmode of interest.

• Select X as the “Clip Plane Normal” and “.05” as the “Origin of Normal Vector” for “X”. Leave the “Origin of
Normal Vector” for “Y” and “Z” as 0.

• Rotate the visualization by left clicking and dragging with your mouse.

• You should see a visualization of the magnitude of the magnetic field of the fundamental mode projected onto
the wall of the cavity as in Fig. 4.19

To see a more quantitative visualization of the eigenmode fields, as shown in Fig. 4.20, do the following:

• Select Field Analysis as the Data View

• Select E_x (Eigenmode)

• Under the Layout drop-down menu, select Side-by-side 2d/1d

The Bessel function dependence of the x-component of the electric field will be clearly plotted on the right.

4.1.4 Rectangular Waveguide (rectangularWaveguide.sdf)

Keywords:

Field Boundary Condition, rectangularWaveguide, Rectangular Waveguide

Problem description

This example illustrates how to create a rectangular waveguide using the Rectangular Waveguide Field Boundary
Condition and Constructive Solid Geometry.
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Fig. 4.19: The magnitude of the magnetic field on the wall of the cavity

Fig. 4.20: Axial component of the electric field in the 𝑧 = 0 plane (left) and plot of the axial electric field along
𝑧 = 0, 𝑥 = 0.07495 (right).
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Three waveguides are demonstrated in this example .

This simulation can be run with a VSimEM, VSimMD, VSimPD, or VSimPA license.

Opening the Simulation

The Rectangular Waveguide example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides option.

• Select Rectangular Waveguide and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is shown in Fig. 4.21.

Fig. 4.21: Setup Window for the Rectangular Waveguide example.

Simulation Properties

This simulation demonstrates how to create a rectangular waveguide. There are three rectangular waveguides in this
simulation. Each is constructed by creating a physical waveguide on the simulation boundary, and defining the wave
that is carried into the simulation. First a metal plate from a box primitive must be placed on the simulation boundary.
It is important that this plate extend from at least one cell outside of the simulation boundary to at least one cell
inside of the simulation. Next a box primitive corresponding to the size and orientation of the actual waveguide must
be created. This is then subtracted from the previously created metal plate. It is important to note here that the
polarization parameter will always be parallel to the width. The wave carried in this waveguide is then created by
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adding a FieldBoundaryCondtion of Rectangular Waveguide. The waveguide surface must be specified to match the
intended simulation boundary and on the right location to match the physically constructed waveguide.

Several standard waveguide sizes are available, or User-Defined may be selected to specify a custom size. If no “Turn
On Time” is specified, it will be set to a time of 2.5 periods of the carried signal, and a warning will be provided after
running the simulation.

Running the Simulation

Once finished with the problem setup, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Use the default values for the stepping.

• Choose parallel computing options if desired

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in the window below.

Fig. 4.22: The Run Window at the end of execution.

Visualizing the Results

After a succesful run, go to the Visualize Window by pressing Visualize in the left column.

Expand Scalar Data, E, and select 𝐸𝑦 . To slice inside the field, select Clip All Plots in the lower left hand corner. Now
step through time using the Dump slider on the bottom of the right pane. This is shown below.
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Fig. 4.23: The 𝐸𝑦 field propagating out of the two waveguides centerd on the z axis.
The effects of the third waveguide can be viewed by adjusting the “Origin of Normal Vector” parametr under the Plane Controls

button.

208 Chapter 4. VSim for Microwave Device Examples



VSim Examples, Release 9.0.2-r2448

Further Experiments

Waveguides can be added or subtracted to this simulation.

4.1.5 S-Matrix of Box Cavity (sMatrix.sdf)

Keywords:

electromagnetics, sMatrix

Problem description

A common measurement made on a 2-port RF device is reflection and transmission of an RF signal, for either a
single frequency, or for a range of frequencies. This measurement results in the Scattering-Matrix, or S-Matrix, whose
elements S11 and S21 are the reflected and transmitted signal for unit input at Port 1. VSim provides the capability to
simulate these S-Matrix parameters for arbitrarily complex devices connected to waveguides propagating TE, TM, and
TEM modes. To demonstrate this capability, we show in this example how to measure S11 and S21 in a dual-mode
cavity filter, connected to a WR-90 waveguide, with the narrow-band band-pass tuned to pass frequencies between
9.95 and 10.05 GHz.

The Dual Mode Cavity Filter operates by coupling the TE01 waveguide mode into the two nearly degenerate TE102
and TE201 modes of the cavity, since the length of the cavity is very close to its width. The differences in these
values, along with the symmetry breaking along the waveguide axis, determine the frequency separation of the two
modes. This separation is what gives the filter finite-bandwidth since frequencies between these modes are passed, and
frequencies above or below the modes are rejected. A pole in the transmitted signal just below the band contributes to
sharpness of the band’s lower edge, but this pole moves easily to the upper frequency edge with small adjustments to
the cavity dimension parameters, and the user is encouraged to experiment in finding optimal placement of this pole.
Some relevant parameters are shown in Fig. 4.24.

This simulation can be performed with a VSimMD or VSimEM license.

Opening the Simulation

The Scattering Matrix example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides option.

• Select “S-Matrix of Box Cavity” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.25.

Simulation Properties

The simulation geometry consists of a standard WR-90 rectangular waveguide with the filter cavity (also referred to as
the Device-Under-Test (DUT) in this writeup) in the center. A planar antenna in the waveguide, near the DUT, launches
the incident wave while allowing reflected signals to pass through into the waveguide behind it. The waveguide ends
are terminated in gradual absorbing layers with negligible reflection, and the reflected and transmitted signals are
measured just in front of these absorbers.
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Fig. 4.24: Some relevant parameters for the S-Matrix Box Cavity example.
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Fig. 4.25: Setup Window for the Scattering Matrix example.

A main feature of this input file is that the waveguide description and the DUT description are short compact sections of
input, that are easily substituted. Thus this example is effectively a template for an S-Matrix simulation of any device.
The time histories of voltage signals used to measure S11 and S21 are also built in and automated for easy substitution.
Furthermore, these signals are easily turned into S11 and S21 frequency variation curves using the standard “FFT”
capabilities in VSimComposer, or if single frequency, then the S11 and S21 values are just the amplitudes of the
signals.

The x axis is aligned with the length of the waveguide, and the input and output waveguide are specified with 10
variables that provide YZ bounding coordinates of the waveguide, YZ coordinates for the voltage measurement, a
boolean specifying whether the excited mode is TM or not, and the waveguide cutoff frequency for the mode. Three
additional analytic functions provide the interior of the waveguide’s YZ cross-section and the Y and Z components
of the mode’s electric field pattern. For this simulation, these parameters all derive from WR90 dimensions, with
the waveguide cross-section centered at the YZ origin. The excited mode is the standard lowest mode, TE01, and in
particular note that for this mode, the Ez component of the field is zero.

The Device-Under-Test, in this case the dual mode cavity filter, is specified by 6 variables that provide the XYZ
bounding coordinates and one macro that constructs the DUT. These all derive from the dimension parameters for the
dual mode cavity filter, which are height, width, and length of the rectangular cavity, and the size of the apertures
connected to the waveguide.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the right pane. You will see the output of the
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run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in the window below.

Fig. 4.26: The Run Window at the end of execution.

This example is more sophisticated than some of the others, in that successful determination of S-Matrix parameters
is not the result of a single run, but rather a result of a procedure involving several runs. This includes at least one
Calibration Run, and at least one Data Run to determine S11 and S21, and then a repetition with input switched to
Port 2, in order to determine S22 and S12. All runs use the same input file and it is a set of control variables which
determine the action of a particular run. Below we discuss in detail some of the features of this example.

Frequency Band vs. Single Frequency

The user may choose whether to compute a single-frequency value of the S-Matrix parameters, or to compute the varia-
tion of the parameters as a function of frequency across a user specified frequency band. The variable, FREQCENTER,
specifies either the single frequency or the center frequency of the band. The variable, FREQBANDWIDTH, provides
the bandwidth or is set to 0 if a single-frequency simulation is desired.

With a single frequency simulation, the variable, NUMBEROFCYCLESTODRIVE, should be large enough to ensure
that the S11 and S21 histories reach a steady amplitude. The History data view can be used to obtain the S-Matrix
value, which is just the amplitude of the signal.

With a finite frequency band, the same variable, NUMBEROFCYCLESTODRIVE, can be adjusted upward to increase
the detail and sharpness of the S-Matrix variation with frequency. The variable, NUMBEROFCYCLESTOCOAST,
may also need to be adjusted upward if the DUT contains internal mode oscillation of large Q (quality) factor. This
variable needs to be large enough so that the signal histories have decreased to a negligible value (10-4, relative to
maximum) by the end of the simulation. The FFT button in the History data view is then used to give the S-Matrix
variation with frequency, with the plot’s Y-axis units being dB. Be aware that it is usually necessary to zoom in
significantly on this plot in order to see the frequency band of interest.
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Finally, in both these cases, only the amplitude of the complex-valued S-Matrix parameters can be obtained with
VSimComposer. More sophisticated post-processing (not covered in this example) is needed in order to get the phase
information.

Calibration Run

The Calibration Run is done first, and the user must ensure that in the geometries, only the material of the object
metalMinuscalibrationWaveguide is set to PEC, i.e., ensuring the material of the object myWaveguideAndDUT is set
to empty. In the Calibration Run, the DUT is automatically omitted and replaced with a continuation of the waveguide,
so that this is a near trivial simulation of a straight length of waveguide that should have effectively 100% transmission.
The calibration run serves two very important purposes:

• To ensure that there is negligible (below 1% amplitude, -40 dB) reflected voltage (S11). If the reflection is
too high it indicates that either the absorbing boundaries are not working well enough, or that the waveguide’s
“modeProfile” description is not accurate enough, and/or that there is not enough grid resolution.

• To adjust the variable DRIVENORMALIZATION, which runs in proportion to observed transmitted voltage
(S21), so that the next time the calibration run is done, the transmitted voltage (S21) will be exactly unit ampli-
tude (single frequency) or zero dB (across frequency band). For example, if the first Calibration Run shows an
amplitude of 0.667 for S21, change the variable DRIVENORMALIZATION to 1.5 times its present value for
the next Calibration Run, since 1/0.667 = 1.5.

Changing center frequency, or any waveguide parameter, or even the nominal cell size, will require re-calibration. If
not sure, always recalibrate, when changing a parameter.

Data Run

Once the Calibration Run is successful at achieving unit transmission with negligible reflection, the Data Run is then
done. The user should ensure that only the material of the object myWaveguideAndDUT is set to PEC, i.e., ensuring
the material of the object metalMinuscalibrationWaveguide is set to empty.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The S-Matrix results are then read from the History data view in the Visualize Window. An example run, for a
frequency band simulation from 8 to 12 GHz, is shown below in Fig. 4.27. The figure shows the History data view
with the FFT’s of the “S11_Voltage” history and the “S21_Voltage” history.

Further Experiments

Experiment with finding optimal placement of the pole in the transmitted signal.

4.2 Cavities and Waveguides (text-based setup)

4.2.1 Coaxial Cylinder (coaxT.pre)

Keywords:

coaxT, coaxial geometry, cylinder, current pulse, rlc circuit, step potential
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Fig. 4.27: Fourier transforms of the histories S11_Voltage and S21_Voltage as a function of frequency (in GHz).

Problem description

This example probes the electromagnetic properties of a semi-infinite coaxial cylinder. One end of the cylinder lies in
the simulation space and its dimensions are large–well beyond the size of a coaxial cable. It’s outer radius is 8 cm, the
inner radius is 2 cm, and the section considered is 20 cm long. The inner cylinder is shorter than the outer cylinder and
there is an electron absorbing cap on the end of the outer cylinder. When the simulation initiates, a single EM pulse is
launched into the open, continuous end of the geometry and propagates to the capped tip. Electrons are ejected from
the tip of the inner cylinder when the pulse reaches it. The pulse has a period of ~0.7 ns and the simulation runs for 5
periods.

This computational model is equivalent to applying a step-potential at one end of the cylinder (location of the other,
unseen end of the cylinder is arbitrary). The step-potential propagates at the speed of light (the medium is a vacuum)
until it reaches the tip of the inner cylinder. There, an attenuating series of oscillations occurs. Gradually the tip
potential stabilizes at the applied potential.

This simulation can be performed with a VSimMD license.

Opening the Simulation

The coaxT example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Introductory Examples (Text-based setup) option.

• Press the arrow button to the left of Introductory.
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Fig. 4.28: The electrons are emitted from the tip of the inner cylinder after the field reaches it.

• Select Coaxial Cylinder and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.29.

Input File Features

Primary Parameters

EXTERNAL_RADIUS_EXTERIOR: Radius of the coaxial cylinder’s outer wall

EXTERNAL_CYLINDER_LENGTH: Length of the outer cylinder, determines simulation domain size

EXTERNAL_CYLINDER_WIDTH: Thickness of the outer cylinder wall

NGRID: Number of cells spanning the length of the simulation space (the axial direction)

MGRID: Number of cells spanning the dimensions of the simulation space transverse to the cylinder axis

EMITTED_CURRENT: The current emitted from the tip of the inner cylinder

VBAR: The average velocity of electrons emitted from the inner cylinder

Secondary and Derived Variables

Can be found in the input file view.
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Fig. 4.29: Setup Window for the Coaxial Cylinder example.

INTERNAL_RADIUS_EXTERIOR: Radius of the inner cylinder’s outer wall; equal to 0.25*EXTER-
NAL_RADIUS_EXTERIOR

INTERNAL_CYLINDER_LENGTH: Length of the inner cylinder; equal to 0.7*EXTER-
NAL_CYLINDER_LENGTH or EXTERNAL_CYLINDER_LENGTH - EXTER-
NAL_RADIUS_EXTERIOR, whichever quantity is longer.

INTERNAL_CYLINDER_WIDTH: Thickness of the inner cylinder wall

OMEGA: Equivalent frequency of incoming EM pulse. Not an actual physical quantity since the pulse
is non-periodic. but it does help determine the rise time of the pulse, called PERIOD below. The
rise-time depends on the cylinder radius and is equal to 2.405𝑐/EXTERNAL_RADIUS_EXTERIOR
= 9.01 × 109rad/sec = 14.2GHz.

PERIOD: The rise-time of the pulse. Equal to 2𝜋/OMEGA. Not used for any physics, PERIOD deter-
mines the simulation run time.

TIMESTEPS: Determines length of simulation. By default the simulation will run for 5*PERIOD.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.30.
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Fig. 4.30: The Run Window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To create the image seen in Fig. 4.31, proceed as follows:

• Expand Scalar Data

• Expand edgeE

• Select edgeE_y

• Select Clip All Plots

• Click the Plane Controls button and set the normal to the Z-direction

• Select Display Contours and set the # of contours to 10

• Set the particle size to 6 and the symbol to Sphere

• Expand Particle Data

• Expand electrons

• Select electrons_ux

• Expand Geometries

• Select poly (coaxTGeom)

• Move the dump slider forward in time

• Click and drag to rotate
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Fig. 4.31: Visualization of the coaxial cylinder as a color contour plot.

To obtain a clearer picture of what is happening at the cylinder tip, switch the Data View to History. One dimensional
plots of the number of electrons (called numberOfMacroParticles), the electric potential, phi, and the current emitted
and absorbed should come up automatically.

You can set Graph 2 to Location “Window 1” as in Fig. 4.32.

The potential is measured at the tip of the cylinder with the interior of the inner cylinder serving as a reference
point. The potential plotted has a lot of noise on it resulting from the free electrons. It may be insightful to run the
simulation once without electrons so you can see the ringing on the waveform of phi, which is not unlike the output
of an oscilloscope hooked up to a coaxial cable. Electrons can be suppressed by setting the EMITTED_CURRENT
parameter to 0 during setup.

The coaxial cylinder acts like an RLC circuit: the inner conductor serves as an inductor, the gap between the tip and the
absorbing cap is a capacitor, and the spacing between the inner and outer cylinders constitutes a resistor. By default,
the rise-time of the pulse is near the resonance period, and this makes it a good driver of the circuit.

Further Experiments

Try experimenting with different geometry sizes. In particular, note the effects of radius on pulse rise-time and cylinder
length on the phi History plot.

4.2.2 A15 Crab Cavity (crabCavityT.pre)

Keywords:

electromagnetic cavities, accelerators, mode frequencies
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Fig. 4.32: The History visualization window with the electrons.

Problem Description

The Crab Cavity simulation illustrates how to extract the modes and frequencies of an accelerator cavity in a given
frequency range. The range of interest here is 3.9 to 4.1 GHz. The simulation is performed by exciting the cavity with
a broadly filtered pulse that excites modes in a given range. The excitation occurs through a temporally and spatially
specified current source that excites the frequencies of interest. The simulation features a variable sampling frequency,
allowing the cavity to first be rung up without generating excessive memory dumps. After the simulation has been
rung up, sampling frequency increases, and when combined with post-processing find the modes and frequencies. The
algorithm is detailed in [1].

This simulation can be performed with a VSimEM, VSimMD or VSimPD license.

Opening the Simulation

The Crab Cavity example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides (text-based setup) option.

• Select “A15 Crab Cavity (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.33.
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Fig. 4.33: Setup Window for the Crab Cavity example.

Input File Features

The input file allows the user to control a number of features of the Crab Cavity simulation. The FREQ_LO_GHZ and
FREQ_HI_GHZ defines the range of frequencies that we are interested in extracting whereas the DELTA_FREQ_GHZ
specifies the separation in frequency between the range of interest and the next nearest mode (at 4.3 GHz).

The input file is written to run for a long time, sufficient to ring up the cavity, then dump periodically during the free
oscillation period. The modes and frequencies will be extracted from those dumps. This can be seen in crabCavityT.in.

The remaining key parameter values correspond to the geometry and discretization of the cells. The focus of the Crab
Cavity simulation is on a four cell cavity with end holes that were originally used for measurement purposes. See [2].
The final ZSQUASH parameter is used to squeeze each cell of the cavity to eliminate the degeneracy due to cylindrical
symmetry.

Running the Simulation

After examining the inputs, do the following:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Select running in parallel as desired.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane on the right.
You will see the output of the run in this pane. The run has completed when you see the output, “Engine
completed successfully.” This is shown in Fig. 4.34.
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Fig. 4.34: The Run Window at the end of execution.

Analyzing the data

It is possible to extract the modes of the A15 crab cavity via post processing using the extractModes.py - Extract
Modes Analysis Script as follows:

• Press the Analyze button in the left column of buttons.

• Click Show All Analyzers.

• Select extractModes.py and press Open.

• Enter the following parameters in the appropriate fields. the default simulation values are used:

– simulationName = crabCavityT

– field = B

– beginDump = 1

– endDump = 25

– nModes = 6

– sampleType = 1

– numberUniformPts = 36

– numberRandomPts = 36

– construct = 1

• Click the Analyze button in the upper right corner of the window.

As shown in Fig. 4.35 below, three columns of data with the titles “freq [Hz]” (eigenmode frequency), “invQ” (inverse
quality factor), and “SVD” (singular value decomposition) will be output in the right pane. The analysis has completed
when you see the output “Analysis completed successfully.” One can see 6 modes, but the first one is not real as one
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can see from its unrealistic value of invQ, which should in fact be zero for this ideal (non-lossy) cavity, and the fact
that it has zero frequency.

Fig. 4.35: The Analysis window at the end of execution of the extractModes.py script.

The magnetic fields at each of the eigenmode frequencies will be available to view in the Visualize Window under the
B Field.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric field:

• Expand Scalar Data

• Expand E

• Select E_z

• Expand Geometries

• Select poly

• Check Clip All Plots and click on Plane Controls

• Fix the coloring by clicking on Colors and set Fix Minimum to -0.0005 and Fix Maximum to 0.0005.

• Move the slider at the bottom of the right pane to see the electric field at different times.

One can instead view the eigenmodes, which are so labeled under B. E.g., Unclick E_z click B_y (Eigenmode). For
these plots a better choice of minimum and maximum are +- 0.005. The slider can be moved to see the eigenmodes.
Slider positions past the last eigenmode will display only the last eigenmode.
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Fig. 4.36: Visualization of the electric field as a color contour plot.

Further Experiments

Additional experiments worth investigating are:

• Use Histories to record the power flow, to compute the coupling efficiency.

• Simulate one period of the waveguide with periodic boundary conditions and a user-defined phase shift, and use
the frequency extraction feature to compute the waveguide modes and dispersion curves.

References

[1] G. R. Werner and J.R. Cary, “Extracting modes and frequencies from time-domain simulations with filter-
diagonalization”, J. Comp. Phys., 227 (10), 5200-5214, 2008.
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4.2.3 Stairstep Cavity in coordinateGrid (emCavityCoordProdT.pre)

Keywords:

stairstep boundary, coordinateGrid, Klystron cavity

Problem description

This example demonstrates how to set up a complex geometry structure in VSim that uses the coordinateGrid
system for a varying mesh size. There are two benefits of constructing a grid of kind coordProdGrid via
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coordinateGrid blocks. The first is a flexible choice of either Cartesian (𝑥, 𝑦, 𝑧) or cylindrical (𝑧, 𝑟, 𝜑) coor-
dinate systems to construct the grid. The second is that it enables one to vary the cell size along each axis of the grid.
For example, a fine grid resolution can be used in a region of the domain consisting of complicated geometry, while a
coarse resolution can be used in a different region of the domain where the geometry is simple. This method reduces
the memory requirement for large multiscale simulations. The gridBoundary block (implemented in this example
through the geometry macro) is used by VSim to represent complex geometrical surfaces with boundary conditions.

This example simulates a klystron cavity using a non-uniform Cartesian mesh generated by VSim’s coordinateGrid
system. Klystron cavities have wide applications as RF power sources by amplifying an RF input with electron beams.
The simulated cavity is defined by a set of VSim geometry macros. Grid cell size is varied in the longitudinal direction
so that a fine mesh exists at the round nose surface connecting the center drifting tube and outer ring cavity. Larger
cell sizes are used at both ends of the drifting tube. The fundamental transverse magnetic (TM) mode is excited by a
Gaussian current pulse.

This simulation can be performed with either a VSimEM, VSimMD, or VSimPD license.

Opening the Simulation

The emCavityCoordProdT example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Cavities and Waveguides (text-based setup) option.

• Select “Stairstep Cavity in Coordinate Grid (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.37.

Input File Features

• At the top of the Editor pane, click View Input File.

The first important feature of this input file is the setup of the non-uniform simulation grid. Scroll to the Grid
block on line 262 (Fig. 4.38). The variable spacing in 𝑥 in the non-uniform grid is specified in the definitions of
sectionBreaks and deltaAtBreaks in the coordinateGrid dir0 block. The deltaAtBreaks field
specifies the grid cell spacing at each of the sectionBreaks positions, and the grid is generated such that the cell
spacing transitions gradually between these positions. In this specific example, on lines 266 and 267, from 𝑥 = XBGN
to 𝑥 = CAV_START the cell spacing transitions from ∆𝑥 = DX to ∆𝑥 = DX/3.0, then from 𝑥 = CAV_START to
𝑥 = CAV_END the cell spacing stays at a constant value of ∆𝑥 = DX/3.0, and finally from 𝑥 = CAV_END to 𝑥 =
XEND the cell spacing transitions from ∆𝑥 = DX/3.0 back to ∆𝑥 = DX.

The second important feature of this input file is the electromagnetic solver for this type of grid. Both the Faraday
and Ampere updaters are set to kind curlUpdaterCoordProd. By setting interiorness = cellcenter
in both updaters, the curl operation is performed with a stair-stepped gridBoundary.

Running the simulation

Because the cells are not uniformly spaced, the number of cells in the simulation is unknown until calculated by
VSim’s Vorpal engine. However, the number of cells in each dimension is required for VSim to preprocess the input
file. To correctly set the number of cells NX in the input file, take the following steps:
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Fig. 4.37: Setup Window for the emCavityCoordProdT example.

Fig. 4.38: Input file for the emCavityCoordProdT example, showing the setup of the coordinateGrid system.
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• Set the parameter NX0 (the default is 72). This specifies the grid spacing (DX) at the ends of the simulation
domain as NX0/LX.

• Run the simulation for one time-step by clicking the Run button in the left column of buttons, and entering “1”
in both the Number of Steps and Dump Periodicity fields.

• After the simulation completes, scroll through the log file to find the value of numPhys in the first row of
Global grid, as circled in Fig. 4.39.

• Go back to the Setup Window by clicking Setup in the left column of buttons, and enter this value into the field
for NX. For the default values of this example, this number should be 162.

Fig. 4.39: Location of the numPhys output to be entered into the NX field by the user.

The simulation is now ready to run. Return to the Run Window, enter the desired values for Number of Steps and
Dump Periodicity and click Run once again. The run has completed when you see the output, “Engine completed
successfully” as shown in Fig. 4.40. This will require approximately two hours of computation time when run in
parallel on four processors on a modern CPU.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by clicking Visualize in the left column of buttons.

To create the plot as shown in Fig. 4.41:

• In the Variables section of the Visualization Controls pane, Expand Geometries

• Select poly_surface

• Expand Meshes
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Fig. 4.40: The Run Window during the execution.

• Expand compGridGlobal

• Select any of the grid choices, for they are all identical for this simulation

• Expand Scalar Data

• Expand edgeE

• Select edgeE_x

• Near the bottom of the Visualization Controls pane, select Clip All Plots

• Click the Plane Controls button and set the normal in the Z-direction (which should already selected by default)

• Select Display Contours

• Decrease the Opacity by moving the Opacity slider the left to better see the fields through the grid

• At the bottom of the Visualization Results pane, move dump slider forward in time

Further Experiments

The coordinateGrid system is also capable of creating non-uniform grids in cylindrical coordinates, by setting
coordinateSystem = Cylindrical in the Grid block. The curlUpdaterCoordProd updater also
works with the same settings in cylindrical coordinates.
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Fig. 4.41: Visualization of the 𝑥-component of the electric field in the simulation of a klystron cavity with a non-
uniform mesh.

4.3 Radiation Generation

4.3.1 A6 Magnetron 1: Modes (a6Magnetron1Modes.sdf)

Keywords:

magnetron, cavity modes, A6

Problem Description

This VSimMD example simulates MIT’s cylindrical A6 magnetron cavity with no outlets in three dimensions. The
structure is generated using shape primitives within the VSim composer. The cavity is excited by a sinc pulse ping
using a distributed current source within one of the resonant cavities. The spectrum of the cavity is used to find the
modes, and FDM is used to extract the exact mode profile of the cold cavity.

This simulation can be performed with a VSimMD license.

Opening the Simulation

The A6 Magnetron example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.
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• Select “A6 Magnetron 1:Modes” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the setup window as shown in Fig. 4.42.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.

Fig. 4.42: Setup window for the A6 Magnetron example showing cathode and anode vanes only.

Simulation Properties

The A6 Magnetron example includes several constants for easy adjustment of simulation properties. User changeable
parameters include:

• RADIUS_ANODE → Inner radius of anode.

• RADIUS_ANODE_OUTER → Outer radius of anode.

• ANGLE_CAVITY → Angle of resonant cavity openings, in degrees.

• THICKNESS_WALL_OUTER → Thickness of all walls.

• WIDTH_VANES → Total width of anode vanes in z-direction.

• RADIUS_CATHODE → Radius of the emitting section of the cathode.

• RADIUS_CATHODE_INNER → Radius of the inner section of the cathode.

• WIDTH_CATHODE → Width (in z-direction) of the emitting section of the cathode.

• FREQ_LOW → Lower frequency of excitation source range.
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• FREQ_HIGH → Upper frequency of excitation source range.

• (X,Y,Z)POS_CURR → Position of excitation distributed current source.

• (XY,Z)SIZE_CURR → Size of excitation distributed current source region.

• (X,Y,Z)POS_HIST → Position of electric field history.

The axis of the cavity coincides with the z-axis and the center is at z = 0. The emitting cathode region is 4.0 cm long.
All surfaces are perfect electric conductors. Histories of the electric and magnetic fields are taken at the inside of one
of the cavities to find the modes. The FFT of the history shows the mode frequencies, and the exact value and profile
is found using extractModes.py - Extract Modes Analysis Scripts.

The excitation frequency range can be set using the constants FREQ_LOW and FREQ_HIGH. The total excitation time
is calculated in TIME_EXCITE. The simulation should be run for longer than TIME_EXCITE to allow the excitation
source to complete.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.43.

Fig. 4.43: Run window for the A6 Magentron mode extraction example after the initial run..

The simulation is best run in two steps: The first with course dump periodicity to excite the modes, and the second
with fine dump periodicity to observe the modes.
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• Initially, the simulation is run for 10,000 time steps, writing one dump file at the end, to allow the current source
excitation to finish.

• After the initial run, change the Number of Time Steps to 2,000, the Dump Periodicity to 50, and enter 1 into
Restart at Dump Number. This will record details of the excited field after the source has finished.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize window by pressing the Visualize button in the left column of buttons.

To visualize a run to determine the resonant frequency, select History from the Data View pull-down menu. Select
outE_0 for Graph 1 and Graph 2, and click Fourier Amplitudes (dB) to the left of one of the outE_0 plot in the
Visualization Results pane. .

• Proceed to the Visualize window by pressing the Visualize icon in the left panel.

• Select History under Data View.

• For Graph 3 and Graph 4, select <None> to be plotted.

• Then for Graph 2 select the Fourier Amplitudes (dB) checkbox * In the upper right corner of each plot, select
Limits and set X-Axis max to 1e10.

• The result should be that shown in Fig. 4.44.

Note that running the simulation longer will more sharply resolve the mode frequencies in the FFT.

Fig. 4.44: Fourier transform of outE_0 versus time (in Hertz).
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Analyzing the spectrum

It is possible to extract the modes of the A6 magnetron cavity via post processing using the extractModes.py - Extract
Modes Analysis Script as follows:

• Press the Analyze button in the left column of buttons.

• Select extractModes.py(default).

• Enter the following parameters in the appropriate fields:

– simulationName = magnetronA6Modes

– field = B

– beginDump = 2

– endDump = 41

– nModes = 7

– sampleType = 0

– numberUniformPts = 20

– numberRandomPts = 100

– construct = 1

• Click the Analyze button in the upper right corner of the window.

Three columns of data with the titles “freq [Hz]” (Eigenmode frequency), “invQ” (inverse quality factor), and “SVD”
(singular value decomposition) will be output in the right pane. The analysis has completed when you see the output
“Analysis completed successfully.” One can see 7 modes in Fig. 4.3.1.

• Proceed to the Visualize window by pressing the Visualize icon in the left panel.
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• Select Data Overview under Data View.

• Expand Scalar Data

• Expand B

• Select B_z (Eigenmode).

• Select Clip All Plots in the bottom left corner.

• Move the dump slider first to dump 2 and then to dump 5.

The axial magnetic field inside the cavity during the 𝜋 and 2𝜋 mode operations are shown in Fig. 4.45 and Fig. 4.46,
respectively:

Fig. 4.45: Visualization of the axial B-field in the 𝜋 Eigenmode.

Further Experiments

The values of FREQ_LOW and FREQ_HIGH can be adjusted to find additional modes, or to focus in on a specific
mode. Narrowing the excitation range to fewer modes will produce a mode accurate frequency and Q-factor extraction
for the mode.

4.3.2 A6 Magnetron 2: Power (a6Magnetron2Power.sdf)

Keywords:

magnetron, bunching, space charge, A6
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Fig. 4.46: Visualization of the axial B-field in the 2𝜋 Eigenmode.

Problem Description

This VSimMD example simulates MIT’s cylindrical A6 magnetron cavity with a slot outlet in three dimensions. The
geometry was defined by using VSimComposer’s constructive solid geometry (CSG) capabilities. The cathode-anode
voltage is ramped up from zero to around 360 kV by a current distribution source. Electrons are emitted from the
emitter section of the cathode, and undergo 𝐸 ×𝐵 drift. Bunching of the space-charge distribution occurs and kinetic
energy from the electrons is transfered to the electromagnetic modes of the cavity. If the simulation is run long enough,
it will be seen that the 2𝜋 mode dominates.

This simulation can be performed with a VSimMD license.

Opening the Simulation

The A6 Magnetron example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.

• Select A6 Magnetron 2: Power and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
4.47. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or de-select the box next to Grid.
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Fig. 4.47: Setup Window for the A6 Magnetron example.

Simulation Properties

The A6 Magnetron example includes several constants for easy adjustment of simulation properties. User changable
parameters include:

• RADIUS_ANODE → Inner radius of anode.

• RADIUS_ANODE_OUTER → Outer radius of anode.

• ANGLE_CAVITY → Angle of resonant cavity openings, in degrees.

• THICKNESS_WALL_OUTER → Thickness of all walls.

• WIDTH_MAGNETRON → Total width of magnetron in z-direction.

• RADIUS_OUTLET → Radius of outlet horn in x-direction.

• WIDTH_IRIS → Width of outlet slit opening.

• WIDTH_VANES → Total width of anode vanes in z-direction.

• RADIUS_CATHODE → Radius of the emitting section of the cathode.

• RADIUS_CATHODE_INNER → Radius of the inner section of the cathode.

• WIDTH_CATHODE → Width (in z-direction) of the emitting section of the cathode.

• (X,Y,Z)POS_HIST → Position of electric field history.

The axial magnetic field is uniform with a constant value of 𝐵𝑧 = 0.6 T. There is an opening at the back of one of the
cavities that allows microwave energy to leave the magnetron through a horn antenna and into a matched absorbing
layer (MAL) boundary. A Poynting Flux history records the power output through the antenna. The emitting region
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of the cathode has a slightly larger radius than the rest of the cathode. There are also end caps, on either side of the
vanes, in electrical contact with the cathode.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Here you can set run parameters, including how many cores to run with (under the MPI tab).

• When you are finished setting run parameters, click on the Run button in the upper right corner. You will see
the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.”

This simulation is setup so that the cathode emission current and anode-cathode (AK) voltage ramp up relatively
slowly (over many RF periods). Once the AK voltage is high enough, the bunching of the electrons will occur. If the
simulation is run for long enough, around 100000 time steps, the 2𝜋 mode will eventually dominate as has been seen
experimentally for this magnetron.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

After the simulation has been run for a sufficient amount of time, spokes will form in the electron distribution (bunch-
ing). Since the A6 is a six-cavity magnetron, operation in the 2𝜋 mode will correspond to six spokes. To visualize the
spokes:

• Select Phase Space from the Data View pull-down menu

• Select electrons_x for the X-axis

• Select electrons_y for the Y-axis

• Use the Dump bar at the bottom of the screen to advance through the solution and visualize each dump file

Eventually, a steady state will be reached in which the electron distribution has six spokes similar to Fig. 4.48.

To visualize the axial magnetic field during the 2𝜋 mode operation, proceed as follows:

• Select Data Overview from the Data View pull-down menu

• Expand B

• Select B_z

• Expand Geometries

• Select poly (a6Magnetron2PowerPecShapes)

• Select Clip All Plots

• Select Colors

• Check Fix Minimum and Fix Maximum and set to -0.4 and 0.4 respectively

• Move the dump slider forward in time to see the evolution.

Image Fig. 4.49 was taken at Dump 16.

To determine the operating frequency:

• Select History from the Data View pull-down menu
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Fig. 4.48: Phase-space plot of the electron distribution showing the formation of six spokes corresponding to operation
in the 2𝜋 mode.

Fig. 4.49: Axial magnetic field of the magnetron operating in the 2𝜋 mode.
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• Select outB_2 for Graph 1 and Graph 2

• Click Fourier Amplitudes (dB) to the left of one of the plots in the Visualization Results pane

• Zoom in on the maximum of this plot to determine the approximate resonance mode frequencies

The resulting plot will resemble Fig. 4.50. If the simulation has been run for long enough, the peak at 4.6 GHz, which
corresponds to the 2𝜋 mode, should be the most prominent.

Fig. 4.50: Plot of outB_2 vs. time and vs. frequency (Fourier transform).

Further Experiments

The power output and operating mode is affected by the 𝐸/𝐵 ratio and the geometry. The user could try adjusting
the strength of the magnetic field and the geometry of the cathode, including the radius of the emitting region and the
configuration of the end-caps, to see how this affects magnetron operation.

4.3.3 Gyrotron Mode (gyrotronMode.sdf)

Keywords:

gyrotron

Problem description

This VSimMD example illustrates a very high order mode, TE-22-6, propagating in a cylindrical waveguide, very near
to the cutoff frequency, which is a common situation in a gyrotron. The example is intended to allow investigation
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of the axial phase and group velocity of such a mode, as a function of frequency, and to highlight the intricacies of
simulating a mode that is propagating within a percent or two of its cutoff frequency.

This simulation can be performed with a VSimMD license.

Opening the Simulation

The Gyrotron Mode example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.

• Select “Gyrotron Mode” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.51.

Fig. 4.51: Setup Window for the Gyrotron Mode example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.51.

Simulation Properties

There are only two geometrical input parameters; the waveguide radius and length. The user may also control the
excitation frequency, the duration of the simulation, and the nature of the excitation, specifically whether it is pulsed
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or continuous-wave. Additional exposed parameters include the grid sizes, and the tuning of the exiting wave boundary
condition, which allows for more in-depth study with this example.

The excitation may be pulsed or continuous-wave, depending on the parameter, KEEP_DRIVE_ON.

Pulsed Simulation (KEEP_DRIVE_ON=0)

In this case, the wave is driven for half of the simulation duration, with a smooth turn-on / turn-off time window. Then,
for the remaining half of the periods, the excitation propagates freely. The axial profile of the pulse will be very short,
typically just one or two axial wavelengths. It will propagate slowly down the waveguide, as expected from the group
velocity which is very small near cutoff. In the center of the pulse the TE-22-6 mode is preserved, but because this is
a pulse, nearby modes in frequency are also present. One can observe a rich set of other mode patterns just a few grid
planes away from the center of the pulse.

Continuous-Wave Simulation (KEEP_DRIVE_ON=1)

The drive may be kept on, instead of having it turn off halfway through the simulation. After an initial transient, this
sets up a single TE-22-6 traveling wave mode pattern throughout the waveguide. This allows for accurate measurement
of the axial wavenumber, beta, for the mode.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.52.

Fig. 4.52: The Run Window at the end of execution.
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Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

Fig. 4.53: Illustration of the mode pattern, and propagation of the mode down the length of the tube.

The 𝐵𝑥 field is the best component for looking at in this simulation, as shown in Fig. 4.53.

• Expand Scalar Data.

• Expand B

• Select B_x

• Using the cursor, grab the image and rotate it from right to left by 90 degrees.

• Move the dump slider to dump 11.

The initial parameters are selected so that the excitation frequency is just barely above cutoff. While the axial phase
velocity is high in this case, the group velocity is quite low, and the simulation shows a narrow wavepacket slowly
moving down the length of the tube, while remarkably still maintaining the very high order TE-22-6 pattern. Contam-
ination of the pattern increases as the duration of the excitation is reduced, since more frequencies are brought into the
transient. The user is encouraged to look at the mode pattern and contamination properties as frequency and duration
are varied.

The TE-22-6 mode’s cutoff frequency, for the suggested initial radius of 20 cm, is known analytically to be 10.8845
GHz, which derives from the value of the 6th root of the 𝐽22 bessel function, which is 45.624312. However, the user
will note that the suggested initial drive frequency is below this, at 10.74 GHz, and yet the wave appears to propagate!
This illustrates an important property of finite-difference dispersion, that in fact the speed of light is ever-so-slightly
slower in the finite-difference-time-domain simulation than in reality. In most cases, this is hardly noticed, however,
when operating this close to the cutoff frequency of a waveguide, this difference can be readily seen, as this example
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illustrates. The discrepancy between the discrete FDTD cutoff frequency and the analytic cutoff frequency, depends
on the grid resolution of the wave, and in general decreases as 𝛿𝑥2, where 𝛿𝑥 is the grid size.

A very useful piece of information is the FDTD cutoff frequency. This may be found with a series of simulations, each
at different drive frequencies, 𝜔. The KEEP_DRIVE_ON parameter should be set to 1, so that the axial wavelength,
𝛽, can be measured from the field plots. A plot of 𝜔2 vs. 𝛽2 should be essentially linear, with the intercept on the
𝜔2 axis being the FDTD cutoff frequency, 𝜔2

𝑐𝑢𝑡𝑜𝑓𝑓 (𝜔2 = 𝜔2
𝑐𝑢𝑡𝑜𝑓𝑓 + 𝑐2𝛽2), and with slope being the FDTD speed-

of-light-squared. A spreadsheet showing this exercise for the suggested initial values of the example is shown below.
The result of this study is that the FDTD cutoff frequency is actually 10.675 GHz, or 2% below the known analytical
result, for the initial suggested grid resolution.

Further Experiments

The user is encouraged to repeat the simulations discussed in the previous section with a finer resolution, to see how
the FDTD cutoff frequency approaches the analytic result as resolution improves.

The detailed TE-22-6 mode pattern is very carefully crafted using polynomial fitting functions, and is introduced into
the axial magnetic field, 𝐵𝑥, at the left side of the simulation. There is no direct option to use a different mode,
although the user may attempt to edit the detail of the input to do so.

Finally, a boundary condition tuning parameter, VPHASE_PORT, is offered to allow the user to experiment with
tuning of the outgoing wave boundary condition in this near cutoff scenario. In this circumstance, the optimal phase
velocity may be 5 to 10 times the speed of light.

An additional exposed user parameter, FREQ_CUTOFF, is offered, and may be used to store the value derived from
the simulations discussed in the previous section. By default, this parameter is not used. However the user may look
into the detail of input file, and notice a comment line that indicates how this parameter might be used to set the value
of VPHASE_PORT more accurately.

4.3.4 Helix Traveling Wave Tube 1: Dispersion (helixTwt1Dispersion.sdf)

Keywords:

Helix TWT Dispersion Analysis Run

Problem description

This VSimMD example is one of a set of simulations showing different calculations to aid the design of a helix
traveling wave tube (TWT) in three dimensions. The 100-turn helix with end feeds is imported from a CAD file, but all
other geometrical parts are created with the Constructive Solid Geometry (CSG) capabilities within VSimComposer.
The dependence of the geometries on the constants and parameters will be discussed in Helix Traveling Wave Tube 2:
Impedance and Attenuation (helixTwt2ImpedAtten.sdf).

This simulation addresses the dispersion analysis of the tube and as such runs with a grid covering a reduced number of
helix turns. An impulse signal is excited between the helix and the body tube (which would be the vacuum interface in
a real device) and periodic boundary conditions are enforced at the two ends. The tube is allowed to run for sufficiently
long to observe the behaviour at relatively low frequencies. We are able to recover the phase velocity of the wave on
the helix (and so the structure/RF curve on an omega beta diagram) from this simulation. It differs from the other
simulations of helix TWT in that the simulated region contains no coaxial coupler. As well the attenuator is outside
the simulated region. For other studies of the TWT, see

• Helix Traveling Wave Tube 2: Impedance and Attenuation (helixTwt2ImpedAtten.sdf)

• Helix Traveling Wave Tube 3: Power Run (helixTwt3PowerRun.sdf)

This simulation can be performed with a VSimMD or VSimPD license.
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Fig. 4.54: Computing the FDTD cutoff frequency of the TE-22-6 mode.
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Opening the Simulation

The Helix TWT example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.

• Select “Helix Traveling Wave Tube 1: Dispersion” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
4.55. The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide
the grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 4.55: Setup Window for the Helix TWT example.

The geometry of the helix can be made more visible by changing the default “opacity” of the surfaces in the Setup
Window, as shown in figure Fig. 4.55. This setting is made available by clicking on the “Properties” button.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.56.
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Fig. 4.56: The Run Window at the end of execution.

The simulation allows a frequency domain analysis to be performed. In order to resolve low frequency signals, a
large number of steps is required. Increasing the number of steps further may help to improve the frequency domain
resolution, especially at the low frequency end of the spectrum. The Dump Periodicity may be increased to reduce the
number of data dumps and save space at the expense of being able to view up to date simulation data while it runs.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To see the fields inside the tube as shown in Fig. 4.57, do the following:

• Expand E

• Select E_x

• Expand Geometries

• Select poly (helixTwtWithFeeds)

• Select Clip All Plots

• Select Colors

• Check Fix Minimum and Fix Maximum and set to -.05 and 0.05 respectively

• Move the dump slider forward in time to see the evolution

• Click and drag to rotate the image

• Select Display Contours and set # of contours to 4.
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The wave travels along the helix, and the strongest fields occur between turns. The individual modes are not separated
out in this case.

Fig. 4.57: Longitudinal field, E_x, for the dispersion run at time step 120,000.

The History records can be used to calculate the dispersion curve:

• Set EonAxisA_0 under Graph 1

• Set EonAxisA_1 under Graph 2

• Under Graph 3 and Graph 4 change the dataset to <None>

• Check “Fourier Amplitudes (dB)” button at top left of plot

• Select Zoom radio button

• Using the Limits button above the plot set both to have limits of 0 to 2e9.

The result is shown in Fig. 4.58 (to which we have added vertical measuring lines using an external image editing
software). A series of peaks can be seen. The mode frequencies correspond to the maxima of this plot. Having more
than one history is important as due to mode variation in space, one history may pick up modes another misses and
vice-versa.

Record the frequencies at which these peaks occur, eg in a spreadsheet. With the view mode switched from Zoom to
Navigate, a wheel mouse can be scrolled up and down to zoom in and out. This may expedite the process of collecting
the data. Or, as we have done, one can add vertical measuring lines after opening the image in some external software.

The first seven frequencies from the 300000 step simulation are listed in the table below. To determine the phase
velocity 𝑣𝑛 for each mode frequency, first note that the wave number for the 𝑛-th mode is given by

𝑘𝑛 =
2𝜋

𝐿
𝑛
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where L is the length of the helix TWT. The phase velocity for the 𝑛-th mode is then

𝑣𝑛
𝑐

=
2𝜋𝑓𝑛
𝑐𝑘𝑛

=
𝐿𝑓𝑛
𝑐𝑛

where 𝑓𝑛 is the frequency of the 𝑛-th mode and c is the speed of light. The first 10 mode phase velocities are listed in
the table below for 𝐿 = 15 cm. For large frequencies, we should expect the phase velocity to approach the ratio of the
helix pitch (0.75 cm) to the circumference (6.28 cm), or 0.119.

n frequency (GHz) phase velocity (c)
1 0.285 0.1425
2 0.555 0.1387
3 0.810 0.1350
4 1.048 0.1310
5 1.285 0.1285
6 1.520 0.1267
7 1.770 0.1264

Higher resolution and longer duration simulation could be used to better measure the frequencies and, hence, determine
the phase velocity. Even more precise frequencies could be obtained by the Filter Diagonalization Method.

Fig. 4.58: Fourier transform of various histories after 300000 timesteps.

Further tests

The axial phase velocity is chosen to be synchronous with the beam. Adjust the helix parameters (in an external CAD
editor) and observe the changes to the phase velocity.

Restarting after the default 300000 steps allows more accurate definition of the frequencies.
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Use the Filter Diagonalization Method to get the frequencies more precisely.

4.3.5 Helix Traveling Wave Tube 2: Impedance and Attenuation (helix-
Twt2ImpedAtten.sdf)

Keywords:

Helix TWT Impedance and Attenuation Run

Problem description

This VSimMD example is one of a set of simulations showing different calculations to aid the design of a helix
traveling wave tube (TWT) in three dimensions. The 100-turn helix with end feeds is imported from a CAD file, but all
other geometrical parts are created with the Constructive Solid Geometry (CSG) capabilities within VSimComposer.

An input signal is sent into a short section of coaxial input waveguide and a similar section of coaxial waveguide
at the opposite end of the tube provides an output power port. The geometry includes three dielectric support rods,
each clad by a section of resistive tubing for attenuation. The interaction impedance run enables the user to calculate
the transverse impedance and Pierce interaction impedance of the helix TWT. The transverse impedance is relevant
for impedance matching at the input and output coaxial ports, and the Pierce interaction impedance is related to the
interaction of the particles with the signal, and thus the signal gain.

The user may wish to run this simulation type multiple times, varying parameters such as the coax radius and dielectric
permittivity, in order to result in a design with the correct impedance parameters.

Related simulations:

• Helix Traveling Wave Tube 1: Dispersion (helixTwt1Dispersion.sdf)

• Helix Traveling Wave Tube 3: Power Run (helixTwt3PowerRun.sdf)

This simulation can be performed with a VSimMD or VSimPD license.

Opening the Simulation

The Helix TWT Impedance and Attenuation example is accessed from within VSimComposer by the following ac-
tions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.

• Select “Helix Traveling Wave Tube 2: Impedance and Attenuation” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
4.59, with the Elements Tree in the upper center, and the Property Editor in the lower center. The right pane shows a
3D view of the geometry as well as the grid, if its visibility has been activated (which it was not when this image was
captured).
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Fig. 4.59: Setup Window for the Helix TWT impedance and attenuation example.

Geometry details

The various geometrical objects can all be seen in the tree by pulling down the bar separating the Elements Tree
from the Property Editor and then expanding Geometries, CSG, and Grids. Make sure tube and Grid are unclicked,
helixWithFeedsGeom is clicked, and that the Toggle Axes button is set to remove the axes from the view. This allows
one to see the interior geometrical objects, including the incoming feed, the dielectric support rods, the resistive tubes
in the center, the particle emission disk at the left, and various planes where measurements are taken. The geometry is
shown in Fig. 4.60.

Constants and Parameters

Pulling the separator bar between the Elements Tree and the Property Editor and opening the Constants part of the tree
gives the view shown in Fig. 4.61.

There are three types of constants. The first set of constants, from PI through ELECMASSEV are not changeable by
the user. These are the various mathematical and physical constants that the simulation will use. The second set of
constants are those with HELIX in the name. These must correspond to the helix geometry, the beginning, mid-radius,
wire radius, pitch, and number of turns of the helix. These cannot be set arbitrarily, as the helix was imported as an STL
file. Instead they must be set to match the imported helix parameters. The remaining constants define fundamental
geometry quantities, such as where the tube begins and its radius, other physical simulation parameters, such as the
wave frequency, and numerical parameters, such as the number of cells in each direction.

Moving the scroll bar and opening the Parameters part of the tree shows the Parameters, values that come from
arithmetically combining constants and other parameters. This is shown in Fig. 4.62.

As an example, LENGTH_HELIX is shown. The expression shows that this is the number of helix turns times the
helix pitch. It also shows the value. Of course, the expression is editable, while the value is not.
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Fig. 4.60: Interior geometry for the Helix TWT impedance and attenuation example.

Fig. 4.61: Constants for the Helix TWT impedance and attenuation example.
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Fig. 4.62: Parameters for the Helix TWT impedance and attenuation example.

Both constants and parameters have a description field that allows the user to document the quantity.

Materials

To bring materials in the simulation, in the right pane, select the Database tab, select one or more materials (with
ctrl-click) and hit the button Add To Simulation. The materials will then appear under Materials in the tree view. At
this point one can change the properties of the materials including the name. In this example we imported resistive
damper, changed its name to LossyMaterial, and changed its value of conductivity to 0.55. This is shown in Fig. 4.63.

Once one has materials in the simulation, one can set the materials of any of the geometries. Click on the geometry,
then in the Property Editor pane, double click on the material value. A context menu will allow you to set the material
of the geometry to any material in the simulation.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.64.

The simulation to determine the impedance should run long for any mismatch at the outgoing boundary to stabilize.
That is, the simulation must be run long enough for the electromagnetic wave to reach the far end of the tube and for
any reflections to return some distance to the last history in the tube. This will take about 100,000 steps. On a 4-core
machine, we have observed 0.23s/step, so this simulation will take about 7 hours. This simulation parallelizes well up
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Fig. 4.63: Materials for the Helix TWT impedance and attenuation example.

Fig. 4.64: The Run Window at the end of execution.
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to 16 cores, so with a sufficient license and workstation or cluster, one can bring this simulation time down to about 2
hours.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To see the fields inside the tube as shown in Fig. 4.65, continue as follows:

• Select Data View: Data Overview

• Expand Scalar Data then D, then select field D_y.

• Expand Geometries then select poly (rod1).

• Check Clip All Plots, which cuts through the data at the 𝑧 = 0 plane.

• Select the Colors option from the upper menu bar in the Visualuization Results pane.

• In the Color Options window: check Fix Minimum and set it to -400, then check Fix Maximum, set it to 400,
and click OK.

• Move the dump slider forward in time to see the evolution.

Fig. 4.65: The transverse displacement field, Dy, on the central x-y plane at dump 31.

This plot shows the transverse displacement field. Once can see that it is confined inside the tube (sanity check), and
that it is most intense inside the dielectric rod at the bottom. The field is larger at the left, as it is just entering and
propagating down the tube.

At any time one can leave this visualization pane to move back to the run pane to see how the simulation is progressing.
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The longitudinal field inside the tube is shown in Fig. 4.66, which can be obtained by the steps:

• Select Data View: Field Analysis

• Select Field E_x.

• Select Horizontal under Lineout Settings, set the Intercept to 0, and click Perform Lineout.

• Under Layout select Stacked 2d/1d

• Move the dump slider forward in time to see the evolution.

Fig. 4.66: The longitudinal field, Ex, on axis at dump 27, which is time step 54,000.

As seen in Fig. 4.66, the longitudinal field has dropped from about 240 V/m to about 68 V/m in the center of
the simulation where the resistive tubes are. This corresponds to about 14 dB of attenuation. The purpose of this
attenuation is to have sufficient damping so that reflections coming back from the end to the beginning and then
reflection again do not grow, as that would change the device into an oscillator, with energy growth that could destroy
the system. If the Helix Traveling Wave Tube 3: Power Run (helixTwt3PowerRun.sdf) shows that this is happening,
one can return to this run and increase the conductivity of the LossyMaterial or the length of the resistive tube (through
BGNTURN_ATTENUATOR and ENDTURN_ATTENUATOR) to provide more attenuation.

Histories contain the time evolution of quantities defined in the input file. These can be seen by selecting the Data
View, History. To determine various impedances we want particular histories obtained by the process:

• Select Data View: History

• Under Graph 1 select poyntingA

• Under Graph 2 select transverseVoltageA

• Under Graph 3 select EonAxisA_0

• Under Graph 4 select <None>
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The result is shown in Fig. 4.67. The power through the plane was defined such that incoming is negative.

Fig. 4.67: Poynting power (W), transverse voltage (V), and electric field (V/m), at Plane A, along the helix TWT as a
function of time (s).

Impedance parameters of interest are the transverse impedance

𝑍𝑡 =
𝑉 2
𝑡

2𝑃

and the Pierce interaction impedance

𝑍𝑝 =
𝐸2

𝑥𝜆
2

8𝜋2𝑃

where 𝑃 is the poynting power (recorded in the history poyntingA), 𝑉𝑡 is the transverse Voltage amplitude (recorded
in the histories transverseVoltage), 𝐸𝑥 is the electric field amplitude (recorded in the history EonAxis), and 𝜆 is the
wavelength of the field along the helix TWT axis.

The histories show the graphs of these quantities. To get precise values for any of these, one can press the Limits button,
which will pop up a window withe the precise values. First, the X-Axis limits show that the units are 𝑛𝑠. Secondly, one
needs to choose a consistent time period, where all amplitudes are roughly constants. The period 28𝑛𝑠 < 𝑡 < 32𝑛𝑠
is chosen. One can now adjust the limits until the peaks line up with the limits. We want average poynting power.
We find 𝑃𝑚𝑖𝑛 = 18. 𝑚𝑊 and 𝑃𝑚𝑎𝑥 = 44. 𝑚𝑊 . Hence, 𝑃𝑎𝑣 = 31. 𝑚𝑊 . During that same time interval we find
𝑉𝑡 = 2.4 𝑉 and 𝐸𝑥 = 240 𝑉/𝑚.

Fig. 4.66 can be used to obtain the wavelength. One can see four wavelengths between 0.20𝑚 and 0.357𝑚. Therefore
the wavelength is (.357𝑚− .20𝑚)/4 = 0.039𝑚

We now compute

𝑍𝑡 =
2.4 * 2.4

2 * .031
= 92.9 Ω
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and the Pierce interaction impedance is

𝑍𝑝 =
2402 · 0.0392

8𝜋0.031
= 35.8 Ω.

Further Experiments

As noted above, one can change the attenuation by varying the conductivity of the resistive tubs or their length. For
any given length, there is a maximum attainable attenuation, as there is no attenuation at zero conductivity (infinite re-
sistance, i.e., vacuum) and none as well at infinite conductivity (metallic shielding). So if more than 14 dB attenuation
is needed one can vary the conductivity, but a maximum will be observed, and if that is insufficient one will have to
vary the rod length.

With additional computing resources, one could increase the grid resolution so that the resistive tube could be made
thinner. As it is made thinner, one can go to greater conductivity without having the skin depth less than the resistive
tube thickness.

The coupling is determined by the transverse impedance of the structure, which in turn depends on the capacitance
provided by the rods. Varying the relative permittivity changes the transverse impedance.

4.3.6 Helix Traveling Wave Tube 3: Power Run (helixTwt3PowerRun.sdf)

Keywords:

Helix TWT Power Run

Problem description

This VSimMD example is the last of a set of simulations showing different calculations to aid the design of a helix
traveling wave tube (TWT) in three dimensions. The 100-turn helix with end feeds is imported from a CAD file, but all
other geometrical parts are created with the Constructive Solid Geometry (CSG) capabilities within VSimComposer.

An input signal is sent into a short section of coaxial input waveguide and a similar section of coaxial waveguide
provides an output power port. The geometries in and constant parameters of this simulation are described in more
detail in Helix Traveling Wave Tube 2: Impedance and Attenuation (helixTwt2ImpedAtten.sdf). Electrons are injected
at the left end of the tube. Gain can be computed from the ratio of voltages in the input and output waveguides.

The user may wish to run this simulation type multiple times, varying parameters such as the input signal power and
the electron energy, in order to result in a design with maximum output power.

Related simulations:

This simulation can be performed with a VSimMD or VSimPD license.

Opening the Simulation

The Helix TWT Power Run example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.

• Select “Helix Travelling Wave Tube 3: Power Run” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.
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All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 4.68.
You can expand the tree elements and navigate through the various properties. Some of these changes will affect the
geometry, and so one should review the look of the geometry in the right pane as one changed geometrical variables.
To show or hide the grid, expand the Grid element and select or deselect the box next to Grid. One can, e.g., hide the
tube to see inside it.

Fig. 4.68: Setup Window for the Helix TWT example.

The geometry of the helix can be made more visible by changing the default “opacity” of the surfaces in the Setup
Window, as shown in figure Fig. 4.68. This setting is made available by clicking on the “Properties” button.

Additional detail of the geometry is shown in figure Fig. 4.69. The top figure shows the dielectric rods and the bottom
figure shows how the coaxial waveguide connects to the helical wire.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.70.

The default number of time steps will run the simulation long enough to verify that the electron beam is traveling down
the tube, that the input signal has entering the simulation and propagated down the tube, that the amplified signal is
leaving the system, and that the amplification has reached a steady state. However, the simulation has not been run
long enough to ensure that there are no deleterious, backward wave oscillations. To determine that, one should run the
simulation twice as long (ensuring a backward and forward traversal) or more, depending on the growth rate of the
oscillation.
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Fig. 4.69: A view in through the input coax.

Fig. 4.70: The Run Window at the end of execution.
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Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The particle phase space, Fig. 4.71, shows how the energy is being extracted from electron beam. To generate this
image:

• For Data View select Phase Space.

• Set X-axis to electron_x.

• Set Y-axis to electron_ux.

• Press Draw.

• Move the dump slider forward in time to see the evolution

• The image is at dump 37.

Fig. 4.71: Longitudinal phase space of the electron beam.

One can see in Fig. 4.71 that the beam has been overdriven, such that trapping is beginning to occur. Hence, one
must either reduce the input power or one must reduce the gain. In the middle of the tube one can see that the beam
oscillation for one cycle decays a bit before taking off again. This is where the attenuator is located.

The effect of overdriving the tube can also be seen in the longitudinal field, Fig. 4.72. This image is obtained by

• For Data View select Field Analysis.

• Set Field to E_x.

• For Lineout Settings, choose Horizontal with Intercept of 0.

4.3. Radiation Generation 259



VSim Examples, Release 9.0.2-r2448

• For Layout select Stacked 2d/1d.

• Press Perform Lineout.

• Set the Colors minima and maxima to /𝑝𝑚2𝑒3.

• Move the dump slider forward in time to see the evolution

• The image is at dump 37.

Fig. 4.72: Longitudinal electric field in the center of the tube.

As expected, the longitudinal field is largely confined within the helix. Again, at around x=0.4, one sees the field being
damped out by the attenuator. Because the tube has been overdriven, harmonics are appearing in the field at the right.
This image shows that the harmonics occur at about 1/5 of the current output power, indicating the amount by which
one should decrease the input power or the gain to obtain linear operation.

The gain can be seen in the History records, which are available under the History Data View. A sample of these is
shown in Fig. 4.73.

To obtain this history image:

• For Data View select History.

• For Graph 1 select inputVoltage.

• For Graph 2 select outputVoltage.

• For Graph 3 and Graph 4 select <None>

This image shows that the voltage gains is about a factor of 10 or 20 dB. The voltage history also shows the harmonics
in the output that come from overdriving the tube.
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Fig. 4.73: Input and output voltage histories.

Further Experiments

As noted at the beginning, this run could be run for many more time steps to determine whether backward oscillations
are present. Additionally, one can experiment with the beam energy to determine what energy gives the most gain.
Varying the input power can determine the maximum output power, which happens when the beam begins trapping at
the end of the tube, or the input power at which one obtains large gain while remaining in the linear regime.

4.3.7 Klystron (klystron.sdf)

Keywords:

klystron

Problem description

This VSimMD example simulates a two cavity klystron in three dimensions. The first cavity is driven at its lowest
resonant frequency. The resultant cavity voltage creates a velocity modulation in the electron beam which translates
to charge modulation as the beam travels in the tube between cavities. The charge modulation then drives the second
cavity. The cavities are loaded to give them finite Q.

This simulation can be performed with a VSimMD or VSimPD license.

Opening the Simulation

The Klystron example is accessed from within VSimComposer by the following actions:
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• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.

• Select Klystron and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the setup window as shown in Fig. 4.74.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.

Fig. 4.74: Setup Window for the Klystron example.

This example illustrates two methods for generating geometries. Under Geometries in the elements tree there are two
paths, CSG and load1Geom. The CSG components are constructed from primitives within VSim. The load1Geom
was imported as an STL file. Highlighting any geometry under the CSG group shows how it was created, either as a
primitive with parameters or by operations on other shapes.

Simulation Properties

This simulation is set up to do a Power Run with full capabilities. After completing the Power Run and visualizing the
results, you may wish to refine the performance of the klystron by adjusting the setup. Some useful tuning procedures
are described in the Further Experiments section. These include the Resonant Frequency Run and the Attenuation
Calibration Run.

Some constants that you may wish to modify include:
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FREQUENCY:The frequency (in Hz) at which the signal across cavity is driven. This can be tuned to the resonant
frequency once determined.

BEAMRADIUS: The radius of the emitted beam of electrons into the klystron.

BEAMCURRENT: The current of the electron beam.

Running the Simulation

With the default setup, complete the Power Run with the following steps:

• Proceed to the Run window by pressing the Run button in the left column.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.75 below.

Fig. 4.75: The Run Window at the end of execution.

Visualizing the Results

After the the simulation run has completed successfully, you may proceed to the Visualize Window by pressing the
Visualize button in the left column. To reproduce Fig. 4.76 follow these steps:

• Select Data Overview from the Data View pull-down menu.

• Expand Particle Data

• Expand electrons0

• Select electrons0_ux
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• Expand Geometries

• Select poly_surface (klystronPecShapes)

• Select Clip All Plots

• Step through time using the dump slider on the bottom of the right pane.

Fig. 4.76: A power run with an electron beam.

Further Experiments

The Attenuation Calibration Run and Resonant Frequency Run are outlined below. These experiments will allow
you to tune the klystron. You may want to iterate through these experiments to get the desired performance. Once the
cavity performance is satisfactory you can repeat the Power Run to see the effects on the electrons. To see the full
behavior of the device, increase the number of steps to (5 x Default). This will allow you to see the saturation of the
second cavity.

Resonant Frequency Run

To determine the resonant frequency of the first cavity we will analyze the fourier transform of its voltage. In the
Setup window, under Basic Settings, set particles to no particles. Then, under SpaceTimeFunctions, in ring1J change
“rampUp” to “rampUpAndDown”. This will ping Cavity 1 and allow us to observe the ringing signal. Run the
simulation with this setup.

To determine the resonant frequency proceed to the Visualize window. Select History from the Data View pull-down
menu. Click FFT to the left of the Cavity1Voltage plot in the Visualization Results pane. The resulting plot will
resemble Fig. 4.77. Zoom in on the maximum of this plot to determine the resonant frequency. You can now update
the FREQUENCY under Contants in the Setup window with this new value and use it to drive future simulations.

Attenuation Calibration Run
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Fig. 4.77: Fourier transform of Cavity1_Voltage versus time (in GHz).

The user can integrate this run type in order to calibrate the observed attenuation to the desired loss. The attenuation
can be tuned by modifying the conductivity of the material, resistive damper. The Q of the cavity can be computed
using a feature of the Analysis Tab, as described below.

For the Attenuation Calibration Run, use the same Setup as the Resonant Frequency Run. After running the
simulation, the quality factors, 𝑄1 and 𝑄2, for cavities 1 and 2 can be calculated using the computeInverseQ.py script
in the Analyze window.

• Press the Analyze button in the left column of buttons.

• Select the computeInverseQ.py analyzer, then Open.

• Enter Cavity1Voltage or Cavity2Voltage in the historyName field to designate the history to analyze.

• Enter the value of the FREQUENCY constant as defined in the Setup window in the frequency field to designate
the frequency at which the history will be analyzed.

• Update the outputFileName field if desired

• Click the Analyze button in the top right corner of the window. As shown in Fig. 4.78 below. Two columns
of data with the titles “Time (s)” and “Inverse Q” will be output in the right pane. The analysis has completed
when you see the output “Analysis completed successfully.”

Scrolling through or plotting the output data in the Visualize window enables the user to understand the Klystron’s
performance. The user may iterate this run type to achieve the desired attenuation.

4.3.8 2D Magnetron (magnetron2D.sdf)

Keywords:
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Fig. 4.78: The Analysis window at the end of execution of the computeInverseQ.py script.

magnetron

Problem description

This VSimMD example simulates a rising sun magnetron in two dimensions. A load is added to one cavity, repre-
senting a coupler to the magnetron through the quality factor, Q. Upon configuring an electrostatic voltage across the
anode and cathode, particles are introduced to the simulation, exhibiting a five spoke pi-mode.

This simulation can be performed with a VSimMD or VSimPD license.

Opening the Simulation

The 2D Magnetron example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation option.

• Select “2D Magnetron” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries. See Fig. 4.79.
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Fig. 4.79: Setup Window for the 2D Magnetron example.

Simulation Properties

As seen in Fig. 4.80 of the rising sun magnetron, the radius of the cathode is RCATHODE and the radius of the anode
is RANODE. Long cavities have radius RCAVITY1 and opening angle ANGLECAVITY1. Short cavities have radius
RCAVITY2 and opening angle ANGLECAVITY2. These dimensions control the spectrum and thus the operating
frequency, which for the default parameters is approximately 960 MHz.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.81 below.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column.

• Expand Particle Data

• Expand electrons

• Select electrons
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Fig. 4.80: Some exposed variables of the 2D Magnetron example.
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Fig. 4.81: The Run Window at the end of execution.

• Expand Geometries

• Select poly (magnetron2DGeomSolid)

The electron modes can be viewed in the right pane. Use the dump slider on the bottom of the right pane to step
through time. When electrons are emitted from the cathode, the four spoke, 650 MHz is present during startup. At
approximately 250 ns, the five spoke begins to dominate and eventually appears as seen in Fig. 4.82.

4.4 Radiation Generation (text-based setup)

4.4.1 Gyrotron Mode (gyrotronModeT.pre)

Keywords:

gyrotron

Problem description

This VSimMD example illustrates a very high order mode, TE-22-6, propagating in a cylindrical waveguide, very near
to the cutoff frequency, which is a common situation in a gyrotron. The example is intended to allow investigation
of the axial phase and group velocity of such a mode, as a function of frequency, and to highlight the intricacies of
simulating a mode that is propagating within a percent or two of its cutoff frequency.

This simulation can be performed with a VSimMD license.
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Fig. 4.82: The five spoke pi-mode at 600 ns.

Opening the Simulation

The Gyrotron Mode example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation (text-based setup) option.

• Select “Gyrotron Mode (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.83.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.83.

Input File Features

There are only two geometrical input parameters; the waveguide radius and length. The user may also control the
excitation frequency, the duration of the simulation, and the nature of the excitation, specifically whether it is pulsed
or continuous-wave. Additional exposed parameters include the grid sizes, and the tuning of the exiting wave boundary
condition, which allows for more in-depth study with this example.

The excitation may be pulsed or continuous-wave, depending on the parameter, KEEP_DRIVE_ON.

Pulsed Simulation (KEEP_DRIVE_ON=0)
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Fig. 4.83: Setup Window for the Gyrotron Mode example.

In this case, the wave is driven for half of the simulation duration, with a smooth turn-on / turn-off time window. Then,
for the remaining half of the periods, the excitation propagates freely. The axial profile of the pulse will be very short,
typically just one or two axial wavelengths. It will propagate slowly down the waveguide, as expected from the group
velocity which is very small near cutoff. In the center of the pulse the TE-22-6 mode is preserved, but because this is
a pulse, nearby modes in frequency are also present. One can observe a rich set of other mode patterns just a few grid
planes away from the center of the pulse.

Continuous-Wave Simulation (KEEP_DRIVE_ON=1)

The drive may be kept on, instead of having it turn off halfway through the simulation. After an initial transient, this
sets up a single TE-22-6 traveling wave mode pattern throughout the waveguide. This allows for accurate measurement
of the axial wavenumber, beta, for the mode.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.84 below.

Visualizing the results

After performing the above actions, continue as follows:
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Fig. 4.84: The Run Window at the end of execution.

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The 𝐵𝑥 field is the best component for looking at in this simulation, as shown in Fig. 4.85. To create this plot:

• Expand Scalar Data.

• Expand faceB.

• Select faceB_x.

• Select Display Contours and set # of Coutours to 10.

• Select Clip All Plots.

• Move the dump slider to dump 11.

The initial parameters are selected so that the excitation frequency is just barely above cutoff. While the axial phase
velocity is high in this case, the group velocity is quite low, and the simulation shows a narrow wavepacket slowly
moving down the length of the tube, while remarkably still maintaining the very high order TE-22-6 pattern. Contam-
ination of the pattern increases as the duration of the excitation is reduced, since more frequencies are brought into the
transient. The user is encouraged to look at the mode pattern and contamination properties as frequency and duration
are varied.

The TE-22-6 mode’s cutoff frequency, for the suggested initial radius of 20 cm, is known analytically to be 10.8845
GHz, which derives from the value of the 6th root of the 𝐽22 bessel function, which is 45.624312. However, the user
will note that the suggested initial drive frequency is below this, at 10.74 GHz, and yet the wave appears to propagate!
This illustrates an important property of finite-difference dispersion, that in fact the speed of light is ever-so-slightly
slower in the finite-difference-time-domain simulation than in reality. In most cases, this is hardly noticed, however,
when operating this close to the cutoff frequency of a waveguide, this difference can be readily seen, as this example
illustrates. The discrepancy between the discrete FDTD cutoff frequency and the analytic cutoff frequency, depends
on the grid resolution of the wave, and in general decreases as 𝛿𝑥2, where 𝛿𝑥 is the grid size.
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Fig. 4.85: Illustration of the mode pattern, and propagation of the mode down the length of the tube.

A very useful piece of information is the FDTD cutoff frequency. This may be found with a series of simulations, each
at different drive frequencies, 𝜔. The KEEP_DRIVE_ON parameter should be set to 1, so that the axial wavelength,
𝛽, can be measured from the field plots. A plot of 𝜔2 vs. 𝛽2 should be essentially linear, with the intercept on the
𝜔2 axis being the FDTD cutoff frequency, 𝜔2

𝑐𝑢𝑡𝑜𝑓𝑓 (𝜔2 = 𝜔2
𝑐𝑢𝑡𝑜𝑓𝑓 + 𝑐2𝛽2), and with slope being the FDTD speed-

of-light-squared. A spreadsheet showing this exercise for the suggested initial values of the example is shown below.
The result of this study is that the FDTD cutoff frequency is actually 10.675 GHz, or 2% below the known analytical
result, for the initial suggested grid resolution.

Further Experiments

The user is encouraged to repeat the simulations discussed in the previous section with a finer resolution, to see how
the FDTD cutoff frequency approaches the analytic result as resolution improves.

The detailed TE-22-6 mode pattern is very carefully crafted using polynomial fitting functions, and is introduced into
the axial magnetic field, 𝐵𝑥, at the left side of the simulation. There is no direct option to use a different mode,
although the user may attempt to edit the detail of the input to do so.

Finally, a boundary condition tuning parameter, VPHASE_PORT, is offered to allow the user to experiment with
tuning of the outgoing wave boundary condition in this near cutoff scenario. In this circumstance, the optimal phase
velocity may be 5 to 10 times the speed of light.

An additional exposed user parameter, FREQ_CUTOFF, is offered, and may be used to store the value derived from
the simulations discussed in the previous section. By default, this parameter is not used. However the user may look
into the detail of input file, and notice a comment line that indicates how this parameter might be used to set the value
of VPHASE_PORT more accurately.

4.4. Radiation Generation (text-based setup) 273



VSim Examples, Release 9.0.2-r2448

Fig. 4.86: Computing the FDTD cutoff frequency of the TE-22-6 mode.

274 Chapter 4. VSim for Microwave Device Examples



VSim Examples, Release 9.0.2-r2448

4.4.2 Klystron (klystronT.pre)

Keywords:

klystronT

Problem description

This VSimMD example simulates a two cavity klystron in three dimensions. First, one cavity is pinged, and the
resulting spectrum yields the resonant frequency used for later simulations. The two cavities are then loaded to
simulate couplers to the cavities and the signal gain is demonstrated in a power run with an electron beam.

This simulation can be performed with a VSimMD, VSimEM or VSimPD license.

Opening the Simulation

The Klystron example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation (text-based setup) option.

• Select “Klystron (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.87 .

Input File Features

As seen in Fig. 4.88, a cylindrical tube of length TUBE_LENGTH and radius REND_TUBE is connected by a gap
to two cavities. The cavities have length CAVITY_LENGTH and beginning and ending radii RBGN_CAVITY and
REND_CAVITY, respectively. The centers of the cavities are a distance CAVITY_CENTER from the ends of the
tube, and the gaps connecting the tube and cavities have length GAP_LENGTH. When electrons are included us-
ing INCLUDE_PARTICLES = 1, they are emitted from the end of the tube near cavity 1 in a beam with radius
BEAM_RADIUS.

The following are three run types accommodated in the klystronT.pre file:

Resonant Frequency Run

The purpose of the resonant frequency run type is to identify the frequency at which to drive the klystron in later
simulations. Cavity 1 is pinged and an analysis of the fourier transform of the generated gap voltage yields the
resonant frequency.

Attenuation Calibration Run

Both klystron cavities are loaded in order to simulate couplers to the cavities. The user can integrate this run type in
order to calibrate the observed attenuation to the desired loss.

Power Run

Finally, an electron beam is emitted inside the klystron from the end of the tube near cavity 1. The previous runs can
be iterated to ensure that the output power gain is as desired.

Designate the run type as follows:
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Fig. 4.87: Setup Window for the Klystron example.

Resonant Frequency Run

Set TURN_DRIVE_OFF = 1, DRIVE_CAVITY1 = 1, DRIVE_CAVITY2 = 0, CAVITY1_LOAD = 0.0, CAV-
ITY2_LOAD = 0.0, and INCLUDE_PARTICLES = 0.

Attenuation Calibration Run

Set TURN_DRIVE_OFF = 1, CAVITY1_LOAD and CAVITY2_LOAD to the desired values, and IN-
CLUDE_PARTICLES = 0. To calibrate cavity 1, set DRIVE_CAVITY1 = 1 and DRIVE_CAVITY2 = 0. To calibrate
cavity 2, set DRIVE_CAVITY1 = 0 and DRIVE_CAVITY2 = 1.

Power Run

Set TURN_DRIVE_OFF = 0, DRIVE_CAVITY1 = 1, DRIVE_CAVITY2 = 0, CAVITY1_LOAD and CAV-
ITY2_LOAD to the desired values, and INCLUDE_PARTICLES = 1.

Running the simulation

After setting the desired run type, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.89 below.
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Fig. 4.88: Some exposed variables of the Klystron example.
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Fig. 4.89: The Run Window at the end of execution.

Visualizing the results

After running the desired run type, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

Resonant Frequency Run

To visualize a run to determine the resonant frequency, select History from the Data View pull-down menu at the
top of the CONTROLS pane. Select Cavity1_Voltage in the CONTROLS pane, and click FFT to the left of the Cav-
ity1_Voltage plot in the VISUALIZATION pane. The resulting plot will resemble Fig. 4.90. Zoom in on the maximum
of this plot to determine the resonant frequency.

Fig. 4.90: Fourier transform of Cavity1_Voltage versus time (in GHz).

Attenuation Calibration Run

For the Attenuation Calibration Run, the quality factors 𝑄1 and 𝑄2 for cavities 1 and 2 can be calculated using the
computeInverseQ - Compute Inverse Q Analysis as follows:
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• Press the Analyze button in the left column of buttons.

• Select computeInverseQ.py from the pull down menu in the Control section of the window.

• Enter Cavity1_Voltage or Cavity2_Voltage in the history field to designate the history to analyze.

• Enter the value of the input parameter DRIVE_FREQ in the frequency field to designate the frequency at which
the history will be analyzed.

• Click the Analyze button in the top right corner of the window. As shown in Fig. 4.91, two columns of data with
the titles “Time (s)” and “Inverse Q” will be output in the right pane. The analysis has completed when you see
the output “Analysis completed successfully.”

Fig. 4.91: The Analysis window at the end of execution of the computeInverseQ.py script.

Scrolling through or plotting the output data enables the user to calculate the values of 1/𝑄1 and 1/𝑄2, and thus
𝑄1 and 𝑄2. The user may iterate this run type to calibrate the quality factors 𝑄1 and 𝑄2 by varying the values of
the input parameters CAVITY1_LOAD and CAVITY2_LOAD. Note that 𝑄1 and 𝑄2 are inversely proportional to
CAVITY1_LOAD and CAVITY2_LOAD, respectively.

Power Run

In the power run, we introduce an electron beam to the simulation as seen in Fig. 4.92. You can reproduce this image
by doing the following:

• Press the Visualize button in the left column of buttons.

• Expand Particle Data

• Expand electrons0

• Select electrons0_ux

• Expand Geometries
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• Select poly_surface (klystronPecShapes)

• Select Display Contours

• Select Clip All Plots

You can change the color table to something that better shows the physics, and in this image the color table is set to
“hot_desaturated”.

Fig. 4.92: A power run with an electron beam.

Further Experiments

Try varying the parameter TUBE_LENGTH in order to maximize the gain.

4.4.3 2D Magnetron (magnetron2DT.pre)

Keywords:

magnetron, electromagnetic cavities, mode frequencies

Problem description

This VSimMD example simulates a rising sun magnetron in two dimensions. The spectrum of the magnetron is first
tuned through geometric properties, yielding the operating frequency. A load is then added to one cavity, representing
a coupler to the magnetron through the quality factor, Q. Upon configuring an electrostatic voltage across the anode
and cathode, particles are introduced to the simulation, exhibiting a five spoke pi-mode.

This simulation can be performed with a VSimMD or VSimPD license.
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Opening the Simulation

The 2D Magnetron example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Radiation Generation (text-based setup) option.

• Select “2D Magnetron (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.93.

Fig. 4.93: Setup Window for the 2D Magnetron example.

Input File Features

As seen in Fig. 4.94 of the rising sun magnetron, the radius of the cathode is RCATHODE and the radius of the anode
is RANODE. Long cavities have radius RCAVITY1 and opening angle ANGLECAVITY1. Short cavities have radius
RCAVITY2 and opening angle ANGLECAVITY2. These geometrical properties control the spectrum and thus the
operating frequency, which for the default parameters is approximately 960 MHz.

One long cavity is loaded with damping parameter NU_LOADING, which may be used to tune the quality factor Q
of the magnetron, which is inversely proportional to NU_LOADING. Once the design of the magnetron is specified,
electrons may be emitted from the cathode by setting INCLUDE_PARTICLES = 1.

The following are four run types accommodated in the magnetron2DT.pre file:

The Mode Spectrum
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Fig. 4.94: Some exposed variables of the 2D Magnetron example.
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The magnetron is rung up with a magnetic field perpendicular to the plane of the magnetron, confined to one of the
long cavities. The generated voltage spectrum can then be analyzed to anticipate the magnetron operating frequency.

Calibrating the Pi-Mode and Quality Factor

The magnetron is again rung up, but with a magnetic field profile with null lines part way up a long cavity arm at
the approximate location required for a pi-mode. At this point, the magnetron geometry can be modified to yield the
desired operating frequency. The load can also be tuned at this point to result in the appropriate cavity quality factor.

Calibrating the DC Voltage

A specific DC voltage between the anode and cathode is required to support a given operating mode for particles in
the magnetron. Thus, in this run type, an electrostatic field generated between the cathode and anode is tuned using a
combined source with feedback and drain, and a finite-difference divergence-free 1/r current profile.

Run with Particles

Finally, electrons are emitted into the magnetron from the cathode. The previous runs can be iterated to ensure that
the electrons exhibit the desired mode.

The four basic run types may be configured as follows:

The Mode Spectrum

Set PI_MODE_PRIMING = 0, INCLUDE_DC_VOLTAGE = 0, INCLUDE_PARTICLES = 0, and IM-
PULSE_EXCITATION = 1.

Calibrating the Pi-Mode and Quality Factor

Set IMPULSE_EXCITATION = 0, INCLUDE_DC_VOLTAGE = 0, INCLUDE_PARTICLES = 0, and
PI_MODE_PRIMING = 1.

Calibrating the DC Voltage

Set IMPULSE_EXCITATION = 0, PI_MODE_PRIMING = 0, INCLUDE_PARTICLES = 0, and IN-
CLUDE_DC_VOLTAGE = 1.

Run with Particles

Set IMPULSE_EXCITATION = 0, PI_MODE_PRIMING = 0, INCLUDE_DC_VOLTAGE = 1, and IN-
CLUDE_PARTICLES = 1.

Running the simulation

For each of the setups described above, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column.

• To run the file, click on the Run button in the upper left corner of the right pane. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.95.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column.

Visualization of the four basic run types is described below.

The Mode Spectrum
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Fig. 4.95: The Run Window at the end of execution.

Fig. 4.96: Fourier transform of voltage across rung up cavity as a function of frequency (in GHz).
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In Fig. 4.96, the fourier transform of the voltage across the rung up cavity is plotted versus frequency (in GHz). This
indicates that we should expect modes near 650 MHz and 960 MHz. To generate this plot, select History from the
Data View pull-down menu at the top of the Visualization Controls pane. Choose the cavity1Voltage plot in the. Then
in the Visualization Results pane, click FFT to the left of the cavity1Voltage plot, and zoom in to the relevant area.

Calibrating the Pi-Mode and Quality Factor

Fig. 4.97: Fourier transform of voltage across rung up cavity as a function of frequency (in GHz).

In Fig. 4.97, the fourier transform of the voltage across the rung up cavity is plotted versus frequency (in GHz). The
960 MHz mode is more pronounced than in the previous run, but the 650 MHz mode remains. If we instead seek
another operating frequency, we could change the geometry of the magnetron to iteratively tune this spectrum.

Another quantity we may wish to tune is the magnetron quality factor, 𝑄. We expect 𝑄 to be inversely proportional to
NU_LOADING, but it is possible to measure 𝑄 using VSim. Using the decay of the cavity1Voltage history, 𝑄 may
be calculated as

𝑄 = 𝜋 𝑓 (𝑡2 − 𝑡1) ln−1

[︂
𝑉 (𝑡1)

𝑉 (𝑡2)

]︂
where 𝑓 is the operating frequency, 𝑉 (𝑡) is measured as in Fig. 4.98. We calculate 𝑄 to be 400 with f = 960 MHz.

Fig. 4.98: Decay of voltage across cavity 1 (in kV) as a function of time (in ns). The two indicated points could be
used to calculate the quality factor.

Calibrating the DC Voltage

An electrostatic field is generated between the cathode and anode using a combined source with feedback and drain,
and a finite-difference divergence-free 1/𝑟 current profile. In Fig. 4.99, the resulting voltage between the anode and
cathode, the history cathodeAnodeVoltage (in kV), is plotted versus time (in ns). The user controls the average value
of this voltage through the variable VOLTAGE_DC.

Run with Particles

When electrons are emitted from the cathode, the four spoke, 650 MHz is present during startup. At approximately
250 ns, the five spoke begins to dominate and eventually appears as seen in Fig. 4.100.
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Fig. 4.99: Voltage between the anode and cathode (in kV) as a function of time (in ns), recorded through the history
cathodeAnodeVoltage.

Fig. 4.100: The five spoke pi-mode.
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Further Experiments

Try varying RCATHODE and observing the effect on the spoke formation.

4.5 Multipacting

4.5.1 Multipacting Growth in Waveguide (multipactingGrowth.sdf)

Keywords:

multipacting

Problem description

Multipacting, which is the resonant build up of secondary electrons, is often a concern in microwave devices. Anytime
there is an oscillating electromagnetic field across a gap between two surfaces there exists the possibility that for the
right voltage across the gap a resonance condition will exist allowing the exponential build up of secondary electrons.
A coaxial waveguide is such a type of structure where these conditions can exist.

This simulation can be performed with the VSimMD or VSimPD license.

Opening the Simulation

The Multipacting Growth example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Multipacting option.

• Select “Multipacting Growth in Waveguide” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
4.101. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Simulation Properties

This example contains a number of Parameters to allow for easy manipulation of the device. Those include:

• R_O: The outer coax radius

• R_I: The inner coax radius

• FREQUENCY: The wave launcher frequency

SpaceTimeFunctions are used to create expressions defining the drive frequency and amplitude of the applied field.

CSG is used to create the coax structure by combining cylinders and cubes.
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Fig. 4.101: Setup Window for the Multipacting Growth example.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 4.102

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view growth in the number of electrons, as shown in Fig. 4.103, do the following:

• Select History from the Data View pull down menu

• Set Graphs 1&2 to “None”

• Graph 3 should already be set to numElectrons (if not, set it)

The overall trend in the number of electrons is an exponential growth with an oscillatory signal that corresponds to the
frequency of the traveling wave.
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Fig. 4.102: The Run Window at the end of execution.

Fig. 4.103: Visualization of the exponential growth of the electrons due to multipacting.
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Further Experiments

Try changing the gap voltage or the frequency of the wave to see if one can take the simulation in and out of resonance.

4.5.2 Multipacting Resonances in Waveguide (multipactingResonances.sdf)

Keywords:

multipacting , multipactingResonances

Problem description

Multipacting, which is the resonant build up of secondary electrons, is often a concern in microwave devices. Anytime
there is an oscillating electromagnetic field across a gap between two surfaces there exists the possibility that for the
right voltage across the gap a resonance condition will exist allowing the exponential build up of secondary electrons.
A coaxial waveguide is such a structure where these conditions can exist.

This simulation can be performed with the VSimMD license.

Opening the Simulation

The Multipacting Resonances example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Multipacting option.

• Select “Multipacting Resonances in Waveguide” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.104.

Simulation Properties

The input file sets the number of cells along the propagation (x) direction to resolve the wavelength. The electrons are
seeded in the middle of the waveguide once the wave has passed. A special electron species is used that allows scans
over power to be done in a single simulation. The time step is chosen to be at 90% of the CFL (stability) limit.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.105.
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Fig. 4.104: Setup Window for the Multipacting Resonances example.

Fig. 4.105: The Run Window at the end of execution.
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Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To track the electrons and their field scaled paramteres as shown in Fig. 4.106, proceed as follows:

• Select Phase Space from the Data View pull down menu (at the top of the Controls pane)

• Select electrons_x for the X-axis

• Select electrons_y for the Y-axis.

• Select electrons_fieldScaleParam for the Color.

• Move the Dump slider to Dump: 11

• Click on Draw.

Fig. 4.106: Location of electrons and their field scaled parameters.

To view growth in the number of electrons, proceed as follows:

• Select Phase Space from the Data View pull down menu (at the top of the Controls pane)

• Select electrons_fieldScaleParam for the X-axis

• Select electrons_weight for the Y-axis.

• Move the Dump slider to the far right.

• Click on Draw.
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Fig. 4.107: Visualization of the resonance bands.

Further Experiments

Try seeing how changing the gap voltage or the frequency of the wave changes the multipacting resonances.

4.5.3 Multipacting in Stripline (striplineMultipacting.sdf)

Keywords:

striplineMultipacting

Problem description

This VSimMD example launches a wave into a stripline multipacting geometry and demonstrates multipacting effects.

This example is run in a portion of a TEM transmission line CAD file, and demonstrates how multipacting occurs at
specific drive voltages. This is done with the use of a Field Scaling Electron particle species.

This simulation can be performed with a VSimMD license.

Opening the Simulation

The Stripline example is accessed from within VSimComposer by the following actions:

• Select the New From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.
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• Expand the Multipacting option.

• Select “3D Stripline Multipacting” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.108.
As shown in the image, Field Scaling Electrons are being used to be able to simulate multiple field powers in one
simulation.

Fig. 4.108: Setup Window for the Stripline example.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane on the right.
You will see the output of the run in the right pane. The run has completed when you see the output, “Engine
completed successfully.” This is shown in Fig. 4.109 below.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the exponential increase in electrons as in Fig. 4.110:

• Select History under the Data View drop down

• Set Graph 2 to numRealElectrons
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Fig. 4.109: The Run Window at the end of execution.

• Set Graphs 3 & 4 to None

To view the voltage at which multipacting occurs in the stripline, as seen in Fig. 4.111:

• Select Phase Space under the Data View drop down

• Set the X-axis to electrons_fieldScaleParameter

• Set the Y-axis to electrons_weight

• Set the Color to electrons_weight

• Press Draw.

• Move the slide to the right to see how the multipacting growth is occurring.

Further Experiments

Try varying the parameter VOLTAGE to observe when multipacting occurs. For example, multipacting does not occur
for VOLTAGE = 45.0 Volts.

4.5.4 Multipacting Growth in Spherical PEC Cavity Using Prescribed Fields (multi-
pactingGrowthPrescribedFields.sdf)

Keywords:

multipacting
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Fig. 4.110: The numRealElectrons history shows exponential growth in the number of electrons.

Fig. 4.111: The multipacting occurs at a scaling value of around 2.5. You can use this to multiply the value of
START_VOLTAGE to find out the voltage at which multipacting occurs. In this case that is around 60.0 Volts
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Problem description

Multipacting, which is the resonant build up of secondary electrons, is often a concern in microwave devices. Anytime
there is an oscillating electromagnetic field across a gap between two surfaces there exists the possibility that for the
right voltage across the gap a resonance condition will exist allowing the exponential build up of secondary electrons.
This example simulates multipacting growth in a spherical PEC cavity. The fundemental mode profile for the spherical
PEC cavity is imported onto the VSim grid, then advanced in time by a single frequency time signal.

This simulation can be performed with the VSimMD or VSimPD license.

Opening the Simulation

The Multipacting Growth Prescribed Fields example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Multipacting option.

• Select “Multipacting Growth Using Prescribed Fields” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
4.112. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 4.112: Setup Window for the Multipacting Growth example.
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Simulation Properties

This example contains a number of Constants to allow for easy manipulation of the device. Those include:

• SPHERE_RADIUS: radius of spherical cavity

• LENGTH_METAL: Length of metal box in each dimension (must be larger than 2*SPHERE_RADIUS)

• RESOLUTION: The number of cells per wavelength in each dimension

SpaceTimeFunctions are used to create expressions defining the drive frequency and amplitude of the applied field.

The amplitude and frequency of this driving function is defined in Parameters:

• MODE_FREQ: frequency at which the mode profile oscillates.

• MODE_AMP: amplitude that is applied to the mode profile each time step.

CSG is used to create the spherical PEC cavity by subtracting sphere from a cube.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.113

Fig. 4.113: The Run Window at the end of execution.
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Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view growth in the number of electrons, as shown in Fig. 4.114, do the following:

• Select History from the Data View pull down menu

• Set Graphs 2-4 to “None”

• Set Graph 1 to numElectrons

The overall trend in the number of electrons is an exponential growth with an ocsillatory signal that corresponds to the
frequency of the time signal.

Fig. 4.114: Visualization of the exponential growth of the electrons due to multipacting.

Further Experiments

Try changing the parameters MODE_AMP and MODE_FREQ to see if one can take the simulation in and out of reso-
nance.

4.6 Multipacting (text-based setup)

4.6.1 Multipacting Resonances in Waveguide (multipactingResonancesT.pre)

Keywords:
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multipacting , multipactingResonancesT

Problem description

Multipacting, which is the resonant build up of secondary electrons, is often a concern in microwave devices. Anytime
there is an oscillating electromagnetic field across a gap between two surfaces there exists the possibility that for the
right voltage across the gap a resonance condition will exist allowing the exponential build up of secondary electrons.
A coaxial waveguide is such a structure where these conditions can exist.

This simulation can be performed with the VSimMD license.

Opening the Simulation

The Multipacting Resonances example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Multipacting (text-based setup) option.

• Select “Multipacting Resonances in Waveguide (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.115.

Fig. 4.115: Setup Window for the Multipacting Resonances example.
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Input File Features

The input file sets the number of cells along the propagation (x) direction to resolve the wavelength. The electrons are
seeded in the middle of the waveguide once the wave has passed. A special electron species is used that allows scans
over power to be done in a single simulation. The time step is chosen to be at 90% of the CFL (stability) limit.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner. of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.116.

Fig. 4.116: The Run window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view growth in the number of electrons:

• Select Phase Space from the Data View drop down

• Select scaleFactor for the X-axis

• Select weight forthe Y-axis
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• Move the Dump slider to the far right then click on Draw.

Fig. 4.117: Visualization of the resonance bands.

Further Experiments

Try seeing how changing the gap voltage or the frequency of the wave changes the multipacting resonances.

4.6.2 3D Stripline Multipacting (striplineMultipactingT.pre)

Keywords:

striplineMultipactingT

Problem description

This VSimMD example launches a wave into a stripline geometry and demonstrates multipacting effects. The use of
“field scaled” particles allows the scanning of multiple power levels in one run. Each particle has a scaling parameter
that multiplies the electromagnetic field, allowing multiple power or voltage levels to exist simultaneously. This feature
allows for quick finding of the cut-off resonance in the stripline.

This simulation can be performed with a VSimMD license.

Opening the Simulation

The Stripline Multipacting example is accessed from within VSimComposer by the following actions:
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• Select the New From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Multipacting (text-based setup) option.

• Select “3D Stripline Multipacting (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 4.118.

Fig. 4.118: Setup Window for the Stripline Multipacting example.

Input File Features

The Stripline Multipacting example has the following input parameters:

• TIMESTEP_FACTOR multiplies the numerical stability limit on the time step to compute the actual time step.
TIMESTEP_FACTOR should be a real number greater than 0 and less than 1.

• START_VOLTAGE specifies the starting voltage for the field scale particles in Volts across the plates in the
stripline. START_VOLTAGE should be a positive real number.

• END_VOLTAGE specifies the ending voltage for the field scale particles in Volts across the plates in the
stripline. END_VOLTAGE should be a positive real number.

• NUMBER_OF_INC specifies the number of increments to use for the voltage between START_VOLTAGE and
END_VOLTAGE.

• FREQ specifies the frequency in Hertz of the signal in the stripline. FREQ should be a positive real number.
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• INCLUDE_PARTICLES = 1 loads electrons into the simulation and INCLUDE_PARTICLES = 0 does not load
electrons into the simulation.

• LOADTIME specifies the time in seconds at which electrons are loaded into the simulation. LOADTIME should
be a non-negative real number.

There are also several input parameters to specify the secondary electron yield based on the equation:

𝑆𝐸𝑌0 * (1 − 𝑒𝑥𝑝(−𝐴 * (𝑥/𝑈0)𝐵))/𝐶/((𝑥/𝑈0)𝐷)

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.119 below.

Fig. 4.119: The Run Window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the exponential increase in electrons as in Fig. 4.120:

• Select History under the Data View drop down
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• Set Graph 2 to numRealElectrons

• Set Graphs 3 & 4 to None

Fig. 4.120: The numRealElectrons history shows exponential growth in the number of electrons.

To view the voltage at which multipacting occurs in the stripline, as seen in Fig. 4.121:

• Select Phase Space under the Data View drop down

• Set the X-axis to electrons_fieldScaleParameter

• Set the Y-axis to electrons_weight

• Set the Color to electrons_weight

• Press Draw.

• Move the slide to the right to see how the multipacting growth is occurring.

Further Experiments

Try varying the starting and ending voltages as well as the number of increments to see if multipacting occurs in
different ranges.

4.7 Other

4.7.1 Electron Gun (electronGun.sdf)

Keywords:
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Fig. 4.121: The multipacting occurs at a scaling value of around 2.5. You can use this to multiply the value of
START_VOLTAGE to find out the voltage at which multipacting occurs. In this case that is around 60.0 Volts

electron, gun, beam, collimate

Problem description

Electron guns are devices that are often found in vacuum electronics as well as in more advanced technologies such as
klystrons, electron microscopes, and particle accelerators. They produce narrow, collimated beams of electrons with
precisely tuned kinetic energies. They were often found in cathode ray tubes at the heart of television sets prior to
the digital revolution. Electron guns are composed of a cathode, an anode, and repulsive rings. A DC or RF signal is
applied to the cathode to produce electrons via thermionic emission. The electrodes produce electric fields that focus
the electron beam. Often an additional anode is placed between the cathode and the main anode to act as a repulsive
ring that focuses the beam into a small hole in the main anode. The small hole in the main anode acts to collimate the
beam.

This example is a specialized electron gun for klystrons and TWTs. It is characterized by high power, a consequence
of which is that electrons not successfully collimated can damage the device. To minimize this effect, the gun includes
a focusing anode cone, the angle of which is conducive to laminar flow of the electron beam.

Opening the Simulation

The Electron Gun example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Other MD option.
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• Select “Electron Gun” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.122.

Fig. 4.122: Setup Window for the Electron Gun example.

Simulation Properties

The input parameters give you total flexibility in in defining the geometry of the example. Along with these one can
define the nominal cell size, the driving voltages, the strength of the magnetic field, and the beam current.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.123.

Visualizing the Results

To reproduce Fig. 4.124 proceed as follows:

• Expand Particle Data.
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Fig. 4.123: The Run Window at the end of execution.

• Expand electron.

• Select electron in red.

• Expand Scalar Data

• Expand E.

• Select “E_magnitude”.

• Expand Geometries.

• Select “poly (electronGunPecShapes)”.

• In the lower part of the left pane select “Display Contours”.

• Select “Clip All Plots”.

• In the lower part of the right pane, move the Dump slider to dump 14.

This will show the electron beam and the electric and magnetic fields.

The phase space diagram can also be viewed by choosing Phase Space in the Data View drop down menu.

The voltages and currents at key locations in the simulation are recorded in Histories and can be viewed by selecting
the History data view.

Further Experiments

The geometry is extremely important for proper functionality in this example. For example, the angle that the focusing
cone makes with the beam axis determines whether the beam will be laminar. If the beam intersects and diverges, the
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Fig. 4.124: The electron beam and electric field.

gun can be damaged by its own power. Try altering the dimensions of the the geometry and see the effect on the
electron beam.

4.7.2 Multistage Collector (multistageCollector.sdf)

Keywords:

electromagnetics, multistageCollector

Problem description

Multistage Depressed Collectors (MDCs) are used to recover energy from a spent beam in linear type microwave
tubes such as traveling wave tubes (TWTs) and klystrons. VSim provides the capability to simulate these collectors
shaped with arbitrarily complex geometries and depressed with different time-dependent voltage profiles to optimize
the recovery efficiency of a design. To demonstrate this capability, we show in this example a 4-stage depressed
collector. One can adjust the depressed potentials at each electrode individually to see how the performance of the
collector is affected.

This simulation can be performed with a VSimMD, VSimEM or VSimPD license.

Opening the Simulation

The Multistage Collector example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

4.7. Other 309



VSim Examples, Release 9.0.2-r2448

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Other MD option.

• Select “Multistage Collector” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.7.2.

Setup Window for the Multistage Collector example.

Simulation Properties

The simulation geometry consisting of an S-band 4-stage depressed collector is imported into the computational engine
from CAD files in stl format. One can easily create new geometry using any CAD program and output or convert the
CAD files into stl files for a new simulation design. The detailed import method is provided in the input file. The
spent beam profile is taken from a TWT simulation provided by Prof. H. Song at University of Colorado at Colorado
Springs.

An optimized design for a MPM module can be found in reference [1]. Users can set preferred spent beam profiles by
employing different emission methods or import data in dat format as in this example. A main feature of this input file
is that the depressed voltage profiles are time-dependent and are stablized with a new external circuit model based on
special feedback algorithms only available in VSim. Interested users may refer to the publication for more a detailed
description and validation. In addition, the convergence of this example is carefully tested.

In this example, the Z coordinate is the direction aligned with the beam axis of the MDC, and the 4 different voltages
can be easily assigned at the input panel. Since it is a time domain simulation, the Dey-Mittra algorithm is employed
and the accuracy is second-order for the complex boundaries.
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Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.7.2.

The Run Window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The results are then read from the Data Overview in the Visualize Window:

• Expand Particle Data.

• Expand electrons.

• Select electrons in red.

• Expand Scalar Data.

• Expand E.

• Select E_z.

• Expand Geometries
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• Select the second option from the top: multistageCollectorGeomSolidMappedPolysData_surface.

• Select Display Cotours in the bottom left corner.

• Select Clip All Plots in the bottom left corner.

• Click on Plane Controls and in the Clip Plane Control window, under Clip Plane Normal select X (plane normal
to x-axis), then click Ok.

• Move the Dump slider all the way to the end.

• Use the cursor to grab the image and rotate it from right to left to see the image in Fig. 4.7.2.

Visualization of the MDC model with a color contour plot of electric fields and electrons in red.

Further Experiments

The depressed voltages or beam current/radius can be varied in the input panel for testing runs. One can also change
the grid cell numbers to see the convergence of the simulations.

References
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Modeling of Multistage Depressed Collectors Using 3D Conformal Finite-Difference Time-Domain Particle-
In-Cell Simulations ”, J. Korean Phys. Soc. 60, 731-738 (2012).
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4.8 Other (text-based setup)

4.8.1 Electron Gun (electronGunT.pre)

Keywords:

electron, gun, beam, collimate

Problem description

Electron guns are devices that are often found in vacuum electronics as well as in more advanced technologies such as
klystrons, electron microscopes, and particle accelerators. They produce narrow, collimated beams of electrons with
precisely tuned kinetic energies. They were often found in cathode ray tubes at the heart of television sets prior to
the digital revolution. Electron guns are composed of a cathode, an anode, and repulsive rings. A DC or RF signal is
applied to the cathode to produce electrons via thermionic emission. The electrodes produce electric fields that focus
the electron beam. Often an additional anode is placed between the cathode and the main anode to act as a repulsive
ring that focuses the beam into a small hole in the main anode. The small hole in the main anode acts to collimate the
beam.

This example is a specialized electron gun for klystrons and TWTs. It is characterized by high power, a consequence
of which is that electrons not successfully collimated can damage the device. To minimize this effect, the gun includes
a focusing anode cone, the angle of which is conducive to laminar flow of the electron beam.

Opening the Simulation

The Electron Gun example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Other MD (text-based setup) option.

• Select “Electron Gun (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.125.

Input File Features

The input parameters give you total flexibility in in defining the geometry of the example. Along with these one can
define the nominal cell size, the driving voltages, the strength of the magnetic field, and the beam current.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in the window below.

After performing the above actions, continue as follows:
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Fig. 4.125: Setup Window for the Electron Gun example.

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.126.

Visualizing the Results

The stream of electrons can be visualized along with the electric field and the geometry by doing the following:

• Expand Particle Data.

• Expand electron.

• Select electron.

• Expand Scalar Data.

• Expand edgeE.

• Select edgeE_magnitude.

• Expand Geometries.

• Select poly (electrodes)

• Select Display Contours

• In the lower part of the left pane select “Display Contours”.

• Select “Clip All Plots”.
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Fig. 4.126: The Run Window at the end of execution.

• In the lower part of the right pane, move the Dump slider to dump 12.

The phase space diagram can also be viewed by choosing Phase Space in the Data View drop down menu.

The voltages and currents at key locations in the simulation are recorded in Histories and can be viewed by selecting
the History data view.

This will show the electron beam and the electric and magnetic fields.

Further Experiments

The geometry is extremely important for proper functionality in this example. For example, the angle that the focusing
cone makes with the beam axis determines whether the beam will be laminar. If the beam intersects and diverges, the
gun can be damaged by its own power. Try altering the dimensions of the the geometry and see the effect on the
electron beam.

4.8.2 Multistage Collector (multistageCollectorT.pre)

Keywords:

electromagnetics, multistageCollectorT

Warning: Due to a known issue in the STL reader during parallel runs, this example may run into trouble if run
on too many cores. We suggest limiting this run to 4 cores, though more may still work.
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Fig. 4.127: The electron beam and electric field.

Problem description

Multistage Depressed Collectors (MDCs) are used to recover energy from a spent beam in linear type microwave
tubes such as traveling wave tubes (TWTs) and klystrons. VSim provides the capability to simulate these collectors
shaped with arbitrarily complex geometries and depressed with different time-dependent voltage profiles to optimize
the recovery efficiency of a design. To demonstrate this capability, we show in this example a 4-stage depressed
collector. One can adjust the depressed potentials at each electrode individually to see how the performance of the
collector is affected.

This simulation can be performed with a VSimMD or VSimPD license.

Opening the Simulation

The Multistage Collector example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Microwave Devices option.

• Expand the Other MD (text-based setup) option.

• Select “Multistage Collector (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 4.128.
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Fig. 4.128: Setup Window for the Multistage Collector example.

Input File Features

The simulation geometry consisting of an S-band 4-stage depressed collector is imported into the computational engine
from CAD files in stl format. One can easily create new geometry using any CAD program and output or convert the
CAD files into stl files for a new simulation design. The detailed import method is provided in the input file. The
spent beam profile is taken from a TWT simulation provided by Prof. H. Song at University of Colorado at Colorado
Springs.

An optimized design for a MPM module can be found in reference [1]. Users can set preferred spent beam profiles by
employing different emission methods or import data in dat format as in this example. A main feature of this input file
is that the depressed voltage profiles are time-dependent and are stablized with a new external circuit model based on
special feedback algorithms only available in VSim. Interested users may refer to the publication for more a detailed
description and validation. In addition, the convergence of this example is carefully tested.

In this example, the Z coordinate is the direction aligned with the beam axis of the MDC, and the 4 different voltages
can be easily assigned at the input panel. Since it is a time domain simulation, the Dey-Mittra algorithm is employed
and the accuracy is second-order for the complex boundaries.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 4.129.
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Fig. 4.129: The Run Window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The results are then read from the Data Overview in the Visualize Window:

• Expand Particle Data.

• Expand electrons.

• Select electrons in red.

• Expand Scalar Data.

• Expand elecField.

• Select elecField_z.

• Expand Geometries.

• Select the second option from the top: poly_surface.

• Select Display Cotours in the bottom left corner.

• Select Clip All Plots in the bottom left corner.

• Click on Plane Controls and in the Clip Plane Control window, under Clip Plane Normal select X (plane normal
to x-axis), then click Ok.

• Use the cursor to grab the image and rotate it from right to left.
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The time dependent evolution of the MDC can be seen by sliding the Dump number from left to right, as shown in
Fig. 4.130.

Fig. 4.130: Visualization of the MDC model with a color contour plot of electric fields and electrons in red.

The potential of each of collector sufraces is recorded using a history. To visualize these values as shown in Fig. 4.131,
do the following:

• Switch Data View to “History”.

• In the left pane, set Graphs 1-4 to each of the different potential histories: “potential10”, “potential20”, “poten-
tial30”, and “potential40”, respectively (see Fig. 4.131).

• Set the Location of each graph to the “Window 1”.

Further Experiments

The depressed voltages or beam current/radius can be varied in the input panel for testing runs. One can also change
the grid cell numbers to see the convergence of the simulations.

References
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Modeling of Multistage Depressed Collectors Using 3D Conformal Finite-Difference Time-Domain Particle-
In-Cell Simulations ”, J. Korean Phys. Soc. 60, 731-738 (2012).
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Fig. 4.131: The value of the potential on each of the collectors.
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CHAPTER

FIVE

VSIM FOR PLASMA ACCELERATION EXAMPLES

These examples illustrate how to solve complex problems in plasma acceleration.

These examples can be run with a VSimPA license.

5.1 Beam Driven (text-based setup)

5.1.1 Electron Beam Driven Plasma Wakefield (electronBeamDrivenPlasmaT.pre)

Keywords:

electron driven, plasma wakefield, CLARA, PARS, AWAKE

Problem description

This example demonstrates a method to simulate an electron beam driven plasma wakefield accelerator. The electron
beam initializes the field using a speed of light frame Poisson equation solve, then the fields and particles are evolved
using FDTD EMPIC. We launch the electron beam from x=0 in the positive x direction using the Lorentz boosted
Poisson fields to ensure that the simulation is self-consistent from start. The primary bunch generates a region of
high field into which one might inject and accelerate a second bunch of charged particles. The example simulation
uses parameters that are appropriate to the plasma acceleration research station (PARS) at the CLARA accelerator at
Daresbury Laboratory in the UK.

Opening the Simulation

The Electron Beam Driven Plasma Wakefield example is accessed from within VSimComposer by the following
actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Acceleration option.

• Expand the Beam Drive Acceleration (text-based setup) option.

• Select Electron Beam Driven Plasma Wakefield (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 5.1.

At this stage one can choose parameters such as LONGITUDINAL_RES and TRANSVERSE_RES which represent
the longitudinal and transverse number of cells per RMS bunch size. The minimum of 6 or default of 8, generates a
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Fig. 5.1: Setup Window for the Electron Driven Plasma Wake example.

simulation that will complete reasonably quickly, but is not adequate to generate good results. Consider 12 or 16 cells
in both dimensions to avoid a “checkerboard” pattern of numerical noise from developing.

Input File Features

The simulation setup consists of an electromagnetic solver using the Yee algorithm and uses the initBeam macro to set
up the inital beam properties. This takes the beam of variable weight particles and calculates self-consistent fields with
which to initialise the simulation. As this beam travels near the speed of light, a moving window that co-propogates
with the beam is employed. MALs are used on the transverse sides of the window to absorb outgoing waves. The
plasma is represented by macro-particles, and both beam and plasma are moved using the Boris push. The particles in
the plasma are variably weighted to represent the density ramp. It is assumed the plasma consists of pre-ionized heavy
ions, which do not move in the time frame of the simulations.

One can specify the size of the region to be simulated through LONGITUDINAL_EXTENT and
TRANSVERSE_EXTENT, which are measured relative to the longitudinal RMS size BEAM_LRMS and transverse
RMS size BEAM_SIGMAR of the beam. The number of cells is determined by the settings of LONGITUDINAL_RES
and TRANSVERSE_RES, as shown in the figure.

The plasma density is ramped up using a flat top cosine function, by default, over a quarter of the longitudinal size of
the simulation window. This can be modified by viewing the input file and editing the STARTRAMP and RAMPLEN
variables.

Running the Simulations

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.
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• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. This is shown in Fig. 5.2. The run has completed when you see the
output, “Engine output has completed succesfully.”

Running in 2D, you can expect a 2 core laptop to take a few minutes at the default resolution and run time.

To produce real significant results, a higher resolution is required by changing LONGITUDINAL_RES and TRANS-
VERSE_RES. Doing so will greatly increase the amount of time to run this simulation. It should also be run for a
longer time than the default 3000 steps.

The 3D simulation is about 100 times bigger, so 256 cores for a few hours is needed.

Fig. 5.2: The Run Window.

Visualizing the Output

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

View the electric field generated by the plasma as shown in Fig. 5.3 by doing the following:

• Switch to Field Analysis in the Data View Controls pane

• Set the Field to ElecFieldPlasma_x

• Choose the Horizontal tab in Lineout Settings set the intercept to zero, and click Perform Lineout

• Check the Auto Reset buttons on both the 2d and the Lineout plots. Sometimes it is necessary to expand the plot
size in order for the box to appear. You can do this by pulling the divider between “Visualization Controls” and
“Visualization Results” to the left and hiding it. Both the 2d and the Lineout plots should be larger now.

• Move the dump slider forward in time.
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Fig. 5.3: Visualization of the longitudinal electric field as a color contour plot and longitudinal lineout.

The plasma density can be seen as shown in Fig. 5.4 by doing the following:

• Switch to Data Overview in the Data View drop down

• Expand Scalar Data

• Select rhoPlasma

• Click Auto Reset

• Move slider all the way to the right.

5.2 Laser Driven

5.2.1 Laser Plasma Accelerator (laserPlasmaAccel.sdf)

Keywords:

Laser Plasma Accelerator

Problem description

This example demonstrates the use of VSim to simulate a simple laser-plasma accelerator problem using the full PIC
algorithm.

An intense, short laser pulse propagating through a plasma can lead to the separation of electrons and ions capable of
producing accelerating electric fields of hundreds of GV/m [GTVT+04]. VSim is capable of simulating laser plasma
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Fig. 5.4: Visualization of the longitudinal plasma density field as a color contour plot.

accelerators (laserPlasmaAccel) using several different models: envelope, fluid and full particle-in-cell (PIC).

Here we look at the full PIC model with a 1-mm long plasma with uniform density of 1.𝑒25 m−3. A gaussian laser
pulse, defined by the transverse electric field

𝐸𝑦 = 𝐸0(0.5 − 0.5 cos(𝜋𝑡/𝑇 ))𝐻(𝑇 − 𝑡) exp(−(𝑦2 + 𝑧2)/(𝑤2
0𝐷𝑦𝐷𝑧)) cos(𝜔𝑡 + 𝜑𝑦 + 𝜑𝑧)

where 𝑤0 is the radius at which the wave amplitude drops to 1/𝑒, 𝑇 is the temporal duration of the pulse,

𝐷𝑦 = 1 + (𝐹/𝑍)2

𝐷𝑧 = 1 + (𝐹/𝑍)2

are the squares of amplitude reductions from being the launching at a distance, 𝐹 , from the focus, 𝑍 is the Rayleigh
length, and

𝜑𝑦 = −(𝐹/𝑍)(𝑦/𝑤0)2/𝐷𝑦

𝜑𝑧 = −(𝐹/𝑍)(𝑧/𝑤0)2/𝐷𝑧

are the Gouy phases.

The laser is launched from the left side of the box. The laser amplitude is determined through the normalized vector
potential 𝐴0 = 𝑒𝐸0/𝜔𝑚𝑒𝑐, where 𝜔 is the laser angular frequency.

The simulation setup consists of an electromagnetic solver using the Yee algorithm. The laser pulse is launched from
the left side of the window using the pre-defined gaussian pulse launcher at the left boundary. Simple conducting
boundary conditions are used at the top and sides. As such, one must ensure that waves reflected off the top or bottom
do not get into the simulation, and that no waves hit the right boundary to be reflected back into the simulation.

The plasma is represented by macro-particles which are moved using the Boris push. The particles are variably
weighted to represent the density ramp.
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The input file allows one to set up plasma and laser parameters. The simulation box size is determined as a function
of the laser length and spot size. The resolution was set to have about 24 cells per wavelength longitudinally and 3
transversely. The time step is chosen to be very close to the courant condition limit in order to have good dispersion.

This simulation can be performed with a VSimPA license.

Opening the Simulation

The Laser Plasma Accelerator example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Acceleration option.

• Expand the Introductory Examples option.

• Select “Laser Plasma Acceleration” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 5.5.
You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the grid,
expand the Grid element and select or deselect the box next to Grid.

Fig. 5.5: Setup Window for the Laser Plasma Acceleration example.

The Setup Window shows a very long simulation. However, the full length is not simulated at any one time. Instead a
moving window is used to simulate only the region where dynamics is occurring. The length seen in Fig. 5.6 is that of
the electron loader.

To see the grid size, one can expand Particle Dynamics → KineticParticles → electrons0 and unclick particleLoader.
If one wishes to simulate this for longer distances, one can set the Parameter, NUM_XLENGTHSS, to a larger number;
400 is more than enough.
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Fig. 5.6: Zoom of Setup Window for the Laser Plasma Acceleration example showing size of grid.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper right corner of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” See
Fig. 5.7.

Running in 2D, this simulation uses around 225,000 cells and nearly 200,000 particles for 20,000 time steps. The run
takes about an hour on a 4-core 2.5 GHz I7.

Visualizing the results

After performing the above actions, click on Visualize in the column of buttons at the left. For all plots, it is useful to
keep Auto Reset on so that the window moves with the data.

To view the electric field, switch to Field Analysis in the Data View drop-down menu. From the Field drop-down
menu, choose the desired component of the electric field, E. The depField field is the current density. See Fig. 5.8.

The acceleration of the particles can be seen by viewing the (𝑥) component of the velocity. To do this, switch to
the Phase Space Data View in VSimComposer and set the X-axis variable to electrons0_x, and the Y-axis variable to
electrons0_ux. Then click Draw. You will see a color-coded picture of particle velocity like in Fig. 5.9.

Further Experiments

Try increasing or decreasing the intensity of the laser pulse through the parameter A_0 and see the effect on the shape
of the plasma wakefield.
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Fig. 5.7: The Run Window at the end of execution.

Fig. 5.8: The output of the run shows the accelerating field 𝐸𝑥 after about 2 picoseconds.
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Fig. 5.9: Phase-space plot of plasma electrons at t = 2.1 picoseconds.

5.3 Laser Driven (text-based setup)

5.3.1 Colliding Pulse Injection (collidingPulseInjT.pre)

Keywords:

laser plasma accelerator, controlled injection, colliding laser pulses

Problem description

This example demonstrates the use of VSim to simulate controlled injection in a laser-plasma accelerator using collid-
ing laser pulses [CMRB+10]. Two laser pulses are launched from opposite sides (one from the left side and the other
one from the right side of the box) and propagate in opposite directions. The laser pulse coming from the left side is
the main pulse that drives the plasma wake. The laser pulse coming from the right is the collider pulse, with much
lower intensity than the main pulse. It can also propagate with a small angle with respect to the main pulse propagation
axis. When the two lasers collide they create a slow beat wave, which allows electrons of the background plasma to
be trapped and be accelerated by the wakefield driven by the main pulse.

In this example, the laser pulses are polarized in the 𝑦 direction and both have a Gaussian profile defined by

𝐸𝑦 = 𝐸pump_(L,R) exp(−𝑥2/LPUMP_(L,R)
2
) exp(−(𝑦2 + 𝑧2)/W0_(L,R)

2
)

where L and R refer to the left and right pulse respectively. The laser intensity is defined through the normalized vector
potential
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APUMP_(L,R) = 𝑒𝐸pump_(L,R)/𝜔(L,R)𝑚𝑒𝑐

where 𝜔 = 2𝜋𝑐/WAVELENGTH_(L,R) is the laser frequency.

The pulses enter a plasma channel with density on axis DENSITY0 through a density ramp of length 20 𝜇 m.

This simulation can be performed with the VSimPA or VSimPD license.

Opening the Simulation

The Colliding Pulse Injection example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Acceleration option.

• Expand the Laser Driven Acceleration (text-based setup) option.

• Select Colliding Pulse Injection (text-based setup) and press the Choose utton.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem can now be changed via the text boxes in the left pane of the Setup Window, as
shown in Fig. 5.10.

Fig. 5.10: Setup Window for the Colliding Pulse Injection example.
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Input File Features

The simulation setup consists of an electromagnetic solver using the Yee algorithm. Two laser launchers are used,
one from the left edge and the other from the right edge of the window. PMLs are used on the transverse sides of
the window to absorb outgoing waves. The plasma is represented by macroparticles which are moved using the Boris
push. The particles are variably weighted to represent the density ramp, and they have a unique tag. The current
deposited by the particles is smoothed using four passes of the 1-2-1 filter and subsequently applying a compensator.

The input file allows one to set up both lasers, plasma and grid parameters.

Running the Simulations

Running in 2D, this simulation uses around 2,600,000 cells and nearly 107 particles. This run requires bout 320 core-
hores for the full 156,000 steps on a 2.5 GHz I7. On less powerful hardware, one can reduce the number of steps to
15000 see just the collision or one can reduce the number of grid points and number of particles per cell to see more
of the evolution, but physical results may not be accurate.

To run on local hardware do

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Set the number of steps to 5000 and the dump periodicity to 500 in order to see the initial evolution. The
collision occurs at step 4500 (dump 9).

• Run in parallel with as many physical cores as are on your machine, because this is a computationally intense
problem. Even with the reduced number of steps, this run can take up to 7 hours on four cores for 5000 steps,
depending on the processor.

• To run the file, click on the Run button in the upper left This is shown in Fig. 5.11. The run has completed when
you see the output, “Engine completed successfully.” in this same pane.

Fig. 5.11: The Run Window.
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Alternatively, copy collidingPulseInjT.pre to your more powerful hardware and run it through the command line or
submit it to your job queue.

Visualizing the Output

If you have run the job on a remote computer, you would now need to copy back the files that you want to visualize
locally into the local directory in which one has the input file open. E.g.,

for dmpnum in 0 8 9 10; do
scp mybigcomputer.mydomain:myspace/collidingPulseInjT_*_${dmpnum}.h5 .

done

Then

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the transverse electric field, switch to the Data Overview in the Visualization Controls pane. From the Field
drop down menu, choose the y component of the ElecMultiField. Set the scale by clicking on the Colors button,
then setting the minimum to -2e12 and the maximum to 2e12. Click the Auto Reset check box. Move the dump slider
to position 8, then 9, then 10 to see the pulses collide. The collision of the pulses is then seen as shown in Fig. 5.12
below.

Fig. 5.12: Visualization of the transverse electric field as a color contour plot and longitudinal lineout.

The x-component shows the wake field of the left incoming pulse and some of the electromagnetic field of the incoming
collider pulse. The wake field can be better seen by clicking on the Colors button and setting the min and max to be
-+ 1.e11. The plasma density can be seen in the zeroth component of the SumRhoJ field.

Particle phase-space can be seen by switching to the Phase Space Data View in the Controls pane. Fig. 5.13 shows the
particle longitudinal momentum as a function of the longitudinal coordinate just after the collision.
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Fig. 5.13: Visualization of the particle longitudinal phase-space during collision. Particles kicked up into the trapped
region by the colliding pulses. One can see the acceleration of particle to high energy in later dumps.

Continuing the simulation

The simulation to this point has allowed one to study the initial injection of particles up to high energy, so that they
can be trapped by the wake. One can now continue this simulation to study the acceleration in the wake. Since this
simulation stopped at dump 10, one can now set the Addition Run Options to unclick Dump at Time Zero and then
set Restart at Dump Number to 10. Since at this point, the evolution changes more slowly, one can set the Number of
Steps to 10000 and the Dump Periodicity to 5000. Again hit Run.

At any time one sees that another data dump has occurred, one can switch over to the Visualize pane and hit Reload
Data to view the new available data, any of the fields or particles as before.

5.3.2 Ionization Injection (fieldIonizeT.pre)

Keywords:

laser plasma accelerator, controlled injection,
ionization of high-Z gas

Problem description

This example demonstrates the use of VSim to simulate ionization-induced injection in a laser plasma accelerator
[CES+12]. An intense laser pulse propagates up a plasma density ramp into a uniform plasma, which creates a
wakefield. Neutral nitrogen atoms are added to the pre-ionized gas at the beginning of the plasma, where the laser
pulse field ionizes them. If the electrons released from the nitrogen ionization are at the correct position relative to the
wakefield phase, they can be trapped and accelerated to high energy [CCMG+13].
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The laser envelope has a Gaussian profile defined at the waist position by (X_0_LASER):

𝐸𝑧 = 𝐸0 exp
(︀
−𝑥2/𝐿𝑃𝑈𝑀𝑃 2

)︀
exp

(︀
−(𝑦2 + 𝑧2)/𝑊_02

)︀
sin (𝜔0𝑡)

where 𝜔0 = 2𝜋𝑐 / WAVELENGTH is the laser frequency. The laser amplitude is defined through the normalized vector
potential A_0 = 𝑒𝐸0/𝜔0𝑚𝑒𝑐.

This simulation can be performed with a VSimPA license.

Opening the Simulation

The Ionization Injection example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Acceleration option.

• Expand the Laser Driven Acceleration (text-based setup) option.

• Select “Ionization injection (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 5.14.

Fig. 5.14: Setup Window for the Ionization injection in Laser Plasma Accelerator example.

334 Chapter 5. VSim for Plasma Acceleration Examples



VSim Examples, Release 9.0.2-r2448

Input File Features

The simulation setup consists of an electromagnetic solver using the Yee algorithm. The laser pulse is launched from
the left side of the window using an expression launcher at the boundary. MALs are used on the transverse sides of
the window to absorb outgoing waves. The plasma is represented by macro-particles which are moved using the Boris
push. The particles are variably weighted to represent the density ramp. The nitrogen atoms are represented using a
fluid neutral gas. The different excited levels of the nitrogen and electrons product of the ionization are represented
through variably weighted macro-particles. The ionization process takes place in MonteCarlo interactions, using the
modified time-resolved ADK formula [CES+12].

Running the Simulations

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• This run is computationally intensive, so you click Run in Parallel and select a number of cores equal to the
number of physical cores on your machine.

• To see the initial evolution, set the Number of Steps to 1000 and the Dump Periodicity to 500.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane on the right.
of the window. You will see the output of the run in that same pane. The run has completed when you see the
output, “Engine completed successfully.” This is shown in Fig. 5.15.

Fig. 5.15: The Run Window at the end of the first execution.

At this point, one can skip ahead to the visualization section to see whether the fields look reasonable. If they do, you
can restart:

• Set the Number of Steps to 9000 and Restart at Dump Number to 2.
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• Click on the Run button. The run has completed when you see the output, “Engine completed successfully.”

This run takes about 70 minutes on a 4 core, 2.5 GHz Intel I7. To run on less powerful hardware one can reduce the
number of grid points and number of particles per cell, however physical results may not be as accurate.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The laser pulse is the 𝑧 component of the field, while the accelerating field is the 𝑥 component. The plasma density
can be seen in rho.

Fig. 5.16 shows the longitudinal laser field along the beam axis. To reproduce:

• Set Data View to Field Analysis

• Click Auto Reset on both the pseudocolor and lineout plots so that the window updates the plot region as one
moves the slider. You may need to expand your visualization window for the Auto Reset checkbox to appear.

• Select edgeE_x from the Field drop down menu

• Select the Horizontal tab in the lineout settings

• Set the intercept to 0

• Click “Perform Lineout

• Move the dump slider forward in time

Fig. 5.16: Left: Longitudinal electric field 𝐸x(𝑥, 𝑦) at t=1.3 picoseconds. Right: Line-out of field plot at 𝑦 = 0.

The acceleration of the particles can be seen by viewing the (𝑥) component of the velocity as shown in Fig. 5.17
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• Set Data View to Phase Space

• Set Base Variable to electrons

• Set the X-axis variable to electrons_x, the Y-axis variable to electrons_ux

• Check Enable Second Plot

• Set Base Varible to ionzedElectrons

• Set the X-axis variable to ionizedElectrons_x, the Y-axis variable to ionizedElectrons_ux

• Click Draw

• Click Reset View

Fig. 5.17: Phase-space plot (𝑥, 𝛾 𝑣x) of plasma electrons at t=0.33 picoseconds.
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CHAPTER

SIX

VSIM FOR PLASMA DISCHARGES EXAMPLES

These examples illustrate how to solve complex problems in plasma discharge modelling.

These examples can be run with a VSimPD license.

6.1 Capacitively Coupled

6.1.1 1D Capacitive Plasma Chamber (capacitivelyCoupledPlasma1D.sdf)

Keywords:

CCP discharge, secondary emission, elastic collision, excitation, ionization.

Problem description

The capacitively coupled plasma (CCP) is one of the most common types of industrial plasma sources. The discharges
usually take place between metal electrodes in a reaction chamber and are driven by a radio-frequency (RF) or DC
power supply. The plasma is sustained by ohmic heating in the main body and stochastic heating through a capacitive
sheath.

This example demonstrates the generation of a capacitively coupled plasma inside two parallel conducting plates
separated by 0.05 m. A background Ar neutral gas at approximately 6 mTorr a number density of approximately
2.0 × 1020 𝑚−3) is filled between the electrodes. The right electrode is grounded, while the left one is connected to a
voltage source of 200 V at 60 MHz.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The 1D Capacitively Coupled Plasma Discharge example is accessed from within VSimComposer by the following
actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Capacitively Coupled Plasmas option.

• Select “1D Capacitive Plasma Chamber” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.
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Fig. 6.1: Setup Window for the 1D Capacitively Coupled Plasma Discharge example.

The Setup Window and elements tree with all the implemented physics and geometries, is shown below in Fig. 6.1.

The time step DT should sufficiently resolve the plasma frequency and collision frequency. The default time step used
in this example is TIMESTEP_FACTOR * (0.1 / Plasma frequency) to ensure stability. The initial primary electrons
are gradually loaded into the simulation domain over a period of LOADSTEPS timesteps, which has a default value
of 5000.

Simulation Properties

This simulation includes some constants and parameters for easy adjustment of the simulation properties. These
include:

Constants

• NEUTRAL_ARGON_DENSITY: number density of the background neutral argon gas (number/m^3).

• FREQUENCY: sets the frequency of the driving voltage set on the lower X boundary.

• VOLTAGE: sets the amplitude of the driving voltage set on the lower X boundary.

• NOMINAL_DENSITY: this adjusts the number of physical particles loaded into the simulation.

• LOADSTEPS: Timestep when particle loading will end.

• NSTEPS: How many timesteps to simulate.

• STEPS_PER_DUMP: number of steps to take between data dumps.

• BMAG: sets the strength of the magnetic field (default = 0T).
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Time-dependent Dirichlet boundary conditions are used to set up the boundaries of electric fields around the reaction
chamber walls, and are set in Field Dynamics -> FieldBoundaryConditions. The self-consistent electric field is solved
from Poisson’s equation by the Generalized Minimum Residual (gmres) electrostatic solver in Cartesian coordinates.
This solver is chosen under Field Dynamics -> PoissonSolver.

The plasma is represented by macroparticles which are moved using the Boris pusher in Cartesian coordinates and
interact with the background neutral argon gas through collisions set up with the Reactions framework. The particles,
background gas, and collisions are set up in the Particle Dynamics Element.

The simulation includes two electron species: Primary electrons which are electrons loaded into the simulation, and
Secondary electrons which are created through physical processes. Both species are managed weight particle species,
which will combine or split macro particles based on user choices.

Elastic collisions between electrons and the background gas, excitation collisions in which an electron will lose energy
to the background gas, and ionization collision in which electrons create argon ions from the background gas are all
included. The cross-sections for this collisions are imported from 2-column data files.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 6.1.

Fig. 6.2: The Run Window at the end of execution.
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Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

From the “Data View” option, select “History”. There are 6 histories that can be plotted in this window: the number
of physical particles and the number of macro particles for each of the three particle species (argon ions, primary
electrons, and secondary electrons). To produce the plot in Fig. 6.14

• Plot the ‘numArgon’ history in Graph 1.

• Plot the ‘numPrimaryElec’ history in Graph 2.

• Plot the ‘numArgon’ history in Graph 3 and change the Location to Window 2

• Plot the ‘numPhysSecondaryElec” history in Graph 4.

The simulation converges as the number of secondary electrons approaches a constant, indicating a steady state plasma.
With the default number of time steps (4000, or 2 nanoseconds), the simulation does not reach steady state (see the
black, numPhysSecondaryElec history curve). To reach steady state, the simulation must run for approximately 100
microseconds.

Fig. 6.3: Visualization of number histories of ion, primary electron, and secondary electrons for at 4000 steps or 20
nanoseconds.

Further Experiments

Set up a History that records the electron current flowing into the left and right sides of the simulation. Right click
on the “Histories” element and under “Add ParticleHistory” select “Absorbed Particle Current.” You can change the
name of the history by double clicking on the new “absorbedPtclCurrent0” element in the tree. Then be sure to pick
the particle absorber from which you would like to collect data.
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The Reactions framework allows one to set up collision interactions flexibly. The collisions involved in this example
are electron-neutral collisions that lead to ionization and ohmic heating. As a further experiment, ion-neutral collisions,
such as elastic scattering and charge exchange, can also be added to the simulation.

The VSim interface can import any cross sections that are in a 2-column format. There should be NO headings in
the data file. The LXcat scattering database (https://fr.lxcat.net/data/set_type.php) and EEDL cross section database
contain cross section data for around one hundred different materials. As another experiment, change the cross-section
used in the simulation or change the species of the background gas and import new cross-sections.

6.1.2 Turner Case 2 (Turner.sdf)

Keywords:

capacitively coupled plasma, CCP, discharge, steady state, Turner

Problem Description

In this example we demonstrate VSim’s ability to simulate capacitively coupled plasmas, using the benchmark cases
of Turner et al. [TDD+13]. Turner’s work documents the successful benchmarking of five independently developed
particle-in-cell codes (not including VSim) for four different capacitive coupling scenarios at various background
pressures.

Here, we consider the second of the Turner scenarios, though the input file can be readily modified to simulate the
others. In addition to being able to accurately reproduce the Turner results, VSim can also employ physics-based
initialization methods to enable more rapid convergence of the simulations to their steady-state. The use of such
methods will also be explained below.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Turner example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item from the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Introductory Examples option.

• Select Turner and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig. 6.4.
In this image, we have unclicked the electrons’ particleLoaderE and the He1NeutralFluid so that they will not hide
the basic grid You can expand the tree elements and navigate through the various properties, making any changes you
desire. The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide
the grid, expand the Grid element and select or deselect the box next to Grid. This is a one-dimensional problem,
which is shown by having the grid have only a single cell above and below the x-axis.

Clicking the electrons’ particleLoaderE shows that the electron loader is defined to exist over a cartesian 3d slab, even
though this is a one-dimensional simulation. The dimensions that do not apply are ignored, with the coordinate set to
zero, but this allows easy conversion from a 1D simulation to a 2D simulation.
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Fig. 6.4: Setup Window for the Turner example.

Simulation Properties

The basic physics of this simulation is a balance between collisional processes and wall losses; a one-dimensional box
of length 6.7 cm contains neutral helium gas at room temperature (300 K) and density 3.21𝑒211/𝑚3 (1 Torr of pressure
at that temperature). The gas is weakly ionized, resulting in a population of free electrons and singly ionized helium
atoms at density 5.12𝑒141/𝑚3. The helium ions are also at room temperature, while the electrons are considerably
hotter (30,000 K). The left wall of the box is grounded, while the right wall oscillates with a bias voltage of 200 V at
frequency 13.56 MHz.

Charged particles are lost upon collision with the wall and are replenished by ionization of the background neutral gas
by the hot electrons; the latter process repopulates both the electrons and helium ions in the plasma (the background
neutral gas is treated as an infinite source). Plasma sheaths form near the walls, containing electric fields which are
strong relative to those elsewhere in the plasma; the particle density profiles adjust in response to the fields in the
sheath. The sheath transit time, for ions, is much longer than the period of the oscillating potential; thus, multiple RF
cycles occur while an ion crosses the sheath. A steady state is attained when the loss rate of particles to the wall comes
into balance with the ionization rate for a particular profile shape.

In our initial run we are not going to model the full evolution of the discharge to its steady-state parameters; rather,
we will explore the basic physics of the discharge and modify the simulation accordingly (with the aim of ultimately
hastening convergence to this steady state, while exploring VSim capabilities).

Running the Simulation

The original runs by Turner were for about 4,000,000 steps. However, the asymptotic state is reached after about
300,000 steps. To illustrate how to run this problem, we will run for only 50,000 steps, which takes about 5 minutes
on a 4-core i7 Windows workstation.
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To run the simulation, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Change Number of Time Steps to 50000 (approximately 1/80 of the length of Turner’s run)

• Consider clicking ‘Disable Communication Text Files’ (yes, if desired - reduces clutter) in and ‘Run with MPI’
(yes, if desired - set ‘Number of Cores’ corresponding to your VSim license) in the MPI tab at the left side of
the run panel.

• To run the file, click on the Run button in the upper left corner of the window. You will see the output of the run
in the right pane. The run has completed when you see the output, “Engine completed successfully.” A snapshot
of the simulation run during execution is shown in Fig. 6.5.

Fig. 6.5: The Run Window during execution.

Analyzing the Results

We are going to run a postprocessing script, computePtclNumDensity.py, which builds density profiles from the parti-
cle data generated by VSim, so that we can look at these profiles and their evolution. To do so, we do the following:

• Click the Analyze Window

• Click Show All Analyzers and choose computePtclNumDensity.py. Then click Open.

• Fill in the text boxes

– The simulationName should be already filled in, but if it is not, type in the name of the .sdf file without the
.sdf extension.

– For the speciesName, type in ‘electrons’ without the quotes.
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• Click Analyze (in the Analyze Window); this will generate the electron density profiles.

• Now replace ‘electrons’ in the speciesName box with ‘He1’, for the helium ions.

• Click Analyze (again in the Analyze Window) to generate the ion density profiles.

The resulting data will be visualizable as electronsDensity and He1Density under the 1-D Fields Data View in the
Visualize Tab.

Visualizing the Results

Now that we’ve got all of our data, let’s look at it.

• Click the Visualize Window

After a brief moment the visualization options for this data should appear.

We’ll first look at the time evolution of some fundamental one-dimensional quantities. From the Data View pulldown
menu on the top left, select History. The default view here should contain four plots, namely, the electron and ion
currents to the left wall and the number of electron and ion macroparticles in the simulation. A number of notable
physics effects can be seen here:

• After a sharp initial decrease in the electron population, both ion and electron populations decline at
approximately the same rate. This is not as apparent from the separate numElec and numIons plots, but
clicking on the “Location” drop-down window in Graph 3 and selecting “Window 4” as the new rendering
destination, places both ion and electron populations in the same plot. (Select “<None>” in the plot variable
(the topmost menu) for both Graph 1 and Graph 2 to resize the electron/ion plot.) The initial decrease in electron
population arises when rapid electron wall losses create a charge imbalance in the plasma and establish plasma
sheaths near the walls. Thereafter, this charge imbalance is preserved and the transport of both electrons and
ions to the wall becomes ambipolar. A history of the particle popuations can be seen in Fig. 6.6

• The electron wall currents are quasi-periodic. The oscillating potential drives the highly mobile electrons
alternately into the left and right walls. In the plot variable menu, change “numElec” to “leftElecCurr” in Graph
3 and “numIons” to “rightElecCurr” in Graph 4. The impacts of the electron cloud on the left and right walls,
and their phasing in time, can be seen in response to the potential oscillations. A history of the electron currents
can be seen in Fig. 6.7

• The ion currents are non-periodic. Ions, being much heavier than the electrons, exhibit relatively little re-
sponse to the oscillating potentials. In the plot variable menu, change the Graph 1 quantity “None” to “left-
IonCurrent” and the location to “Window 4”, then change the Graph 2 quantity “None” to “rightIonCurrent”
and the location again to “Window 4”. The ion currents do not have the quasi-periodic structure of the electron
currents; rather, ions diffuse outward to the walls in response to the DC sheath potentials, which are established
by the initial departure of electrons and may also be rectified by the RF. A history of all the particle currents can
be seen in Fig. 6.8

• Ion losses are negligible before the initial establishment of the sheath. Change the plot quantity in Graph 3
from “leftElecCurr” to “None”. Change the plot quantity in Graph 4 from “rightElecCurr” to “numElec” and
the “Location” to “Window 3”. It is clear that the dominant loss of ions to the wall only begins after the initial
decrease in electron population (which corresponds to the establishment of the sheath). A history of the electron
popluation against the ion currents can be seen in Fig. 6.9

We can also look at the plasma sheath and the ensuing changes in density profiles directly. In the “Data View”
menu at the top left of the Composer window, select “1-D fields”. The plot controls here are similar to those of the
history window. Select “E_x” for the plot variable in Graph 1. Select “Phi” for the plot variable in Graph 2. Select
“electronsDensity” for the plot variable in Graph 3. Select “He1Density” for the plot variable in Graph 4, and select
“Window 3” for the location of this plot. The evolution of the discharge in time can be viewed by moving the time
slider below the plots.

A number of additional physics features can be seen:
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Fig. 6.6: The electron and ion populations versus time.

Fig. 6.7: Electron currents on the left (green) and right (black) walls versus time
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Fig. 6.8: Electron and ion currents on the left and right walls versus time

• Sheath effects are present. Regions of sharp potential variation, corresponding to strong electric fields, arise
near the walls, but such fields are screened out in the bulk plasma. Moving the time slider, it is clear that this
sheath behavior persists regardless of the phase of the oscillating wall potential.

• Electron profiles are altered much faster than ion profiles. Both ions and electron profiles are initially con-
stant (5.12e14 1/m^3), but by the time the first nontrivial dump file is produced (at time dumpPeriodicity * dt,
approximately 1/3 of the way through the period of the first wall oscillation), electron-poor regions correspond-
ing to the sheaths have already been established in the electron profile, while the ions have barely begun to
respond to the presence of the sheath. Moving the slider forward in time, one observes that the electron pro-
file predominantly oscillates in response to the wall potential, while the ion profile evolves considerably more
slowly, particularly outside the sheath regions. The 1-D fields can be seen in Fig. 6.10

Further Experiments

Now that we understand some of the basic physics of the discharge, we are in position to apply physics-based particle
loading methods to hasten its eventual convergence to steady-state. The underlying principle here is to identify the
‘slow’ processes involved in the evolution of the discharge toward steady state, and then alter the loading to more
closely mimic the state to which the plasma is being driven. While we cannot entirely predict the parameters of the
steady-state, it is not difficult to at least get some idea of how the simulation is evolving and adjust the particle loads
accordingly. We have already observed a number of physical processes of possible relevance:

• initial electron loss and the establishment of ambipolarity

• the slow decay of the total ion and electron population following the initial electron loss

• the rapid response of electrons to applied electric fields, particularly in the sheath region
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Fig. 6.9: History plots showing the majority of the ion current to the walls only begins after initial decrease in electron
population
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Fig. 6.10: Plots of various 1-D field quantities showing the final state of the run.

• the slow evolution of ion density profiles.

Of these, we will primarily consider the ion profiles; the high mobility of the electrons suggests that electron profiles
will adjust correspondingly on much shorter timescales. Additionally, since the strong electric fields in the plasma
sheath region are screened out via Debye shielding as we move away from the walls, it seems clear that profile
adjustments in the bulk plasma (where the driving electric fields are weakest) will ensue more slowly than in the
plasma edge. We therefore concentrate our attention first on obtaining an approximately correct value for the ion
density at the center of the domain.

From the ‘Data View’ menu at the top, select ‘1-D Fields’ again, and set the plot variable to ‘<None>’ in plots 2, 3,
and 4. In Graph 1, set the plot variable to ‘He1Density’ and again move the timeslider on the bottom right of the
window. The central ion density steadily rises; from its initial value of 5.12e14 1/m^3, it rises to 7.5e14 1/m^3 by the
end of our comparatively short run. In addition, a rapid decrease in density near the walls (associated with the plasma
sheath) has lowered the edge densities to less than 1e14 1/m^3. The ion density can be seen in Fig. 6.11

Additional Studies

It is possible to try other techniques to converge to steady state faster. These techniques are outlined in detail in the
text-based version of this example. In summary:

Another thing you can try are by loading the particle with a non-uniform profile that better resembles the outcome.

Yet another is to leave a gap near the walls when loading electrons and ions. What happens in the discharge? The
electrons, being highly mobile, rush to fill the gap, but rather than immediately being lost to the wall, they instead
produce strong electric fields at the plasma edge which begin to modify the ion profile and bring about ambipolarity. If
the gap is sufficiently large, the collisional production of ions and electrons will begin before appreciable wall losses
ensue, and we can thus assess the relative rates of production and loss fairly early in the simulation. Since the electrons
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Fig. 6.11: The He ion density at the end of the run

are highly mobile, let’s treat the average electron population as a measure of how well we’ve achieved this balance; net
electron production as we move into the ambipolar phase means that our gap is too low (we have removed too much
density), while net losses mean that our gap is insufficiently wide. As the profile shapes near the walls tend to adjust
themselves fairly quickly (due to the larger electric fields in this region), we can in this manner obtain approximately
correct values for the total ion and electron populations at the simulation outset.

6.2 Capacitively Coupled (text-based setup)

6.2.1 1D Capacitive Plasma Chamber (capacitivelyCoupledPlasma1DT.pre)

Keywords:

CCP discharge, secondary emission, elastic collision, excitation, ionization.

Problem description

The capacitively coupled plasma (CCP) is one of the most common types of industrial plasma sources. The discharges
usually take place between metal electrodes in a reaction chamber and are driven by a radio-frequency (RF) or DC
power supply. The plasma is sustained by ohmic heating in the main body and stochastic heating through a capacitive
sheath.

This example demonstrates the generation of a capacitively coupled plasma inside two parallel conducting plates
separated by 0.05 m. A background Ar neutral gas at approximately 6 mTorr

(︀
2.0 × 1020 𝑚−3

)︀
is filled between the

electrodes. The right electrode is grounded, while the left one is connected to a voltage source of 200 V at 60 MHz.
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This simulation can be performed with a VSimPD license.

Opening the Simulation

The 1D Capacitively Coupled Plasma Discharge example is accessed from within VSimComposer by the following
actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window, expand the VSim for Plasma Discharges option.

• Expand the Capacitively Coupled Plasmas (text-based setup) option.

• Select “1D Capacitive Plasma Chamber (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 6.12.

Fig. 6.12: Setup Window for the 1D Capacitively Coupled Plasma Discharge example.

The time step DT should sufficiently resolve the plasma frequency and collision frequency. The default time step used
in this example is TIMESTEP_FACTOR * (0.1 / Plasma frequency) to ensure stability. The initial primary electrons
are gradually loaded into the simulation domain over a period of LOADSTEPS timesteps, which has a default value
of 5000.

Input File Features

The self-consistent electric field is solved from Poisson’s equation by the electrostatic solver in cylindrical coordinates.
Time-dependent Dirichlet boundary conditions are used to set up the boundaries of electric fields around the reaction
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chamber walls.

The plasma is represented by macroparticles which are moved using the Boris pusher in cylindrical coordinates.
Various types of elastic and inelastic collisions of the particles are calculated.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window Fig. 6.13 below.

Fig. 6.13: The Run Window at the end of execution.

Visualizing the results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

The ion, primary electron, and secondary electron particle number histories can be shown as in Fig. 6.14 as follows:

• From the “Data View” option, select “History”

• Set the Location of Graphs 2 and 3 to Window 1

• Set Graph 4 to secondaries with color Green
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After around 10ns (2000 time steps), the numbers of ions, primaries, and secondary electrons are each increasing. The
simulation converges as the number of secondary electrons approaches a constant, indicating a steady state plasma. At
20ns, when this example ends, the simulation has not yet reached steady state.

Fig. 6.14: Visualization of number histories of ion, primary electron and secondary electron macroparticles for around
4000 steps or 20 nanoseconds.

Further Experiments

Vorpal allows one to set up collision interactions with considerable flexibility. The collisions involved in this exam-
ple are electron-neutral collisions that produce ionization and ohmic heating. As a further experiment, ion-neutral
collisions, such as elastic scattering and charge exchange, can also be added to the simulation.

This example uses sample cross-section files (sampleElasticCrossSection.dat, sampleExcitationCrossSection.dat, and
sampleIonizationCrossSection.dat) for the neutral argon gas. While the data in these cross-section files is not neces-
sarily physically correct, these files can easily be modified by users to make use of more accurate scattering datasets
(EEDL, LXcat, etc.) VSim can directly import scattering data from the LXcat database, which contains cross section
data for around one hundred different materials. As another further experiment, the background argon gas and its
cross section data can be replaced with other materials in the LXcat database. This enables one to easily switch the
background gas in a CCP simulation.

The format of a user-defined cross-sectional data file (e.g. the sample cross-section files used in this example), is
formatted as follows:

• Line 1: Process specifier as a capitalized text string, either ELASTIC, EXCITATION or IONIZATION.

• Line 2: Threshold, the minimum energy in eV needed for this process to occur, as a float

• Line 3: Number of table entries, as an integer
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• Lines 4 - end: A two-column table in which the first column is the collision energy in eV, and the second column
is the cross-section in square meters.

As an example, the cross-sectional data file sampleElasticCrossSection.dat is shown below:

1 ELASTIC
2 0.000
3 7
4 0.000 0.00e-20
5 10.50 16.7e-20
6 25.00 7.75e-20
7 40.00 4.45e-20
8 70.00 2.25e-20
9 100.0 1.50e-20

10 150.0 1.00e-20

Users may import data from other sources as text files with this format, enabling precision control over the collision
processes used in their model.

6.2.2 2D Capacitive Plasma Chamber (capacitivelyCoupledPlasma2DT.pre)

Keywords:

capacitively coupled plasma discharge under RF and DC voltage in 2D cylindrical system.

Problem description

The capacitively coupled plasma (CCP) is one of the most common types of industrial plasma sources. These plasma
discharges typically take place between metal electrodes in a reaction chamber and are driven by a radio frequency
(RF) or direct current (DC) power supply. The plasma is sustained by ohmic heating in the main body and stochastic
heating through the capacitive sheath.

This example demonstrates the generation of a capacitively coupled plasma inside an axially symmetric reaction
chamber with a 50 mm radius and 50 mm length. The top and side walls are grounded at zero potential. A target
located at the bottom of the chamber is connected to a 60 MHz AC voltage source at 200 V. There is a small gap of 5
mm between the target and the grounded wall. The chamber is filled with a background gas of Argon at about 0.005
Torr

(︀
2.0 × 1020 m−3

)︀
. An initial electron density at 1012 m−3 is seeded to start the discharge.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Capacitively Coupled Plasma 2D example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Capacitively Coupled Plasmas (text-based setup) option.

• Select “2D Capacitive Plasma Chamber (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in figure Fig. 6.15.
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Fig. 6.15: Setup Window for the Capacitively Coupled Plasma 2D example.

Input File Features

The self-consistent electric field is solved from Poisson’s equation by an electrostatic solver in cylindrical coordinates.
Time-dependent Dirichlet boundary conditions are used to set up the boundaries of electric fields around the reaction
chamber walls.

The plasma is simulated with macroparticles which are moved using the Boris pusher in cylindrical coordinates.
Various types of elastic and inelastic collisions of the particles are calculated.

The Setup Window has various parameters available for easy manipulation including the density of the argon back-
ground gas (DENSITY_Ar), the voltage (VOLTAGE), and the frequency (FREQ).

Running the simulation

Once finished with the problem setup, continue as follows:

• Proceed to the Run Window by clicking the Run button in the left column of buttons.

• Choose your desired parallel computing options under Parallel Run Options.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in that pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 6.16.

Visualizing the results

After performing the above actions, continue as follows:
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Fig. 6.16: The Run Window at the end of execution.

• Proceed to the Visualize Window by clicking the Visualize button in the left column of buttons.

To plot the potential:

• In the Variables section of the Visualization Controls pane, expand Scalar Data

• Select phi

• Move the dump slider at the bottom of the Visualization Results pane to the right to move forward in time. Once
the slider is selected, the left and right arrow keys will control the slider position as well.

Further Experiments

With a time-step of 10−11 seconds, running this simulation for the default 200 time-steps will only capture part of
the first oscillation. With the frequency set to 6 × 107 Hz, the oscillation period is 1.667 × 10−8 seconds, which
corresponds to 1,667 time-steps. To see the approximate steady-state behavior of this example, set the number of
time-steps to 10,000 or more and restart or re-run the simulation. When running in parallel on 4 processors, this
should take approximately two hours to complete.

After 5 × 10−8 seconds, or 500 dumps, the plasma sheath starts to exhibit oscillating steady-state behavior. To view
the behavior of the oscillating plasma sheath, take the following steps:

• In the Variables section of the Visualization Controls pane, expand Scalar Data

• Select rho

• At the top of the Visualization Results pane, click Colors to open the Color Options window

• Select “Fix Minimum” and set the minimum to -0.0005, then select “Fix Maximum” and set the Maximum
to 0.0005 (or experiment with minimum and maximum values for best results) and click OK
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Fig. 6.17: Visualization of the electric potential in 𝑟-𝑧 coordinates.

• Move the dump slider at the bottom of the Visualization Results pane to dump 250. Once the slider is selected,
the left and right arrow keys will control the slider position.

After 250 time-steps, the plasma density should appear as shown in Fig. 6.18. The green areas at approximately
zero charge density denote the quasi-neutral plasma bulk, while the red areas (positive charge density) denote the
non-neutral the plasma sheath.

To view the plasma sheath potential profile, take the following steps:

• In the Variables section of the Visualization Controls pane, select Field Analysis from the Data View drop-down
menu

• In the Field drop-down menu, select phi

• Under Lineout Settings click on the Horizontal tab, and change the intercept value if desired

• Click Perform Lineout

The electric potential as well as the axial potential profile should now be visible as shown in Fig. 6.19. Move the slider
to the right to see how the plasma sheath potential oscillates in time.

6.2.3 TurnerT Case 2 (TurnerT.pre)

Keywords:

capacitively coupled plasma, CCP, discharge, steady state, TurnerT
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Fig. 6.18: Visualization of the plasma sheath via the charge density.

Fig. 6.19: Visualization of the plasma sheath via the charge density.
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Problem Description

In this example we demonstrate VSim’s ability to simulate capacitively coupled plasmas, using the benchmark cases
of Turner et al. [TDD+13]. Turner’s work documents the successful benchmarking of five independently developed
particle-in-cell codes (not including VSim) for four different capacitively coupled discharges at various background
pressures.

Here, we consider the second of the Turner scenarios, though the input file can be readily modified to simulate the
others. In addition to being able to accurately reproduce the Turner results, VSim can also employ physics-based
initialization methods to enable more rapid convergence of the simulations to their steady-state. The use of such
methods will also be explained below.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The TurnerT example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item from the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Capacitively Coupled Plasmas (text-based setup) option.

• Select Turner case 2 (text-based setup) and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 6.20.

Fig. 6.20: Setup Window for the TurnerT example.
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Input File Features

The basic physics of this simulation is a balance between collisional processes and wall losses; a one-dimensional
box of length 6.7 cm contains neutral helium gas at room temperature (300 K) and density 3.21e21 1/m^3. The gas is
weakly ionized, resulting in a population of free electrons and singly ionized helium atoms at density 5.12e14 1/m^3.
The helium ions are also at room temperature, while the electrons are considerably hotter (30,000 K). The left wall of
the box is grounded, while the right wall oscillates with a bias voltage of 200 V at frequency 13.56 MHz.

Charged particles are lost upon collision with the wall, and are replenished by ionization of the background neutral gas
by the hot electrons; the latter process repopulates both the electrons and helium ions in the plasma (the background
neutral gas is treated as an infinite source). Plasma sheaths form near the walls, containing electric fields which are
strong relative to those elsewhere in the plasma; the particle density profiles adjust in response to the fields in the
sheath. The sheath transit time, for ions, is much longer than the period of the oscillating potential; thus, multiple RF
cycles occur while an ion crosses the sheath. A steady state is attained when the loss rate of particles to the wall comes
into balance with the ionization rate for a particular profile shape.

In our initial run we are not going to model the full evolution of the discharge to its steady-state parameters; rather,
we will explore the basic physics of the discharge and modify the simulation accordingly (with the aim of ultimately
hastening convergence to this steady state, while exploring VSim capabilities).

Running the Simulation

To run the simulation, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• The Number of Time Steps is 10240 (1/400 of the length of Turner’s run) for this example, and can be modified
if desired.

• Consider checking the ‘Run In Parallel’ box if desired (set a ‘Number of Cores’ appropriate for your VSim
license).

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of
the run in the right pane. The run has completed when you see the output, “Engine completed successfully.” A
snapshot of the simulation run during execution is shown in Fig. 6.21.

Note: 10240 steps takes roughly ten minutes on a MacBook Pro in serial, and less than four minutes on a four-core
Windows machine.

Analyzing the Results

We are going to run a postprocessing script, computePtclNumDensity.py, which builds density profiles from the parti-
cle data generated by VSim, so that we can look at these profiles and their evolution. To do so, we do the following:

• Click the Analyze Window

• Check the Show All Analyzers box

• Select computePtclNumDensity.py from the list of analyzers and click the Open button at the bottom of the left
panel

• Fill in the text boxes

– The simulationName should already be filled in, but if it is not, type in the name of the .pre file without the
.pre extension, which is TurnerT.

– For the speciesName, type in ‘electrons’ without the quotes.
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Fig. 6.21: The Run Window during execution.

• Click the Analyze button in the top right of the right panel; this will generate the electron density profiles.

• Now replace ‘electrons’ in the speciesName box with ‘He1’, for the helium ions.

• Click the Analyze button again to generate the ion density profiles.

The resulting data will be visualizable as electronsDensity and He1Density under the 1-D Fields Data View in the
Visualize Tab.

Visualizing the Results

Now that we’ve got all of our data, let’s look at it.

• Click the Visualize Window

After a brief moment the visualization options for this data should appear.

We’ll first look at the time evolution of some fundamental one-dimensional quantities. From the Data View pulldown
menu on the top left, select History. The default view here should contain four plots, namely, the electron and ion
currents to the left wall and the number of electrons and ions in the simulation. A number of notable physics effects
can be seen here:

• After a sharp initial decrease in the electron population, both ion and electron populations decline at
approximately the same rate. This is not as apparent from the separate numElec and numIons plots, but
clicking on the “Location” dropdown window in Graph 3 and selecting “Window 4” as the new rendering
destination, places both ion and electron populations in the same plot. (Select “<None>” in the plot variable
(the topmost menu) for both Graph 1 and Graph 2 to resize the electron/ion plot.) The initial decrease in electron
population arises when rapid electron wall losses create a charge imbalance in the plasma and establish plasma
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Fig. 6.22: Analysis window for the TurnerT example.

sheaths near the walls. Thereafter, this charge imbalance is preserved and the transport of both electrons and
ions to the wall becomes ambipolar. A history of the particle popluations can be seen in Fig. 6.23.

• The electron wall currents are quasi-periodic. The oscillating potential drives the highly mobile electrons
alternately into the left and right walls. In the plot variable menu, change “numElec” to “leftElecCurr” in Graph
3 and “numIons” to “rightElecCurr” in Graph 4. The impacts of the electron cloud on the left and right walls,
and their phasing in time, can be seen in response to the potential oscillations. A history of the electron currents
can be seen in Fig. 6.24.

• The ion currents are non-periodic. Ions, being much heavier than the electrons, exhibit relatively little re-
sponse to the oscillating potentials. In the plot variable menu, change the Graph 1 quantity “None” to “left-
IonCurrent” and the location to “Window 4”, then change the Graph 2 quantity “None” to “rightIonCurrent”
and the location again to “Window 4”. The ion currents do not have the quasi-periodic structure of the electron
currents; rather, ions diffuse outward to the walls in response to the DC sheath potentials, which are established
by the initial departure of electrons and may also be rectified by the RF. A history of all the particle currents can
be seen in Fig. 6.25.

• Ion losses are negligible before the initial establishment of the sheath. Change the plot quantity in Graph 3
from “leftElecCurr” to “None”. Change the plot quantity in Graph 4 from “rightElecCurr” to “numElec” and
the “Location” to “Window 3”. It is clear that the dominant loss of ions to the wall only begins after the initial
decrease in electron population (which corresponds to the establishment of the sheath). A history of the electron
population against the ion currents can be seen in Fig. 6.26.

We can also look at the plasma sheath and the ensuing changes in density profiles directly. In the “Data View” menu at
the top left of the Composer window, select “1-D fields”. The plot controls here are similar to those of the history win-
dow. Select “YeeStaticElecFldTrilinos_x” for the plot variable in Graph 1. Select “YeeStaticElecFldTrilinosPotential”
for the plot variable in Graph 2. Select “electronsDensity” for the plot variable in Graph 3. Select “He1Density” for
the plot variable in Graph 4, and select “Window 3” for the location of this plot. The evolution of the discharge in time
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Fig. 6.23: The electron and ion populations versus time.

Fig. 6.24: Electron currents on the left (green) and right (black) walls versus time.
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Fig. 6.25: Electron and ion currents on the left and right walls versus time.

Fig. 6.26: History plots showing the majority of the ion current to the walls only begins after initial decrease in electron
population.
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can be viewed by moving the time slider below the plots.

A number of additional physics features can be seen:

• Sheath effects are present. Regions of sharp potential variation, corresponding to strong electric fields, arise
near the walls, but such fields are screened out in the bulk plasma. Moving the time slider, it is clear that this
sheath behavior persists regardless of the phase of the oscillating wall potential.

• Electron profiles are altered much faster than ion profiles. Both ions and electron profiles are initially con-
stant (5.12e14 1/m^3), but by the time the first nontrivial dump file is produced (at time dumpPeriodicity * dt,
approximately 1/3 of the way through the period of the first wall oscillation), electron-poor regions correspond-
ing to the sheaths have already been established in the electron profile, while the ions have barely begun to
respond to the presence of the sheath. Moving the slider forward in time, one observes that the electron pro-
file predominantly oscillates in response to the wall potential, while the ion profile evolves considerably more
slowly, particularly outside the sheath regions. The 1-D fields can be seen in Fig. 6.27.

Fig. 6.27: Plots of various 1-D field quantities showing the final state of the run.

Further Experiments

Now that we understand some of the basic physics of the discharge, we are in position to apply physics-based particle
loading methods to hasten its eventual convergence to steady-state. The underlying principle here is to identify the
‘slow’ processes involved in the evolution of the discharge toward steady state, and then alter the loading to more
closely mimic the state to which the plasma is being driven. While we cannot entirely predict the parameters of the
steady-state, it is not difficult to at least get some idea of how the simulation is evolving and adjust the particle loads
accordingly. We have already observed a number of physical processes of possible relevance:

• initial electron loss and the establishment of ambipolarity

• the slow decay of the total ion and electron population following the initial electron loss
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• the rapid response of electrons to applied electric fields, particularly in the sheath region

• the slow evolution of ion density profiles.

Of these, we will primarily consider the ion profiles; the high mobility of the electrons suggests that electron profiles
will adjust correspondingly on much shorter timescales. Additionally, since the strong electric fields in the plasma
sheath region are screened out via Debye shielding as we move away from the walls, it seems clear that profile
adjustments in the bulk plasma (where the driving electric fields are weakest) will ensue more slowly than in the
plasma edge. We therefore concentrate our attention first on obtaining an approximately correct value for the ion
density at the center of the domain.

From the ‘Data View’ menu at the top, select ‘1-D Fields’ again, and set the plot variable to ‘<None>’ in plots 2, 3,
and 4. In Graph 1, set the plot variable to ‘He1Density’ and again move the timeslider on the bottom right of the
window. Observe that the central ion density appears to be steadily but slowly rising; from its initial value of 5.12e14
1/m^3, it rises to 6.0e14 1/m^3 by the end of our comparatively short run. In addition, a rapid decrease in density near
the walls (associated with the plasma sheath) has lowered the edge densities to around 1.2e14 1/m^3. The ion density
can be seen in Fig. 6.28.

Fig. 6.28: The He ion density at the end of the run.

Iteration 2

Now we’ll create a new run which accounts for the central density buildup at the outset, by returning to the Welcome
tab. The run we just did should appear in the list of Recent Simulations; we’ll want to click on that entry in the list
and then hit the Copy Recent button on the bottom right. In the Select Files to be Copied window, the default settings
are fine; just hit Select, choose a name and location for your new run, and save the files. We are automatically taken
to the Setup Window, where we can adjust the density. Let’s try a value half again as big as the previous value; set
PLASMA_DENS to 1.5 * 5.12e14 1/m^3 = 7.68e14 1/m^3 and Validate using the button at the upper right. Move to
the Run Window and again adjust computation parameters (number of cores, etc.) as before before clicking Run.
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When the simulation completes, return to the Analyze Window and rerun the ‘computePtclNumDensity.py’ script as
before, inputting the new simulationName appropriate for the most recent run and again running the script for both
the ‘electrons’ and ‘He1’ species. Then return to the Visualize Window. In the Data View menu, again choose 1-D
Fields, set the plot variable to ‘<None>’ in plots 2, 3, and 4, and again select ‘He1Density’ in Graph 1. Moving the
timeslider this time reveals that the central density continues to rise somewhat, but not as much as in the previous
case. We could continue to raise PLASMA_DENS until this behavior ceases, but will forego that for the moment. We
also observe that the edge density plummets sharply, ultimately nearing the 1.2e14 1/m^3 measurement we observed
in the previous run. These observations suggest that a spatially dependent profile peaked at the center may be more
appropriate. The ion density can be seen in Fig. 6.29.

Fig. 6.29: The He ion density at the end of the run.

Iteration 3

Let’s create yet another new run by returning to the Welcome tab and repeating the Copy Recent procedure we did
a moment ago. When we are taken to the Setup Window, we now want to focus on the DENSITY_RAT parameter.
Rather than loading the particles uniformly, we will now impose a symmetric, parabolic function (with value 1 at the
domain center, and falling off to value DENSITY_RAT at the walls) as a probabilistic restriction of the particle load.
Explicitly, this function has the form

𝑓(𝑥) =
4𝑥

𝐿
(1 − 𝑥

𝐿
) + 𝐷(1 − 2𝑥

𝐿
)2

where L = LENGTH (the extent of the spatial domain, as given in the input file) and D = DENSITY_RAT. The
probability of generating a particle at point x is f(x); we thereby generate fewer particles near the walls. We’ll choose
DENSITY_RAT as 0.1667 (i.e. 1/6) to begin with and see how things evolve. Make this change and save in the Setup
Window. In the runtime options in the Run, again adjust the computational parameters (number of cores, etc.) as
before, and run the new simulation.

When the simulation completes, we will need to repeat a number of steps we have done before:
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• Return to the Analyze Window and select the ‘computePtclNumDensity.py’ script, inputting the new simula-
tionName appropriate for the most recent run and again running the script for both the ‘electrons’ and ‘He1’
species

• Return to the Visualize Window, again choosing 1-D Fields in the Data View menu, setting the plot variable to
‘<None>’ in plots 2, 3, and 4, and selecting ‘He1Density’ in Graph 1.

As we move the timeslider, the evolution of the ion density profile is now much less pronounced, suggesting that our
initial particle loading more closely resembles the steady-state profile. Yet if we switch the Data View menu at the top
left to look at History, we can see that the particle densities have not yet come to steady-state. This is done by again
repeating steps we have performed previously:

• Set the plot variable to ‘<None>’ in plots 3 and 4

• Set the plot variable to ‘physIons’ and ‘physElec’ in plots 1 and 2 respectively

• Set the Location variable in plots 1 and 2 to the same value, e.g. ‘Window 1’.

Now we can see that both ion and electron densities decrease slightly as the simulation proceeds; a slight excess of
plasma density is slowly being transported out of the system. This excess will persist until a balance is struck between
the production rate and the rate of wall losses associated with a given profile; we are slightly over-predicting the
density production and the plasma thus adjusts itself in such a way that more particles are expelled. The electron and
ion populations can be seen in Fig. 6.30.

Fig. 6.30: The electron and ion populations versus time.

Lowering the PLASMA_DENS parameter to reduce the initial particle count is one way of dealing with this problem,
but a more elegant solution which takes advantage of the more rapid physics processes occurring near the walls can
also improve our initial particle loading. Recall that the initial behavior of the plasma, even before the ambipolar
phase, centers on the establishment of the plasma sheath and the strong electric fields associated with the sheath. This
behavior happens on a timescale much faster than any process in the ambipolar phase, and is characterized by high
electron losses to the wall.
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Iteration 4

Suppose that rather than loading particles all the way to the wall, we reduce the overall plasma density by leaving a gap
near the wall where neither electrons nor ions are present. What happens in the discharge? The electrons, being highly
mobile, rush to fill the gap, but rather than immediately being lost to the wall, they instead produce strong electric
fields at the plasma edge which begin to modify the ion profile and bring about ambipolarity. If the gap is sufficiently
large, the collisional production of ions and electrons will begin before appreciable wall losses ensue, and we can thus
assess the relative rates of production and loss fairly early in the simulation. Since the electrons are highly mobile, let’s
treat the average electron population as a measure of how well we’ve achieved this balance; net electron production
as we move into the ambipolar phase means that our gap is too low (we have removed too much density), while net
losses mean that our gap is insufficiently wide. As the profile shapes near the walls tend to adjust themselves fairly
quickly (due to the larger electric fields in this region), we can in this manner obtain approximately correct values for
the total ion and electron populations at the simulation outset.

Return to the Welcome tab and create another new run, using the run we just carried out as a basis. In the Setup
Window, the parameter ‘SHEATH_GAP’ describes the physical width of the particle-deficient region we’ll introduce
near the walls. We’ll need to do a bit of work since our profile is now parabolic. Recall that the probability function
we’re using for the parabolic load has the form

𝑓(𝑥) =
4𝑥

𝐿
(1 − 𝑥

𝐿
) + 𝐷(1 − 2𝑥

𝐿
)2

where L=LENGTH and D=DENSITY_RAT. If we average f(x) across the simulation domain, we obtain

< 𝑓(𝑥) >=

∫︁ 𝐿

0
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3

The function <f(x)> is proportional to the average species population; introducing a gap of width S = SHEATH_GAP
to reduce this average population modifies this calculation such that

< 𝑓(𝑥) >=

∫︁ 𝐿−𝑆

𝑆

𝑓(𝑥)

𝐿
𝑑𝑥 = (1 − 2𝑆

𝐿
) − (1 − 2𝑆

𝐿
)3

(1 −𝐷)

3

Assuming we want the new <f(x)> to equal some fraction B of the original population, we can find the appropriate
sheath gap by numerically solving the cubic equation

𝐵(1 − (1 −𝐷)

3
) = (1 − 2𝑆
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)3
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3

for the SHEATH_GAP parameter S. (Alternatively, we could just make a guess for a sensible value and adjust accord-
ingly.) For our case, with D = 1/6; letting B = 3/4 yields three real solutions to the cubic, but one is negative (and thus
unphysical) while another is greater than L (and thus also unphysical). The remaining solution yields a value 0.0133
for SHEATH_GAP, so let’s try that as a starting value.

• Run the simulation with the modified SHEATH_GAP parameter, with other parameters the same as were used
previously

• Return to the Analyze Window and select the ‘computePtclNumDensity.py’ script, inputting the new simula-
tionName appropriate for the most recent run and again running the script for both the ‘electrons’ and ‘He1’
species

• Return to the Visualize Window, again choosing History in the Data View menu, setting the plot variable to
‘<None>’ in plots 3, and 4, and selecting ‘physIons’ and ‘physElec’ in plots 1 and 2 while giving the Location
variable the same value.

The electron and ion populations can be seen in Fig. 6.31.

The average electron population, after the initial wall losses, remains relatively constant, so we have struck a good
balance between ionization (an electron source) and wall loss (an electron sink). Modified loading techniques have
enabled us to observe and balance the rapid physics processes which ensue as electrons rush to fill our imposed sheath
gap S. Such balancing hastens the ultimate convergence of the simulation to steady-state.
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Fig. 6.31: The electron and ion populations versus time.

6.3 DC Plasmas

6.3.1 Drifting Electrons (driftingElectrons.sdf)

Keywords:

electron transport, electron mobility, monte carlo, electrostatic

Problem description

VSim may be used to model charged particles drifting in a background neutral gas. When charged particles, such as
electrons, are injected into a background neutral gas, collisions between gas atoms and electrons eventually lead to
thermal equilibrium, and electrons will reach the same temperature as the background gas. However, when an external
electric field is applied across the neutral gas, the electron collisions and distribution will change due to this applied
field. Electrons will gain energy from the applied electric field. The energy loss due to electron-atom collision is small,
and most of the energy ends up heating the electrons. Assuming only elastic collisions take place between electrons
and atoms, the electron mobility is defined as

𝜇𝑒 = ( 𝜋𝜆
2𝑚𝐸 )

1
2

which describes the relation between electron drifting velocity and applied electric field.

This simulation can be performed with a VSimPD license.

6.3. DC Plasmas 371



VSim Examples, Release 9.0.2-r2448

Opening the Simulation

The Electron Drifting example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Other PD option.

• Select “Electron Drifting” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 6.32.

Fig. 6.32: Setup Window for the Electron Drifting example.

Simulation Properties

This input file contains electron as kinetic species as well as a background fluid description of a gas. Elastic col-
lisions between kinetic particles and the background gas are described by Monte Carlo interaction blocks of kind
impactIonization.

The fields are solved for electrostatically at each time step, including the fields due to all charged particles, subject to
the boundary conditions specified in the input file. There are a number of histories that record the number of particles
for electrons.

Running the Simulation

After performing the above actions, continue as follows:
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• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window below.

Fig. 6.33: The Run Window at the end of execution.

Visualizing the Results

After run completion, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the phase space distribution for the drifting electrons, select Phase Space from the drop down Data View
menu. In Base Variable, select electrons. Select electrons_x for X-axis and electrons_ux for Y-aixs. Click DRAW and
move the Dump slider to view electron accelerating and scattering when they drift over the space. The electron phase
space at dump number 10 is shown in Fig. 6.3.1.

Further Experiments

At lower applied electric fields, electrons are more collisional due to increased cross section. Try reducing the CATH-
ODE_POTENTIAL, and observe more scattered electron distribution when drift over space.

At higher applied electric fields, not only elastic collisions, but also inelastic collisions will take place between elec-
trons and atoms, which further reduce electron drifting velocity and mobility. For further experiments, try adding other
collision types, such as excitation and ionization, and observe the effects to electron drifting velocity.
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6.3.2 Langmuir Probe (langmuirProbe.sdf)

Keywords:

electrostatics, particle in cell, sheath, box bounding, internal boundary

Problem description

This example computes the fields and particles in a box, with an interior probe, modeled as a particle absorber and a
constant-voltage (Dirichlet) boundary condition. There is an immobile, background neutralizing charge density. The
electrons move to the walls and the probe, creating sheaths at all interfaces.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Langmuir Probe example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Other PD option.

• Select “Langmuir Probe” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
6.34. You can expand the tree elements and navigate through the various properties, making any changes you desire.
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The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 6.34: Setup Window for the Langmuir Probe example.

Simulation Properties

Constants are set up to allow setting the electron temperature in eV (ELEC_TEMP_EV), the electron density
(NOM_DENS_E), the number of cells (NCELLS_X, NCELLS_Y) in the x and y directions, the number of parti-
cles per cell (PPC), and the size of the simulation (LEN_X, LEN_Y) in the x and y directions.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” A snapshot of the simulation run completion is shown in Fig. 6.35.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.
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Fig. 6.35: The Run Window at the end of execution.

Fig. 6.36: The electrostatic potential
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To view the electric potential, expand Scalar Data and select Phi. The potential in the visualization window resembles
that shown in Fig. 6.36.

To view the electrons and sheaths, expand the Particle Data, expand electrons and select electrons. Move the dump
slider forward in time to see the formation of the sheaths as seen in Fig. 6.37.

Fig. 6.37: The sheath formation

Further Experiments

Try adding in another geometry for inclusion of the support rod or try changing the geometry to represent a different
probe.

6.4 Ion Sources

6.5 Processes

6.5.1 Laser Ionization (laserIonization.sdf)

Keywords:

electromagnetic, particle in cell, field ionization, moving window
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Problem description

This example launches an electromagnetic laser pulse into a homogeneous volume of neutral argon gas. The field
strength is significant enough to ionize the argon to multiple ionization states, which are included in the simulation.
The neutral gas density is depleted as the ionization occurs, with layers of argon atoms at increasing ionization levels
towards the center of the Gaussian beam.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Laser Ionization example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Processes option.

• Select “Laser Ionization” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
6.38. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 6.38: Setup Window for the Laser Ionization example.
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Simulation Properties

Constants are set up to allow setting the laser amplitude and the neutral argon density (1/m^3).

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” A snapshot of the simulation run completion is shown in Fig. 6.39.

Fig. 6.39: The Run Window at the end of execution.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

To view the electric field magnitude, expand Scalar Data, expand E and select E_magnitude. Scrolling through time
(by moving the slider at the bottom of the window) will show the laser pulse propataing across the simluation domain.
Next, untick the E_magnitude and instead tick neutralArgon. You can now see the depletion of the neutral background
gas as the laser passes through. This will appear the same as in Fig. 6.40.
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Fig. 6.40: The ionized charge states of argon during laser pulse propagation

Further Experiments

Try adding more charge states of Argon (past 6+) and find the limit of ionization that is achievable with this laser
pulse.

6.5.2 Negative Ion Beam (negativeIonBeam.sdf)

Keywords:

ion beam, beam transport, reactions, electrostatic

Problem description

VSim may be used to model ion beam transport and particle dynamics where the beam is represented by kinetic
simulation particles. Low density background gasses can cause instabilities in the beams due to collisions between the
beam particles and the background gas.

In this simulation, a beam of H- ions propagates through a background H2 gas. Collisions between the beam ions and
the background gas produce electrons, H2+, and neutral H through the following reactions:

𝐻− + 𝐻2 → 𝐻− + 𝐻+
2 + 𝑒− (ion impact ionization)

𝑒− + 𝐻2 → 𝐻+
2 + 2𝑒− (electron impact ionization)

𝐻− + 𝐻2 → 𝐻 + 𝐻2 + 𝑒− (detachment)

𝐻− + 𝑒− → 𝐻 + 2𝑒− (stripping)
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There are other reactions that are not included in this tutorial simulation. Typically these reactions have low cross
sections. Fig. 6.41 shows the cross sections for the above reactions as a function of incident energy.

Fig. 6.41: Cross sections for the four collision reactions included in this example.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Kinetic Collisions example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Processes option.

• Select “Negative Ion Beam” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is now shown with all the implemented physics and geometries, if applicable. See Fig. 6.42.

Simulation Properties

This input file contains a number of different kinetic species as well as a background fluid description of a gas. Ion-
ization collisions between kinetic particles and the background gas are described by Monte Carlo interaction blocks
of kind impactIonization, and detachment of electrons due to a collision with the background gas are of kind nega-
tiveIonDetachment. Collisions between kinetic particles and other kinetic particles are described in the input file by
an interaction of kind binaryIonization.
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Fig. 6.42: Setup Window for the Negative Ion Beam example.

The fields are electrostatically solved for at each time step, including the fields due to all charged particles, subject to
the boundary conditions specified in the input file. There are a number of histories that record the number of particles
for different species, their energies, as well as currents absorbed at the boundaries.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window below.

Analyzing the Results

If it is desired to calculate the density of the electrons the analysis script computePtclNumDensity.py must be used.

• First click on the Analyze Tab.

• Click Show All Analyzers and choose computePtclNumDensity.py. Then click Open at the bottom of the Analysis
Controls pane.

• Ensure that the “simulationName” field is “negativeIonBeam” and enter “Electrons” in the “speciesName” field.
Leave the “aveNxN” and “iterateAve” with their default values.

• Press the Analyze button on in the upper right corner of the window to run the analysis. Below, the Analyze Tab
is shown at the end of a successful run.
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Fig. 6.43: The Run Window at the end of execution.

Fig. 6.44: The Analyze Window at the end of execution.
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The resulting data can be visualized as “ElectronsDensity” under the Scalar Data menu in the Visualize Tab. A plot
of this data is shown below in Fig. 6.45. The density of H2plus, Hminus or Hneutral can also be calculated if those
species names are used in place of “Electrons” and the analyzer is re-run. If you have previously navigated to the
Visualize Tab, you will need to press the Reload Data button at the bottom of the Visualize Tab to view the data.

Fig. 6.45: Plot of the electron density at dump 64.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

• Expand “Particle Data” and select “Electrons,” “H,” “H2Plus,” and “Hminus.

• Then expand “Scalar Data” and select “Phi.”

• Check the Display Contours” box, which is below the *Variables box in the Visualization Controls pane.

• Set the “# of Contours” to 20. The scroll through the dumps to produce the image in Fig. 6.46.

Further Experiments

The background gas pressure is higher than one would typically see in an accelerator in this example so that the
example will produce results quickly. Decreasing the pressure will give the same results, but over longer time scales.

Since this beam is negatively charged, it repulses electrons from the region near the beam. Decreasing the beam
current will produce more neutralizing H2+ near the beam as the electrons can more effectively ionize the background
H2 gas in that area.
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Fig. 6.46: Visualization of particle densities as a color contour plot, overlaid with a scatter plot of the particle positions.

6.5.3 Neutral Heat Transport (neutralHeatTransport.sdf)

Keywords:

heat transport, DSMC, elastic collisions, reactions

Problem description

VSim may be used to model the heat flux through a neutral gas confined between two plates of different temperatures.
This problem is a common benchmark for DSMC simulations, and is described by Bird in “Molecular gas dynamics
and the direct simulation of molecular gas flows” (1994) on page 280. In this example, we model the heat transport
between cold (250K) and hot (1000K) plates separated by a meter. Between the plates is a volume of neutral Argon
gas that transports the heat through either free-molecular motion (in the case of lower pressure) or through collisional
transport via elastic collisions (in the case of higher pressure). The simulated heat flux can then be compared to the
analytic result, validating the reactions framework in VSim.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Neutral Heat Transport example is accessed from within VSimComposer by the following actions:

• Select the New –> From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Processes option.
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• Select “Neutral Heat Transport” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window is shown with all the implemented physics and geometries in Fig. 6.47.

Fig. 6.47: Setup Window for the Neutral Heat Transport example.

Simulation Properties

This input file contains one kinetic species of neutral Argon, the required thermalizing boundary conditions for the
hot and cold plates, and the Ar-Ar elastic collisions. The constants and parameters are set up so that the Argon
pressure (ARPRES) in Pa can be changed, and the simulation grid will adjust resolution to ensure that the mean-free
path is always resolved. This means that multiple simulations can be run to match the analytic result for a variety of
pressures/collisionality.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in the window below.

Visualizing the Results

After run completion, continue as follows:

• Proceed to the Visualize Tab by pressing the Visualize button in the left column of buttons.
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Fig. 6.48: The Run Window at the end of execution.

• Select “History” from the Data View drop down menu, which is located in the upper right corner the window.

Two graphs will be shown in the resulting window (see Fig. 6.5.3). The first graph, ArEnergy, shows the total kinetic
energy of the argon species. The second, AverageEnergyExchange, shows the average energy transferred between the
particles and the plates as a function of time. The AverageEnergyExchange plot divided by the cross-sectional area
of a plate gives the average heat flux. A python script, validation.py, is provided to calculate this heat flux from the
simulation data, and plot the heat flux versus the analytic heat flux. To run this script, go to the examples directory and
run python from the command line (using the command “python validation.py”). The first plot is the same histories
seen in the VSim Composer visualization. The second plot is the validation.

Further Experiments

As stated in the simulation properties section, simulations can be run with varying pressures (maintaining all else
constant) and the resulting heat fluxes plotted against the analytic result, as shown in Fig. 6.5.3. The provided python
script will only plot one simulation result at a time, but it can be modified easily to overplot multiple simulations. Each
simulation should lie on the analytic green line. It is important to ensure that the statistics of the collisions are good
enough, so when moving to lower collisionality (pressure) the number of macro particles per cell should be increased.
Additionally, it is useful to switch the kinetic particle type so that it is variable weight with managed weights. This
allows an isotropic macroparticle density while accounting for a variable physical particle density. Alternatively, the
temperature of the plates, distance between them, species of neutral gas, etc. can all be modified to test the generality
of the model and collisions.

6.5.4 Proton Beam (protonBeam.sdf)

Keywords:

electromagnetic, particle in cell, material boundary, reactions, particle emitter
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Problem description

This example injects a proton beam into a column of neutral H2 gas. The geometry is setup like an electron column in
an accelerator beamline (ie. external solenoidal B-field and negative electrodes on either end for electron confinement).
Upon entering the neutral gas multiple reactions begin to occur including ionization, charge exchange, dissociation,
H3+ formation, and others. The beam leaves the column, leaving behind a combination of ions, electrons, and neutrals
that are either confined or ejected by the background electrode potential.

In this simulation, a beam of H+ ions propagates through a background H2 gas. Collisions between the beam ions and
the background gas produce electrons, H2+, neutral H, and H3+ through the following reactions:

𝐻+ + 𝐻2 → 𝐻+ + 𝐻+
2 + 𝑒− (ion impact ionization)

𝑒− + 𝐻2 → 𝐻+
2 + 2𝑒− (electron impact ionization)

𝐻+ + 𝐻2 → 𝐻+ + 𝐻2 (elastic)

𝐻+ + 𝐻2 → 𝐻 + 𝐻+
2 (charge exchange)

𝐻+
2 + 𝐻2 → 𝐻+

3 + 𝐻 (H3+ formation)

𝐻+
2 + 𝐻2 → 𝐻+

2 + 𝐻2 (charge exchange)

𝐻2 + 𝑒− → 𝐻+ + 𝐻 + 2𝑒− (dissociative ionization)

𝐻+
3 + 𝐻2 → 𝐻+

3 + 𝐻2 (elastic)

Fig. 6.49 shows the cross sections for the above reactions as a function of incident energy.

Fig. 6.49: Cross sections for the collisions included in this example.

This simulation can be performed with a VSimPD license.
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Opening the Simulation

The Proton Beam example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Processes option.

• Select “Proton Beam” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
6.50. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Fig. 6.50: Setup Window for the Proton Beam example.

Simulation Properties

Constants are set up to allow setting the proton beam energy and current, the background H2 pressure and temperature,
and the cross-sectional size of the beam emission.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.
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• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” A snapshot of the simulation run completion is shown in Fig. 6.51.

Fig. 6.51: The Run Window at the end of execution.

Analyzing the Results

The reactions do not occur at the beginning of the simulation because the protons must propagate to the
neutral gas. This means that some species, such as the electrons, do not exist in the simulation until a later
time. For the time slider to be consistent across species in the visualization, we must generate empty time
slices for these particles for early in time. This can be quickly and easily accomplished in the Analyzers
tab.

• First click on the Analyze Tab.

• Click Show All Analyzers and choose createMissingPtclsDumps.py. Then click Open at
the bottom of the Analysis Controls pane.

• Ensure that the “simulationName” field is “protonBeam” and enter “Electrons” in the
“speciesName” field.

• Press the Analyze button on in the upper right corner of the window to run the analysis.
Below, the Analyze Tab is shown at the end of a successful run.

• Repeat this for the H2Plus and any other species that are generated (be default, only these
two)
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Fig. 6.52: The Analyze Window at the end of execution.

Visualizing the Results

We can now visualize all of the particles at a particular time slice. To do this:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons

• Expand Particle Data and select Electrons, H2Plus, and Hplus.

• Slide the time slider to advance the simulation in time (step 50 is shown in Fig. 6.53)

Next we can visualize the potential due to the particles and the electrodes:

• Unselect the particle data (Electrons, H2Plus, and Hplus).

• Expand Scalar Data and select Phi.

• Check the Clip All Plots box and scroll through the dumps.

The potential shown in Fig. 6.54 is the total potential, that is, the potential due to the static electrodes, the proton beam,
and other charged species resulting from the reactions.

Further Experiments

Try changing the neutral gas pressure (which in turn will modify its density). At higher densities more reactions will
occur and the proton beam will not be able to traverse the column intact. For lower densities, which are more in line
with experiment, the proton beam will cause small amounts of ionization in the background gas, generating an electron
cloud that is confined by the electrodes that can provide space-charge compensation for the beam. Lowering the beam
energy will allow some lower energy reactions, such as H3+ formation, to occur.

392 Chapter 6. VSim for Plasma Discharges Examples



VSim Examples, Release 9.0.2-r2448

Fig. 6.53: Plot of all the particles at timestep 50. Notice that the electrons are confined by the magnetic field to the
inner radius of the device. Some will also be confined by the electrodes to oscillate along the device.

Fig. 6.54: The electrostatic potential
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6.5.5 Single Particle Circular Motion (singleParticleCircularMotion.sdf)

Keywords:

single particle, circular motion, finite difference effects

Problem Description

This example shows how to simulate the uniform circular motion of a single electron in a constant, uniform magnetic
field in VSim. The electron is loaded inside a cylindrical capacitor with grounded walls to eliminate any stray electric
fields. The electron is loaded far from the walls to reduce any effects from image charges. The magnetic field points
down the positive z-axis.

Due to the finite difference algorithm utilized by VSim, two corrections must be made in order to get the electron to
take a true circular trajectory. The first correction is to the cyclotron frequency. In the finite difference world of VSim,
the electron does not move along a circular arc from time step to time step, instead it moves along a straight line. To
correct for this we need to set our 𝜔𝑐𝑦𝑐𝑙𝑜𝐹𝐷

= 2
Δ𝑇 arctan

(︁
𝜔𝑐𝑦𝑐𝑙𝑜Δ𝑇

2

)︁
[1] (see chapter 4 section 3).

The next correction is to account for the implementation of the Boris Method [1], the algorithm used in VSim to push
particles. In the Boris Method, the position of the particle, 𝑥⃗(𝑡), is defined at full time steps, while the velocity, 𝑣⃗(𝑡),
is defined at half time steps. This scheme of ‘well-centered’ derivatives means that VSim is automatically accurate
to second order, but it means we have to be careful about our initial conditions for the electron’s velocity. The initial
velocity is set under Particle Dynamics → Kinetic Particle → electrons0 → particleLoader0 then velocity distribution.
VSim will assume that this is the particle’s velocity a ONE HALF time step before the start of the simulation, so we
must load the particle with the velocity it would have a half time step before the start of the simulation.

This simulation can be performed with a VSimBase license.

Opening the Simulation

The Single Particle Circular Motion example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Processes option.

• Select Single Particle Circular Motion and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
6.55. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Simulation Properties

The Single Particle Circular Motion example includes some constants for easy adjustment of simulation properties:

• B0: The magnitude of the magnetic field

• VOLTAGE_OUTER and VOLTAGE_INNER: sets the value of the radial electric field experienced by electron
(default value for both is zero)
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Fig. 6.55: Setup Window for the Single Particle Circular Motion example.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Here you can set run parameters. The default is to run in serial.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 6.56

In serial, this simulation only takes seconds to run.

Visualizing the results

After performing the above actions, continue as follows:

Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

• In the Visualize Window, expand ‘Particle Data’ then ‘electrons0’ and check the box next to the red ‘electrons0.’
This will plot our single electron.

• Expand ‘Meshes’ then ‘globalGridGlobal’ and check the box next to ‘globalGridGlobal (ChargeDensity)’ as
shown in Fig. 6.57.

• Scroll through the dump slider (found below the plot), the electron will be stationary because the axial coordinate
(𝑝ℎ𝑖) has been compressed. This means the electron remains at the same r and z coordinate (this is a 2D
simulation).
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Fig. 6.56: The Run Window at the end of execution in serial.

Fig. 6.57: Visualization of Single Particle Circular Motion at dump 100.
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Further Experiments

Simulations are correct only to some accuracy. The corrections we made to the cyclotron frequency and the initial
velocity make this simulation correct to second order. By looking at the phase space plot, we can explore the second
order accuracy of this simulation. Navigate to the Visualize Window, select ‘Phase Space’ from the ‘Data View’ drop
down menu, and plot ‘electrons0_r’ vs ‘electrons0_ur.’

As you scroll through the dumps for the first time (with the ‘Auto Reset’ box UN-checked), the axes will adjust. The
particle is taking an elliptical path in phase space. In a perfect simulation, the electron would remain at the same
position in phase space with constant radius and zero radial velocity. Instead, the electron oscillates between the
positions 𝑟 = 0.50500 m and 𝑟 = 0.50542 m for a ∆𝑟 = 0.00042 m. Cut the time step in half and double the number
of timesteps taken (so that the simulation runs through the same amount of time). Now look at the phase space plot
again. By approximately what factor did ∆𝑟 drop? Since the simulation is correct to second order, dropping the time
step by a factor of 2 should drop the error by a factor of 4.

Other things you can play around with:

• Reset the electron speed, electron loading position, or the cyclotron frequency, OMEGA, back to the uncorrected
versions and redo the error analysis described above.

• Change the values for VOLTAGE_INNER and VOLTAGE_OUTER to see the effects of a radial electric field
on the single electron.

References

[1] Birdsall, C. K., & Langdon, A. B. (1985). Plasma Physics via Computer Simulation. New York: McGraw-Hill.

6.6 Processes (text-based setup)

6.6.1 Negative Ion Beam (negativeIonBeamT.pre)

Keywords:

negativeIonBeamT, beam transport, monte carlo, electrostatic

Problem description

VSim may be used to model ion beam transport and particle dynamics where the beam is represented by kinetic
simulation particles. Low density background gasses can cause instabilities in the beams due to collisions between the
beam particles and the background gas.

In this simulation, a beam of H- ions propagates through a background H2 gas. Collisions between the beam ions and
the background gas produce electrons, H2+, and neutral H through the following reactions:

𝐻− + 𝐻2 → 𝐻− + 𝐻+
2 + 𝑒− (ion impact ionization)

𝑒− + 𝐻2 → 𝐻+
2 + 2𝑒− (electron impact ionization)

𝐻− + 𝐻2 → 𝐻 + 𝐻2 + 𝑒− (detachment)

𝐻− + 𝑒− → 𝐻 + 2𝑒− (stripping)

There are other reactions that are not included in this tutorial simulation. Typically these reactions have low cross
sections. Fig. 6.58 shows the cross sections for the above reactions as a function of incident energy.

This simulation can be performed with a VSimPD license.
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Fig. 6.58: Cross sections for the four collision reactions included in this example.
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Opening the Simulation

The Kinetic Collisions example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Processes (text-based setup) option.

• Select “Negative Ion Beam” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 6.59.

Fig. 6.59: Setup Window for the Kinetic Collisions example.

Input File Features

This input file contains a number of different kinetic species as well as a background fluid description of a gas. Ion-
ization collisions between kinetic particles and the background gas are described by Monte Carlo interaction blocks
of kind impactIonization, and detachment of electrons due to a collision with the background gas are of kind nega-
tiveIonDetachment. Collisions between kinetic particles and other kinetic particles are described in the input file by
an interaction of kind binaryIonization.

The fields are electrostatically solved for at each time step, including the fields due to all charged particles, subject to
the boundary conditions specified in the input file. There are a number of histories that record the number of particles
for different species, their energies, as well as currents absorbed at the boundaries.
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Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the window. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in the window below.

Fig. 6.60: The Run Window at the end of execution.

Analyzing the Results

If it is desired to calculate the density of the electrons the analysis script computePtclNumDensity.py must be used.
First click on the Analyze Tab. Then select computePtclNumDensity.py From the drop down menu in the Control Pane.
This script accepts the simulationName of the simulation (Name of the input file) and speciesName to be calculated
(species of particles). In this case the simulationName is negativeIonBeamT and the speciesName is electrons. Then
click on the Run button. The resulting data will be visualizable as “electronsDensity” under the Scalar Data menu in
the Visualize Tab. The density of H2plus, Hminus or Hneutral can also be calculated if those species names are used
in place of electrons.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.
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Under Particle Data select H2plus and electrons to view the beam traversing the simulation space.

You can also add electric potential contours by expanding Scalar Data and selecting phi, and clicking Display Contours
in the bottom half of the Visualization Controls pane. The visualization of the particles and contours is shown in Fig.
6.61.

Fig. 6.61: Visualization of particles and potential field.

Further Experiments

The background gas pressure is higher than one would typically see in an accelerator in this example so that the
example will produce results quickly. Decreasing the pressure will give the same results, but over longer time scales.

Since this beam is negatively charged, it repulses electrons from the region near the beam. Decreasing the beam
current will produce more neutralizing H2+ near the beam as the electrons can more effectively ionize the background
H2 gas in that area.

6.7 Spacecraft

6.7.1 Coupon Array Charging (couponArrayCharging.sdf)

Keywords:

solar wind, electrostatics, surface charging
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Problem description

In orbit, insulating outer surfaces of satellites will develop a surface charge due to the impinging solar wind. If enough
surface charge accumulates electric breakdown can occur across or through the satellite and damage the craft.

This simulation models the accumulation of solar wind particles on an array of solar cells (coupons). The array
includes 6 coupons, a kapton backing, and 6 metal busbars. Using post-simulation analysis, the component of the
electric field normal to the surface of the satellite is calculated.

With additional data specific a particular spacecraft and materials, this simulation can indicate locations where break-
down is likely to occur.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Electron Drifting example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Spacecraft option.

• Select “Coupon Array Charging” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The Setup Window as seen after opening the example is shown in Fig. 6.62.

Fig. 6.62: Setup Window for the Coupon Array Charging example.
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Simulation Properties

The geometry for the busbars and coupon array are imported from stl files. Material properties are set on the geome-
tries: perfect electrical conductor (PEC) for the busbars, and absorbium, a insulating particle absorbing material, on
the array of cells.

A voltage of 5 volts is set on the busbars. The upper z boundary is set as the 𝑉 = 0 point, a Neumann boundary
condition is set on the lower z boundary of the simulation grid, which enforces that the gradient of the electric field
normal to this surface is zero. Periodic boundary conditions (for particles and fields) are set on all other simulation
boundaries.

The solar wind is emitted off the upper z boundary of the simulation domain with a number density of 1.e7 particles
per meter cubed. The masses of the ions are artificially set to 100x the mass of the electrons. Particle accumulation
boundary conditions are set on the insulating surface of the coupons, and a particle absorbing boundary condition is
set on the metal busbars.

Histories save the absorbed particle energy deposited onto the satellite surface.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 6.63 below.

Fig. 6.63: The Run Window at the end of execution.
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Analyzing the Results

The physics engine, vorpal, inside VSim only calculates field values on edges, nodes, or faces of grid cells. The
putFieldOnSurfaceMesh.py analyzer can interpolate the values calculated on the grid to the surface of a geometry in
the simulation.

To calculate the normal component of the electric field on the surface of the array, proceed to the Analyze Tab. The
putFieldOnSurfaceMesh.py analyzer is included by default to this simulation. Click on the text “putFieldOnSur-
faceMesh.py (Default)” to highlight it, then click the “Open” button at the bottom of the Analysis Controls pane.
Ensure the following is entered into each field:

• simulationName: “couponArrayCharging”

• geometryName: “satelliteSurfaceGeomSolid”

• fieldName: “E”

• beginDump: “1”

• endDump: “9”

• outputFileName: “elecFieldOnSurface”

• Click Analyze in upper right corner of the window. When the analysis is finished, you should see a window
similar to Fig. 6.64.

Fig. 6.64: The Analyze Window at the end of execution.

Visualizing the Results

After run completion, continue as follows:
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Proceed to the Visualize Tab by pressing the Visualize button in the left column of buttons. To view the normal
component of the electric field on the surface of the array follow the following steps.

• If you have previously switched to the Visualize Tab, you will have to click the Reload Data button at the bottom
of the Visualization Controls pane.

• Expand “Scalar Data” then expand “elecFieldOnSurface” and check the box for “elecFieldOnSurface_z” to plot
the component of the electric field normal to the surface of the coupon array. It is also possible to plot the two
tangential components of the field, as well as the magnitude.

• To visualize the field better, click the “Colors” button in the row of buttons in the upper right of the Visualization
Results pane. The Color Options window will open.

• In the Color Options window, check the boxes for “Fix Minimum” and “Fix Maximum” and set the values to
“-0.002” and “0.002,” respectively. Press the “Apply” Button to apply the color range.

• The resulting visualization is shown in Fig. 6.7.1.

Further Experiments

Perform the same analysis done above for the electric potential, “Phi,” and charge density, “ChargeDensity,” to create
plots of those fields on the surface of the satellite geometry.

Import your own geometry and reset the materials, grid size, and particle absorbers as necessary.

Increase the grid resolution to get finer data on the electric field that develops on the surface of the spacecraft.

Change the number density and speeds of the incident particles to values for orbits at different altitudes.
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6.7.2 Cylindrical Hall Thruster (cylHallThruster.sdf)

Keywords:

electric propulsion, Hall thruster channel, erosion models.

Problem description

Electric Hall thrusters are used for in-space propulsion and satellite station-keeping needs. The discharge plasma
inside the Hall thruster channel is produced by the ionization of electrons with a neutral propellant gas such as xenon.
The electrons are emitted from the neutralizer cathode placed at the exit of the Hall thruster (cathode end). The neutral
gas is fed into the channel from the anode end of the Hall thruster channel. The electrons are confined inside the Hall
thruster channel by the radial magnetic field applied through the solenoidal magnetic fields. Plasma xenon ions are
accelerated out of the channel at high velocity, which produces the thrust necessary for space propulsion. Recently
these thrusters are being designed to support long life time, high-power and high-thrust operations. The channel wall
erosion occurring inside of the Hall thruster is one of the main limitations to these design needs. It becomes important
to understand the plasma discharge processes occurring inside the Hall thruster channel and predict the lifetime of the
Hall thruster based on the calculations of sputtered material from the Hall thruster channel.

This example demonstrates elements of the full cylindrical Hall thruster text-based example. Please refer to that
documentation for a detailed description of the simulation geometry, and physical properties of the full model. This
visual-setup model employs the same physical geometry (2D, cylindrical coordinates) as the text-based setup model.
As with the text-based setup example, there is an electron source and a background xenon gas that is ionized by kinetic
electrons to produce kinetic xenon ion particles. Particle sinks, and the physical extent of the background gas are the
same as in the text-based example.

The primary difference is that there are no dielectric materials in this example, and so the electromagnetic fields are
different. This leads to a different pattern for electrons exiting the simulation than in the text-based example. Also,
there is no neutral particle sputtering of wall material included in this example. This example does demonstrate
ionization of neutral gas in cylindrical geometry.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Cylindrical Hall Thruster example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Spacecraft option.

• Select Cylindrical Hall Thruster and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

All of the properties and values that create the simulation are now available in the Setup Window as shown in Fig.
6.65. You can expand the tree elements and navigate through the various properties, making any changes you desire.
The right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. To show or hide the
grid, expand the Grid element and select or deselect the box next to Grid.

Simulation Properties

This example contains many user defined Constants which help simplify the setup and make it easy to modify. These
include constants such as:

406 Chapter 6. VSim for Plasma Discharges Examples



VSim Examples, Release 9.0.2-r2448

Fig. 6.65: Setup Window for the Cylindrical Hall Thruster Channel example.

• B0: The amplitude of the background magnetic field

• anodeV: the anode voltage

• innerRad and outerRad: inner and outer cylinder radius

• xeMaxDensity: the maximum density of the background Xe gas

There are also several SpaceTimeFunctions that are used to define spatially and/or temporally varying inputs to other
properties. These include:

• By: the magnetic field profile

• initialGasDensity: the profile for the background gas density

The self-consistent electric field is solved from Poisson’s equation by the electrostatic solver in a cylindrical coordi-
nate system. The simulation is performed in axisymmetric 2-D fashion. The plasma is represented by macro-particles
which are moved using the Boris pusher in cylindrical coordinate system. Various types of elastic and inelastic colli-
sions of the particles are also taken into account.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the Logs and Output Files pane. You will
see the output of the run in this pane. The run has completed when you see the output, “Engine completed
successfully.” A snapshot of the simulation run completion is shown in Fig. 6.66.
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Fig. 6.66: The Run Window at the end of execution.

On an 8 core I7-6000 CPU, it takes about 40 minutes to run for 6,000 time steps. To reach steady state, about 100,000
time steps are required.

Analyzing the Results

If it is desired to calculate the density of the electrons or ions the analysis script computePtclNumDensity.py must be
used.

• First click on the Analyze Tab.

• Click Show All Analyzers and choose computePtclNumDensity.py. Then click Open.

• This script accepts the simulationName (Name of the input file) and speciesName to be calculated (species of
particles).

• To calculate the density of the electrons, set the simulationName to “cylHallThruster” and the speciesName to
“electrons”.

• Click on the Analyze button at the top right of the Analysis Results pane.

• A snapshot of the simulation run completion is shown in Fig. 6.67.

The resulting data will be visualizable as electronsDensity under the Scalar Data menu in the Visualize Tab. The
density of other particles such as heavyIons, or Xeplus can also be calculated if those species names are used in place
of electrons.
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Fig. 6.67: The Analyze Window at the end of execution.

Visualizing the Results

To visualize the results, continue as follows:

• Proceed to the Visualize Window by pressing the Visualize button in the left column of buttons.

There are many different fields, particles, and histories that can be visualized in this example. The horizontal axis
represents Z direction and the vertical axis represents R direction.

To view the electric potential, switch to the Data View to Data Overview in the Controls pane. Expand Scalar Data and
choose Phi. Move the Dump slider to the right most position. Fig. 6.68 shows the visualization seen for the electric
potential of the cylindrical Hall thruster channel and in the exit region.

In the Hall thruster channel plasma, the electrons injected from the right end (i.e., exit of the channel) are accelerated
towards the anode biased wall at the left end. To plot the particles, expand Particle Data and select “electrons” and
“XePlus” check boxes The figure below, Fig. 6.69, shows the distribution of positively charged xenon ions (red dots)
and electrons (blue dots).

The static radial magnetic field distribution considered for the SPT-100 Hall thruster channel set up is shown in Fig.
6.70. To reproduce this plot, expand Scalar Data then nodalB and select nodalB_r. The magnetic field is strong near
the inner cylinder and has a Gaussian bell-shaped field distribution both inside and at the exit of the channel.

The background xenon neutral gas density distribution (plottable as XeNeutralFluid under Scalar Data) used in the
simulation set up is shown in Fig. 6.71. The maximum neutral gas density is taken at the left end of the channel near
the anode wall. A linearly varying neutral gas density is assumed.
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Fig. 6.68: Visualization of Cylindrical Hall thruster channel electric potential results.

Fig. 6.69: Visualization of Cylindrical Hall thruster channel particle phase-space distribution results.

410 Chapter 6. VSim for Plasma Discharges Examples



VSim Examples, Release 9.0.2-r2448

Fig. 6.70: Visualization of radial magnetic field in the Cylindrical Hall thruster channel.

Fig. 6.71: Visualization of xenon neutral gas density in the Cylindrical Hall thruster channel.
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Further Experiments

This example can be modified to test different design parameters such as varying anode voltages, varying background
neutral gas densities and varying electron emission currents. This will allow users to study high-to-low power and
high-to-low throttle levels.

Also the background gas type can be changed to investigate other neutral gas kinds in this simulation set up.

6.8 Spacecraft (text-based setup)

6.8.1 Cylindrical Hall Thruster (cylHallThrusterT.pre)

Keywords:

electric propulsion, Hall thruster channel, erosion models.

Problem description

Electric Hall thrusters are used for in-space propulsion and satellite station-keeping needs. The discharge plasma
inside the Hall thruster channel is produced by the ionization of electrons with a neutral propellant gas such as xenon.
The electrons are emitted from the neutralizer cathode placed at the exit of the Hall thruster (cathode end). The neutral
gas is fed into the channel from the anode end of the Hall thruster channel. The electrons are confined inside the Hall
thruster channel by the radial magnetic field applied through the solenoidal magnetic fields. Plasma xenon ions are
accelerated out of the channel at high velocity, which produces the thrust necessary for space propulsion. Recently
these thrusters are being designed to support long lifetime, high-power and high-thrust operations. The channel wall
erosion occurring inside of the Hall thruster is one of the main limitations to these design needs. It is important to
understand the plasma discharge processes occurring inside the Hall thruster channel to predict the lifetime of the Hall
thruster based on the calculations of sputtered material from the Hall thruster channel.

This example demonstrates the xenon discharge plasma processes of a Stationary Plasma Thruster (SPT-100) channel.
The outer cylinder has a radius of 5 cm and the inner cylinder has a radius of 3.5 cm. The radial channel gap is 1.5 cm.
The channel length is 2.5 cm and the simulation domain extends 1 cm outside the channel region (to simulate both
the channel and the plume plasma). The anode on the left wall is biased to 300 V. Both inner and outer cylinders are
modeled as dielectric cylinders (with hexagonal boron-nitride dielectric material coating) with a dielectric permittivity
ratio of 4.6. The exit boundary is set to 0 V. An electron source is placed at the channel exit to simulate electron
emission from the neutralizer cathode and the cathode emission current is set to 4.5 A. Neutral xenon gas is modeled
as a static fluid background. The neutral gas density is set to be linearly decreasing with a maximum gas density
at the anode end of the channel. The simulation is initiated from a uniform plasma with both electrons and xenon
ions. Self-similar scaling system laws for the simulation of Hall thruster channel are enabled as described by Figure
1 in [MCL+11]. This is based on earlier work by Taccogna [TLCS04][TLCS05]. The scale factor is set to 1/50, i.e.,
the thruster dimensions are scaled by 1/50. This scaling is followed so that the kinetic Hall thruster channel plasma
simulations can be performed in a reasonable run time. The scaling affects the physical dimensions and external
potentials.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The cylindrical Hall thruster example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.
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• Expand the Spacecraft (text-based setup) option.

• Select “Cylindrical Hall Thruster (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup pane, as
shown in Fig. 6.72.

Fig. 6.72: Setup Window for the Cylindrical Hall Thruster Channel example.

Input File Features

The input file allows one to choose the Hall thruster channel dimensions (length, inner and outer cylinder radius, inner
cylinder dielectric wall thickness, outer cylinder dielectric wall thickness, channel exit region length) and physical
quantities (anode voltage, cathode voltage, emission current, emitted electron energy, radial magnetic field strength,
neutral number density), the resolution (number of cells in each direction) and SHRINK_FACTOR, the factor by which
the size of the thruster is reduced in each dimension in the simulation.

The self-consistent electric field is solved from Poisson’s equation by the electrostatic solver in a cylindrical coordinate
system. Dielectric coaxial cylinders are considered in this simulation. The simulation is performed in axisymmetric
2-D fashion.

The plasma is represented by macro-particles which are moved using the Boris scheme in a cylindrical coordinate
system. Various types of elastic and inelastic collisions of the particles are calculated with the Vorpal engine’s Monte
Carlo package.

Running the simulation

After performing the above actions, continue as follows:
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• Proceed to the run window by pressing the Run button in the left column of buttons.

• This simulation requires approximately 34 hours when running on four MPI cores on a modern CPU to simulate
200,000 time-steps. To view only the initial transient conditions, set Number of Steps to 1000 and Dump Peri-
odicity to 10. Then the simulation can either be reset and rerun with the default run parameters, or by entering
in the last dump into Restart at Dump Number (in this case, 100) the simulation can be restart from the chosen
data dump.

• To run the file, click on the Run button in the upper right corner of the window. You will see the output of the run
in the right pane. The run has completed when you see the output, “Engine completed successfully” as shown
in Fig. 6.73.

Fig. 6.73: The Run Window at the end of execution.

Analyzing the Results

If the electron density is desired the analysis script computePtclNumDensity.py may be used.

• In the leftmost panel, click the Analyze button. Select Show All Analyzers and then select computePtclNum-
Density.py from the list of analyzers, then click Open at the bottom of the Analysis Controls pane.

• Enter “electrons” into the speciesName field.

• Click the Analyze button near the upper right of the Analysis Results pane.

• Repeat with other particle species if desired (“Xeplus”, “XeNeutralsGas”)

The analysis results are now viewable in the Visualize window, as shown in the following section.
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Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize window by clicking the

• Visualize* button in the leftmost panel.

• In the top of the Visualization Controls pane, switch the Data View dropdown menu to Field Analysis.

• In the Field dropdown menu, select nodalB_r to view the radial component of the magnetic field (the magnetic
field is only radial). A pseudocolor plot of the potential with a radial lineout performed should be displayed
as shown in Fig. 6.68. The magnetic field is strongest near the inner cylinder and falls off towards the outer
cylinder.

• To plot the radial profile of the magnetic field at its strongest point, in the Lineout Settings section, set Intercept
to “0.0005” and click Perform Lineout. If desired, select the Advanced tab to choose arbitrary start and end
points for the lineout.

Fig. 6.74: Visualization of radial magnetic field in the cylindrical Hall thruster channel.

• To view the The background xenon neutral gas density, in the top of the Visualization Controls pane, switch the
Data View dropdown menu to Data Overview.

• In the Variables section, expand Scalar Data.

• Select XeNeutralGas. A plot of the electron number density distribution will be displayed as shown in Fig. 6.75.

The maximum neutral gas density is set near the anode wall at the left end of the channel and decreases linearly until
a minimum at channel opening at the right end of the channel.

To analyze the plasma sheath, plot the electric potential and particle positions by following the steps below:

• In the top of the Visualization Controls pane, switch the Data View dropdown menu to Field Analysis.
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Fig. 6.75: Visualization of xenon neutral gas density in the cylindrical Hall thruster channel.

• In the Field dropdown menu, select phi to view the electric potential. A pseudocolor plot of the potential with a
radial lineout performed should be displayed as shown in Fig. 6.76. The voltage is highest down the center of
the channel.

• To plot the axial profile of the potential as shown in Fig. 6.76, in the Lineout Settings section, select the Hori-
zontal tab, set Intercept to “0.00085” and click Perform Lineout. If desired, select the Advanced tab to choose
arbitrary start and end points for the lineout.

In the lineout, it can be seen that the potential of the plasma bulk is approximately 310 volts. The anode voltage is set
to exactly 300 volts, so the potential drop at the anode sheath is approximately 10 volts, while the potential drop at the
exit sheath is the same as the bulk plasma potential.

• To view the macroparticle locations, return to the Data View dropdown menu to Data Overview.

• In the Variables section, expand Scalar Data and select phi

• Expand Particle Data, then expand Xeplus and select Xeplus_uz to view the locations of xenon ion macroparti-
cles colored by their axial (𝑧) velocity.

• In the Particle Style section, set Size to 6 and Symbol to “Sphere”.

• Still under Particle Data, expand electrons and select electrons to view electron macroparticle positions
monochromatically.

Plots of the electron and ion macroparticle positions overlayed on the electric potential should now be visible as shown
in Fig. 6.77

• To plot the sputter material macroparticle locations, deselect the electrons and xenon ions, then expand
BNAtoms, and select BNAtoms, as shown in Fig. 6.78

The sputtered material from the Hall Thruster channel can be shown by plotting the BNAtoms (red).
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Fig. 6.76: Visualization of the cylindrical Hall thruster electric potential with a line-out showing the axial sheath
structure.

Further Experiments

This input file can be modified to test different design parameters such as varying anode voltages, varying background
neutral gas densities and varying electron emission currents. This will allow users to study high-to-low power and
high-to-low throttle levels.

Also the background gas type can be changed to investigate other neutral gas kinds in this simulation set up.

A more substantial further step for a user would be to take the following steps to calculate the thrust from the device.
This will require adding the history (see the code block below) to collect the appropriate data, writing a post-processing
analysis script to calculate the thrust, then importing the analyzer into VSim.

• Return to the Setup window by clicking the Setup button in the leftmost panel

• Near the top of the Editor pane, click View Input File

• Scroll to the bottom of the input file and paste the following code:

<History absorbedIonVelocity>
kind = speciesAbsPtclData2
species = [ Xeplus ]
ptclAbsorbers = [ topOuterIonAbsorber rightIonAbsorber botOuterIonAbsorber ]
ptclAttributes = [ xVelocity numPtclsInMacro kineticEnergy xPosition yPosition ]
collectMethod = statsForEachStep

</History>

the collectMethod = statsForEachStep provides sums of the desired quantities in the history file. The calculation thrust
would be performed in the analysis tab. Other post-run analyses can be performed in order to see a sum of where the
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Fig. 6.77: Visualization of the cylindrical Hall thruster sheath via ion and electron macroparticle positions with electric
potential and ions colored according to their axial velocity.

Fig. 6.78: Visualization of the sputtered material from the channel walls.
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particles are arriving, their velocity, and the creation of other figures of merit to determine the performance of the the
thruster.

6.8.2 Ion Thruster (ionThrusterT.pre)

Keywords:

electric ion thruster discharge chamber plasma processes in 2D cylindrical system.

Problem Description

Ion thrusters are electric propulsion devices used for in-space propulsion and satellite station-keeping. In this device, a
propellant gas (xenon in this example) is ionized into a plasma state inside a cylindrical discharge chamber. The plasma
ions are accelerated out of the chamber through an electrostatic grid optics system to produce thrust. The device
consists of the following components: an anode-biased discharge chamber, a discharge hollow cathode assembly,
permanent magnet rings, a neutral propellant feed system, grid optics (screen and accelerator plates), and a neutralising
hollow cathode. The discharge hollow cathode is placed in the center of the discharge chamber and emits energetic
electrons (primary electrons) into the system. Primary electrons undergo ionizing collisions with the neutral propellant
gas inside the chamber to produce plasma ions and secondary electrons. An energetic electron impacting a xenon atom
that is already singly ionized may cause another electron to detach, resulting in a doubly ionized xenon atom. The
permanent magnetic rings within the discharge chamber confine the electrons, increasing their time of flight in the
chamber, and thus their chances of ionizing neutrals before collection at the anode-biased discharge chamber walls.
The plasma ions produced in the chamber leave primarily through the screen grid plate with some losses to the cathode
biased walls. To ensure long discharge cathode lifetimes, a protective enclosure called a cathode keeper (generally
kept between 3 and 5 volts above the discharge cathode voltage) is used to shield the cathode plate from plasma ion
collisions. The bombardment of singly charged and doubly charged ions during thruster operation will over time
erode the face of the cathode keeper and expose the discharge cathode to energetic ions. Thus, it becomes important
to model the ion flux around the cathodes. Recently ion thrusters have been designed to meet high-power and high-
thrust-to-power space propulsion requirements. Numerical discharge chamber plasma simulations provide a detailed
understanding of the plasma processes that go on inside a discharge chamber and help with the calculation of electron
discharge currents, ion beam currents, and ion current losses to the chamber walls.

This example demonstrates the xenon discharge plasma processes inside of a cylindrical discharge chamber with a
three-ring magnetic circuit arrangement. One magnetic ring is mounted on the forward wall (seen as the left wall in
the geometry of the example) and two magnetic rings are mounted to the exterior wall of the cylindrical discharge
chamber (seen as the top wall in the example setup). The radius of the cylindrical chamber is 20 cm and it is 18 cm
long. The screen grid plate has a radius of 18 cm and is placed at the aft end of the discharge chamber (far right in
the example setup). The discharge hollow cathode assembly is placed at the center of the discharge chamber. The
radius of the cathode keeper assembly is taken to be 0.75 cm and its orifice protrudes out 7 cm from the forward
wall (from the left wall in the example diagram). An electron particle source is implanted next to the cathode keeper
orifice to model the electron emission of the discharge cathode. In this simulation the cathode emission current is
taken as 10 A. The same cathode emission source location is also used for modelling the neutral propellant flow from
the discharge cathode. The main xenon neutral propellant source is modelled along the exterior wall (top wall in the
example diagram). We have taken neutral propellant flow rates of 4.5 sccm and 43.5 sccm for the discharge cathode
neutral source and main neutral source respectively. The anode biased discharge chamber walls are kept at 25 V. The
discharge cathode keeper is biased at 5 V and the screen grid plate is kept at 0 V. Finally, we enable a self-similar
scaling system for the simulation of discharge chamber plasma described by figure 1 in [MCL+11]. This is based on
earlier work by Taccogna [TLCS04][TLCS05]. By default the shrink scale factor is 200, i.e., the thruster dimensions
are scaled by 1/200. This scaling ensures that simulations can be performed in a reasonable run time but it requires
use of an inflated permittivity scale factor, i.e. the permittivity of free space is artificially inflated so that numerical
parameters like grid spacing and time step values satisfy the smaller plasma frequency and Debye length.

The simulation is initiated with the chamber pre-filled with xenon neutrals. This is because the neutrals are heavy
and slow, and it would take a great many time steps at the start of every run to populate an empty chamber. To view
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the initial distribution of neutrals, the input file can be run with particle sources turned-off. To do this, switch the
TURN_THRUSTER_OFF parameter to 1 and run with a time step of ~10^-6 sec (timestep is 1 ps by default).

This simulation can be performed with a VSimPD license.

Opening the Simulation

The ion thruster example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item from the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Spacecraft (text-based setup) option.

• Select Ion Thruster (text-based setup) and click the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 6.79.

Fig. 6.79: Setup Window for the Ion Thruster example.

Input File Features

The input file allows the user a choice of ion thruster operating parameters such as discharge voltage, cathode keeper
voltage, screen grid voltage, discharge cathode electron emission current, cathode neutral flow rate, and main neutral
flow rate. Also it gives the user an option to specify the inflated permittivity scale factor by which the real permittivity
of free space is scaled.

420 Chapter 6. VSim for Plasma Discharges Examples



VSim Examples, Release 9.0.2-r2448

The self-consistent electric field is solved from Poisson’s equation by the electrostatic solver in cylindrical coordinates.
The simulation is performed in an axisymmetric 2-D domain. The actual thruster dimensions are reduced by the
SHRINK_FACTOR variable in the input file (default 200). Correspondingly the physical parameters such as electric
fields, magnetic fields, and particle densities are scaled by the shrink factor to maintain consistent physical effects (e.g.
Larmor radius, Knudsen number).

The plasma is represented by macro-particles which are moved via the Boris pusher in cylindrical coordinates. Various
types of elastic and inelastic particle collisions are calculated with the computational engine’s Monte Carlo package.
In this simulation the propellant xenon neutrals are tracked as kinetic particles and undergo collisions with electrons.
The simulation employs variable-weight particle splitting and self-combination via NullInteraction blocks to
help maintain good particle resolution over orders-of-magnitude variations in density across the domain.

This input file contains an imported magnetic field. The external magnetic field file is in units of Gauss, and is
converted into Teslas when imported by VSim.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the Run Window by pressing the Run button in the left column of buttons.

• Check the box labeled “Dump at Time Zero” so that the initial electric potential may be plotted.

• To run the file, click on the Run button in the upper right corner of the window. You will see the output of the run
in the right pane. The run has completed when you see the output, “Engine completed successfully.” A snapshot
of the simulation run completion is shown in Fig. 6.80.

The default number of time-steps for this simulation is 5,000, but to approach steady-state, approximately 500,000
time-steps are required. The Visualizing the Results section provides a review of the results at 5,000 time-steps, while
the Further Experiments section is a review of the results after 500,000 time-steps.

Analyzing the Results

If the electron density is desired the analysis script computePtclNumDensity.py may be used.

• In the leftmost panel, click the Analyze button. Select Show All Analyzers and then select computePtclNum-
Density.py from the list of analyzers, then click Open at the bottom of the Analysis Controls pane.

• Enter “electrons” into the speciesName field.

• Click the Analyze button near the upper right of the Analysis Results pane.

• Repeat with other particle species if desired (“XeIons”, “XeNeutrals”)

The analysis results are now viewable in the Visualize window, as shown in the following section.

Visualizing the Results

After performing the above actions, continue as follows:

• Proceed to the Visualize window by clicking the Visualize button in the leftmost panel.

• In the top of the Visualization Controls pane, switch the Data View dropdown menu to Field Analysis.

• In the Field dropdown menu, select phi. A pseudocolor plot of the potential with a radial lineout performed
should be displayed as shown in Fig. 6.81.
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Fig. 6.80: The Run Window at the end of execution.

• To plot the axial potential profile, in the Lineout Settings section, select the Horizontal tab, change the intercept
to 0.00005, and click Perform Lineout to plot the axial accelerating potential as shown in Fig. 6.81. If desired,
select the Advanced tab to choose arbitrary start and end points for the lineout.

• In the top of the Visualization Controls pane, switch the Data View dropdown menu to Phase Space.

• In the Base Variable dropdown menu, select electrons.

• To maintain the same 𝑧-𝑟 convention as the previous electric potential plot, in the X-axis dropdown menu select
electrons_z and in the Y-axis dropdown menu select electrons_r.

• Near the bottom of the Visualization Controls pane click DRAW and at the bottom of the Visualization Results
pane move the Dump slider to the right to dump 5. The 𝑧-𝑟 phase space should be visible as shown in Fig. 6.82.

Recall that the electron number density distribution was calculated in Analyzing the Results. Plot the results of this
analyzer as follows:

• In the top of the Visualization Controls pane, switch the Data View dropdown menu to Data Overview.

• In the Variables section, expand Scalar Data.

• Select electronDensity. A plot of the electron number density distribution should be displayed, though due to
the large variation in densities, only a small portion of the domain will appear to be non-zero

• At the bottom of the variables section of the Visualization Controls pane, select the Log Scale Color checkbox.

• At the top of the Visualization Results pane click the Colors button, and in the resulting dialog set the limits
to a minimum of 1e16 and maximum of 1e22, or experiment with limits as desired. The electron density on a
logarithmic color scale should now displayed as shown in Fig. 6.83.
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Fig. 6.81: Visualization of the Field Analysis result for the electric potential inside the ion thruster discharge chamber
after 5,000 steps.

Fig. 6.82: Electron phase-space distribution results after 5,000 steps.
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Fig. 6.83: Electron number density distribution results inside the discharge chamber after 5,000 steps.

Further Experiments

Return to the Run window by clicking on the Run button in the leftmost panel, change Number of Steps to 500,000,
and then click the Run button at the top of the Logs and Output Files pane. A high-performance computing cluster is
recommended for this run, which will require approximately 6 days running on 64 cores. When the run has completed,
take the following steps.

• Plot the potential at the final data dump similar to the steps taken in Visualizing the Results.

• In the Visualization Results pane, in the 2d section, click the Colors button

• Set the minimum to 0 and the maximum to 25 (Volts). The resulting plot is shown in Fig. 6.84

It can be seen that the ions experience most of their acceleration in the sheath near the right-side boundary of the
plasma chamber. Plot the electron and ion densities by taking the following steps:

• Following once again the steps taken in Visualizing the Results, run the computePtclNumDensity.py analyzer on
both electrons and XeIons.

• Plot the electrons density using the color log scale and the same limits as previous, as shown in Fig. 6.85

• Plot the ion density using the color log scale with a minimum of 1e18 and a maximum of 1e23 to get the image
shown in Fig. 6.86 or experiment with the limits as desired.

It can be seen from Fig. 6.85 and Fig. 6.86 that the electrons are confined by the magnetic field lines while the much
heavier ions are not, allowing a more uniform acceleration of ions out the right side of the chamber, resulting in thrust.

Plot the electron and ion macroparticle positions with the following steps:

• In the top of the Visualization Controls pane, switch the Data View dropdown menu to Phase Space.

• Under Plot 1 click the Base Variable drop-down menu and select electrons
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Fig. 6.84: Electric potential of the plasma inside the ion thruster discharge chamber after 500,000 time-steps.

Fig. 6.85: Electron number density distribution results inside the discharge chamber after 500,000 steps.
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Fig. 6.86: Ion number density distribution results inside the discharge chamber after 500,000 steps.

• Change X-axis to electrons_z and Y-axis to electrons_r, change Point Size to 1, and at the bottom of the Visual-
ization Controls pane, click DRAW to see the electron macro-particle positions.

• Check the Enable Second Plot button.

• Under Plot 2 change Base Variable to XeIons, change X-axis to XeIons_z and Y-axis to XeIons_r, change Point
Size to 1, and click DRAW once again to see the electron and singly-ionized xenon macro-particle positions.

• Check the Enable Third Plot button.

• Under Plot 3 change Base Variable to XeDblIons, change X-axis to XeDblIons_z and Y-axis to XeDblIons_r,
leave Point Size at 2, and click DRAW once again. The ion and electron positions should be displayed as shown
in Fig. 6.87.

The electrons appear well confined by the 3-ring magnetic circuit arrangement, and move along the magnetic cusp
regions formed between the magnets. Most of the electrons are lost to the discharge chamber walls through the
magnetic cusps and are absorbed at the walls in 3 small areas. Only a few electrons are able to cross the strong
magnetic field lines and reach the top wall between the cusps.

Singly and doubly ionized xenon are generated inside the discharge chamber through ionizing collisions of electrons
with xenon neutrals. Only electrons with energies above the ionization thresholds (12.1 eV for the first ionization level
and 21.25 eV for the second) can ionize neutrals.

This input file can be modified to test different design parameters covering a range of anode voltages, xenon flow rates,
and electron emission currents, to allow study of high-to-low power and high-to-low throttle levels.

A more substantial further step for a user would be to take the following steps to calculate the thrust from the device
by recording the velocities of exiting ions. This will require adding a History block (see code below) to collect
the appropriate data, writing a post-processing analysis script to calculate the thrust, then importing the analyzer into
VSim. Details of how to write your own analyzer are provided at VSim Customization: Custom Analyzers.
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Fig. 6.87: Electron and ion phase-space distribution results after 500,000 steps.

• Return to the Setup window by clicking the Setup button in the leftmost panel

• Near the top of the Editor pane, click View Input File

• Scroll to the bottom of the input file and paste the following code:

<History absorbedIonVelocity>
kind = speciesAbsPtclData2
species = [Xeplus]
ptclAbsorbers = [topOuterIonAbsorber rightIonAbsorber botOuterIonAbsorber]
ptclAttributes = [xVelocity numPtclsInMacro kineticEnergy xPosition yPosition]
collectMethod = statsForEachStep

</History>

the collectMethod = statsForEachStep provides sums of the desired quantities in the history file. The calculation thrust
would be performed in the analysis tab. Other post-run analyses can be performed in order to see a sum of where the
particles are arriving, their velocity, and the creation of other figures of merit to determine the performance of the the
thruster.

6.8.3 Satellite Surface Charging (satelliteSurfaceChargeT.pre)

Keywords:

electrostatics, surface charges
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Problem description

Satellites and other spacecraft operating in the space environment often suffer arcing and breakdown problems due to
surface charging. Charged particles build up on the spacecraft surfaces (such as solar panel arrays and other compo-
nents) leading to localized arcing/breakdown discharges that can critically fail a component or the entire unit. This
problem is made worse as the demand for high power space missions in both satellite and deep-space applications
rises. These high-power spacecraft are outfitted with high-voltage solar panels. These panels minimize the overall
payload requirements and offer other advantages over more massive, low-voltage arrays. However, they are also more
vulnerable to surface charge related arcing. It therefore becomes important to predict the surface charge build-up
on spacecraft bodies operating in different space environments, where the ion sources may be natural solar wind or
human-made space plasma resulting from electric thruster plasma plumes.

This example demonstrates a satellite body operating in the solar wind environment where the space plasma consists
of ions and electrons. The simulation box is set up with dimensions of 15 m x 30 m x 15 m. The satellite system is
placed in the middle of the domain. It has a 3 m radius x 5 m long cylindrical central unit connected to solar panels at
either end. Each solar panel has a total span length of 7.8 m and a width of 5 m. The satellite central unit has a 5-volt
equipotential circular body with radius 2 m and length 3 m. The satellite system is treated as a conductor floating
in free space. The system domain boundaries are assumed to have zero perpendicular electric field, i.e. Neumann
boundary conditions. The solar wind plasma is introduced in the simulation domain from the positive z direction. The
solar wind density is set to 1 × 107m−3 with a temperature of 10 eV. The number of physical particles per macro-
particle is set to 5000. Both electrons and ions are introduced from the source based on the solar wind density and
temperature. To maintain plasma uniformity within finite bounds, the electron source rate is inflated slightly because
electrons are lighter and leave the system more quickly than do ions. At the same time, the positive ions are imbued
with a lighter mass value to speed up the simulation. All simulation boundaries are set up to absorb particles. The
charges collected in the satellite system are counted by emitting a heavy electron or heavy ion at the point where an
electron or ion was absorbed. The heavy electron/ion is not a physical concept, it is a computational trick whereby
any charged particle striking the satellite gets converted to a new species, one with equivalent charge but drastically
swollen mass (1 kg in this case) and suppressed energy (suppressed by a factor of 10 billion). In this way, the heavy
particles do not propagate from their point of origin, effectively sticking to the satellite surface. To limit the number
of macro heavy particles tracked we apply a particle combining algorithm which limits the number of macro particle
per cell to one. The collected electron and ion currents on the satellite surfaces are otput as histories.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The satellite surface charging example is accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Spacecraft (text-based setup) option.

• Select “Satellite Surface Charging (text-based setup)” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

The basic variables of this problem should now be alterable via the text boxes in the left pane of the Setup Window, as
shown in Fig. 6.88.

Input File Features

The input file allows a choice of space environment parameters (number density, plasma temperature, drift speed),
satellite body voltage, simulation domain size, and resolution (number of cells in each direction).
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Fig. 6.88: Setup Window for the Satellite Surface Charging example.

The self-consistent electric field is solved from Poisson’s equation by the electrostatic solver. The far-field space
boundaries are handled with Neumann boundary conditions. The satellite inner body is set up with an equipotential
boundary. The surface charges collected on the satellite system make the satellite body float at a slightly higher voltage
than the space plasma.

This is a large domain, 3-D problem, and its resolution is aided by several numerical methods. The plasma is rep-
resented by macro-particles which are moved according to the Boris pusher. Variable weight particle treatment is
employed on all simulated species, reducing the overall number of macro-particles in the computation. Additionally,
null interactions are considered as part of the Monte Carlo analysis to limit the number of macro-particles per cell;
macro-particles are eliminated in overcrowded cells by means of inelastic combination.

Running the simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• To run the file, click on the Run button in the upper left corner of the right panel. You will see the output of the
run in the right pane. The run has completed when you see the output, “Engine completed successfully.” This is
shown in Fig. 6.89.

Analyzing the Results

If the electron density is desired, then proceed as follows:

• Press the Analyze button in the left column of buttons.
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Fig. 6.89: The Run Window at the end of execution.

• Check the Show All Analyzers box.

• Select computePtclNumDensity.py.

• Click Open.

• Enter the following parameters in the appropriate fields:

– simulationName = satelliteSurfaceChargeT

– speciesName = solarElectrons

– avgNxN = 1

– iterateAvg = 1

• Click the Analyze button in the upper right corner of the window.

See Fig. 6.90.

The resulting data will be visualizable as solarElectronsDensity under the Scalar Data menu in the Visualize Tab. The
density of solarIons can be calculated in the same way by substituting that species name in place of solarElectrons.

Visualizing the results

After performing the above actions, proceed to the Visualize Window by pressing the Visualize button in the left
column of buttons.

To visualize the satellite geometry with electrons Fig. 6.91, proceed as follows:

• Expand Particle Data.
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Fig. 6.90: The Run Window at the end of execution.

• Expand heavyElectrons.

• Select “heavyElectrons” in red.

• Expand solarElectrons.

• Select “solarElectrons” in green.

• Expand Geometries.

• Select “poly_surface (Satellite)”.

• Move the Dump slider to dump 7.

Here are some things to try:

• Under Data Overview you can access plots of the electric field, charge density (rho), and electric potential (phi).
Select the Display Contours check box for viewing these.

• To view the phase space distribution for the electrons and ions, click on the Data View drop down menu and
select Phase Space. Click the Draw button to generate a plot.

• Also from the Data View menu select History to observe the satellite currents and the time history results for the
number of macro-particles broken down by species.

To generate Fig. 6.92, that shows the satellite system with the inner equipotential cylindrical body, proceed as follows:

• In the Data View pane on the left side select “Data Overview” from the drop-down menu.

• Expand Geometries

• Select “poly (Satellite)”

• Select “poly_surface (SatelliteInner)”.
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Fig. 6.91: Visualization plot of satellite system with solar wind electrons in green and the electrons that stick to the
satellite surface in red.

The phase-space distribution of the positive ions (solarIons species) surrounding the satellite system is shown in Fig.
6.93 which is obtained after running the simulation for 500 time steps. Solar wind plasma enters into the simulation
system from the top z boundary, i.e. above the satellite body.

Surface charge accumulation on the satellite body after 93,000 time steps is shown in Fig. 6.94. The red dots indicate
electrons and the green dots ions. The surface charges on the satellite body can be viewed in VSimComposer by
turning on Particle Data –> heavyElectrons and ParticleData -> heavyIons under the Data Overview pane.

The charge density built-up on the satellite system is shown in Fig. 6.95 after running for 93,000 time steps. To view
the charge density in the simulation domain, turn on the Scalar Data -> rho field in the Data Overview pane. In this
figure the satellite body is also included by turning on the Geometries -> poly_surface(Satellite) option in the Data
Overview pane. The charge density appears net positive in most regions of the solar panels.

To view the electrostatic potential, turn on phi under the Scalar Data in the Data Overview pane. The electrostatic
potential of the satellite system simulated is shown in Fig. 6.96 after running for 93,000 time steps. The electrostatic
potential is plotted in X-Y-Z with domain clipping in the X and Z directions. The bulk of the plasma potential in
the space region is close to 0 volts (blue contours). The surface charge built-up on the solar panels raises the surface
potential by up to 4 to 5 volts above the bulk space plasma.

The magnitude of the electric field distribution on the satellite surface after 93,000 time steps is shown in Fig. 6.97.
The peak of the distribution coincides with regions on the solar array where there is net positive charge build-up. The
magnitude of the electric field was computed using the Expressions function in the Visit interface. Should you wish to
get to those calculations, right-click on the plot and select Open GUI. (You must have the Enable VisIt context menu
box check-marked in Vizualization Options. Go to Tools -> Settings -> Visualization Options, to enable this.) This
will launch the VisIt control panel. From there, go to Controls -> Expressions. You can select any plottable variable
to view its mathematical definition.
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Fig. 6.92: Visualization of the inner body inside the satellite system.

Fig. 6.93: Visualization of the satellite system with solar ions.

Fig. 6.94: Visualization of surface charge build-up on the satellite system after 93,000 time steps.
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Fig. 6.95: Visualization of the charge density on the satellite system.

Fig. 6.96: Visualization of the electric potential surrounding the satellite system.
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Fig. 6.97: Visualization of the magnitude of electric field surrounding the satellite system.

Further Experiments

The geometry and background space plasma parameters of this input file can be modified to test satellite inner body
voltages and satellite surface charge collection in a variety of different space environments.

VSim allows the use of “open” boundary conditions to represent the far-field boundaries in the space environment.

6.9 Sputtering

6.9.1 Ion Beam Sputtering (ionBeamSputtering.sdf)

Keywords:

sputtering, ion beam, electrostatics

Problem Description

In this simulation, a 450 eV beam of positively charged argon ions strikes a copper plate (cathode) at -25 volts with
respect to the walls on the upper and lower x boundaries of the simulation. A Neumann boundary condition (the slope
of the electric potential is zero) is placed on the upper and lower y walls of the simulation.

The argon ion beam travels through a vacuum and sputter off neutral copper atoms from the cathode.

This demonstrates how to set up a sputtering interaction through the Visual Setup in VSimComposer.

This simulation can be performed with a VSimPD license.

Opening the Simulation

The Ion Beam Sputtering example can be accessed from within VSimComposer by the following actions:

• Select the New → From Example. . . menu item in the File menu.

• In the resulting Examples window expand the VSim for Plasma Discharges option.

• Expand the Sputtering option.
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• Select “Ion Beam Sputtering” and press the Choose button.

• In the resulting dialog, create a New Folder if desired, and press the Save button to create a copy of this example.

You can expand the tree elements and navigate through the various properties, making any changes you desire. The
right pane shows a 3D view of the geometry, if any, as well as the grid, if actively shown. The setup window, with the
Particle Dynamics → Kinetic Particles → ArgonIons, and neutralCopper elements expanded is shown in Fig. 6.98.

Fig. 6.98: Setup window for the Ion Beam Sputtering example.

Simulation Properties

The Ion Beam Sputtering example includes some constants for easy adjustment of simulation properties:

• BEAM_RADIUS: sets the radius of the argon ion beam

• BEAM_ENERGY: sets the energy (and speed) of the ion beam

• BEAM_CURRENT: sets the emitted current. Note: the total current emitted will be less than this value if a mask
is applied to the particle emitter (which is the case in this simulation).

• CATHODE_VOLTAGE: the negative bias for the cathode.

Running the Simulation

After performing the above actions, continue as follows:

• Proceed to the run window by pressing the Run button in the left column of buttons.

• Here you can set run parameters, including how many cores to run with (under the MPI tab).
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• When you are finished setting run parameters, click on the Run button in the upper right corner. You will see
the output of the run in the right pane. The run has completed when you see the output, “Engine completed
successfully.” This is shown in Fig. 6.99.

Fig. 6.99: The Run window at the end of execution.

Analyzing the data

This simulation includes particle species which enter the simulation at different times. When this is the case, the
createMissingPtclDumps.py analyzer must be run. If no particles of a particular species exist in a simulation when
data is written (dumped), then there will be no dump files for that particular species. This will cause particle data to
not be lined up to the same dump in the Visualize Tab.

To fill in these missing files, navigate to the Analyze Tab and check the box “Show All Analyzers”. Select createMiss-
ingPtclDumps.py from the list and click “Open”. Ensure the following is entered into each field:

• simulationName: “ionBeamSputtering”

• speciesName: “neutralCopper”

Click Analyze in upper right corner of the window. When the analysis is finished, you should see a window similar to
Fig. 6.9.1.

Visualizing the results

After performing the above actions, continue as follows:

1. Proceed to the Visualize window by pressing the Visualize button in the left column of buttons. Be sure to press
the “Reload Data” button at the bottom of the window if you have previously navigated to the Visualize window.
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2. Expand “Particle Data” then expand “ArgonIons” and check the red “ArgonIons” box.

3. Expand “neutralCopper” and check the green “neutralCopper” box.

4. Expand “Scalar Data” and check “Phi”. Then check the “Display Contours” box.

5. Expand “Geometries” and select poly (cathode).

Scrolling through the dumps, you should see the argon beam expand as it travels towards the cathode, as in Fig. 6.100.
Because we ran the createMissingPtclDumps.py analyzer, copper atoms won’t appear until after the argon beam strikes
the cathode.

Next, in the Data View drop down menu at the top left of the window, switch from “Data Overview” to “History”. In
Graph 2, change from “emittedArgonCurrent” to “<None>” to see the plots shown in Fig. 6.101

These plots show the energy deposited onto the cathode from the argon ion species as well as the number of neutral
copper macro particles. From these plots its clear that the ion beam strikes the cathode after about 2.5 microseconds.
A history for the total number of physical copper atoms is also available to be added to the simulation.

Further Experiments

1. Vary the BEAM_ENERGY constant, the species of ions in the beam, and the target material to see how the
sputter yield changes in response (see the “numMacroCopper” history available in the Visualize Tab).

To change the material of the target to see the affect on the sputtering yield, expand the Particle Dynamics
element, then neutralCopper. Select the sputterNeutralEmitter and choose a new material from the “material
properties” dropdown menu.

Note: Savvy users may notice that the material of the cathode is also set in the Geometries element under CSG
→ cathode. This assignment of “PEC” sets the _electromagnetic_ properties of the geometry, not the particle
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Fig. 6.100: Ion Beam Sputtering a few dumps after the argon beam strikes the wall. The first few sputtered copper
atoms can be seen in green.

Fig. 6.101: Plots of the absorbed power and neutralCopper macro particle count.
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properties.

2. Add electrons, secondary electron emission, an RF oscillating frequency on the cathode, and possibly an external
magnetic field. Add a copperIons species and an electron impact ionization process to create copperIons from
neutralCoppers. Add a second copper sputter emitter to the cathode that creates copper neutrals from copperIons
to simulate self-sputtering.

3. Modify the beam current to account for the loss in current due to the mask. See the Negative Ion Beam example
(Negative Ion Beam (negativeIonBeam.sdf)) for an example of how this is accomplished.
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SEVEN

TRADEMARKS AND LICENSING

• Vorpal™ © 1999-2002 University of Colorado. All rights reserved.

• Vorpal™ © 2002-2018 University of Colorado and Tech-X Corporation. All rights reserved.

• VSim™ except for Vorpal™ is © 2012-2018 Tech-X Corporation. All rights reserved.

For VSim™ licensing details please email sales@txcorp.com. All trademarks are the property of their
respective owners. Redistribution of any VSim™ input files from the VSim™ installation or the VSim™
document set, including VSim Installation, VSim Examples, VSim User Guide, VSim Reference, and VSim
Customization, is allowed provided that this Copyright statement is also included with the redistribution.
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Electrostatic Particle in Cell (Text-based setup), 44
Ground Penetrating Radar (Text-based setup), 167
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Two-Stream Instability (Text-based setup), 50

far field, 76, 80
Far-Field Box Data

2.4 GHz Yagi Uda, 55
Antenna on Predator Drone, 85

Far-Field Observation

Index 449



VSim Examples, Release 9.0.2-r2448

Dipole Above Conducting Plane, 64
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ity, 139
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Coaxial Cylinder (Text-based setup), 213
Colliding Pulse Injection (Text-based setup), 329
Cylindrical Hall Thruster (Text-based setup), 412
Dipole Source Illuminating a Photonic Crystal Cav-

ity (Text-based setup), 146
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Negative Ion Beam (Text-based setup), 397
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Photonic Crystal in Metal Cavity (Text-based setup),
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Vacuum Electromagnetic Pulse (Text-based setup),
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2D Capacitive Plasma Chamber (Text-based setup),
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Magnetic Fields of Wire (Text-based setup), 30
Negative Ion Beam (Text-based setup), 397
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Ion Thruster (Text-based setup), 419
Magnetic Fields of Wire (Text-based setup), 30
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Dipole Above Conducting Plane, 64
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Klystron (Text-based setup), 275
Multistage Collector (Text-based setup), 315
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geometry
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Electron Beam Driven Plasma Wakefield (Text-
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Vacuum Electromagnetic Pulse (Text-based setup),
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A15 Crab Cavity (Text-based setup), 218
Coaxial Cylinder (Text-based setup), 213
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160
Electron Gun (Text-based setup), 313
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Two-Stream Instability (Text-based setup), 50
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3D Stripline Multipacting (Text-based setup), 302
Multistage Collector (Text-based setup), 315
Specific Absorption Rate (Text-based setup), 178
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Drude-Lorentz MIM Waveguide (Text-based setup),
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Photonic Crystal in Metal Cavity (Text-based setup),
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2D Capacitive Plasma Chamber (Text-based setup),
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351
2D Capacitive Plasma Chamber (Text-based setup),
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Coupon Array Charging, 401
Dielectric Waveguide Mode Calculation, 112
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Helix Traveling Wave Tube, 242, 248, 256
Klystron, 261
Microring Resonator Mode Calculator, 127
Microring Resonator with Gaussian Launcher, 124
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Ion Thruster (Text-based setup), 419
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Satellite Surface Charging (Text-based setup), 427
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Ground Penetrating Radar (Text-based setup), 167
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Like-Charge Dipole (Text-based setup), 97
Magnetic Fields of Wire (Text-based setup), 30
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181
Satellite Surface Charging (Text-based setup), 427
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Cylindrical Hall Thruster (Text-based setup), 412
Ion Thruster (Text-based setup), 419
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Negative Ion Beam (Text-based setup), 397
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Cylindrical Hall Thruster, 406

interpolatedFromFile
Ion Thruster (Text-based setup), 419

Ion Neutral Fluid Collisions
Cylindrical Hall Thruster, 406
Turner case 2, 343

Ionization
Cylindrical Hall Thruster, 406
Turner case 2, 343

iterativeSolver
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Like-Charge Dipole (Text-based setup), 97
Magnetic Fields of Wire (Text-based setup), 30
Parallel Plate Capacitor (Text-based setup), 48
Satellite Surface Charging (Text-based setup), 427
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Radar Cross Section of a Cylinder (Text-based
setup), 170
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Colliding Pulse Injection (Text-based setup), 329
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LinearSolver
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Ion Thruster (Text-based setup), 419
Like-Charge Dipole (Text-based setup), 97
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Negative Ion Beam (Text-based setup), 397
Parallel Plate Capacitor (Text-based setup), 48
Satellite Surface Charging (Text-based setup), 427

linearSolveUpdater
1D Capacitive Plasma Chamber (Text-based setup),
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2D Capacitive Plasma Chamber (Text-based setup),
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